Problem mit MPlayer Paketen

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Benutzeravatar
Tux-Manni
Member
Member
Beiträge: 172
Registriert: 12. Jun 2004, 18:46
Wohnort: Ludwigsburg

Problem mit MPlayer Paketen

Beitrag von Tux-Manni » 20. Dez 2005, 20:28

Hallo
Mittlerweile bin ich umgestiegen auf OSS 10.
Beim installieren habe ich die MPlayer Pakete von suser-jengelh gewählt.
MPlayer-1.0pre7try2-28.i586.rpm usw..

Allerdings konnte ich diesen Player weder über das Menü noch über die Konsole starten. Es gibt auch keine Fehlermeldungen dazu.
Daraufhin wollte ich die Pakete von suser-jengelh wieder deinstallieren; aber Pustekuchen. Die Pakete gehen nicht mehr runter!!!
Meldung:
Preparing... ########################################### [100%]
/var/tmp/rpm-tmp.81801: line 1: DEFINE_FLAVOR_DEL: command not found
/var/tmp/rpm-tmp.81801: line 2: flavor_del: command not found
error: %preun(MPlayer-athlon1-1.0pre7try2-28 ) scriptlet failed, exit status 127
/var/tmp/rpm-tmp.81801: line 1: DEFINE_FLAVOR_DEL: command not found
/var/tmp/rpm-tmp.81801: line 2: flavor_del: command not found
error: %preun(MPlayer-pentium3-1.0pre7try2-28 ) scriptlet failed, exit status 127
/var/tmp/rpm-tmp.81801: line 1: DEFINE_FLAVOR_DEL: command not found
/var/tmp/rpm-tmp.81801: line 2: flavor_del: command not found
error: %preun(MPlayer-pentium4-1.0pre7try2-28 ) scriptlet failed, exit status 127.....
Zur Zeit habe ich auch den MPlayer von Packman drauf (gleichzeitig).
Dieser läuft selbstverständlich top.

Wo liegt der Fehler bei der anderen Version (MPlayer-1.0pre7try2-28.i586.rpm)?
Oder wie bekomm ich diese Pakete wieder runter?

Danke und Gruß
Manni
Suse 10 / KDE 3.5.1 Level "a"
Kernel 2.6.13-15.8-default
xorg 6.9.0-3.1
Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.12) Gecko/20050920 Firefox/1.0.7 SUSE/1.0.7-0.1

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 20. Dez 2005, 22:43

oha, da scheint das preun-Script nicht zu wollen.

Probiere: rpm -e --noscripts MPlayer
damit solltest du diese Version deinstallieren können.

man rpm:

Code: Alles auswählen

--noscripts --nopre --nopost --nopreun --nopostun
Don't execute the scriptlet of the same name.  The --noscripts option is equivalent to  --nopre --nopost --nopreun --nopostun and turns off the execution of the corresponding %pre, %post, %preun, and %postun scriptlet(s).
ein BugReport an den packager wäre auch nett.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
Tux-Manni
Member
Member
Beiträge: 172
Registriert: 12. Jun 2004, 18:46
Wohnort: Ludwigsburg

Beitrag von Tux-Manni » 21. Dez 2005, 20:25

Hallo oc2pus

Danke für die Hilfe. Man lernt nie aus........
ein BugReport an den packager wäre auch nett
Ist geschehen, voraussichtlich gibts morgen ein Update.

Gruß Manni
Suse 10 / KDE 3.5.1 Level "a"
Kernel 2.6.13-15.8-default
xorg 6.9.0-3.1
Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.12) Gecko/20050920 Firefox/1.0.7 SUSE/1.0.7-0.1

ambkosh
Member
Member
Beiträge: 79
Registriert: 22. Sep 2005, 12:22
Wohnort: Berlin
Kontaktdaten:

Beitrag von ambkosh » 23. Dez 2005, 10:55

Bei diesem MPlayer-Paketen von jengelh gibt es zum eigentlich Paket noch eines "MPlayer-{Processor}", das musst du auch mit installieren, dann lässt er sich starten.

Gruß
Kosh

jengelh
Guru
Guru
Beiträge: 4039
Registriert: 20. Nov 2004, 17:42
Kontaktdaten:

Beitrag von jengelh » 23. Dez 2005, 15:28

Soweit isser schon. Schließlich hat "MPlayer" "MPlayer-PROCESSOR_FLAVOR" als Requires, sodass dir, egal ob über yast oder apt oder rpm, sofort gesagt wird, dass du noch was brauchst...

Benutzeravatar
michael_33
Member
Member
Beiträge: 70
Registriert: 20. Jul 2004, 09:58

Beitrag von michael_33 » 23. Dez 2005, 23:53

Hi,

mit den Paketen von Jens gibts einige Probleme.
Ich hab hier diverse davon:

apt update erzeugt:

Code: Alles auswählen

Lese Paketlisten... Fertig                                                     
Erzeuge AbhÀngigkeitsbaum... Fertig
W: There are multiple versions of "MPlayer-athlon4" in your system.

This package won't be cleanly updated, unless you leave
only one version. To leave multiple versions installed,
you may remove that warning by setting the following
option in your configuration file:

RPM::Allow-Duplicated { "^MPlayer-athlon4$"; };

To disable these warnings completely set:

RPM::Allow-Duplicated-Warning "false";

W: Sie möchten `apt-get update' ausfÌhren um diese Problem zu beheben
beim beheben kommt dann sowas:

Code: Alles auswählen

thor:~ # apt remove MPlayer-athlon4#1.0pre7try2-26
Lese Paketlisten... Fertig
Erzeuge AbhÀngigkeitsbaum... Fertig
Die folgenden Pakete werden ENTFERNT:
  MPlayer-athlon4#1.0pre7try2-26
0 upgraded, 0 newly installed, 1 entfernt und 26 nicht upgegradet.
Muss 0B an Archiven holen.
Nach dem Auspacken werden 7601kB Plattenplatz freigegeben werden.
Wollen Sie fortsetzen? [J/n] j
Committing changes...
Preparing...                ########################################### [100%]
/var/tmp/rpm-tmp.230: line 1: /usr/sbin/uaconf-mplayer: Datei oder Verzeichnis nicht gefunden
error: %preun(MPlayer-athlon4-1.0pre7try2-26) scriptlet failed, exit status 127
apt executing: /sbin/SuSEconfig
so langsam weiss ich auch nich mehr weiter...
.| 2.6.15-gentoo-r1 | .. fluxbox 0.9.14 ..|.
.| AMD Athlon(tm) XP 2400+ | GSA-4040B | Elitegroup K7S5A | Matrox Millennium G400 |.

Benutzeravatar
michael_33
Member
Member
Beiträge: 70
Registriert: 20. Jul 2004, 09:58

Beitrag von michael_33 » 24. Dez 2005, 09:36

Zusatz:

Code: Alles auswählen

thor:~ # rpm -e --noscripts MPlayer-athlon4#1.0pre7try2-26
error: package MPlayer-athlon4#1.0pre7try2-26 is not installed
Offensichtlich sind rpm und apt unterschiedlicher Meinung. Denn:

Code: Alles auswählen

thor:~ # apt remove MPlayer-athlon4#1.0pre7try2-26
Lese Paketlisten... Fertig
Erzeuge AbhÀngigkeitsbaum... Fertig
Die folgenden Pakete werden ENTFERNT:
  MPlayer-athlon4#1.0pre7try2-26
0 upgraded, 0 newly installed, 1 entfernt und 26 nicht upgegradet.
Muss 0B an Archiven holen.
Nach dem Auspacken werden 7601kB Plattenplatz freigegeben werden.
Wollen Sie fortsetzen? [J/n] n
Abgebrochen.
.| 2.6.15-gentoo-r1 | .. fluxbox 0.9.14 ..|.
.| AMD Athlon(tm) XP 2400+ | GSA-4040B | Elitegroup K7S5A | Matrox Millennium G400 |.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 24. Dez 2005, 10:31

probiere einfach mal:
rpm -e --noscripts MPlayer-athlon4
bzw
apt remove MPlayer-athlon4

ansonsten ermittele den korrekten Paketnamen und nicht irgendwas mit "#" ..
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
michael_33
Member
Member
Beiträge: 70
Registriert: 20. Jul 2004, 09:58

Beitrag von michael_33 » 24. Dez 2005, 10:59

oc2pus hat geschrieben: rpm -e --noscripts MPlayer-athlon4
bzw
apt remove MPlayer-athlon4
Scheitert beides an:

Code: Alles auswählen

thor:~ # rpm -e --noscripts MPlayer-athlon4
error: "MPlayer-athlon4" specifies multiple packages
ansonsten ermittele den korrekten Paketnamen und nicht irgendwas mit "#"
Tja, wenn MPlayer-athlon4#1.0pre7try2-26 nunmal der korrekte Paketname ist!? Ich hab mir den nicht ausgedacht!
.| 2.6.15-gentoo-r1 | .. fluxbox 0.9.14 ..|.
.| AMD Athlon(tm) XP 2400+ | GSA-4040B | Elitegroup K7S5A | Matrox Millennium G400 |.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 24. Dez 2005, 11:11

dann nimm die Option --allmatches beim rpm -e dazu

siehe man rpm :)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

jengelh
Guru
Guru
Beiträge: 4039
Registriert: 20. Nov 2004, 17:42
Kontaktdaten:

Beitrag von jengelh » 24. Dez 2005, 16:29

rpm -qa 'MP*' und (wenn man nicht gerade sich mit --allmatches durchboxen will) rpm -e 'paketname-version' (z.B. `MPlayer-athlon4-1.0pre7try2-28`)

marix
Newbie
Newbie
Beiträge: 9
Registriert: 11. Jul 2005, 22:48
Wohnort: HH

Beitrag von marix » 2. Jan 2006, 11:56

Frohes Neues Jahr.

Ist dieses Problem gelöst? Für mich leider nicht. Auch bei mir läßt sich MPlayer-athlon4-1.0pre7try2-28 nicht deinstallieren. Ich habe bisher folgendes versucht.

Code: Alles auswählen

linux:/home/kasi # rpm -e --noscripts MPlayer-pentium4#1.0pre7try2-28
error: package MPlayer-pentium4#1.0pre7try2-28 is not installed

Code: Alles auswählen

linux:/home/kasi # apt remove MPlayer-athlon4-1.0pre7try2-28
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
E: Konnte Paket MPlayer-athlon4-1.0pre7try2-28 nicht finden

Code: Alles auswählen

linux:/home/kasi # rpm -qa MPlayer-pentium4-1.0pre7try2-28


Synaptic und Yast geben aus, dass sich das Programm aber noch auf dem System befindet.

Synaptic gibt aus:
  • Während der Vorbereitung für die Installation:

    /var/tmp/rpm-tmp.75086: line 1: DEFINE_FLAVOR_DEL: command not found
    /var/tmp/rpm-tmp.75086: line 2: flavor_del: command not found
    error: %preun(MPlayer-pentium4-1.0pre7try2-28) scriptlet failed, exit status 127
    Starting SuSEconfig, the SuSE Configuration Tool...
    Running in full featured mode.
    Reading /etc/sysconfig and updating the system...
    Executing /sbin/conf.d/SuSEconfig.desktop-file-utils...
    Executing /sbin/conf.d/SuSEconfig.fonts...
    Creating cache files for Xft ............................
    Creating fonts.{scale,dir} files ..........
    generating java font setup
    writing /etc/fonts/suse-hinting.conf
    writing /etc/fonts/suse-bitmaps.conf
    Executing /sbin/conf.d/SuSEconfig.groff...
    Executing /sbin/conf.d/SuSEconfig.gtk2...
    Executing /sbin/conf.d/SuSEconfig.isdn...
    Modify isdn.conf
    Executing /sbin/conf.d/SuSEconfig.ispell...
    Executing /sbin/conf.d/SuSEconfig.kde...
    Executing /sbin/conf.d/SuSEconfig.kdm3...
    Executing /sbin/conf.d/SuSEconfig.libxml2...
    Executing /sbin/conf.d/SuSEconfig.news...
    Executing /sbin/conf.d/SuSEconfig.pango...
    Executing /sbin/conf.d/SuSEconfig.perl...
    Executing /sbin/conf.d/SuSEconfig.permissions...
    Executing /sbin/conf.d/SuSEconfig.postfix...
    Setting up postfix local as MDA...
    Setting SPAM protection to "off"...
    Executing /sbin/conf.d/SuSEconfig.scpm...
    Executing /sbin/conf.d/SuSEconfig.sgml-skel...
    Executing /sbin/conf.d/SuSEconfig.sortpasswd...
    Executing /sbin/conf.d/SuSEconfig.susehelp...
    DOCALLOW: localhost
    Executing /sbin/conf.d/SuSEconfig.syslog-ng...
    Executing /sbin/conf.d/SuSEconfig.words...
    Executing /sbin/conf.d/SuSEconfig.xdm...
    Executing /sbin/conf.d/SuSEconfig.xpdf...
    Executing /sbin/conf.d/SuSEconfig.zmessages...
    Finished.
yast gibt aus:
  • ERROR(InstTarget:E_RpmDB_subprocess_failed)
    ---
    /var/tmp/rpm-tmp.86919: line 1: DEFINE_FLAVOR_DEL: command not found
    /var/tmp/rpm-tmp.86919: line 2: flavor_del: command not found
    error: %preun(MPlayer-pentium4-1.0pre7try2-28) scriptlet failed, exit status 127

    2006-01-02 12:55:42 MPlayer-pentium4 remove failed
    rpm output:
    /var/tmp/rpm-tmp.811: line 1: DEFINE_FLAVOR_DEL: command not found
    /var/tmp/rpm-tmp.811: line 2: flavor_del: command not found
    error: %preun(MPlayer-pentium4-1.0pre7try2-28) scriptlet failed, exit status 127
Wer hat nun recht?

Danke marix[quote][/quote]
Mfg marix

SuSe 9.3 SE auf Barebone Shuttle xpc SB83G5, CPU Intel Celeron D 340J 2.93 GHz, 2 x 512 RAM, Printer: Canon ip4000r über Netzwerk, MX500

marix
Newbie
Newbie
Beiträge: 9
Registriert: 11. Jul 2005, 22:48
Wohnort: HH

Beitrag von marix » 2. Jan 2006, 12:06

Sorry, mein Fehler.

Ich konnte nun doch das Programm aus dem System deinstallieren. Folgender Befehl führte zum Erfolg:

Code: Alles auswählen

linux:/home/kasi # rpm -e --noscripts MPlayer-pentium4-1.0pre7try2-28
Offensichtlich habe ich mich von der unterschiedlichen Schreibweise (MPlayer-pentium4#1.0pre7try2-28 und MPlayer-pentium4-1.0pre7try2-28) verwirren lassen. Warum ist das so? Synaptic nennt das Packet MPlayer-pentium4#1.0pre7try2-28. Auf der Komandozeile gilt offensichtlich MPlayer-pentium4-1.0pre7try2-28. Beides ist doch im Grunde apt.

marix
Mfg marix

SuSe 9.3 SE auf Barebone Shuttle xpc SB83G5, CPU Intel Celeron D 340J 2.93 GHz, 2 x 512 RAM, Printer: Canon ip4000r über Netzwerk, MX500

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste