gcc mit apt beziehen

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Gesperrt
smoovn
Newbie
Newbie
Beiträge: 25
Registriert: 7. Dez 2005, 15:49

gcc mit apt beziehen

Beitrag von smoovn » 16. Dez 2005, 14:22

hi
ich versuche gcc mit apt runter zu ziehen aber es will net :( ich mache:
apt-get install gcc dan kommt

Code: Alles auswählen

linux:/ # apt-get install gcc
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
You might want to run `apt-get --fix-broken install' to correct these:
Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
  gcc: Hängt ab von: glibc-devel aber es wird nicht installiert werden
  multisync-evolution: Hängt ab von: multisync (= 0.82) aber es wird nicht installiert werden
                       Hängt ab von: evolution (>= 2.0) aber es wird nicht installiert werden
                       Hängt ab von: libebook.so.8
                       Hängt ab von: libecal.so.6
                       Hängt ab von: libedata-book.so.1
                       Hängt ab von: libedata-cal.so.5
                       Hängt ab von: libedataserver.so.3
E: Unmet dependencies. Try 'apt-get --fix-broken install' with no packages (or specify a solution).
an was liegt das? denke ich falsch ? heißt das packet anderst ?

mfg smoovn

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 16. Dez 2005, 14:26

du hast wahrscheinlich zu wenige Repositories in deiner sources.list drin.

hast du ein "ordentliches" System ohne schwebende Abhängigkeiten ?
was ergibt apt -s upgrade ?
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

smoovn
Newbie
Newbie
Beiträge: 25
Registriert: 7. Dez 2005, 15:49

Beitrag von smoovn » 16. Dez 2005, 14:31

Code: Alles auswählen

linux:/home/smoovn # apt -s upgrade
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
You might want to run `apt-get --fix-broken install' to correct these.
Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
  multisync-evolution: Hängt ab von: multisync (= 0.82) aber es ist nicht installiert
                       Hängt ab von: evolution (>= 2.0) aber es ist nicht installiert
                       Hängt ab von: libebook.so.8
                       Hängt ab von: libecal.so.6
                       Hängt ab von: libedata-book.so.1
                       Hängt ab von: libedata-cal.so.5
                       Hängt ab von: libedataserver.so.3
E: Unmet dependencies. Try using --fix-broken.

^^hier kommt der gleiche ramsch

sources.list
# Erstellt am Do Dez 15 16:25:54 CET 2005
#
# Repository created by: aptate (version 0.69.3)
# At: Thu Dec 15 02:17:13 MET 2005
# More info about aptate at: http://apt4rpm.sourceforge.net
#
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 update
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-guru
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 packman
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 packman-i686
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 security
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 rpmkeys
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 base
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 kde
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 gnome
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 xorg
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 mozilla
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 samba3
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-rbos
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 jacklab
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-oc2pus
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-gbv
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-kpietrz
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-obengs
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-tcousin
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-scorot
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-sbarnin
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-ollakka
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 funktronics
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 wine
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suse-projects
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 kde3-stable
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 update
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-guru
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 packman
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 packman-i686
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 security
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 rpmkeys
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 base
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 kde
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 gnome
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 xorg
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 mozilla
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 samba3
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-rbos
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 jacklab
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-oc2pus
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-gbv
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-kpietrz
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-obengs
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-tcousin
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-scorot
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-sbarnin
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-ollakka
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 funktronics
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 wine
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suse-projects
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 kde3-stable

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 16. Dez 2005, 14:42

smoovn hat geschrieben:

Code: Alles auswählen

linux:/home/smoovn # apt -s upgrade
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
You might want to run `apt-get --fix-broken install' to correct these.
Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
  multisync-evolution: Hängt ab von: multisync (= 0.82) aber es ist nicht installiert
                       Hängt ab von: evolution (>= 2.0) aber es ist nicht installiert
                       Hängt ab von: libebook.so.8
                       Hängt ab von: libecal.so.6
                       Hängt ab von: libedata-book.so.1
                       Hängt ab von: libedata-cal.so.5
                       Hängt ab von: libedataserver.so.3
E: Unmet dependencies. Try using --fix-broken.
^^hier kommt der gleiche ramsch
nö, da steht nur eine Leiche im Keller: multisync-evolution.
und es nicht der gleiche "Ramsch" :)

d.h. solange du diese "Leiche" nicht korrekt löst, wird apt sich weigern etwas zu tun....
dein Problem kommt daher eher aus der gnome Ecke, du hast eine evolution-Version die nicht zur Version evolution-multisync passt.

schau mit apt policy evolution-multisync evolution, welche Versionen es gibt und installiere diese passend zueinander.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

smoovn
Newbie
Newbie
Beiträge: 25
Registriert: 7. Dez 2005, 15:49

Beitrag von smoovn » 16. Dez 2005, 14:47

was ist wen ich dir sagen das ich nicht verstehe was du da schreibst =)

also soll ich jetzt mit apt multisync-evolution laden oder wie siehts aus?

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 16. Dez 2005, 17:56

wenn eine Leiche im Keller steht: dann entsorge sie ;)

also weg mit dem Paket multisync-evolution, das hält andere Pakete fest ...
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

smoovn
Newbie
Newbie
Beiträge: 25
Registriert: 7. Dez 2005, 15:49

Beitrag von smoovn » 17. Dez 2005, 22:48

also erst mal blicke ich hier garnet mehr durch weil jemand sehr viele posts gelöscht hat -.- warum was bringts auser verwirrung ?

also wie soll ich deinstallieren wen ichs net mal habe ??

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 18. Dez 2005, 11:19

smoovn hat geschrieben:also erst mal blicke ich hier garnet mehr durch weil jemand sehr viele posts gelöscht hat -.- warum was bringts auser verwirrung ?

also wie soll ich deinstallieren wen ichs net mal habe ??
aha, die anderen unqualifizierten Bemerkungen helfen dir also weiter ? Dann solltest du dein Problem in Blafasel abhandeln lassen, aber nicht hier im apt-Forum ... und lass es dir gesagt sein: ICH moderiere hier, ICH lösche ggfl. Postings die nichts mit der Sache zu tun haben ..

zurück zu deinem Problem:
du sollst ganz einfach das Paket multisync-revolution deinstallieren.
rpm -e --nodeps multisync-evolution oder
apt remove multisync-evolution
....
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

smoovn
Newbie
Newbie
Beiträge: 25
Registriert: 7. Dez 2005, 15:49

Beitrag von smoovn » 19. Dez 2005, 13:53

es tut mir leid wen du dich angegriffen fühlst aber ich meine es stört mehr als es hilft das löschen der postst...

hat bestens geklapt danke!

mfg smoovn

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast