Update Probleme

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Benutzeravatar
Outcop
Newbie
Newbie
Beiträge: 8
Registriert: 29. Feb 2004, 14:03
Wohnort: Duisburg
Kontaktdaten:

Update Probleme

Beitrag von Outcop » 11. Dez 2005, 18:03

Hallo,

ich versuche seit 6 Stunden mein suse linux 9.3 upzudaten. Die packete werden runtergeldaden, aber bei der installation bekomme ich die Fehlermeldung

"ERROR(InstTarget:E_RpmDB_subprocess_failed)
---
error: cannot open Packages index using db3 - Operation not permitted (1)
error: cannot open Packages database in /var/lib/rpm

2005-12-11 18:00:45 liby2util-2.11.6-1.1.i586.rpm install failed
rpm output:
warning: waiting for exclusive lock on /var/lib/rpm/Packages
error: cannot get exclusive lock on /var/lib/rpm/Packages
error: cannot open Packages index using db3 - Operation not permitted (1)
error: cannot open Packages database in /var/lib/rpm"

ERROR(InstTarget:E_RpmDB_subprocess_failed)
---
error: cannot open Packages index using db3 - Operation not permitted (1)
error: cannot open Packages database in /var/lib/rpm

2005-12-11 18:00:45 liby2util-2.11.6-1.1.i586.rpm install failed
rpm output:
warning: waiting for exclusive lock on /var/lib/rpm/Packages
error: cannot get exclusive lock on /var/lib/rpm/Packages
error: cannot open Packages index using db3 - Operation not permitted (1)
error: cannot open Packages database in /var/lib/rpm

ERROR(InstTarget:E_RpmDB_subprocess_failed)
---
error: cannot open Packages index using db3 - Operation not permitted (1)
error: cannot open Packages database in /var/lib/rpm

2005-12-11 18:00:45 liby2util-2.11.6-1.1.i586.rpm install failed
rpm output:
warning: waiting for exclusive lock on /var/lib/rpm/Packages
error: cannot get exclusive lock on /var/lib/rpm/Packages
error: cannot open Packages index using db3 - Operation not permitted (1)
error: cannot open Packages database in /var/lib/rpm



rpm --rebuilddb hat auch nichts gebracht. Kann mir jemand helfen?

Werbung:
towo
Moderator
Moderator
Beiträge: 3702
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo » 11. Dez 2005, 18:07

Du bist aber schon Root, gell?
Signatur nach Diktat spazieren gegangen

Bild

Benutzeravatar
Outcop
Newbie
Newbie
Beiträge: 8
Registriert: 29. Feb 2004, 14:03
Wohnort: Duisburg
Kontaktdaten:

Beitrag von Outcop » 11. Dez 2005, 18:08

Ja, natürlich starte ich die installation als root :-)

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 11. Dez 2005, 18:29

Mach mal alle Programm zu die evtl. auf die rpm-Datenbank zugreifen könnten. Wie willst du updaten? Mit yast? Mit apt?
Und mach das Bild was kleiner...
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

Benutzeravatar
Outcop
Newbie
Newbie
Beiträge: 8
Registriert: 29. Feb 2004, 14:03
Wohnort: Duisburg
Kontaktdaten:

Beitrag von Outcop » 11. Dez 2005, 18:44

Bilder nehm ich nachher raus. Ich update mit Yast bzw YOU Das Problem scheint zu sein, das 9.1 pakete von yast (ge)downgreadet hat. Ich werde nun neu installieren, hätt ich sowieso die tage gemusst um auf 64 bit zu installieren. Sollte jemand dennoch ne lösung haben wäre ich sehr interessiert, wodurch dies verursacht wurde und wie es hätte gelöst werden können.

PS. Es liefen keine anderen Apps, die hätten rpm nutzen können. Im runlevel 1-3 funktionierte es auch nicht.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste