Kann keine Programme mehr installieren mit Yast

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Gesperrt
Benutzeravatar
Mystique
Member
Member
Beiträge: 153
Registriert: 23. Jul 2004, 22:18
Wohnort: Hauptstadt
Kontaktdaten:

Kann keine Programme mehr installieren mit Yast

Beitrag von Mystique » 9. Dez 2005, 17:48

Ich wollte ein paar Progamme von der CD und andere .rpm's aus dem Netz nachinstallieren. Leider erhalte ich dann die Fehlermeldung:

ERROR(InstTarget:E_RpmDB_subprocess_failed)
error: db4 error(-30978) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30978) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30978) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30978) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30978) from dbenv->close: DB_RUNRECOVERY: Fatal error, run database recovery


in einem neuen Fenster in Yast. Woran kann das liegen. Ich installiere natürlich als Root.
openSUSE Leap 42.1 @ 64-Bit, Asus K8V-X SE VIA K8T800, AMD Athlon64 3400+ (Sockel 754), 2x 1GB DDR400 RAM,
Gigabyte ATI X1050 256MB DDR2, 2x WesternDigital SATA @ 1TB, NEC DV-5800E 16x DVD-ROM, NEC AD-5170A 18x DVD-RW, Nova-T DVB-T PCI

Werbung:
Benutzeravatar
admine
Administrator
Administrator
Beiträge: 8723
Registriert: 15. Feb 2004, 21:13
Wohnort: Dresden
Kontaktdaten:

Beitrag von admine » 9. Dez 2005, 17:51

Führe einmal als root das aus:

Code: Alles auswählen

rpm --rebuilddb
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Benutzeravatar
Mystique
Member
Member
Beiträge: 153
Registriert: 23. Jul 2004, 22:18
Wohnort: Hauptstadt
Kontaktdaten:

Beitrag von Mystique » 9. Dez 2005, 20:49

:D freu :D

.....nu jet dit wieder. Was ist das Geheimnis? Wodurch kann der Fehler herkommen?
openSUSE Leap 42.1 @ 64-Bit, Asus K8V-X SE VIA K8T800, AMD Athlon64 3400+ (Sockel 754), 2x 1GB DDR400 RAM,
Gigabyte ATI X1050 256MB DDR2, 2x WesternDigital SATA @ 1TB, NEC DV-5800E 16x DVD-ROM, NEC AD-5170A 18x DVD-RW, Nova-T DVB-T PCI

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 9. Dez 2005, 20:59

Gibt ein paar Möglichkeiten. Beim Installieren mal abgebrochen, falsche Pakete eingespielt apt/you durcheinander benutzt...
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast