Smart dist-upgrade und GUI?

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Gesperrt
shattered
Member
Member
Beiträge: 155
Registriert: 2. Aug 2004, 01:14

Smart dist-upgrade und GUI?

Beitrag von shattered » 24. Nov 2005, 15:51

Hallo,

ich bin vor einiger Zeit auf smart umgestiegen, war kein Problem dank der Hilfe hier im Forum. Danke! Ich bin soweit zufrieden, habe allerdings eine kleine Frage: Bei apt hatte ich immer apt-get dist-upgrade verwendet, ein smart dist-upgrade scheint es nicht zu geben. Stimmt das und soll ich einfach smart upgrade verwenden, so wie bisher?

Ach ja, noch was, gerade zum ersten Mal getestet:

Code: Alles auswählen

fish@fishbox:~> smart --gui
error: Interface 'gtk' not available
Hm? Hm... :roll:
Zuletzt geändert von shattered am 24. Nov 2005, 18:47, insgesamt 2-mal geändert.

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 24. Nov 2005, 15:55

dir fehlen die gtk2-Pakete, siehe Howto :)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

shattered
Member
Member
Beiträge: 155
Registriert: 2. Aug 2004, 01:14

Beitrag von shattered » 24. Nov 2005, 16:48

oc2pus hat geschrieben:dir fehlen die gtk2-Pakete, siehe Howto :)

Code: Alles auswählen

fish@fishbox:~> smart install python-gtk gtk2
Loading cache...
Updating cache...                                        ############################################################################## [100%]

warning: python-gtk-2.8.0-3@i586 is already installed
warning: gtk2-2.8.7-3@i586 is already installed
Computing transaction...

fish@fishbox:~> smart --gui
error: Interface 'gtk' not available

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 24. Nov 2005, 18:19

Code: Alles auswählen

rpm -q gtk2 python-gtk
gtk2-2.8.7-3
python-gtk-2.8.2-3
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

shattered
Member
Member
Beiträge: 155
Registriert: 2. Aug 2004, 01:14

Beitrag von shattered » 24. Nov 2005, 18:40

oc2pus hat geschrieben:Bei manueller Installation sollte man die aktuellen gtk2 and python-gtk von hier verwenden: ftp://ftp.suse.com/pub/suse/i386/supplementary/GNOME
Ich konnte da zuerst einfach keine neuere python-gtk finden, sorry.

Wieso ist die in applications? Ist das eine Anwendung? Huh... :roll:

Nun gut, geholfen hat es auch nicht:

Code: Alles auswählen

fishbox:/home/fish # rpm -q python-gtk
python-gtk-2.8.2-3
fishbox:/home/fish # smart --gui
error: Interface 'gtk' not available
fishbox:/home/fish # exit
exit
fish@fishbox:~> smart --gui
error: Interface 'gtk' not available

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 24. Nov 2005, 18:51

hast du smart und smart-gui installiert ?
das sind jetzt ZWEI Pakete !
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

shattered
Member
Member
Beiträge: 155
Registriert: 2. Aug 2004, 01:14

Beitrag von shattered » 24. Nov 2005, 19:03

Eeeehhhmmm... :roll:

Vielen Dank, hat geklappt! :D

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste