suche quellen für tomcat5

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Gesperrt
spaci76
Newbie
Newbie
Beiträge: 9
Registriert: 5. Sep 2003, 13:18

suche quellen für tomcat5

Beitrag von spaci76 » 23. Nov 2005, 11:58

Hallo zusammen,

ich versuche tomcat5 mittels apt-get zu installieren.

meine source.list schaut so aus.

Code: Alles auswählen

# A very basic sources.list file.
# Remove "base" in case you are behind a slow connection.
# Fastest repository comes first, with netselect it is possible to determine
# the fastest repository easily.
# Visit the server to determine which apt components are provided.
#rpm ftp://mirrors.mathematik.uni-bielefeld.de/pub/linux/suse/apt/ SuSE/10.0-i386 base update security rpmkeys
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 base update security rpmkeys

# The list with all available components can be found at:
# http://linix01.gwdg.de/apt4rpm
# Some components provide experimental software, select wisely!
# http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386/examples/sources.list.FTP

# Consult the link above if you want to include uri's for src rpms
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 update security
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 update security suser-guru
als fehlermeldung erhalte ich :

Code: Alles auswählen

paraveredus:/ # apt-get install tomcat5
Reading Package Lists... Done
Building Dependency Tree... Done
Package tomcat5 has no available version, but exists in the database.
This typically means that the package was mentioned in a dependency and
never uploaded, has been obsoleted or is not available with the contents
of sources.list
E: Package tomcat5 has no installation candidate
paraveredus:/ #
hat jemand ein anderes repository wo ich tomcat5 erbei ziehen kann.??

vielen dank im voraus..

cu spaci76

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 23. Nov 2005, 12:02

du must die Pakete von hier miteinbinden in dein apt:
http://www.jpackage.org/

in der /etc/apt/sources.list folgendes ergänzen:

Code: Alles auswählen

# jpackage
rpm http://mirrors.sunsite.dk/jpackage/ 1.6/generic free
rpm-src http://mirrors.sunsite.dk/jpackage/ 1.6/generic free non-free
danach ein apt update
apt install tomcat5

aber Vorsicht: viele Pakete dort sind nur als nosrc.rpm verfügbar. D.h. du musst die tar.gz selber downloaden (wegen den Lizenzen,...) und umwandeln
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

spaci76
Newbie
Newbie
Beiträge: 9
Registriert: 5. Sep 2003, 13:18

Beitrag von spaci76 » 24. Nov 2005, 10:42

Hi,

danke erst einmal für die schnelle Info,

apt erkennt das mittels rpm installierte sdk nicht da kommt nur ..

Code: Alles auswählen

paraveredus:~/install # apt install tomcat5
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  tomcat5: Depends: java-sdk (>= 1.4)
E: Broken packages
paraveredus:~/install #
das paket heist aber im yast java-1_5_0-sun oder java-1_4_0-sun

kann ich das "irgendwie umbiegen"??

vielen dank im voraus

cu spaci76

spaci76
Newbie
Newbie
Beiträge: 9
Registriert: 5. Sep 2003, 13:18

Beitrag von spaci76 » 24. Nov 2005, 11:16

vielen dank nochmal .. hat sich erledigt.

hatte nur die jre installiert nicht die sdk...

danke

cu spaci76

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste