Gibt es qt3-non-mt nicht länger?

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
ojkastl
Hacker
Hacker
Beiträge: 547
Registriert: 15. Dez 2004, 04:51
Wohnort: Erlangen
Kontaktdaten:

Gibt es qt3-non-mt nicht länger?

Beitrag von ojkastl » 19. Nov 2005, 08:24

Hallo,

ich war mir nicht sicher wo das Thema am besten hinpasst. Hab mich mal für apt entschieden.

Ich brauche für ein etwas älteres Programm die qt3-non-mt, da das Programm die libqt.so.3 benötigt, die anscheinend in diesem Paket steckt.

Jetzt gibt es dieses Paket aber nicht in einer zur neuesten qt3-Version passenden Version. Seit ein paar Tage (seit auch das Problem hier auftrat) fehlt es jetzt schon, und ich bin mir nicht sicher ob das vielleicht gelöscht wurde. oder nicht mehr existiert als Paket, und irgendwo eingebaut wurde.

Wo sollte denn sowas stehen? Wisst ihr Näheres zu qt3-non-mt?

Danke, Saber

Werbung:
traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 19. Nov 2005, 09:17

Für welches Programm brauchst Du das denn, und wie alt ist es denn genau? Was sagt "ldd /pfad/zum/alten/programm/um/das/es/geht"? Und welche SuSE-Version benutzt Du?

Wenn Du SuSE 10.0 benutzt und die Ausgabe des oben genannten Befehls "libstdc++.so.5" oder statt der "5" sogar eine noch kleinere Zahl enthält, würde es wegen der CXXABI-Änderung sowieso nicht laufen.

ojkastl
Hacker
Hacker
Beiträge: 547
Registriert: 15. Dez 2004, 04:51
Wohnort: Erlangen
Kontaktdaten:

Beitrag von ojkastl » 19. Nov 2005, 09:38

Oh Mann, vor lauter Hektik selber die ganzen infos vergessen:

Suse 9.3, das Programm ist CDCat (von cdcat.sourceforge.net)

Ich krieg bei der versuchten Installation des RPMs eine Meldung:
RobinLinux:~ # apt install /home/ojkastl/Administration/RPMs_ab_20050818/installiert/cdcat-0.99-1.i586.rpm
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Selecting Cdcat for '/home/ojkastl/Administration/RPMs_ab_20050818/installiert/cdcat-0.99-1.i586.rpm'
Einige Pakete konnten nicht installiert werden. Dies könnte bedeuten,
dass Sie eine unmögliche Situation angefordert haben oder, falls Sie die
instabile Distribution verwenden, dass einige benötigte Pakete noch nicht
erzeugt oder aus 'Incoming' verschoben worden sind.

Da Sie nur eine einzelne Operation angefordert haben, ist es extrem
wahrscheinlich, dass das Paket schlichtweg nicht installierbar ist und
ein Bugreport über dieses Paket eingereicht werden sollte.
Die folgende Information könnte helfen die Sitation zu beheben:

Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
Cdcat: Hängt ab von: libqt.so.3
E: Fehlerhafte Pakete
RobinLinux:~ #
Und diese libqt.so.3 ist laut apt-Suche in qt3-non-mt.

Und die ist seit ein paar Tagen nicht mehr aufzufinden, zumindest nicht in einer Version für mein aktuelles qt.

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 19. Nov 2005, 10:10

qt3-non-mt gibt es doch für SuSE 9.3:

http://rpm.pbone.net/index.php3/stat/4/ ... 6.rpm.html

Erst ab SuSE 10.0 ist es weg, was aus den genannten Gründen auch sinnvoll ist, weil alte C++-Programme (kompiliert mit GCC < 3.4) auf SuSE 10.0 (kompiliert mit GCC 4.0) sowieso nicht mehr laufen würden.

Keine Ahnung, warum apt das Paket nicht findet. Vielleicht sind Deine Quellen unvollständig. Welches qt3-Paket hast Du denn installiert?

Code: Alles auswählen

rpm -q qt3
Probier das oben verlinkte RPM einfach mal von Hand zu installieren, und wenn die Versionen nicht zusammenpassen, such selbst auf rpm.pbone.net nach einer passenden Version oder downgrade qt3 auf eine Version, für die es ein passendes qt3-non-mt gibt. Zur Not eben von Hand.

Wenn es gar nicht anders geht, kannst Du auch den Compiler anwerfen und selbst ein Paket passend zu Deiner Qt-Version erstellen.

ojkastl
Hacker
Hacker
Beiträge: 547
Registriert: 15. Dez 2004, 04:51
Wohnort: Erlangen
Kontaktdaten:

Beitrag von ojkastl » 19. Nov 2005, 10:17

Moment:

Ich hab nicht bestritten dass es keinen Installationskandidaten mehr gibt. Nur passt keiner davon zu meiner momentanen qt3.
RobinLinux:~ # apt install qt3-non-mt
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Einige Pakete konnten nicht installiert werden. Dies könnte bedeuten,
dass Sie eine unmögliche Situation angefordert haben oder, falls Sie die
instabile Distribution verwenden, dass einige benötigte Pakete noch nicht
erzeugt oder aus 'Incoming' verschoben worden sind.

Da Sie nur eine einzelne Operation angefordert haben, ist es extrem
wahrscheinlich, dass das Paket schlichtweg nicht installierbar ist und
ein Bugreport über dieses Paket eingereicht werden sollte.
Die folgende Information könnte helfen die Sitation zu beheben:

Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
qt3-non-mt: Hängt ab von: qt3 (= 3.3.4) aber 3.3.5-17 wird installiert werden
E: Fehlerhafte Pakete
RobinLinux:~ #

Benutzeravatar
pawe
Member
Member
Beiträge: 148
Registriert: 14. Dez 2004, 21:38
Wohnort: Bayern
Kontaktdaten:

Beitrag von pawe » 19. Nov 2005, 13:12

Hallo Saber_Rider

das qt3-non-mt befindet sich im kde-Repository.

Code: Alles auswählen

 qt3-non-mt: Hängt ab von: qt3 (= 3.3.4) aber 3.3.5-17 wird installiert werden 
Das ist die entscheidende Zeile: Du hast eine neuere Version von qt3 als qt3-non-mt sie braucht. Man könnte qt3 downgraden (Wenn es geht).

mit

Code: Alles auswählen

apt install qt-non-mt qt3=3.3.4
sollte die Installation klappen :wink:

Gruß pawe
P III, 700 MHz, 384 MB Ram, SuSE 9.3 - fluxbox/idesk // NB: AMD 2800+, 704 MB Ram, SuSE 9.3 - KDE 3.4.

Fundiertes Wissen über Linux: www.de.linwiki.org
HowTo´s, Tutorials, Softwarelisten, Begriffserklärungen und vieles mehr!

ojkastl
Hacker
Hacker
Beiträge: 547
Registriert: 15. Dez 2004, 04:51
Wohnort: Erlangen
Kontaktdaten:

Beitrag von ojkastl » 19. Nov 2005, 23:16

Eben das will ich nicht, weil ganz viel anderes von qt in der 3.5-Version abhängt. Was ich eigentlich in Erfahrung bringen wollte ist ob es für qt3-3.5 eine qt3-non-mt geben wird, oder nicht. Wenn ja muss ich warten, wenn nicht muss ich ne andere Lösung finden. Evtl. neues RPM bauen. O.ä.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast