smart bleibt nach dem Download oftmals hängen...

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Hype
Member
Member
Beiträge: 171
Registriert: 23. Aug 2004, 19:48
Wohnort: Winden im schönen Schwarzwald

smart bleibt nach dem Download oftmals hängen...

Beitrag von Hype » 10. Nov 2005, 15:55

smart ist ja an sich eine gute Sache, habe jetzt mal ein wenig damit rumgespielt! Leider passiert es sehr oft (bei mir zumindest), dass smart nach dem Download der Pakete und während der Installation einfach hängen bleibt!

Die Folge ist meist, dass das Paktet nicht richtig funktioniert! So ging es mir zum Beispiel beim OpenOffice 2 Paket. Da ich dieses Problem jetzt schon öfters hatte, hoffe ich mal, dass es nicht noch zu weiteren Schäden führt!!!

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 10. Nov 2005, 16:05

bitte zukünftig immer die SuSE-Version und die smart-Version angeben, ich bin kein Hellseher ;)

evtl hilft ein upgrade auf die neueste Version
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Hype
Member
Member
Beiträge: 171
Registriert: 23. Aug 2004, 19:48
Wohnort: Winden im schönen Schwarzwald

Beitrag von Hype » 10. Nov 2005, 16:08

Sorry, also hier die Infos

System: Suse 10
smart-Version: 0.40-12

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 10. Nov 2005, 16:42

Sehr wahrscheinlich ist es nicht hängen geblieben. smart ist nur SEHR langsam, insbesondere wenn es mit GUI läuft. Einfach laufen lassen. Kann schon mal 'ne dreiviertel Stunde dauern...
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

Hype
Member
Member
Beiträge: 171
Registriert: 23. Aug 2004, 19:48
Wohnort: Winden im schönen Schwarzwald

Beitrag von Hype » 10. Nov 2005, 17:01

Tja, also die GUI lief eine gute Stunde und blieb dann wie gesagt beim OO2-Paket bei 50% hängen. Vorhin versuchte ich das gleiche nocheinmal, da war es dann das SAMBA-Paket, welches sich nicht installieren lassen wollte!

Werde mal versuchen über nacht alles laufen zu lassen...vielleicht wache ich ja morgen auf und alles hat sich in Wohlwollen verwandelt...

Hype
Member
Member
Beiträge: 171
Registriert: 23. Aug 2004, 19:48
Wohnort: Winden im schönen Schwarzwald

Beitrag von Hype » 13. Nov 2005, 13:39

So nachdem ich mir mein komplettes KDE abgeschossen hatte musste ich es mit der SuSe-DVD wieder lauffähig machen! Danach versuchte ich ein weiteres Mal SMART das Update durchführen zu lassen, doch auch dieses Mal blieb es bei der "Bereinigung" eines Paketes hängen, was sich auch nach einigen Stunden nicht veränderte!

Ich werde jetzt vorerst mal die Finger davon lassen, bis das Progie richtig ausgewachsen ist!

Hype
Member
Member
Beiträge: 171
Registriert: 23. Aug 2004, 19:48
Wohnort: Winden im schönen Schwarzwald

Beitrag von Hype » 13. Nov 2005, 16:10

Noch als Tipp für die Entwickler:
Mir ist aufgefallen, dass SMART vor allem dann hängen bleibt, wenn ein Paket eine "Protokoll"-Fenster aufruft! Danach geht SMART einfach nicht weiter (bei dem SAMBA-Server-Paket zum Beispiel)

eet
Member
Member
Beiträge: 73
Registriert: 29. Apr 2005, 14:23

Beitrag von eet » 13. Nov 2005, 21:56

Tatsächlich habe auch ich dieses Problem bei einem größeren Update (praktisch der gesamte Gnome-Desktop und anderes) beobachtet. Ich habe Smart ganz brutal ein Dutzend mal abgeschossen, danach jeweils das Update weiter laufen lassen und am Ende einmal bereinigt. OHNE zwischendurch neu zu starten, versteht sich. Das Ergebnis war OK, aber der Weg dahin...

(SuSE 10.0, Smart jeweils die neueste Version vom guru, also weiß ich leider nicht mehr, welche das Problem hatte... :-()

Benutzeravatar
DemoFreak
Member
Member
Beiträge: 92
Registriert: 29. Feb 2004, 16:03
Kontaktdaten:

Beitrag von DemoFreak » 13. Nov 2005, 22:54

Kann ich bestätigen. Bei mir trat das schon bei einer zu installierenden Anzahl von ca. 15 Paketen auf, da blieb es dann beim 8. oder 9. hängen.

(SuSE 10.0, smart ebenfalls immer auf dem aktuellen Stand der suser-Repos)
"Das Licht am Ende des Tunnels ist ein entgegenkommender Zug."

Bild

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast