Installation eines Paketes mit Yast

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
padersuse
Member
Member
Beiträge: 200
Registriert: 13. Mai 2005, 09:30

Installation eines Paketes mit Yast

Beitrag von padersuse » 27. Okt 2005, 10:24

Hallo,

ich habe folgendes Problem : Ich möchte auf einem Suse Linux 9.3 Rechner DVDREAD und DVDAUTHOR installieren bzw. ein Update dafür vornehmen. Ein notwendiges Paket dafür ist z.B. libdvdread.so.3. Dieses ist auf meinem Rechner auch vorhanden. Trotzdem meckert yast bei der Installation, er würde diese Paket benötigen. Ich hab schon rpm --rebuilddb laufen lassen und auch über die Installations-DVD eine Reparatur der Software laufenlassen, es hat aber nichts geändert. Auf einem anderen Rechner klappte alles. Was läuft falsch

Gruß Padersuse

Werbung:
Benutzeravatar
admine
Administrator
Administrator
Beiträge: 8723
Registriert: 15. Feb 2004, 21:13
Wohnort: Dresden
Kontaktdaten:

Beitrag von admine » 27. Okt 2005, 10:30

Könntest du evt. die genaue Fehlermeldung dazu posten?
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

nollsa
Advanced Hacker
Advanced Hacker
Beiträge: 1072
Registriert: 31. Mär 2004, 21:02
Kontaktdaten:

Beitrag von nollsa » 27. Okt 2005, 11:39

hat er bei mir auch gemacht. scheint nen kleiner bug in den paketen zu sein. zwing ihn einfach mit rpm -Uvh --force *.rpm (oder dein paketname, je nachdem wo dus liegen hast) die pakete zu installieren. im notfall noch die abhängigkeiten mit --nodeps ausschalten. bei mir liefs dann.
Acer Aspire 5610
SuSE 10.3, KDE 3.5.5

padersuse
Member
Member
Beiträge: 200
Registriert: 13. Mai 2005, 09:30

Installation eines rpm-Paketes

Beitrag von padersuse » 28. Okt 2005, 07:26

Folgende Fehlermeldung wird ausgegeben (habs dann in der Konsole mit rpm -Uhv versucht) :

warning: dvdauthor-0.6.11-0.pm.1.suse93.i586.rpm: V3 DSA signature: NOKEY, key ID cd3140cd
error: Failed dependencies:
libdvdread.so.3 is needed by dvdauthor-0.6.11-0.pm.1
libMagick.so.6 is needed by dvdauthor-0.6.11-0.pm.1

Beide lib-dateien sind aber auf meinem Rechner :
/usr/lib64/libMagick.so.6 und
/usr/lib64/libdvdread.so.3

Padersuse

nollsa
Advanced Hacker
Advanced Hacker
Beiträge: 1072
Registriert: 31. Mär 2004, 21:02
Kontaktdaten:

Beitrag von nollsa » 28. Okt 2005, 08:22

dann versuchs mal ohne abhängigkeiten rpm -Uvh --force --nodeps *.rpm, wie gesagt bei mir liefs dann.
Acer Aspire 5610
SuSE 10.3, KDE 3.5.5

Antworten

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 1 Gast