kann smart-channels nicht hinzufügen

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Benutzeravatar
Sören
Member
Member
Beiträge: 63
Registriert: 9. Nov 2004, 18:07

kann smart-channels nicht hinzufügen

Beitrag von Sören » 26. Okt 2005, 17:38

Hallo,

ich habe mit Interesse die Howtos von oc2pus zum Thema smartpm gelesen.

Leider kriege ich es nicht hin, weitere channels hinzuzufügen.

Also die Datei ist da...

Code: Alles auswählen

# cat /etc/smart/channels/suser-oc2pus-gwd.channel
[oc2pus-apt]
name = suser-oc2pus 3rd party package repository for SUSE Linux on 
ftp.gwdg.de
baseurl = http://ftp4.gwdg.de/pub/linux/suse/apt/SuSE/9.3-i386
type = apt-rpm
components = suser-oc2pus
(bei mir ist es /etc/smart/channels und nicht nur channel, wie im Howto. Weiß nicht, ob das einfach unterschiedlich, oder nur ein Fipptehler ist).

Also:

Code: Alles auswählen

linux:/home/soeren # smart channel --add /etc/smart/channels/suser-oc2pus-gwd.channel 

Alias: oc2pus-apt
Variante: apt-rpm
Name: suser-oc2pus 3rd party package repository for SUSE Linux on
Basis-URL: http://ftp4.gwdg.de/pub/linux/suse/apt/SuSE/9.3-i386
Komponenten: suser-oc2pus

Diesen Channel einschließen? (j/N) : j
Scheint also geklappt zu haben.

Wenn ich aber jetzt smart --gui oder smart update starte, dann ist vom oc2pus-channel nichts zu sehen.

Auch smart --show zeigt nur folgendes (die, die schon von anfang an dabei sind):

Code: Alles auswählen

linux:/home/soeren # smart channel --show
[rpm-sys]
type = rpm-sys
name = RPM System

[guru-apt]
type = apt-rpm
name = suser-guru 3rd party package repository for SUSE Linux on ftp.gwdg.de
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386
components = suser-guru

[suse-apt-gwdg]
type = apt-rpm
name = SUSE Linux packages apt-rpm repository on ftp.gwdg.de
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386
components = security

[packman-apt]
type = apt-rpm
name = Packman 3rd party package repository for SUSE Linux on ftp.gwdg.de
baseurl = http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386
components = packman packman-i686
Das hier:
http://linux-club.de/viewtopic.php?t=44913

habe ich auch durchgeführt.. ohne erfolg.
In /etc/smart/channels sind immernoch nur die 6 Dateien, wovon eine die oc2pus -Datei ist, die ja offenbar auch nicht funktioniert.


Kann mir da jemand helfen?


Danke im vorraus

gruß
Sören

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 26. Okt 2005, 17:44

smart update mal laufen lassen

das HowTo ist gerade in Arbeit ... also bitte nicht auf Tippfehler und Unvollständigkeit festnageln ;)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
Sören
Member
Member
Beiträge: 63
Registriert: 9. Nov 2004, 18:07

Beitrag von Sören » 26. Okt 2005, 17:53

oc2pus hat geschrieben:smart update mal laufen lassen

Code: Alles auswählen

linux:/home/soeren # smart update
Lade Zwischenspeicher...
Update Zwischenspeicher...                                                   ############################################################################################################ [100%]

Hole Informationen für 'suser-guru 3rd party package repository for SUSE Linux on ftp.gwdg.de'                                                                                                  
-> http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386/base/release                                                                                                                            
release                                                                      ############################################################################################################ [  9%]
                                                                                                                                                                                                
Hole Informationen für 'SUSE Linux packages apt-rpm repository on ftp.gwdg.de'
                                                                                                                                                                                                
Hole Informationen für 'Packman 3rd party package repository for SUSE Linux on ftp.gwdg.de'

Update Zwischenspeicher...                                                   ############################################################################################################ [100%]

Channel haben keine neuen Pakete
linux:/home/soeren # 
Bringt irgendwie nichts... die anderen Channel sind immernoch weg (smart channel --show, smart --gui, etc..)
das HowTo ist gerade in Arbeit ... also bitte nicht auf Tippfehler und Unvollständigkeit festnageln ;)
Klar. Ist schon toll, dass du dir die ganze Mühe machst. Aber ich dachte mir, wenn ich den Fehler schon gefunden habe, dann musst du ihn nicht mehr finden ;-)

gruß
Sören

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 26. Okt 2005, 18:00

man soll Postings immer genau lesen
man soll Postings immer genau lesen
man soll Postings immer genau lesen
man soll Postings immer genau lesen
man soll Postings immer genau lesen

für SuSE-10 habe ich noch kein Repository ;)
deshalb wird da nix angezeigt, das sample war für SuSE-9.3
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
Sören
Member
Member
Beiträge: 63
Registriert: 9. Nov 2004, 18:07

Beitrag von Sören » 26. Okt 2005, 18:12

Ah... OK..

Aber die Channelliste für 10.0 kann ich auch nicht hinzufügen :-(

cherzog
Newbie
Newbie
Beiträge: 1
Registriert: 18. Okt 2005, 16:32

Beitrag von cherzog » 27. Okt 2005, 17:26

Versuch es mal mit dem Schalter -y

smart channel -y --add /PfadZuDerChanneldatei

Irgendwie wird bei mir bei der Abfrage das "j" oder "J" nicht akzeptiert (evtl. müsste man "y" eingeben??).
Zuletzt geändert von cherzog am 28. Okt 2005, 13:26, insgesamt 1-mal geändert.

Benutzeravatar
Sören
Member
Member
Beiträge: 63
Registriert: 9. Nov 2004, 18:07

Beitrag von Sören » 27. Okt 2005, 17:43

Danke für eure Hilfe...

das Problem war ein ganz anderes:

Ich war nicht der "richtige" root, sondern hatte mich nur mit "su" als root angemeldet.

Anscheinend liegen da auch nicht alle wichtigen sachen aufm dem $path vom "root".

Zumindest mit "su -" klappts jetzt alles.


Gruß
Sören

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 27. Okt 2005, 23:34

Sören hat geschrieben:Zumindest mit "su -" klappts jetzt alles.
dann scheint in SuSE-10 der Zugriff von root auf den X-Server wieder erlaubt zu sein ...
falls "su -" nicht klappt für den Start der GUI etc, einfach mal "sux -" probieren.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast