Problem bei update SuSE-9.2 auf SuSE-9.3

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Undying
Member
Member
Beiträge: 73
Registriert: 26. Sep 2005, 11:32

Problem bei update SuSE-9.2 auf SuSE-9.3

Beitrag von Undying » 29. Sep 2005, 15:32

Also ich hab versucht das Tutorial für das updaten von 9.1 -> 9.2 auf meine Bedürfnisse anzuwenden, in diesem Fall update von 9.2 -> 9.3.
Seite gerade fängt APT an ein bisschen verrückt zu spielen und schmeißt mir Fehlermeldungen raus.
Repos sind hier die Beispielliste:
http://ftp.gwdg.de/pub/linux/suse/apt/S ... s.list.FTP

Bei:
apt update

kam folgendes:
(vorher hatte er die entsprechenden Listen vom Server geholt.)
/usr/bin/apt: line 123: 6949 Segmentation fault apt-get $ARG

bei:
apt -s dist-upgrade | tee upgrade.txt

Reading Package Lists.../usr/bin/apt: line 123: 6959 Segmentation fault apt-get $ARG


Würde mich über Tipps & Hilfe freuen. Bin doch SuSE (und auch denk ich Linux) - Neuling ;-) Danke!

//EDIT
Bevor wer anfängt zusagen, du hast falsch gemacht oder was weiß ich. Bestimmt ist das der Fall aber laut der Anleitungen und meinen vergleichen stimmt alles über ein. Zudem weiß ich entsprechende Line nicht zuzuordnen.
Zuletzt geändert von Undying am 29. Sep 2005, 15:33, insgesamt 1-mal geändert.

Werbung:
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 29. Sep 2005, 15:33

Schaut mir danach aus:

http://www.linux-club.de/viewtopic.php?t=42511

Und nimm BITTE diese Repos raus, so kann das nix werden...

kernel-of-the-day
update-drpm
update-prpm
ximian
usr-local-bin
suse-people
suse-projects
kde-unstable
security-prpm
Zuletzt geändert von Grothesk am 29. Sep 2005, 15:36, insgesamt 1-mal geändert.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

Undying
Member
Member
Beiträge: 73
Registriert: 26. Sep 2005, 11:32

Beitrag von Undying » 29. Sep 2005, 16:31

Der obige Fehler konnte behoben werden, aber hier folgende Ausgabe nachdem ich bei Schritt 18 angelangt bin habe ich das angelegte Script ausgeführt und dann kam nach einigen Fehlermeldungen die ich erfolgreich lösen konnte, noch mehr aber eben "nur" unmet dependencies. Wie finde ich Dateien die irgendwo enthalten sein könnten?

Hier die Liste:

Code: Alles auswählen

Xalan-c: Depends: libicui18n.so.32
           Depends: libicuuc.so.32
  Xerces-c: Depends: libicudata.so.32
            Depends: libicuuc.so.32
  bug-buddy: Depends: libgnome-menu.so.2 but it is not installable
  control-center2: Depends: libgnome-menu.so.2 but it is not installable
  cvs2svn: Obsoletes: subversion-cvs2svn
  eel: Depends: libgnome-menu.so.2 but it is not installable
  evolution-data-server: Depends: libgnutls.so.11
  gedit: Depends: libgnome-menu.so.2 but it is not installable
  gnome-media: Depends: gstreamer-plugins-default but it is not going to be installed
               Depends: gstreamer-plugins-extra but it is not going to be installed
  jamin: Depends: libcairo.so.1
  libsoup: Depends: libgnutls.so.11
           Depends: libgnutls.so.11(GNUTLS_REL_1_0_9)
  nautilus: Depends: libgnome-menu.so.2 but it is not installable
  planner: Depends: libcamel-1.2.so.0
           Depends: libcamel-provider-1.2.so.6 but it is not installable
           Depends: libebook-1.2.so.5 but it is not installable
           Depends: libecal-1.2.so.3 but it is not installable
           Depends: libedata-cal-1.2.so.1
           Depends: libedataserver-1.2.so.4
           Depends: libeutil.so.0
  subversion-cvs2svn: Depends: python (< 2.3.99) but 2.4-14 is to be installed
  totem: Depends: gstreamer-plugins-extra but it is not going to be installed
  viewcvs: Obsoletes: subversion-viewcvs
Zum Teil Pakete enthalten die gelöscht werden sollen.

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 29. Sep 2005, 16:34

Auch mal 'gnome' aus der sources.list nehmen.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 29. Sep 2005, 16:43

cvs2svn: Obsoletes: subversion-cvs2svn
Meldungen dieser Bauart werden durch Einfügen von "subversion-cvs2svn- cvs2svn" in deinem Update-Script erledigt.
subversion-cvs2svn: Depends: python (< 2.3.99) but 2.4-14 is to be installed
d.h. mit grosser Wahrschienlichkeit ist deine installierte Version neuer als die von 9.3, d.h. du musst explizit subversion-cvs2svn=<version> in deinem Script eintragen, aber dieses Paket ist eh obsolet...

Ich würde mir das Leben vereinfachen und diese "Störenfriede" erst mal alle deinstallieren. Sie werden ja durch dein script eh neu installiert, aber in der neuen SuSE-9.3er Version.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Undying
Member
Member
Beiträge: 73
Registriert: 26. Sep 2005, 11:32

Beitrag von Undying » 29. Sep 2005, 19:34

Das Skript läuft durch :-) Dann scheitert aber nachdem ich mit Y bestätigt habe bei dem Verbindungsaufbau mit folgender Meldung:

Code: Alles auswählen

E: Method ftp has died unexpectedly!
E: Tried to dequeue a fetching object
Dachte erst das wäre eine Ausnahme weil ich vielleicht zu lange benötigt habe oder so aber anscheinend bleibt das auch weiterhin.

//EDIT
Hab gesehen das der eh am lahmen und entsprechenden Thread aufgesucht und ftp4... andstatt ftp... Jetzt sagt er mir wiederum kann Paket afs-kbr5 nicht finden. Ist das da unvollständig?

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste