Nach Update Umlaute weg

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Benutzeravatar
trapper
Newbie
Newbie
Beiträge: 23
Registriert: 19. Feb 2005, 12:05
Wohnort: Staufenberg/Hessen

Nach Update Umlaute weg

Beitrag von trapper » 23. Sep 2005, 16:38

Servus beisammen,


Situation:
Dateiserver mit SuSE 8.x wurde auf 9.3 geupdated. Dabei wurde kein echtes Update gemacht, sondern SuSE 9.3 wurde sauber neu installiert.
In dem Rechner sind 2 zusätzliche Festplatten, die als Dateiablage im Windows-Netz dienen (Samba). Diese beiden Platten waren ursprünglich unter 8.x eingerichtet worden, wurden beim Wechsel auf 9.3 ohne Änderungen übernommen, und werden sauber gemountet. Platten haben als Dateisystem-ID "0x83 Linux".

Problem:
Umlaute in Archiv- und Dateinamen auf den beiden Dateiserver-Festplatten werden nach dem Wechsel auf 9.3 nicht mehr dargestellt. Und zwar nicht nur über das Netz/Samba, sondern auch beim Direktzugriff auf dem Rechner.

Lösungsversuch:
* mit und ohne UTF-8 Kodierung in Spracheinstellungen = kein Unterschied
* /etc/sysconfig/languages mit Zeichensatz ISO-8859-15 = kein Unterschied

Bei <locale> zeigt er bei allen Einstellungen immer "LC-CTYPE=de_DE.UTF-8" an.

Gibt es noch eine andere Konfig zum Einstellen der Zeichensatzparameter?


Viele Grüße,

CV
--
Christian Velten

-- Powered by David Pro XL --
The incredible CV strikes again!

Werbung:
SP
Member
Member
Beiträge: 206
Registriert: 14. Mär 2004, 09:43

Beitrag von SP » 24. Sep 2005, 01:26

evtl benutzt der mount befehl die falsche codepage - versuch ma in /etc/fstab die zeile die die platte(n) betrifft mit iocharset=iso8859-1 (latin-1) zu ergänzen (das is zwar eigentlich standard aber wer weiß)

statt iso8859-1 kannste auch ma iso8859-15 oder utf-8 versuchen

gruß sp
Die Optimisten glauben, dass wir auf der besten aller möglichen Welten leben;
Die Pessimisten befürchten, dass das stimmt.

openSUSE 10.3

Benutzeravatar
trapper
Newbie
Newbie
Beiträge: 23
Registriert: 19. Feb 2005, 12:05
Wohnort: Staufenberg/Hessen

Beitrag von trapper » 27. Sep 2005, 00:58

SP hat geschrieben:evtl benutzt der mount befehl die falsche codepage - versuch ma in /etc/fstab die zeile die die platte(n) betrifft mit iocharset=iso8859-1 (latin-1) zu ergänzen (das is zwar eigentlich standard aber wer weiß)
Servus,

danke für die Info. habe ich probiert, aber da gibt er mir nur einen file system Fehler aus und ich kann das Laufwerk nicht mehr mounten.

Viele Grüße,

trapper
--
Christian Velten

-- Powered by David Pro XL --
The incredible CV strikes again!

Benutzeravatar
trapper
Newbie
Newbie
Beiträge: 23
Registriert: 19. Feb 2005, 12:05
Wohnort: Staufenberg/Hessen

Beitrag von trapper » 7. Okt 2005, 13:01

Ergänzend ...

Wenn ich neue Dateien anlege oder Dateien umbenenne, kann ich Umlaute verwenden. Nur die "alten" Umlaute der Datei- udn Archivnamen scheinen beim Wechsel von 8.x zu 9.3 verloren gegangen zu sein.

:?: :?: :?:


trapper
--
Christian Velten

-- Powered by David Pro XL --
The incredible CV strikes again!

Benutzeravatar
nbkr
Guru
Guru
Beiträge: 2857
Registriert: 10. Jul 2004, 15:47

Beitrag von nbkr » 7. Okt 2005, 13:03

Du kannst in YaST unter System -> Sprache den Zeichensatz umstellen.
Kann gar nicht sein, ich bin gefürchtet Wald aus, Wald ein.

Benutzeravatar
trapper
Newbie
Newbie
Beiträge: 23
Registriert: 19. Feb 2005, 12:05
Wohnort: Staufenberg/Hessen

Beitrag von trapper » 14. Okt 2005, 15:38

nbkr hat geschrieben:Du kannst in YaST unter System -> Sprache den Zeichensatz umstellen.
Das habe ich natürlich als Erstes überprüft! :wink:

Nee, das ist alles in Ordnung. Alle Codierungs-Einstellungen scheinen in Ordnung zu sein. Ich kann ja auch sowohl über Samba-Share-Zugriff als auch direkt am Linuxrechner neue Dateien mit Umlautnamen auf dem Share/dem Mount erstellen und bearbeiten.

Nur die alten, die vor dem Wechsel von SuSE 8 auf SuSE 9 angelegt worden waren, sind weg. Und da es eine Dateiserverplatte ist, wäre es ein enormer Aufwand, die alle wieder manuell zu ändern.

Ich verstehe auch nicht, warum das Problem ausgerechnet dann auftaucht, wenn ich eine native Linuxpartition, die mit Linuxdateisystem formatiert ist, von einem Linuxsystem in ein anderes übernehme? :cry:

Ich würde mich echt freuen, wenn vielleicht doch noch jemand etwas einfällt!

BTW, den faux-pas, die SuSE-Version mit der Linux-Version zu verwechseln, habe ich in meinen Postings bewusst vermieden. :wink:


Viele Grüße,

trapper
--
Christian Velten

-- Powered by David Pro XL --
The incredible CV strikes again!

Benutzeravatar
trapper
Newbie
Newbie
Beiträge: 23
Registriert: 19. Feb 2005, 12:05
Wohnort: Staufenberg/Hessen

Beitrag von trapper » 18. Okt 2005, 13:57

Also, wie ich gerade in http://www.linux-club.de/viewtopic.php?t=6420 gesehen habe, scheine ich nicht der einzige mit Codepage-Problemen zu sein.

Zumindest den Samba-Zugriff konnte ich zwischenzeitlich lösen, indem ich smb.conf um unix charset = utf-8 ergänzt habe. Damit waren beim Zugriff auf das share eine ganze Menge Umlaute schon wieder da (wenn auch nicht in allen Verzeichnissen).

Auf dem Linux-Rechner selber sehe ich die Umlaute zwar immer noch nicht, aber das ist momentan nicht so schlimm.

Im file language habe ich jetzt übrigens folgendes stehen ...

Code: Alles auswählen

RC_LANG="de_DE@euro"
RC_LC_ALL="de_DE@euro"
ROOT_USES_LANG="ctype"
AUTO_DETECT_UTF8="yes"
INSTALLED_LANGUAGES="de_DE@euro"
Da andere User Probleme beim Einstellen von UTF-8 in language berichtet haben, werde ich das vorerst vermeiden.


Viele Grüße,

trapper
--
Christian Velten

-- Powered by David Pro XL --
The incredible CV strikes again!

Benutzeravatar
trapper
Newbie
Newbie
Beiträge: 23
Registriert: 19. Feb 2005, 12:05
Wohnort: Staufenberg/Hessen

Beitrag von trapper » 19. Okt 2005, 17:14

Aaaalso ... für alle, die dasselbe Problem haben oder die es interessiert, habe ich jetzt mal alle Lösungsversuche zusammengestellt ...

Problem: Nach Wechsel von SuSE 8.x auf SuSE 9.3 werden auf zwei Dateiserverpatten im System (0x83 Linux, ReiserFS) Umlaute in Datei- und Archivnamen nicht mehr dargestellt (und zwar schon bei Zugriff im Linuxsystem nicht). Beide Platten wurden unter SuSE 8.x installiert und eingerichtet und waren in der vergangenheit über Samba von Windows-Rechnern (XP, WinServer 2003) über Samba genutzt worden.


Lösungsansätze:


1. YaST Spracheinstellungen
Primäre Sprache "Deutsch" eingestellt.
Locale-Einstellungen für den Benutzer root "nur ctype" und "ja" ausprobiert. (aktuell "ja")
UTF-8 Kodierung eingeschaltet und ausgeschaltet ausprobiert. (aktuell eingeschaltet)
Problem bleibt.


2. Locale (aktuell)

Code: Alles auswählen

LANG=de_DE.UTF-8
LC_CTYPE="de_DE@euro"
LC_NUMERIC="de_DE@euro"
LC_TIME="de_DE@euro"
LC_COLLATE="de_DE@euro"
LC_MONETARY="de_DE@euro"
LC_MESSAGES="de_DE@euro"
LC_PAPER="de_DE@euro"
LC_NAME="de_DE@euro"
LC_ADDRESS="de_DE@euro"
LC_TELEPHONE="de_DE@euro"
LC_MEASUREMENT="de_DE@euro"
LC_IDENTIFICATION="de_DE@euro"
LC_ALL=de_DE@euro
3. Datei etc/sysconfig/language

Code: Alles auswählen

string(POSIX,ca_ES.ISO-8859-1,ca_ES.UTF-8, cs_CZ.ISO-8859-2,cs_CZ.UTF-8,da_DE@euro,da_DK.ISO-8859-1, da_DK.UTF-8,de_DE@euro,de_DE.ISO-8859-1,de_DE.UTF-8, el_GR.ISO-8859-7,el_GR.UTF-8,en_GB.ISO-8859-1,en_GB.UTF-8, en_IE@euro,en_IE.ISO-8859-1,en_US.ISO-8859-1,es_ES@euro, es_ES.ISO-8859-1,es_ES.UTF-8,fr_FR@euro,fr_FR.ISO-8859-1, fr_FR.UTF-8,gl_ES@euro,gl_ES.ISO-8859-1,gl_ES.utf-8, hr_HR.ISO-8859-2,hu_HU.ISO-8859-2,hu_HU.UTF-8,it_IT@euro, it_IT.ISO-8859-1,it_IT.UTF-8,ja_JP.eucJP,ja_JP.UTF-8,lt_LT. ISO-8859-13,lt_LT.UTF-8,nl_NL@euro,nl_NL.ISO-8859-1, nl_NL.UTF-8,ru_RU.ISO-8859-5,ru_RU.KOI8R,ru_RU.UTF-8, sk_SK.ISO-8859-2,sk_SK.UTF-8,tr_TR.ISO-8859-9,tr_TR.UTF-8, ko_KR.eucKR,ko_KR.UTF-8,zh_TW.Big5,zh_TW.UTF-8, zh_CN.GB2312,zh_CN.UTF-8)
RC_LANG="de_DE.UTF-8"
RC_LC_ALL="de_DE@euro"
RC_LC_MESSAGES=""
RC_LC_CTYPE=""
RC_LC_COLLATE=""
RC_LC_TIME=""
RC_LC_NUMERIC=""
RC_LC_MONETARY=""
RC_LC_PAPER=""
ROOT_USES_LANG="yes"
AUTO_DETECT_UTF8="yes"
INSTALLED_LANGUAGES="de_DE"
INPUT_METHOD=""
4. Datei etc/fstab
Nach Ergänzen der Parameter iocharset=iso8859-1, iocharset=utf-8, unixcharset=iso8859-1 oder unixcharset=utf-8 werden die Laufwerke gar nicht gemounted. (aktuell "defaults")
Problem bleibt.


5. Laufwerk konvertieren

Code: Alles auswählen

convmv -f iso-8859-1 -t utf8 -i -r --notest /mountpoint/der/betroffenen/partition
... mit dem Resultat, dass fehlerhafte Umlaute (Kastensymbol) durch fehlerhafte andere Zeichen (Kastensymbol+"Â") ersetzt werden sollen. Allerdings scheint convmv die Datei- und Archivnamen zumindest als iso-8859-1 zu akzeptieren und zu erkennen.
Beim Versuch des umgekehrten Wegs von utf8 zu iso-889-1 meckert convmv, dass die Dateien keine UTF-8-kodierte Namen hätten.
Problem bleibt.


So, habe nun sp ziemlich alle Hinweise und Tipps diverser threads in diesem Forum getestet, und bin keinen Schritt weiter. Muss ich mich damit abfinden, dass meine Daten Schrott sind? :cry:

Und wie kann ich das zumindest das nächste Mal (Systemupdate, Ausbau der Platte und Einbau in einen anderen -Linux-Rechner, etc.) von vornherein vermeiden? :?:


Fragt sich ...

trapper
--
Christian Velten

-- Powered by David Pro XL --
The incredible CV strikes again!

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast