Seite 1 von 1

Netzwerkinstallation

Verfasst: 17. Aug 2005, 14:34
von Arashi
Hi!
Ich möchte Suse 9.3 übers Netzwerk installieren, boote übers Netzwerk (PXE) was auch soweit tut.
Ich habe im tftpboot/pxelinux.cfg/default den nfs-pfad der cd-iso's angegeben aber nun will er anstelle, dass er installiert, dass ich die CD 1 einlege.
Wo könnte der Fehler liegen?/Wie kann ich die Problemursache weiter eingrenzen?
Lösungsvorschläge?

Verfasst: 17. Aug 2005, 15:07
von nobbiew
Ich denke nicht dass das so geht. Da bei PXE ein Diskettenlaufwerk emuliert wird. Also glaubt er, er sei auf A: (ich weiß das Linux /dev/fd0 annimmt).

Was du tun musst ist einen FTP o. NFS-Server mit den CD´s bestücken und dann das ISO für die Netzsinstallation im TFTP-Server hinterlegen. Geht natürlich mit CD1 allerdings musst du von beginn an die Netzinstallation über NFS anwählen.

Verfasst: 17. Aug 2005, 15:14
von Arashi
Ich hab nen TFTP eingerichtet und die CD's als Iso's auf dem Server abgelegt und über NFS freigegeben wenn ich das Suse auf dem Client starte, was ja derzeit noch installiert ist, kann ich darauf zugreifen.
Aber wie sag ich dem Client, dass er auf die Iso´s zugreifen soll?

Verfasst: 17. Aug 2005, 15:22
von nobbiew
Leg in deinem NFS-ROOT ein verzeichnis suse93 mit den Unterverzeichnissen CD1 - CD5 an. Besser währe die DVD
dann mit

mount -o loop ISOCD1 NFS-ROOT/suse93/CD1
-
mount -o loop ISOCD5 NFS-ROOT/suse93/CD5

die CD´s mounten. Am Client dann per PXE o.g. ISO booten und eine NFS-Installation starten. Installroot ist dann
NFSSERVER:/NFS-ROOT/suse93

Yast findet dann die einzelnen CD´s selber. Besser wie gesagt du machst das mit der DVD, dann hast du gleich alles erschlagen.

Verfasst: 17. Aug 2005, 16:15
von Arashi
Es funktioniert leider immernoch nicht.
Ich hab jetzt in der tftpboot/pxelinux.cfg/default folgendes:

...
install=NFSSERVER:/NFS-ROOT/suse93

was auch nicht getan hat ist:
...
install=nfs://NFSSERVER/NFS-ROOT/suse93

Verfasst: 18. Aug 2005, 09:55
von Arashi
Ich hab aus der default-Datei mal den eintrag rausgenommen in dem auf das autoyastfile verwiesen wird.
An der Stelle, an der er nun nach der CD fragt breche ich ab um im yast anschließend die Installation zu starten und ihm als Installationsmedium den NFS zu geben. Die Konfiguration über den DHCP tut, nur bekomme ich folgende Fehlermeldung :

"An error occured while trying to mount the NFS directory
Reason given by Server: Permission denied"

hab auch schon nach gesucht, aber nichts gefunden, was mir weiterhelfen würde

Verfasst: 18. Aug 2005, 10:34
von nobbiew
Hast du NFS-SERVERROOT über /etc/exports freigegeben?

Verfasst: 18. Aug 2005, 10:48
von Arashi
jup

hab auch exportfs ausgeführt

Verfasst: 18. Aug 2005, 11:04
von nobbiew
Lass dir halt nicht alles aus der Nase ziehen. Wenn du schon ein Problem mit NFS hast, dann zeig uns halt auch den Eintrag in der /etc/exports
u. die ausgabe von

exportfs -v

zumindest den teil der uns hier interessiert.

Verfasst: 18. Aug 2005, 11:14
von Arashi
ja, sorry

exports:

/data/tftpboot *(rw)
/data/suse9.3 *(rw)

exportfs -v:

/data/tftpboot <world> (rw,wdelay,root_squash)
/data/suse9.3 <world> (rw,wdelay,root_squash)