[gelöst] Fehler in "apt install rpmkey* ??

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Benutzeravatar
Erischa
Member
Member
Beiträge: 119
Registriert: 21. Jun 2004, 18:36
Wohnort: Schweiz

[gelöst] Fehler in "apt install rpmkey* ??

Beitrag von Erischa » 17. Aug 2005, 01:08

Hallo,

es ist mir nicht möglich gpg-signierte Pakete zu installieren.
In meiner Konsole erscheint folgende Meldung

Code: Alles auswählen

apt install rpmkeys*
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Selecting rpmkey-suser-sbarnin for 'rpmkeys*'
Selecting rpmkey-suser-jogley_usr-local-bin for 'rpmkeys*'
Selecting rpmkey-suser-scorot for 'rpmkeys*'
Selecting rpmkey-apcupsd for 'rpmkeys*'
Selecting rpmkey-suser-guru for 'rpmkeys*'
Selecting rpmkey-stark for 'rpmkeys*'
Selecting rpmkey-appleonkel for 'rpmkeys*'
Selecting rpmkey-suser-tcousin for 'rpmkeys*'
Selecting rpmkey-suser-rbos for 'rpmkeys*'
Selecting rpmkey-suser-jmorris for 'rpmkeys*'
Selecting rpmkey-funktronics for 'rpmkeys*'
Selecting rpmkey-suse-meissner for 'rpmkeys*'
Selecting rpmkey-packman for 'rpmkeys*'
Selecting rpmkey-lmeyer for 'rpmkeys*'
Selecting rpmkey-suser-oc2pus for 'rpmkeys*'
Selecting rpmkey-suser-gbv for 'rpmkeys*'
Selecting rpmkey-bacula for 'rpmkeys*'
Selecting rpmkey-suser-ollakka for 'rpmkeys*'
Selecting rpmkey-suser-tux for 'rpmkeys*'
Die folgenden zusätzlichen Pakete werden installiert werden:
  rpmkey-apcupsd rpmkey-appleonkel rpmkey-bacula rpmkey-funktronics
  rpmkey-lmeyer rpmkey-packman rpmkey-stark rpmkey-suse-meissner
  rpmkey-suser-gbv rpmkey-suser-guru rpmkey-suser-jmorris
  rpmkey-suser-jogley_usr-local-bin rpmkey-suser-oc2pus rpmkey-suser-ollakka
  rpmkey-suser-rbos rpmkey-suser-sbarnin rpmkey-suser-scorot
  rpmkey-suser-tcousin rpmkey-suser-tux
Die folgenden NEUEN Pakete werden installiert werden:
  rpmkey-apcupsd rpmkey-appleonkel rpmkey-bacula rpmkey-funktronics
  rpmkey-lmeyer rpmkey-packman rpmkey-stark rpmkey-suse-meissner
  rpmkey-suser-gbv rpmkey-suser-guru rpmkey-suser-jmorris
  rpmkey-suser-jogley_usr-local-bin rpmkey-suser-oc2pus rpmkey-suser-ollakka
  rpmkey-suser-rbos rpmkey-suser-sbarnin rpmkey-suser-scorot
  rpmkey-suser-tcousin rpmkey-suser-tux
0 upgraded, 19 newly installed, 0 entfernt und 0 nicht upgegradet.
Muss 0B/111kB an Archiven holen.
Nach dem Auspacken werden 90,1kB zusätzlicher Plattenplatz benutzt werden.
Wollen Sie fortsetzen? [J/n] j
        /usr/bin/find is needed by (installed) aaa_base-9.3-9.2
        /usr/bin/xargs is needed by (installed) aaa_base-9.3-9.2
        libcrack.so.2 is needed by (installed) yast2-users-2.11.16-3
        libcrack.so.2 is needed by (installed) pam-0.78-8
        libcrack.so.2 is needed by (installed) pam-modules-9.3-4
        cracklib is needed by (installed) yast2-users-2.11.16-3
        shadow is needed by (installed) apache2-2.0.53-9.2
        pwdutils is needed by (installed) powersave-0.9.25-3
        /usr/sbin/groupadd is needed by (installed) postfix-2.2.1-3
        /usr/sbin/groupadd is needed by (installed) bind-9.3.1-3
        /usr/sbin/groupadd is needed by (installed) bind-chrootenv-9.3.1-3
        /usr/sbin/groupadd is needed by (installed) dbus-1-0.23.4-7
        /usr/sbin/groupadd is needed by (installed) openssh-3.9p1-12
        /usr/sbin/groupadd is needed by (installed) at-3.1.8-902
        /usr/sbin/groupadd is needed by (installed) mysql-4.1.10a-3.2
        /usr/sbin/groupadd is needed by (installed) hal-0.4.7-26.3
        /usr/sbin/groupadd is needed by (installed) clamav-0.86.2-1.1
        /usr/sbin/groupadd is needed by (installed) cups-1.1.23-7
        /usr/sbin/useradd is needed by (installed) postfix-2.2.1-3
        /usr/sbin/useradd is needed by (installed) bind-9.3.1-3
        /usr/sbin/useradd is needed by (installed) bind-chrootenv-9.3.1-3
        /usr/sbin/useradd is needed by (installed) dbus-1-0.23.4-7
        /usr/sbin/useradd is needed by (installed) openssh-3.9p1-12
        /usr/sbin/useradd is needed by (installed) at-3.1.8-902
        /usr/sbin/useradd is needed by (installed) mysql-4.1.10a-3.2
        /usr/sbin/useradd is needed by (installed) hal-0.4.7-26.3
        /usr/sbin/useradd is needed by (installed) clamav-0.86.2-1.1
        /usr/sbin/usermod is needed by (installed) bind-9.3.1-3
E: Transaction set check failed
E: Handler silently failed
dhcppc0:/var/lib/home/erich #
Woran liegt das?

GPG Check in /etc/apt/apt.conf.d/gpg-checker.conf auf "false" gestellt.
Zuletzt geändert von Erischa am 17. Aug 2005, 10:35, insgesamt 1-mal geändert.
Es Grüssle Erich

Öfters hilft ein rpm --rebuilddb
Compaq Presario 700
Linux Suse 9.3
Kernel 2.6.11-XX.XX-default
KDE 3.4

Werbung:
rm -rf /

Re: Fehler in "apt install rpmkey* ??

Beitrag von rm -rf / » 17. Aug 2005, 04:45

Erischa hat geschrieben: usr/bin/find is needed by
/usr/bin/xargs is needed by
libcrack.so.2 is needed by
cracklib is needed by
shadow is needed by
pwdutils is needed by
/usr/sbin/useradd is needed by
/usr/sbin/groupadd is needed by
/usr/sbin/usermod is needed by
also tut mir leid, aber mit deiner erfahrung/manege an posts solltest du eigentlich genug englisch können, um zu wissen was hier benötigt wird, immerhin STEHT ES DA!!

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 17. Aug 2005, 08:07

du hast noch einige Pakete nicht auf deinem System, die solltest du zuerst mal nachinstallieren. Die haben aber nichts mit den rpmkeys zu tun ...

apt -s upgrade sollte dir die fehlenden Pakete anzeigen.
Dann diese nachinstallieren mit apt install <p1 p2 p3 p4 ...>
dann die rpmkeys draufladen mit apt install rpmkeys*
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
Erischa
Member
Member
Beiträge: 119
Registriert: 21. Jun 2004, 18:36
Wohnort: Schweiz

Beitrag von Erischa » 17. Aug 2005, 08:46

Hallo,

leider bringen mich diese Antworten nicht weiter da ein apt -s upgrade folgendes zeigt

Code: Alles auswählen

apt -s upgrade
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
0 upgraded, 0 newly installed, 0 entfernt und 0 nicht upgegradet.
auch ein apt policy ..... von den oben genannten Paketen bringt ein installiert.
Es Grüssle Erich

Öfters hilft ein rpm --rebuilddb
Compaq Presario 700
Linux Suse 9.3
Kernel 2.6.11-XX.XX-default
KDE 3.4

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 17. Aug 2005, 09:30

hm, also du hast überprüft ob pwdutils, shadow etc installiert sind ?

Was mich etwas wundert, das apt direkt nach bestimmten Programmen sucht (/usr/sbin/groupadd etc)
Wenn diese auf Platte vorhanden sind aber deine RPM-Datenbank die nicht "provided" ist das schon sehr merkwürdig.
Evtl mal ein rpm --rebuilddb laufen lassen.

Und es handelt sich bei den Programmen und angemeckerten Paketen um ziemlich zentrale Stützen eines SuSE-Linux (aaa_base, pwdutils, shadow, ...) die sollten schon da sein.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
Erischa
Member
Member
Beiträge: 119
Registriert: 21. Jun 2004, 18:36
Wohnort: Schweiz

Beitrag von Erischa » 17. Aug 2005, 10:31

Hallo,
oc2pus hat geschrieben:Evtl mal ein rpm --rebuilddb laufen lassen.
Das war's, vielen Dank .

Damit ich es nicht mehr vergesse schreibe ich es jetzt in die Signature!
Es Grüssle Erich

Öfters hilft ein rpm --rebuilddb
Compaq Presario 700
Linux Suse 9.3
Kernel 2.6.11-XX.XX-default
KDE 3.4

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast