Installation von Programmen unter Linux

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Gesperrt
Benutzeravatar
Chrissy_XXLE
Newbie
Newbie
Beiträge: 6
Registriert: 25. Jun 2005, 21:41
Wohnort: Leipzig
Kontaktdaten:

Installation von Programmen unter Linux

Beitrag von Chrissy_XXLE » 7. Aug 2005, 23:56

Hallo Leute

Ich möchte bei meinen Linux 9.3 einige Programme inatllieren, bei denen ich die Installations Dateien auf der Festplatte habe. Wie kann ich diese installieren??:roll:

Danke schon mal im Voraus

Werbung:
lin-pro
Member
Member
Beiträge: 218
Registriert: 26. Feb 2004, 13:40
Wohnort: (mittel) Hessen
Kontaktdaten:

Beitrag von lin-pro » 8. Aug 2005, 00:20

Erstmal du verwendest kein Linux 9.3 sondern wahrscheinlich SuSE Linux 9.3 :wink:

Sind das RPM Pakete, die du installieren möchtest :?:
Websites sind momentan nicht aktuell
---
MfG 8)

Benutzeravatar
Chrissy_XXLE
Newbie
Newbie
Beiträge: 6
Registriert: 25. Jun 2005, 21:41
Wohnort: Leipzig
Kontaktdaten:

Beitrag von Chrissy_XXLE » 8. Aug 2005, 00:23

das Stimmt, 1 Paket ist ein RPM Paket, die andern 2 sind *.tar Archive.

lin-pro
Member
Member
Beiträge: 218
Registriert: 26. Feb 2004, 13:40
Wohnort: (mittel) Hessen
Kontaktdaten:

Beitrag von lin-pro » 8. Aug 2005, 00:28

Das RPM Paket müsstest du durch einfaches draufklicken installieren können (eine entsprechene Schaltfläche erscheint), das *.tar Archiv musst du erstmal entpacken.
Websites sind momentan nicht aktuell
---
MfG 8)

Benutzeravatar
Chrissy_XXLE
Newbie
Newbie
Beiträge: 6
Registriert: 25. Jun 2005, 21:41
Wohnort: Leipzig
Kontaktdaten:

Beitrag von Chrissy_XXLE » 8. Aug 2005, 00:39

Wenn ich das .tar Archiv entpackt habe und es poer konsole installieren will, kommt beio den befehl "make" ein Syntax Error. Wie kann ich dies umgehen??

HaukeW
Member
Member
Beiträge: 189
Registriert: 30. Jan 2005, 14:39
Wohnort: Hamburg
Kontaktdaten:

Beitrag von HaukeW » 8. Aug 2005, 05:26

poste den error bitte hier ins forum.

Meistens fehlen dir dann (soweit ich das kapiert habe) irgendwelche -devel Pakete.
Angenommen du installierst AmaroK (ein Programm ähnlich wie Winamp), und in der Fehlermeldung (man kann meistens gut nachvollziehen, warum der Fehler aufgetreten ist) steht was von xine, kann es z.B. sein, dass dir die xinelib-devel-Pakete fehlen. In solchen Fällen schaut man, was für Abhängigkeiten das zu kompilierende Programm hat und installiert nach - einfacher ist aber in jedem Fall, sich ´ne .rpm zu holen :) (Außer du musst das Programm irgendwie an deine Bedürfnisse anpassen). Es gibt da diverse Seiten für im Netz.

z.B.

http://www.rpmseek.com/
http://home.tiscali.be/raoul.linux/download.htm

Schau dir außerdem mal das hier an:
http://www.linux-club.de/viewtopic.php?t=9039

Gruß, Hauke
System: SuSE 11.3
AMD Athlon 3500+
Asus Mainboard
Soundblaster audigy2
Nvidia GeForce 8600
Festplatte+DVD-Brenner
----
eingetragener Linux-User #391592
http://counter.li.org

Benutzeravatar
roemi
Advanced Hacker
Advanced Hacker
Beiträge: 822
Registriert: 1. Apr 2004, 19:01
Wohnort: Hanau
Kontaktdaten:

Beitrag von roemi » 8. Aug 2005, 10:31

Sodele, auch hier haben wir ein Fachforum für ... und daher verschiebe ich es mal spontan dorthin.

Benutzeravatar
admine
Administrator
Administrator
Beiträge: 8736
Registriert: 15. Feb 2004, 21:13
Wohnort: Dresden
Kontaktdaten:

Beitrag von admine » 8. Aug 2005, 13:23

und ich mach das aber gleich mal zu ... weil das Thema mehr als umfangreich schon so oft hier diskutiert wurde!
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste