EasyLinux SuSE9.3 Special Edition

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Olaf
Member
Member
Beiträge: 244
Registriert: 24. Nov 2003, 09:54

EasyLinux SuSE9.3 Special Edition

Beitrag von Olaf » 6. Aug 2005, 10:57

Hallo!
Habe mich noch nicht dazu durchringen können, die Boxed Version von 9.3 zu erwerben, da meine 8.2 eigentlich perfekt läuft.
Daher mal o.a. probiert.
Die Installation erfolgte wohl etwas ungewöhnlich - da ich auf den beiden ersten IDE-Platten (hda komplett SuSE, hdb komplett WinXPHome) keinen Platz mehr hatte und ich nicht riskieren wollte, die NTFS-Platte von YaST kleiner machen zu lassen, um Platz zu schaffen (Falls was schief geht, so hätte Win evtl. neu installiert werden müssen und ich kriege da keine Internetverbindung über Netzwerkkarte hin - aber das ist ein gänzlich anderes Thema ...), habe ich die 9.3 auf die hdg installiert, die an einem PCI-IDE-Controller am Bus 1 als Master hängt.
Die Installation (mit GRUB auf hdg) erfolgte ohne Probleme und auch der Start nach Installation über die DVD funktionierte perfekt.
Dann kam allerdings der Knackpunkt: Ich wollte GRUB in den MBR der ersten Platte schreiben lassen - die Installtion blieb da bei 50% stehen, der Rechner ließ sich nur noch per Reset-Knopf wieder zum Leben erwecken. Mehrere Male probiert, immer das gleiche Ergebnis ...
Dann habe ich versucht durch Übernahme der Orts-Angaben von 9.3 auf den GRUB von 8.2 eben dort die 9.3 zu integrieren, doch da wird aus hdg immer wieder sdb (Ja, ich habe auch noch einen SCSI-Controller mit einer weiteren Platte für Linux) ...
Die Frage ist nun: Zählt GRUB der 9.3 die Platten anders als bei 8.2? Nur so könnte ich mir die Sache erklären - aber vielleicht hat jemand eine bessere Idee?
Gruß
Der ewige Einsteiger!

Werbung:
Benutzeravatar
Fytzi
Hacker
Hacker
Beiträge: 305
Registriert: 1. Aug 2004, 17:14
Kontaktdaten:

Beitrag von Fytzi » 6. Aug 2005, 11:46

Bei Suse 9.3 ist die Zählweise gleich, da hat sich nichts geändert. Du könntest aber mal Lilo als Bootmanager verwenden. Manchmal funktioniert das, auch wenn Grub nicht funktioniert.
There are only 10 types of people in the world: those who understand binary and those who don't.

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16597
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 6. Aug 2005, 14:03

Hi Olaf

Ich habe ein Problemloses :!: update von 8.2 auf 9.3 Privat gefahren.

Allerdings hat er meine LILO erhalten.

Olaf
Member
Member
Beiträge: 244
Registriert: 24. Nov 2003, 09:54

Beitrag von Olaf » 7. Aug 2005, 10:47

LILO möchte ich eigentlich nicht benutzen - GRUB gefällt mir seit SuSE8, da LILO zu wenig automatisch läuft ...

Ein Update wollte ich auf jeden Fall vermeiden, aus ganz oben beschriebenem Grunde (Erhalt von 8.2).



P.S. Hilfe! Wo ist denn mein schöner Screenshot der Plattenpartitionierung geblieben?
Der ewige Einsteiger!

Olaf
Member
Member
Beiträge: 244
Registriert: 24. Nov 2003, 09:54

Beitrag von Olaf » 8. Aug 2005, 10:08

Hallo!

Da ich Win nur in den allerseltensten Fällen benötige, habe ich mich nun doch dazu entschlossen, die SuSE9.3 auf die Platte zu installieren, auf der das NTFS ist, da es sich ja auf einer der "normalen" IDE-Platten befindet.
Dazu wurde von YaST die Platte verkleinert, dann das System aufgespielt, eingerichtet - alles ohne Probleme, 9.3 läuft erst einmal.
Die 8.2 wurde automatisch in den neuen GRUB eingetragen und läuft auch noch immer (Warum auch nicht?).
Nur Win machte mal wieder Probleme, es mußte beim nächsten Start erst einmal irgendwelche Fehler auf dem Laufwerk korregieren - na ja, ist man ja gewohnt ;-)

Nun wird die 9.3 ausgiiiiiebig getestet und dann irgendwann einmal die 8.2 von der Platte geputzt.

Dank nochmals für die Tipps!

Gruß
Der ewige Einsteiger!

Antworten

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 2 Gäste