[Gelöst] upgrade 9.2 auf 9.3 hat "unmet dependencies&qu

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
wolfgang-362
Newbie
Newbie
Beiträge: 35
Registriert: 20. Jan 2005, 12:46

[Gelöst] upgrade 9.2 auf 9.3 hat "unmet dependencies&qu

Beitrag von wolfgang-362 » 4. Aug 2005, 13:57

Hallo,

nach der Anleitung "[HOWTO] Upgrade einer SuSE Version 9.1 auf 9.2 mit apt" habe ich analog 9.3 eingetragen. Beim Schritt 12 "apt -s dist-upgrade | tee upgrade.txt" kommt folgende Meldung:

Code: Alles auswählen

Reading Package Lists...
Building Dependency Tree...
You might want to run `apt-get --fix-broken install' to correct these.
The following packages have unmet dependencies:
  perl-spamassassin: Depends: perl (= 5.8.6) but 5.8.5-3.2 is installed
  python-aqbanking: PreDepends: python (>= 2.4) but 2.3.4-3.2 is installed
  python-ctypes: PreDepends: python (>= 2.4) but 2.3.4-3.2 is installed
  python-ktoblzcheck: PreDepends: python (>= 2.4) but 2.3.4-3.2 is installed
E: Unmet dependencies. Try using --fix-broken.
Laut "[Tip] Abhängigkeiten lösen / Fehlermeldungen von apt" habe ich perl und python in der /etc/apt/apt.conf.d/apt.conf auf "ignore" gestellt, dann kommt eine noch längere Fehlerliste (gekürzt):

Code: Alles auswählen

athlon:~/update # apt -s dist-upgrade | tee upgrade.txt
Reading Package Lists...
Building Dependency Tree...
You might want to run `apt-get --fix-broken install' to correct these.
The following packages have unmet dependencies:
  OpenOffice_org: Depends: /usr/bin/perl but it is not installable
  SDL_perl: Depends: perl (= 5.8.5) but it is not installable
  Video-DVDRip: Depends: perl (= 5.8.5) but it is not installable
                Depends: /usr/bin/perl but it is not installable
  WindowMaker: Depends: /usr/bin/perl but it is not installable
...
 yast2-users: Depends: /usr/bin/perl but it is not installable
  yast2-x11: Depends: /usr/bin/perl but it is not installable
  yudit: PreDepends: perl but it is not installable
E: Unmet dependencies. Try using --fix-broken.
Die ganzen Pakete kann man schlecht deinstallieren. Ich weiss ab hier nicht mehr weiter. Hat jemand bitte eine weiterführende Idee?
Zuletzt geändert von wolfgang-362 am 6. Aug 2005, 08:38, insgesamt 2-mal geändert.
Grüße,
wolfgang

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 4. Aug 2005, 14:07

du solltest mal das Pferd von hinten aufzäumen ...

python-ctypes, python-qbanking, python-ktoblzcheck (und kmymoney, ..) mal temporär deinstallieren und dann unter 9.3 wieder neu drauf kopieren.

bei perl-spamassassin solltest du mal schauen ob es andere Versionen gibt und installiere eine Version mit Angabe dieser Versionsnummer.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

wolfgang-362
Newbie
Newbie
Beiträge: 35
Registriert: 20. Jan 2005, 12:46

Beitrag von wolfgang-362 » 4. Aug 2005, 19:30

Hallo und danke für die Antwort.
oc2pus hat geschrieben: python-ctypes, python-qbanking, python-ktoblzcheck (und kmymoney, ..) mal temporär deinstallieren und dann unter 9.3 wieder neu drauf kopieren.
spamassassin habe ich ebenfalls deinstalliert. Danach lief das Script immer noch nicht durch, weil in der Zwischenzeit wieder aktuellere Pakete auf den Servern eingetroffen waren. Nach erneutem "apt-get update" und "apt install rpmkeys* --no-checksig" kam folgender Fehler:

Code: Alles auswählen

...
Need to get 0B/913MB of archives.
After unpacking 37.0MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Checking GPG signatures...
Unknown signature /local/cache/apt/archives-9.3/lirc_0.7.0-6_i586.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#3a8f0245)
Unknown signature /local/cache/apt/archives-9.3/azureus_2.3.0.2-0_i586.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#3a8f0245)
E: Error(s) while checking package signatures:
0 unsigned package(s)
2 package(s) with unknown signatures
0 package(s) with illegal/corrupted signatures
E: Handler silently failed
In das Skript habe ich zusätzlich --no-checksig eingefügt, die Ausgabe war dann:

Code: Alles auswählen

Need to get 0B/913MB of archives.
After unpacking 37.0MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
        libgssapi.so.1 is needed by (installed) MozillaFirefox-1.0.6-4.1
        libgssapi.so.1 is needed by (installed) kdelibs3-3.4.2-3
        libkrb5.so.17 is needed by (installed) MozillaFirefox-1.0.6-4.1
        libroken.so.16 is needed by (installed) MozillaFirefox-1.0.6-4.1
        libFLAC.so.4 is needed by (installed) kdemultimedia3-CD-3.4.2-3
        libFLAC.so.4 is needed by (installed) kdemultimedia3-3.4.2-3
E: Transaction set check failed
E: Handler silently failed
Ich habe jetzt in den YAST-Installationsquellen KDE-Unsupported herausgenommen und versuche ein downgrade auf das urprüngliche KDE 3.3 samt Mozilla 0.10. Ist das der richtige Weg?
Grüße,
wolfgang

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 4. Aug 2005, 21:20

na dann nimm den azureus und den lirc ebenfalls mal temporär raus .. die brauchst du nun wirklich nicht bei einem Update. Und später wenn du 9.3 hast kannst du sie ja wieder drauf schieben :)

Merke: immer den Weg des geringsten Wiederstandes gehen, und weniger ist mehr, gerade bei einem Update und so komplexen Zusammenhängen der Pakete. Ruhig alle Pakete welche nicht wirklich "wichtig" sind mal rausnehmen, das vereinfacht die Sache ungemein, anstatt stundenlang "Kreiselabhängigkeiten" zu lösen.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

wolfgang-362
Newbie
Newbie
Beiträge: 35
Registriert: 20. Jan 2005, 12:46

Beitrag von wolfgang-362 » 5. Aug 2005, 23:01

Hi,
oc2pus hat geschrieben: Merke: immer den Weg des geringsten Wiederstandes gehen, und weniger ist mehr, gerade bei einem Update und so komplexen Zusammenhängen der Pakete.
Auf jeden Fall danke für die Anregungen. Ich habe aber irgendwann heute morgen die Geduld verloren und einfach ein "apt upgrade" gemacht. Das Gewirr wurde dadurch nicht gelöst, war ja klar.

Es half am Ende die c't-DVD. Damit habe ich wenigstens geschafft, per Update auf ein konsistentes Grundsystem zurückzugehen. YAST hat einfach alle nicht zum System gehörenden Pakete moniert, die ich dann zur Deinstallation freigegeben habe. Nun muss ich nach und nach meine wichtigsten Programme per apt wieder neu einbauen und die beiden kommerziellen Treiber neu installieren.

Wäre schön, wenn die dll-hell bei Linux mal irgendwann sinnig gelöst werden könnte, um auch zusammengestückelte Systeme wie meins vernünftig zu pflegen.

P.S.: Der bisher nicht erwähnte Witz ist: *Nach* dem "apt upgrade" habe ich festgestellt, dass in der sources.list unter meinem letzten Eintrag viele Leerzeilen waren und darunter (also ausserhalb des Sichtbereiches vom Editor) stand ein Verweis auf eine 9.2er Quelle. Keine Ahnung, wie dieser Eintrag dahin gekommen ist, aber er hat sicher die vorherigen Störungen ausgelöst.
Grüße,
wolfgang

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste