[gelöst] Ein Duplicate lässt sich nicht löschen

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
bmartin
Newbie
Newbie
Beiträge: 1
Registriert: 31. Jul 2005, 14:11

[gelöst] Ein Duplicate lässt sich nicht löschen

Beitrag von bmartin » 31. Jul 2005, 14:14

Hallo zusammen,

ich weiss nicht wie ich es geschafft habe, aber seit einiger Zeit bekomme ich bei Benutzung von APT die Fehlermeldung:

W: There are multiple versions of "heimdal-lib" in your system.

nach stöbern hier im Forum bin ich auf zwei Befehle gestoßen die meine Freunde sein sollten und zwar wären das:

rpm -qa|grep heimdal-lib

sowie

rpm -e --allmatches heimdal-lib-0.6.2-8.2

doch leider wird der letzte Befehl ebenfalls mit einem Fehler quittiert:

error: Failed dependencies:
libgssapi.so.1 is needed by (installed) cyrus-sasl-saslauthd-2.1.19-5.2
libgssapi.so.1 is needed by (installed) libsmbclient-3.0.9-2.3
libgssapi.so.1 is needed by (installed) openssh-3.9p1-3.2
libgssapi.so.1 is needed by (installed) kdelibs3-3.3.0-34.7
libgssapi.so.1 is needed by (installed) mozilla-1.7.10-3.1
libkafs.so.0 is needed by (installed) openssh-3.9p1-3.2

FRAGE: wie bekomme ich jetzt das lästige Duplicate wieder los?

Vielen Dank für ein Lösungsvorschlag.

Gruß
Martin
Zuletzt geändert von bmartin am 31. Jul 2005, 17:20, insgesamt 2-mal geändert.

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 31. Jul 2005, 15:16

Code: Alles auswählen

rpm -e --allmatches --nodeps heimdal-lib-0.6.2-8.2
evtl zusätzlich noch ein --force dazu ;)

dann apt install heimdal-lib um die aktuellste Version wieder zu installieren
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast