Zwei Versionen einer Bibliothek gleichzeitig (libdvbpsi3+4)

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
spilker
Newbie
Newbie
Beiträge: 5
Registriert: 12. Jul 2005, 04:44

Zwei Versionen einer Bibliothek gleichzeitig (libdvbpsi3+4)

Beitrag von spilker » 30. Jul 2005, 10:04

Ich möchte gerne 2 Releases der Bibliothek libdvbpsi installiert halten. Die 3ér Version, weil der video lan client die .so.3 benötigt. Ich habe die 4ér Version mit per Hand via rpm --force --nodeps über die 3ér Version installiert. vlc läuft damit weiter. Und neu kompilierte Anwendungen arbeiten mit der 4ér Variante.

Nur leider meldet apt upgrade nun ein: libdvbpsi4: Obsoletes: libdvbpsi3. Ich möchte eigentlich nur, daß die Meldung ignoriert wird.

Order gibt es einen anderen eleganten Weg, die .so.3 zu erhalten ohne überhaupt erst das genannten Abhängigkeitsproblem auszulösen.

Mfg Jörg

Werbung:
Benutzeravatar
pawe
Member
Member
Beiträge: 148
Registriert: 14. Dez 2004, 21:38
Wohnort: Bayern
Kontaktdaten:

Beitrag von pawe » 30. Jul 2005, 12:19

In der Datei /etc/apt/apt.conf.d/apt.conf kannst du mit der Funktion Ignore Pakete bestimmen, die von der Abhängigkeitsprüfung ausgeschlossen werden sollen. Dort ist die Zeile bereits vorhanden, du musst sie lediglich weiterführen.
standardmäßig steht in der apt.conf:

Code: Alles auswählen

Ignore {"gpg-pubkey"; }; 
Ich habe z.B. ergänzt:

Code: Alles auswählen

Ignore {"gpg-pubkey";"z600cups"; }; 
Gruß Pawe
P III, 700 MHz, 384 MB Ram, SuSE 9.3 - fluxbox/idesk // NB: AMD 2800+, 704 MB Ram, SuSE 9.3 - KDE 3.4.

Fundiertes Wissen über Linux: www.de.linwiki.org
HowTo´s, Tutorials, Softwarelisten, Begriffserklärungen und vieles mehr!

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast