Anfänger hat Problem mit Installation von Dateien

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Apophys
Newbie
Newbie
Beiträge: 11
Registriert: 24. Jul 2005, 01:17

Anfänger hat Problem mit Installation von Dateien

Beitrag von Apophys » 24. Jul 2005, 16:26

Hallo zusammen

Ich habe da mal ein Paar Fragen zur Installation, über dir SSH-Konsole (Putty).

Also ich habe ein Root-Server gemietet, auf dem ist eine Minimalinstallation enthalten.
Als erstes habe ich da VNC-Server Installiert. Danach habe ich bemerkt dass da gar kein Desktop drauf ist, den habe ich dann aber in Handarbeit über die SSH-Konsole Installiert, mehr oder weniger. Zur Algemeinen Info sollte ich noch erwähnen das ich kaum Ahnung von Linux habe.
Also VNC startet jetzt aber schon mal die „startkde“ Datei, aber leider mit Fehlermeldung,
ich komme aber dennoch auf den Desktop meines Root-Servers.
Das Problem ist nun, das ich nicht weiß wie das mit der Installation von System Programmen funktioniert wzb. Yast2. Da es ja aus unzähligen .rpm Dateien besteht und vorher ja auch noch andere .rpm Pakete wie „perl“ Installiert werden müssen, dir „perl“ bekomme ich noch nicht mal Installiert, da noch was fehlt und ich weiß nicht was.
Lange rede kurzer Sinn, Ich komme mit dem „rpm-Paket“ durcheinander nicht klar.

Ich habe übrigens die Linux Suse DVD (ISO) auf meinem Root-Server liegen und gemountet,
da sollten doch alle Pakete drauf sein die man so braucht denke ich.

Nun hoffe ich dass mir jemand erklären kann wie ich das System richtig Installiert bekomme.

Gruß Apophys

Werbung:
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 24. Jul 2005, 16:33

Grafische Oberfläche auf einem root-Server ? Wozu das denn ?

Verwaltung mit VNC ? Nicht gerade das sicherste Protokoll.
Zur Algemeinen Info sollte ich noch erwähnen das ich kaum Ahnung von Linux habe.
Dann lern doch erstmal Linux bevor Du Dich als Gefahr für die Allgemeinheit betätigst.

Sorry aber für sowas habe ich gar kein Verständnis.

Wie Yast2 funktioniert steht im SuSE Administratorhandbuch.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

tomte
Hacker
Hacker
Beiträge: 798
Registriert: 15. Nov 2003, 13:40
Wohnort: 16°08'12"E / 56°34'08"N

Beitrag von tomte » 24. Jul 2005, 16:43

lies dir doch mal die manpages von ssh und rpm durch, und ansonsten noch sowas:
http://www.rootforum.de/forum/
http://rootiewiki.de/
http://webhostingwiki.de/

btw, yast funktioniert auch ohne graphische Oberfläche...
Nothing is easier than being busy - and nothing more difficult than being effective.

Apophys
Newbie
Newbie
Beiträge: 11
Registriert: 24. Jul 2005, 01:17

Beitrag von Apophys » 25. Jul 2005, 00:40

Hallo noch mal

Danke für die Antworten, leider haben die Antworten nicht geholfen.

Als erstes @Martin Breidenbach ist es wohl meine Sache was ich mit dem Server vorhabe.
Es gibt da ein paar Programme w.z.B. Azureus, das man nicht über den SSH Zugang steuern kann, aber egal, lieber die Fragen eines Anfängers mit Gegenfragen beantworten damit hier im Forum bloß keine Informationen stehen.

@tomte, danke für die Links, leider habe die mir aber auch nicht geholfen, da die wichtigste Seite „rpm.org“ in Englisch ist und mein Englisch reicht nicht um alles richtig zu verstehen.

Noch mal zum meinem Problem, ich möchte auf dem Root-Server (jetzt mit Grafische Oberfläche)
Das Programm Yast2 Installieren, um z.B. das Online Update zu nutzen. Dazu habe ich mir Die DVD ISO-Datei auf den Root-Server geladen und gemountet.
Auf der Linux Suse DVD befinden sich mehrere „RPM-Pakete“ ich weiß nur nicht in welcher Reihenfolge diese Installiert werden müssen.

Hier mal ein Beispiel:
Ich tippe den Befehl „rpm -Uvh /mnt/suse/i586/yast2-2.11.48-3.1.i586.rpm“ in die Konsole, um das erste Packet zu Installieren.

Als Meldung bekomme ich dann:

Preparing... ########################################### [100%]
file /usr/share/YaST2/modules/CWMFirewallInterfaces.ybc from install of yast2-2.11.48-3.1 conflicts with file from package yast2-firewall-2.10.13-2
file /usr/share/YaST2/modules/CWMFirewallInterfaces.ycp from install of yast2-2.11.48-3.1 conflicts with file from package yast2-firewall-2.10.13-2
file /usr/share/YaST2/modules/SuSEFirewall.ybc from install of yast2-2.11.48-3.1 conflicts with file from package yast2-firewall-2.10.13-2
file /usr/share/YaST2/modules/SuSEFirewall.ycp from install of yast2-2.11.48-3.1 conflicts with file from package yast2-firewall-2.10.13-2
file /usr/share/YaST2/scrconf/cfg_firewall2.scr from install of yast2-2.11.48-3.1 conflicts with file from package yast2-firewall-2.10.13-2
file /usr/share/YaST2/modules/NetworkDevices.ybc from install of yast2-2.11.48-3.1 conflicts with file from package yast2-network-2.10.33-2
file /usr/share/YaST2/modules/NetworkDevices.ycp from install of yast2-2.11.48-3.1 conflicts with file from package yast2-network-2.10.33-2
file /usr/share/YaST2/scrconf/network.scr from install of yast2-2.11.48-3.1 conflicts with file from package yast2-network-2.10.33-2

Vermutlicherweise liegt es daran, dass noch nicht alle benötigten Pakete Installiert sind.
Soweit ich weiß, braut Yast2 das Paket „perl-5.8.6-5.1.i586.rpm“ aber auch bei der Installation kommt eine ähnliche Meldung.

Die Frage ist also WAS MACHE ICH FALSCH??? BITTE UM ANTWORT FÜR DUMMIS, DANKE!!!

rpm -Uvh /mnt/suse/i586/perl-5.8.6-5.1.i586.rpm

error: Failed dependencies:
perl = 5.8.5 is needed by (installed) mirror-2.9-752
perl = 5.8.5 is needed by (installed) perl-AppConfig-1.56-29
perl = 5.8.5 is needed by (installed) perl-Archive-Tar-1.08-30
perl = 5.8.5 is needed by (installed) perl-Authen-SASL-2.08-2
perl = 5.8.5 is needed by (installed) perl-BIND-Conf_Parser-0.97-353
perl = 5.8.5 is needed by (installed) perl-BSD-Resource-1.24-2
perl = 5.8.5 is needed by (installed) perl-Bit-Vector-6.3-200
perl = 5.8.5 is needed by (installed) perl-CDDB_get-2.23-44
perl = 5.8.5 is needed by (installed) perl-CGI-Application-3.22-28
perl = 5.8.5 is needed by (installed) perl-Carp-Assert-0.18-2
perl = 5.8.5 is needed by (installed) perl-Class-Data-Inheritable-0.02-427
perl = 5.8.5 is needed by (installed) perl-Class-Date-1.1.7-68
perl = 5.8.5 is needed by (installed) perl-Class-MethodMaker-2.02-2
perl = 5.8.5 is needed by (installed) perl-Class-Multimethods-1.70-433
perl = 5.8.5 is needed by (installed) perl-Class-WhiteHole-0.04-66
perl = 5.8.5 is needed by (installed) perl-Config-Crontab-1.03-48
perl = 5.8.5 is needed by (installed) perl-Config-General-2.24-46
perl = 5.8.5 is needed by (installed) perl-Config-IniFiles-2.38-114
perl = 5.8.5 is needed by (installed) perl-Convert-ASN1-0.18-68
perl = 5.8.5 is needed by (installed) perl-Convert-BER-1.3101-192
perl = 5.8.5 is needed by (installed) perl-Convert-TNEF-0.17-260
perl = 5.8.5 is needed by (installed) perl-Crypt-Blowfish-2.09-363
perl = 5.8.5 is needed by (installed) perl-Crypt-DES-2.03-361
perl = 5.8.5 is needed by (installed) perl-Curses-1.06-472
perl = 5.8.5 is needed by (installed) perl-DBD-XBase-0.241-28
perl = 5.8.5 is needed by (installed) perl-Data-ShowTable-3.3-571
perl = 5.8.5 is needed by (installed) perl-DateManip-5.42a-126
perl = 5.8.5 is needed by (installed) perl-Devel-Symdump-2.03-252
perl = 5.8.5 is needed by (installed) perl-Digest-MD2-2.03-67
perl = 5.8.5 is needed by (installed) perl-Digest-MD4-1.3-29
perl = 5.8.5 is needed by (installed) perl-Digest-SHA1-2.10-2
perl = 5.8.5 is needed by (installed) perl-Encode-HanExtra-0.07-142
perl = 5.8.5 is needed by (installed) perl-Encode-JIS2K-0.01-144
perl = 5.8.5 is needed by (installed) perl-Event-1.00-2
perl = 5.8.5 is needed by (installed) perl-ExtUtils-F77-1.14-350
perl = 5.8.5 is needed by (installed) perl-File-MMagic-1.22-2
perl = 5.8.5 is needed by (installed) perl-File-Tail-0.98-261
perl = 5.8.5 is needed by (installed) perl-Filter-1.30-68
perl = 5.8.5 is needed by (installed) perl-Getopt-Mixed-1.008-186
perl = 5.8.5 is needed by (installed) perl-HTML-Clean-0.8-666
perl = 5.8.5 is needed by (installed) perl-HTML-SimpleParse-0.12-121
perl = 5.8.5 is needed by (installed) perl-HTML-Tagset-3.03-552
perl = 5.8.5 is needed by (installed) perl-HTML-Template-2.6-137
perl = 5.8.5 is needed by (installed) perl-HTML-Template-JIT-0.04-204
perl = 5.8.5 is needed by (installed) perl-IO-Stty-.02-519
perl = 5.8.5 is needed by (installed) perl-IO-Tty-1.02-294
perl = 5.8.5 is needed by (installed) perl-IO-stringy-2.109-29
perl = 5.8.5 is needed by (installed) perl-IPC-Run-0.78-2
perl = 5.8.5 is needed by (installed) perl-Image-Size-2.992-121
perl = 5.8.5 is needed by (installed) perl-MIME-Lite-3.01-141
perl = 5.8.5 is needed by (installed) perl-MIME-Types-1.12-29
perl = 5.8.5 is needed by (installed) perl-MLDBM-2.01-249
perl = 5.8.5 is needed by (installed) perl-MailTools-1.60-31
perl = 5.8.5 is needed by (installed) perl-Mcrypt-2.4.8.2-468
perl = 5.8.5 is needed by (installed) perl-Net-Daemon-0.38-48
perl = 5.8.5 is needed by (installed) perl-Net-IP-1.20-117
perl = 5.8.5 is needed by (installed) perl-Net-Netmask-1.9011-2
perl = 5.8.5 is needed by (installed) perl-Net-Telnet-3.03-181
perl = 5.8.5 is needed by (installed) perl-NetxAP-0.02-556
perl = 5.8.5 is needed by (installed) perl-Parallel-Pvm-1.3.0-576
perl = 5.8.5 is needed by (installed) perl-Params-Validate-0.14-278
perl = 5.8.5 is needed by (installed) perl-Parse-RecDescent-1.80-246
perl = 5.8.5 is needed by (installed) perl-Parse-Syslog-1.03-2
perl = 5.8.5 is needed by (installed) perl-Parse-Yapp-1.05-390
perl = 5.8.5 is needed by (installed) perl-PostScript-Simple-0.04-248
perl = 5.8.5 is needed by (installed) perl-SQL-Statement-1.005-129
perl = 5.8.5 is needed by (installed) perl-Set-Crontab-1.00-430
perl = 5.8.5 is needed by (installed) perl-Set-Object-1.06-2
perl = 5.8.5 is needed by (installed) perl-Set-Scalar-1.19-2
perl = 5.8.5 is needed by (installed) perl-Socket6-0.17-2
perl = 5.8.5 is needed by (installed) perl-Template-Toolkit-2.13-27
perl = 5.8.5 is needed by (installed) perl-TermReadKey-2.21-294
perl = 5.8.5 is needed by (installed) perl-Text-CSV_XS-0.23-358
perl = 5.8.5 is needed by (installed) perl-Text-DelimMatch-1.06-44
perl = 5.8.5 is needed by (installed) perl-Text-Iconv-1.2-185
perl = 5.8.5 is needed by (installed) perl-Text-Kakasi-1.05-385
perl = 5.8.5 is needed by (installed) perl-Tie-Cache-0.17-242
perl = 5.8.5 is needed by (installed) perl-Tie-IxHash-1.21-586
perl = 5.8.5 is needed by (installed) perl-Time-Period-1.20-303
perl = 5.8.5 is needed by (installed) perl-Time-modules-2003.1126-30
perl = 5.8.5 is needed by (installed) perl-TimeDate-1.16-123
perl = 5.8.5 is needed by (installed) perl-URI-1.33-2
perl = 5.8.5 is needed by (installed) perl-Unicode-String-2.07-130
perl = 5.8.5 is needed by (installed) perl-Unix-Syslog-0.100-27
perl = 5.8.5 is needed by (installed) perl-XML-Generator-0.93-132
perl = 5.8.5 is needed by (installed) perl-XML-Parser-2.34-30
perl = 5.8.5 is needed by (installed) perl-XML-RegExp-0.03-477
perl = 5.8.5 is needed by (installed) perl-XML-Writer-0.510-2
perl = 5.8.5 is needed by (installed) perl-gettext-1.01-578
perl = 5.8.5 is needed by (installed) rrdtool-1.0.49-2
perl = 5.8.5 is needed by (installed) perl-Class-Accessor-0.19-2
perl = 5.8.5 is needed by (installed) perl-Crypt-CBC-2.08-133
perl = 5.8.5 is needed by (installed) perl-Cyrus-IMAP-2.2.8-6
perl = 5.8.5 is needed by (installed) perl-Cyrus-SIEVE-managesieve-2.2.8-6
perl = 5.8.5 is needed by (installed) perl-DBD-CSV-0.21-2
perl = 5.8.5 is needed by (installed) perl-DBD-ODBC-1.06-231
perl = 5.8.5 is needed by (installed) perl-DBD-mysql-2.9004-2
perl = 5.8.5 is needed by (installed) perl-Date-Calc-5.3-187
perl = 5.8.5 is needed by (installed) perl-Digest-HMAC-1.01-494
perl = 5.8.5 is needed by (installed) perl-Expect-1.15-295
perl = 5.8.5 is needed by (installed) perl-GD-2.16-3
perl = 5.8.5 is needed by (installed) perl-HTML-Mason-1.05-257
perl = 5.8.5 is needed by (installed) perl-HTML-Parser-3.36-2
perl = 5.8.5 is needed by (installed) perl-Inline-0.44-193
perl = 5.8.5 is needed by (installed) perl-Log-Dispatch-2.10-40
perl = 5.8.5 is needed by (installed) perl-MLDBM-Sync-0.30-245
perl = 5.8.5 is needed by (installed) perl-Net_SSLeay-1.25-29
perl = 5.8.5 is needed by (installed) perl-Quantum-Superpositions-2.02-122
perl = 5.8.5 is needed by (installed) perl-Unicode-Map8-0.12-149
perl = 5.8.5 is needed by (installed) perl-X500-DN-0.28-119
perl = 5.8.5 is needed by (installed) perl-XML-Simple-2.12-2
perl = 5.8.5 is needed by (installed) perl-XML-XQL-0.68-139
perl = 5.8.5 is needed by (installed) perl-ldap-0.29-136
perl = 5.8.5 is needed by (installed) perl-libxml-perl-0.07-480
perl = 5.8.5 is needed by (installed) perl-Crypt-SSLeay-0.51-110
perl = 5.8.5 is needed by (installed) perl-HTML-FillInForm-1.04-2
perl = 5.8.5 is needed by (installed) perl-Inline-C-0.12-206
perl = 5.8.5 is needed by (installed) perl-Net-DNS-0.48-2
perl = 5.8.5 is needed by (installed) perl-Net-SNMP-5.0.0-2
perl = 5.8.5 is needed by (installed) perl-OpenCA-OpenSSL-0.9.91-72
perl = 5.8.5 is needed by (installed) perl-libwww-perl-5.76-32
perl = 5.8.5 is needed by (installed) perl-DBD-Pg-1.22-198
perl = 5.8.5 is needed by (installed) perl-IO-Socket-SSL-0.96-3
perl = 5.8.5 is needed by (installed) perl-OpenCA-X509-0.9.47-71
perl = 5.8.5 is needed by (installed) perl-XML-XSLT-0.48-27
perl = 5.8.5 is needed by (installed) perl-razor-agents-2.61-3
perl = 5.8.5 is needed by (installed) pgperl-2.1.1-2
perl = 5.8.5 is needed by (installed) w3mir-1.0.10-518
perl = 5.8.5 is needed by (installed) apache2-mod_perl-1.99_12_20040302-38
perl = 5.8.5 is needed by (installed) perl-OpenCA-CRL-0.9.17-61
perl = 5.8.5 is needed by (installed) perl-OpenCA-REQ-0.9.52-61
perl = 5.8.5 is needed by (installed) perl-XML-Stream-1.17-30
perl = 5.8.5 is needed by (installed) perl-ldap-ssl-0.29-136
perl = 5.8.5 is needed by (installed) perl-Net-Jabber-1.29-29
perl = 5.8.5 is needed by (installed) perl-Pod-HtmlPsPdf-0.04-349
perl = 5.8.5 is needed by (installed) perl-Parallel-MPI-0.03-706
perl = 5.8.5 is needed by (installed) yast2-core-2.10.16-2
perl = 5.8.5 is needed by (installed) perl-MIME-tools-5.411a-370.2
perl = 5.8.5 is needed by (installed) perl-Archive-Zip-1.14-3.1
perl = 5.8.5 is needed by (installed) perl-DBI-1.43-2.2
perl = 5.8.5 is needed by (installed) perl-PerlMagick-6.0.7-4.6
perl = 5.8.5 is needed by (installed) perl-Convert-UUlib-1.0-27.2
perl = 5.8.5 is needed by (installed) perl-spamassassin-3.0.4-1.1
perl = 5.8.5 is needed by (installed) perl-Net-Server-0.87-31.2
perl = 5.8.5 is needed by (installed) perl-Compress-Zlib-1.33-32.2
perl = 5.8.5 is needed by (installed) perl-Quota-1.5.0-1.intergenia
perl = 5.8.5 is needed by (installed) perl-Proc-ProcessTable-0.39-1.intergenia

Benutzeravatar
TomcatMJ
Guru
Guru
Beiträge: 2480
Registriert: 1. Apr 2004, 00:29
Wohnort: Köln
Kontaktdaten:

Beitrag von TomcatMJ » 25. Jul 2005, 01:52

Hi!
Also den Fehlermeldungen entnehme ich folgendes:
1.) Du hast dir ein SuSE-System auf den Rootserver packen lassen bei dem bereits Yast installiert ist. Du willst per Hand eine neuere installation draufpacken ohne vorher die Abhängigkeiten der alten Version zu beachten,das steht glasklar in den Fehlermeldungen drin die du offenbar nicht wirklich gelesen sondern blind kopiert zu haben scheinst.
2.) Du willst das vorhandene Perl updaten ohne den regulären Weg über Yast zu gehen udn verstehst nicht das dort ebenfalls eine Menge abhängigkeiten vorhanden sind die es entweder zuerst zu beseitigen gilt oder wo du eben Yast zu nutzen solltest um sie automatisch lösen zu lassen.

Dem Rest deiner Postings in diesem Thread entnehme ich ferner das du offenbar Null Ahnung hast was du da tust und erstmal dir besser das SuSE Adminhandbuch schnappen solltest um es zu verstehen was du da vorhast. Dann solltest du dir besser erstmal Gedanken über die Sicherheit deines Servers machen, denn VNC überträgt normalerweise Passwörter im KLARTEXT und X-Windows sollte auch besser ein paar Ports geschlossen haben bevor man den Rechner aufs Netz loslässt da er sonst schneller gekapert wird als du es dir momentan vorstellen kannst (und womit dir ein ganzer Haufen Traffic in Rechnung gestellt werden könnte,mal abgesehen von den weiteren rechtlichen Folgen als Mitstörer wenn dein Rechner z.B. für eine DDoS-Attacke genutzt würde). Falls du schonmal etwas von der DISPLAY-Variable und dem Befehl screen gehört haben solltest, solltest du wissen das du auch für Azureus mit Sicherheit kein XWindows auf dem Server laufen haben musst um es zu benutzen. Da die eigentliche Serververwaltung somit kein XWIndows benötigt frage ich mich wieso du dir eigentlich die ganzen Risiken für dich UND ANDERE NETZBENUTZER(!) antun willst. Genau,es betrifft auch andere Netzbenutzer die du noch nichteinmal kennst, spätestens wenn aufgrund mangelhafter Absicherung deines Servers ein Spamrelay mehr im Lande steht oder ein Ankerpunkt für eine DDoS-Attacke auf anderer Leutz Rechner auf deinen Namen gebucht und abgerechnet aber nicht mehr unter deiner Kontrolle "in freier Wildbahn" läuft.
Ergo: Lern besser erstmal die Grundlagen von Linux und Netzwerksicherheit bevor du dich an einen Root-Server begibst und lese Fehlermeldungen und denk drüber nach,auch 2 oder 3 mal, bevor du sie einfach nur blind kopierst, das ist gesünder für deine Nerven,deinen Geldbeutel und deine Rechtschutzversicherung.

Bis denne,
Tom

Apophys
Newbie
Newbie
Beiträge: 11
Registriert: 24. Jul 2005, 01:17

Beitrag von Apophys » 25. Jul 2005, 04:15

Hallo

Ja also da ich echt Null Ahnung von Suse habe, brauche ich hier mal richtig dolle Hilfe.
Zunächst mal, das VNC habe ich wider gelöscht, da es ja nicht so Sicher sein soll.

Also bin ich nun wider mit Putty (SSH) unterwegs. Leider muss ich feststellen das ich echt scheiße gebaut habe. Ich hoffe das Ihr mir helfen könnt das wider hin zubekommen.

Das wichtigste ist wohl der Befehl „yast (2)“ nur dich meine sinnlose Installierung von Hand ist dies Funktion nicht mehr lauffähig.

Diese Meldung kommet:

:~ # yast2
/usr/lib/YaST2/bin/y2base: symbol lookup error: /usr/lib/liby2pm.so.2: undefined symbol: _ZTV7_Handle

:~ # yast
/usr/lib/YaST2/bin/y2base: symbol lookup error: /usr/lib/liby2pm.so.2: undefined symbol: _ZTV7_Handle

Ich habe inzwischen Suse 9.0 als Verzeichnis Version auf den Server geladen, da auch genau diese (9.0) Installiert ist.

Bitte um Hilfe!!!

rolle
Guru
Guru
Beiträge: 3721
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 25. Jul 2005, 08:26

So blöd es auch klingt: Es ist nie ein Fehler, mal ein 'SuSEconfig' und ein 'online_update' zu machen. Ansonsten lassen sich die einzelnen YaST-Module auch alleine starten. 'yast --help' müßte Dir da helfen.
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste