Update auf Suse 9.3

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

nicki
Newbie
Newbie
Beiträge: 34
Registriert: 3. Jan 2005, 09:23

Update auf Suse 9.3

Beitrag von nicki » 22. Jul 2005, 11:12

Hallo zusammen,

ich habe jetzt ein bißchen im Forum gelesen und festgestellt das einige von euch schon das Upgrade auf 9.3 gemacht haben. Kurze Frage: Kann man sich an das Howto von 9.1 auf 9.2 halten oder ist noch was zu beachten?

Danke

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 22. Jul 2005, 11:32

ja, die HowTo's kannst du verwenden.
Es sollte straight nach diesen HowTo's durchlaufen, keine besonderen Fallstricke ;)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

nicki
Newbie
Newbie
Beiträge: 34
Registriert: 3. Jan 2005, 09:23

Beitrag von nicki » 22. Jul 2005, 11:39

Super! Dann werd ich mal mein Glück versuchen!
Danke!

PS: oc2pus, tolle Arbeit die du dir hier machst! Echt klasse!

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 22. Jul 2005, 11:54

kleiner Tip noch:
ich hatte eine ziemlich aktuelle SuSE-9.2 und es gab einige Pakete mit gleicher Versionsnummer in SuSE-92 und SuSE-9.3.

Dort habe ich dann zunächst einen downgrade auf die SuSE-9.3er base Pakete durch das script durchführen lassen. Also im Downloadscript bei diesen Paketen die Syntax <paket>=<version-aus-base-9.3> verwendet.

Als dann das gesamte System auf 9.3 umgestellt war, habe ich in einem neuen apt upgrade Durchgang die neueren aus suse-projects, suse-people, etc draufgespielt.

Und ein Paket krb5 scheint wohl neu dabei zu sein in 9.3, dieses einfach an die Liste der zu installierenden Pakete anhängen im Script.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

nicki
Newbie
Newbie
Beiträge: 34
Registriert: 3. Jan 2005, 09:23

Beitrag von nicki » 24. Jul 2005, 15:10

Habe jetzt mal versucht das Upgrade zu machen. apt --test install läuft jetzt auch. Nur bei force kommt folgendes:

Code: Alles auswählen

KippingPC:~/update # ./myUpgrade
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Die folgenden zusätzlichen Pakete werden installiert werden:
  amule openldap2-client
Die folgenden Pakete werden upgegradet werden:
  3ddiag CheckHardware Crystalcursors DirectFB ImageMagick OpenOffice_org
  OpenOffice_org-Quickstarter OpenOffice_org-de OpenOffice_org-de-templates
  OpenOffice_org-kde SDL SDL_image SDL_mixer SDL_net SDL_perl SDL_ttf
  SuSEfirewall2 WindowMaker WindowMaker-applets WindowMaker-themes a2ps
  aaa_base aaa_skel aalib acl acpid alsa alsa-devel amarok amarok-xmms ash
  aspell at atk atk-devel attr audiofile autoconf autofs autoyast2
  autoyast2-installation avifile awesfx bash bc bin2iso bind-libs bind-utils
  binutils bluez-libs bluez-utils bonobo bootsplash bootsplash-theme-SuSE
  bzip2 cabextract capi4linux cdk cdparanoia cdrdao cdrecord compat
  compat-curl2 compat-readline4 control-center convmv coreutils cpio cpp
  cracklib cron cups cups-SUSE-ppds-dat cups-client cups-drivers
  cups-drivers-stp cups-libs cvs cyrus-sasl cyrus-sasl-saslauthd db db1 dcraw
  deltarpm desktop-data-SuSE device-mapper devs dhcpcd dialog diffutils
  dirmngr djvulibre dmraid docbook-xsl-stylesheets docbook_4 dos2unix
  dosbootdisk dosfstools dvd+rw-tools e2fsprogs ed efont-unicode eject
  enscript esound ethtool evms evms-gui expat fam fam-devel fbset file
  filesystem fillup filters findutils finger flac flash-player fltk fontconfig
  fontconfig-devel fonts-config foomatic-filters fping freeglut freeglut-devel
  freetype2 freetype2-devel fribidi frozen-bubble fvwm2 gail gal gawk gcc
  gcc-c++ gconf gconf2 gdb gdbm gdk-pixbuf gdk-pixbuf-gnome gettext
  ghostscript-fonts-other ghostscript-fonts-std ghostscript-library
  ghostscript-x11 giflib gimp gimp-cmyk gkrellm gl-117 gle glib glibc
  glibc-devel glibc-locale gnokii gnome-filesystem gnome-icon-theme
  gnome-keyring gnome-libs gnome-mime-data gnome-print gnome-spell
  gnome-spell2 gnome-vfs2 gpart gpg gpg2 gpgme gpm grep groff grub gtk
  gtk-qt-engine gtk2 gtk2-devel gtkdoc gtkhtml gtkhtml2 guile gwenview gxmhtml
  gzip hdparm hermes hotplug hotplugctl hp-officeJet htdig hwinfo i4l-base
  i4l-isdnlog i4lfirm id3lib ifnteuro imlib info info2html initviocons insserv
  intlfnts iproute2 iptables iputils isapnp iso_ent ispell ispell-american
  ispell-british ispell-german ispell-ngerman itcl iwidgets jack jack-devel
  jfsutils joe jpackage-utils jpeg k3b kavi2svcd kbd kdebase3 kdebase3-SuSE
  kdebase3-devel kdebase3-kdm kdebase3-ksysguardd kdebase3-nsplugin
  kdebase3-samba kernel-default kernel-default-nongpl kinternet kio_slp
  kipi-plugins knights kover kpowersave krecord kscpm ksymoops lame
  latex2html-pngicons ldapcpplib less libacl libao libattr libbonobo
  libbonoboui libcap libcdio libcdio-devel libcroco libdc1394 libdv libdvdnav
  libexif libgcc libgcj libgcrypt libghttp libgimpprint libglade libglade2
  libgnome libgnomecanvas libgnomecups libgnomeprint libgnomeprintui
  libgnomeui libgpg-error libgsf libgtkhtml libidl libidn libidn-devel
  libjasper libjpeg libkexif libkipi libksba liblcms liblcms-devel libmal
  libmikmod libmng libmng-devel libmpeg3 libmspack libnetpbm libnscd libogg
  libogg-devel libpcap libpng libpng-devel libquicktime librsvg libsamplerate
  libselinux libsmbclient libsndfile libstdc++ libstdc++-devel libstroke
  libtheora libtiff libtool libwmf libxcrypt libxml libxml2 libxml2-devel
  libxslt libxslt-devel liby2util libzio libzvt lilo linc linux-atm-lib liquid
  logrotate lsof lukemftp lzo m4 mad mailx make man man-pages
  manufacturer-PPDs mc mdadm microcode_ctl mingetty mkinitrd mkisofs mktemp
  module-init-tools mtools myspell-german ncurses neon net-snmp net-tools
  netcat netcfg netpbm nfs-utils normalize nscd ntfsprogs oaf openct openh323
  openhbci openjade openmotif-libs openobex opensc openslp openslp-server
  opensp openssh openssh-askpass openssl orbit orbit2 p7zip pam pam-modules
  pango pango-devel parted patch pciutils pcre pcre-devel pcsc-lite perl
  perl-Config-Crontab perl-Crypt-SmbHash perl-Digest-MD4 perl-Digest-SHA1
  perl-Gtk-Perl perl-PDA-Pilot perl-Parse-RecDescent perl-TermReadKey
  perl-X500-DN perl-XML-Parser perl-gettext permissions phalanx pico
  pilot-link pin pinentry pkgconfig pmtools popt popt-devel portmap postfix
  powersave ppp pptp procinfo procmail procps providers psmisc pvm pwdutils
  pwlib python python-gtk python-numeric python-xml qdvdauthor raidtools
  rdesktop readline readline-devel recode reiserfs rekall rekall-xbase
  release-notes resmgr rpm rrdtool rsh samba samba-client samba-doc sash sax2
  sax2-gui sax2-ident sax2-tools scpm screen scrollkeeper scsi sed sensors
  setserial sgml-skel shared-mime-info siga sitar slang slib smpeg smpppd sox
  sqlite src_vipa startup-notification strace streamripper streamtuner
  submount sudo supertux suse-build-key suse-release susehelp susehelp_de
  suselinux-adminguide_de suselinux-userguide_de synaptic sysconfig syslogd
  sysvinit tar tcl tcpd tcpdump tcsh telnet terminfo thinkeramik
  thinkeramik-style tiff tightvnc timezone tk transcode udev unace unclutter
  unixODBC unzip update-alternatives usbutils utempter util-linux v4l-conf
  vacation vcdimager vim vorbis-tools w3m wget wireless-tools words wvdial
  wvstreams wxGTK wxGTK-compat wxGTK-devel wxGTK-gl xanim xaw3d xbanner xbase
  xbsql xdelta xdg-menu xdmbgrd xf86tools xfsprogs xine-ui xinetd xlockmore
  xmlcharent xmms xmms-lib xntp xscreensaver xsu xtermset yast2 yast2-backup
  yast2-bluetooth yast2-bootfloppy yast2-bootloader yast2-control-center
  yast2-core yast2-country yast2-dhcp-server yast2-dns-server yast2-firewall
  yast2-http-server yast2-inetd yast2-installation yast2-irda
  yast2-kerberos-client yast2-ldap yast2-ldap-client yast2-mail
  yast2-mail-aliases yast2-mouse yast2-ncurses yast2-network yast2-nfs-client
  yast2-nfs-server yast2-nis-client yast2-nis-server yast2-ntp-client
  yast2-online-update yast2-packagemanager yast2-packager yast2-pam
  yast2-perl-bindings yast2-phone-services yast2-power-management
  yast2-powertweak yast2-printer yast2-profile-manager yast2-qt yast2-repair
  yast2-restore yast2-runlevel yast2-samba-client yast2-samba-server
  yast2-scanner yast2-schema yast2-security yast2-slp yast2-sound
  yast2-storage yast2-support yast2-sysconfig yast2-tftp-server
  yast2-theme-SuSELinux yast2-trans-de yast2-transfer yast2-tune yast2-tv
  yast2-update yast2-users yast2-x11 yast2-xml yp-tools ypbind yudit zip
  ziptool zisofs-tools zlib zlib-devel zsh zvbi
Die folgenden Pakete werden ERSETZT:
  heimdal-lib (by krb5)  mpg123 (by mpg321)  pwlib-plugins-alsa (by pwlib)
  pwlib-plugins-v4l (by pwlib)
Die folgenden Pakete werden ENTFERNT:
  digikam
Die folgenden NEUEN Pakete werden installiert werden:
  ImageMagick-Magick++ MozillaFirefox checkmedia cifs-mount dbus-1 dbus-1-glib
  dbus-1-qt desktop-file-utils faac ffmpeg gnome-desktop gstreamer
  gstreamer-plugins hal hplip-hpijs java-1_4_2-sun-plugin
  kdepim3-networkstatus klogd krb5 libid3tag libmpeg2 libmusepack libpostproc
  libvisual mDNSResponder meanwhile mpg321 myspell-american myspell-british
  mysql-shared perl-Bootloader perl-TermReadLine-Gnu toolame xvidcore
  yast2-pkg-bindings yast2-trans-stats
Die folgenden Pakete werden DOWNGRADED:
  DVDStyler MPlayer OpenEXR RealPlayer amule arts boehm-gc busybox curl faad2
  filelight gd gphoto imlib2-loaders kde3-i18n-de kdebluetooth kdegraphics3
  kdelibs3 kdemultimedia3 kdemultimedia3-CD kdemultimedia3-mixer
  kdenetwork3-InstantMessenger kdenetwork3-vnc kdepim3 kdepim3-sync kdesdk3
  kdetv kdeutils3 libfame libffmpeg0 libgphoto2 libmusicbrainz libofx
  libtunepimp libusb libxine1 lirc lve mpgtx ogmtools openldap2-client qt3
  qt3-devel sane subversion wine xorg-x11 xorg-x11-Mesa xorg-x11-Mesa-devel
  xorg-x11-Xvnc xorg-x11-devel xorg-x11-fonts-75dpi xorg-x11-fonts-scalable
  xorg-x11-libs xorg-x11-server xorg-x11-server-glx
612 upgraded, 36 newly installed, 56 downgegradet, 4 ersetzt, 1 entfernt und 1 nicht upgegradet.
Muss 3369kB/818MB an Archiven holen.
Nach dem Auspacken werden 94,3MB zusätzlicher Plattenplatz benutzt werden.
Wollen Sie fortsetzen? [J/n] j
E: Method ftp has died unexpectedly!
E: Tried to dequeue a fetching object
KippingPC:~/update #         
Eigentlich habe ich doch nicht zu viele Pakete. Ich hab mal gelesen, das es Probleme mit 800 gibt...

nicki
Newbie
Newbie
Beiträge: 34
Registriert: 3. Jan 2005, 09:23

Beitrag von nicki » 24. Jul 2005, 15:48

Habe jetzt mal in der apt.conf amule bei Ignore eingetragen, da der dort nie das rpm vom ftp bekommt. Jetzt kommt diese Meldung:

Code: Alles auswählen

Wollen Sie fortsetzen? [J/n] j
        libgssapi.so.1 is needed by (installed) kdelibs3-3.4.1-5
        libFLAC.so.4 is needed by (installed) libxine1-1.0.1-0.pm.0
        libFLAC.so.4 is needed by (installed) kdemultimedia3-3.4.1-4
        libFLAC.so.4 is needed by (installed) kdemultimedia3-CD-3.4.1-4
        libbfd-2.15.91.0.2.so is needed by (installed) amule-2.0.1-0.gbv.1
        libdirectfb-0.9.so.20 is needed by (installed) MPlayer-1.0pre7-pm.2
        libexif.so.10 is needed by (installed) sane-1.0.15-16
        libwx_base-2.5.so.2 is needed by (installed) amule-2.0.1-0.gbv.1
        libwx_base-2.5.so.2(WX_2.5) is needed by (installed) amule-2.0.1-0.gbv.1
        libwx_base_net-2.5.so.2 is needed by (installed) amule-2.0.1-0.gbv.1
        libwx_base_net-2.5.so.2(WX_2.5) is needed by (installed) amule-2.0.1-0.gbv.1
        libwx_base_odbc-2.5.so.2 is needed by (installed) amule-2.0.1-0.gbv.1
        libwx_base_xml-2.5.so.2 is needed by (installed) amule-2.0.1-0.gbv.1
        libwx_gtk2_adv-2.5.so.2 is needed by (installed) amule-2.0.1-0.gbv.1
        libwx_gtk2_adv-2.5.so.2(WX_2.5) is needed by (installed) amule-2.0.1-0.gbv.1
        libwx_gtk2_core-2.5.so.2 is needed by (installed) amule-2.0.1-0.gbv.1
        libwx_gtk2_core-2.5.so.2(WX_2.5) is needed by (installed) amule-2.0.1-0.gbv.1
        libwx_gtk2_dbgrid-2.5.so.2 is needed by (installed) amule-2.0.1-0.gbv.1
        libwx_gtk2_html-2.5.so.2 is needed by (installed) amule-2.0.1-0.gbv.1
E: Transaction set check failed
E: Handler silently failed
Kann irgendeiner ggf. was damit anfangen? amule löschen?

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 24. Jul 2005, 15:56

amule deinstallieren,
libxine1 temporär deinstallieren,
sane downgraden (apt policy sane ==> die aus base verwenden, nach erfolgreichem update auf 9.3 upgraden)
MPlayer deinstallieren und später neu installieren
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

nicki
Newbie
Newbie
Beiträge: 34
Registriert: 3. Jan 2005, 09:23

Beitrag von nicki » 24. Jul 2005, 16:13

ibxine1 temporär deinstallieren,
Wie geht das?

nicki
Newbie
Newbie
Beiträge: 34
Registriert: 3. Jan 2005, 09:23

Beitrag von nicki » 24. Jul 2005, 16:41

So habe jetzt folgendes gemacht:
amule deinstalliert
sane downgrade
MPlayer deinstaliert

Darauf kam:

Code: Alles auswählen

Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
You might want to run `apt-get --fix-broken install' to correct these:
Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
  digikam: Hängt ab von: libexif.so.10
           Hängt ab von: libsqlite.so.0
E: Unmet dependencies. Try 'apt-get --fix-broken install' with no packages (or specify a solution).
Was mache ich nur falsch?

Also
downgrade auf digikam 0.7.2-8 und sqlite2
beides ins script eingefügt.

Danach nochmal das Script ausgeführt und es kam:

Code: Alles auswählen

612 upgraded, 38 newly installed, 55 downgegradet, 4 ersetzt, 0 entfernt und 1 nicht upgegradet.
Muss 0B/825MB an Archiven holen.
Nach dem Auspacken werden 135MB zusätzlicher Plattenplatz benutzt werden.
Wollen Sie fortsetzen? [J/n] j
        libgssapi.so.1 is needed by (installed) kdelibs3-3.4.1-5
        libFLAC.so.4 is needed by (installed) libxine1-1.0.1-0.pm.0
        libFLAC.so.4 is needed by (installed) kdemultimedia3-3.4.1-4
        libFLAC.so.4 is needed by (installed) kdemultimedia3-CD-3.4.1-4
E: Transaction set check failed
E: Handler silently failed

nicki
Newbie
Newbie
Beiträge: 34
Registriert: 3. Jan 2005, 09:23

Beitrag von nicki » 24. Jul 2005, 17:42

So, ich bin wieder weiter! Ich habe jetzt den kompletten downgrade von kde3.4 eingetragen. Jetzt fehlt nur noch libxin1!

Wie deinstalliere ich diese temporär? Hab schon im Forum gesucht finde aber keine Antwort!

Danke an alle!

nicki
Newbie
Newbie
Beiträge: 34
Registriert: 3. Jan 2005, 09:23

Beitrag von nicki » 24. Jul 2005, 20:49

Hallo zusammen,

ist eine temporäre deinstallation so richtig?

Code: Alles auswählen

apt-get remove libxin1

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 24. Jul 2005, 21:00

1.) kdemultimedia3 und kdemultimedia3-CD als 3.4.0xxx in das script schreiben.

2.) entweder libxine1 deinstallieren (gxine, xine-ui, etc auch gleich weg) und anschliessend neu installieren oder ganz brutal die 9.3er libxine1 installieren mit rpm -Uhv --nodeps --force libxine1-....

dann script starten ;)

[EDIT] --force noch ergänzt[/EDIT]
Zuletzt geändert von oc2pus am 25. Jul 2005, 08:30, insgesamt 2-mal geändert.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

nicki
Newbie
Newbie
Beiträge: 34
Registriert: 3. Jan 2005, 09:23

Beitrag von nicki » 24. Jul 2005, 21:58

Brutal mit rpm ergiebt:

Code: Alles auswählen

rpm -Uhv --nodeps libxine1-1.0.1-0.pm.0.i686.rpm
warning: libxine1-1.0.1-0.pm.0.i686.rpm: V3 DSA signature: NOKEY, key ID 5277a2fa
Preparing...                ########################################### [100%]
        package libxine1-1.0.1-0.pm.0 is already installed
        file /usr/lib/libxine.so.1.12.0 from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/post/xineplug_post_audio_filters.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/post/xineplug_post_goom.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/post/xineplug_post_mosaico.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/post/xineplug_post_planar.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/post/xineplug_post_switch.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/post/xineplug_post_tvtime.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/post/xineplug_post_visualizations.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/vidix/cyberblade_vid.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/vidix/mach64_vid.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/vidix/mga_crtc2_vid.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/vidix/mga_vid.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/vidix/nvidia_vid.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/vidix/pm2_vid.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/vidix/pm3_vid.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/vidix/radeon_vid.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/vidix/rage128_vid.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/vidix/savage_vid.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/vidix/sis_vid.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/vidix/unichrome_vid.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_ao_out_alsa.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_ao_out_arts.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_ao_out_esd.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_ao_out_file.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_ao_out_none.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_ao_out_oss.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_a52.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_bitplane.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_dts.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_dvaudio.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_faad.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_ff.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_gsm610.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_image.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_lpcm.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_mad.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_mpc.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_mpeg2.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_nsf.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_qt.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_real.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_real_audio.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_rgb.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_speex.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_spu.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_spucc.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_spucmml.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_spudvb.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_sputext.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_theora.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_vorbis.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_w32dll.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_decode_yuv.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_dmx_asf.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_dmx_audio.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_dmx_avi.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_dmx_fli.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_dmx_flv.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_dmx_games.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_dmx_iff.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_dmx_image.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_dmx_matroska.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_dmx_mng.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_dmx_mpeg.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_dmx_mpeg_block.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_dmx_mpeg_elem.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_dmx_mpeg_pes.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_dmx_mpeg_ts.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_dmx_nsv.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_dmx_ogg.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_dmx_pva.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_dmx_qt.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_dmx_rawdv.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_dmx_real.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_dmx_slave.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_dmx_sputext.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_dmx_yuv4mpeg2.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_dmx_yuv_frames.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_flac.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_inp_cdda.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_inp_dvd.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_inp_file.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_inp_http.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_inp_mms.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_inp_net.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_inp_pnm.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_inp_pvr.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_inp_rtp.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_inp_rtsp.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_inp_smb.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_inp_stdin_fifo.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_inp_v4l.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_inp_vcd.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_inp_vcdo.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_vo_out_caca.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_vo_out_fb.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_vo_out_none.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_vo_out_opengl.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_vo_out_vidix.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_vo_out_xshm.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
        file /usr/lib/xine/plugins/1.0.1/xineplug_vo_out_xv.so from install of libxine1-1.0.1-0.pm.0 conflicts with file from package libxine1-1.0.1-0.pm.0
Ich probier mal deinstall :-)

}-Tux-{
Moderator
Moderator
Beiträge: 696
Registriert: 12. Dez 2004, 19:54
Kontaktdaten:

Beitrag von }-Tux-{ » 24. Jul 2005, 22:22

dann füge noch --force hinzu, dann wird es noch brutaler :p
oder verwende die andere methode...

mfg }-Tux-{

nicki
Newbie
Newbie
Beiträge: 34
Registriert: 3. Jan 2005, 09:23

Beitrag von nicki » 25. Jul 2005, 00:27

Bingo! Es läuft! Suse 9.3 startet. Ich muss nur noch an die Nvidia Karte, aber dazu morgen :-)

Danke an alle die mir geholfen haben, ein extra Danke an oc2pus

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 25. Jul 2005, 11:06

Die meisten deiner Probleme resultieren daraus, das du eine sehr sehr aktuelle SuSE-9.2 hattest und in der SuSE-9.3 Pakete die gleiche Versionsnummer haben. Leider fehlt bei diesen Paketen der Eintrag für welche SuSE Version diese Pakete sind, deshalb der "kleine" Umweg mit den SuSE-base-Komponenten.

Weiterhin hlft es oft solche "Quälgeister" RPMs einfach mal zu deinstallieren, das erstellte Script installiert sie ja eh neu. Diesen "workaround" kann man immer dann wählen, wenn es um nicht Systemwichtige Pakete geht. Hier eben libxine1. Wenn man sie nicht deinstallieren will, kann man sie auch einfach aus dem APT-Cache in der 9.3er Version installieren, das muss dann aber mit --nodeps --force erfolgen.

Wichtig nach dem upgrade UND vor dem reboot!
rcrpmconfigcheck aufrufen und die Konfigurationsdateien überprüfen!!

Beim Upgrade auf 9.3 wird OpenOffice 1.99 installiert, dort denke ich kann man sich das überprüfen sparen, da es ja ein neues Major-Release ist. Nur wer selber an den aufgelisteten Dateien rumgespielt hat, sollte dort kontrollieren. Am schnellsten wird man die *.rpmorig von OpenOffice los mit dem Befehl:

Code: Alles auswählen

cd /usr/lib/ooo-2.0
find . -name *.rpmorig | xargs rm -f
Wegen dem kernel update wird man den nVidia Treiber neu instalieren müssen, gleiches gilt für bestimmte WLAN Treiber. Also auch hier noch mal dran denken VOR dem reboot die entsprechenden Dateien via Download besorgen ... denn ohne I-Net Zugang kein Download :)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

nicki
Newbie
Newbie
Beiträge: 34
Registriert: 3. Jan 2005, 09:23

Beitrag von nicki » 25. Jul 2005, 13:21

Ich habe die libxine und die "abhängigen" Pakete einfach deinstalliert. Muss heute mal noch die 9.3 er installieren. KDE läuft noch sehr langsam, da ich den ganzen graphischen "Unsinn" aktiviert habe (Tranzparenz, Animationen). Ich denke aber, das es noch an dem Nvidia-Treiber liegt.

Da ich nach dem Upgrade wie in der Anleitung beschrieben apt -s upgrade ausgeführt habe stand aber leider nichts von nicht installierten Paketen in der Datei /var/log/apt.log! Kann ich davon ausgehen das die Pakete alle ersetzt wurden?

Die Konfigurationsdateien waren bei mir alle i.O.! Die Drucker wurden richtig geschrieben und auch die Netzwerkkarte (kein WLan) lief sofort nach dem Neustart wieder.

Alles in allem kann ich jedem der sich ein bißchen mehr mit Linux beschäftigen will eine solche Aktion empfehlen. Man lernt so mehr von seinem System! Nur Zeit sollte man schon mitbringen. Es ist schon ein bißchen Arbeit, die ganzen Abhängigkeiten (bei einem sehr aktuellem System) zu bereinigen.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 25. Jul 2005, 13:24

Da ich nach dem Upgrade wie in der Anleitung beschrieben apt -s upgrade ausgeführt habe stand aber leider nichts von nicht installierten Paketen in der Datei /var/log/apt.log! Kann ich davon ausgehen das die Pakete alle ersetzt wurden?
Vorsicht!
apt -s upgrade "rechnet" nur, das "-s" steht für simulate. Es wird NICHTS an deinem System verändert. Erst wenn du das "-s" weglässt wird richtig installiert und das wird dann auch in das logfle geschrieben.
apt hat aber bereits alle Pakete in den Cache downgeloaded (normalerweise /var/cache/apt/archives) dort sollten ziemlich viele RPMs stehen bei dir.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

nicki
Newbie
Newbie
Beiträge: 34
Registriert: 3. Jan 2005, 09:23

Beitrag von nicki » 25. Jul 2005, 23:50

Hallo nochmal. Jetzt hat es geklappt. Welcher ist denn der Nvidi Treiber? Den letzten habe ich mit You eingespielt. Leider zeigt You jetzt immer noch Suse 9.2 an.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 26. Jul 2005, 08:00

nicki hat geschrieben:Leider zeigt You jetzt immer noch Suse 9.2 an.
ändere diese Dateien:
/var/adm/YaST/ProdDB/prod_00000001
/var/adm/YaST/InstSrcManager/IS_CACHE_0x00000001/DESCRIPTION/description

und trage dort 9.3 ein :)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast