evolution 2.3.3 fehlen Dateien im Repository?

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
wolfgang-362
Newbie
Newbie
Beiträge: 35
Registriert: 20. Jan 2005, 12:46

evolution 2.3.3 fehlen Dateien im Repository?

Beitrag von wolfgang-362 » 21. Jul 2005, 11:45

Hallo,

die verschiedenen Threads zu diesem Thema und evolution habe ich durchgesehen, u.v.a. "Gnome installieren mit apt" "Evolution gibt's nicht mehr?" "[Tip] Was steht in welchem Repository von apt?", allerdings komme ich trotzdem nicht weiter.

Als Quelle verwende ich:

Code: Alles auswählen

rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/9.2-i386 update security rpmkeys packman gnome ximian kde mozilla suser-rbos base
suser-jogley gibt es nur für 9.3

Beim Installationsversuch von evolution erhalte ich folgendes Ergebnis:

Code: Alles auswählen

athlon:~ # apt install evolution yelp gnome-utils libpanel-applet-2.so.0 libecal-1.2.so.2
Reading Package Lists... Done
Building Dependency Tree... Done
Selecting gnome-panel for 'libpanel-applet-2.so.0'
Package libecal-1.2.so.2 has no available version, but exists in the database.
This typically means that the package was mentioned in a dependency and
never uploaded, has been obsoleted or is not available with the contents
of sources.list
E: Package libecal-1.2.so.2 has no installation candidate
athlon:~ #                                                     
Ich habe es mit YAST versucht und erhalte da ein ähnliches Ergebnis. Woher bekomme ich libecal-1.2.so.2? Die Suche per RPMsearch findet diese Datei in 9.3er Paketen. Wenn ich eine 9.3er Quelle mit in die sources.list aufnehme, gibt es eine Fehlermeldung.

Das mit dem Dummy-Paket würde ich lieber erst probieren, wenn mir jemand den Nutzen bestätigen kann.

Für weitere Hinweise wäre ich dankbar.
Grüße,
wolfgang

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 21. Jul 2005, 12:22

probiere:
apt install evolution yelp gnome-utils gnome-panel
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 21. Jul 2005, 12:37

Ich kann das für SuSE 9.2 bestätigen. "libecal-1.2.so.2" fehlt zur Zeit, da es zu evolution-data-server gehört und SuSE das Paket evolution-data-server leider entfernt und durch eine Version ersetzt hat, die "libecal-1.2.so.3" enthält. Das ist ein Problem, weil das Paket gnome-panel noch nicht aktualisiert wurde und "libecal-1.2.so.2" benötigt. Eine Lösung weiß ich nicht, außer zu warten, bis auch gnome-panel aktualisiert wurde. Der alte evolution-data-server ist wie gesagt nicht mehr zu bekommen.
openSUSE Factory - GNOME 2.32.1

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 21. Jul 2005, 12:41

ok, nach der Info von Traffic gibt es diese lib zur Zeit nicht. Dann kannst du probieren sie mit einem Dummy-RPM in deine RPM-Datenbank einzufügen.

Aber ob die libecal-1.2.so.3 das gleiche leistet wie die libecal-1.2so.2 und ob sie abwärtskompatibel ist, wird sich erst im laufenden Betrieb zeigen ... ein Versuch ist es Wert ;)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

wolfgang-362
Newbie
Newbie
Beiträge: 35
Registriert: 20. Jan 2005, 12:46

Beitrag von wolfgang-362 » 21. Jul 2005, 14:21

Hallo,

Code: Alles auswählen

athlon:~ # apt install evolution yelp gnome-utils gnome-panel
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  gnome-panel: Depends: libecal-1.2.so.2 but it is not installable
E: Broken packages
athlon:~ #
Ich habe die Pakete evolution-data-server-1.2.1-7.i586 und gnutls-1.2.0-3.i586 (benötigt) von /9.3/suse/i586/ gezogen und versucht, händisch zu installieren. Es scheitert hier an Problemen mit der libgnutls.so.12/11.

Es wurde der Rest an Abhängigkeiten ebenfalls aus dem o.a. Verzeichnis geholt und installiert:

Code: Alles auswählen

rpm -Uvi evolution-2.2.1-7.i586.rpm yelp-2.9.3-5.i586.rpm gtkhtml2-3.6.1-5.i586.rpm libgtkhtml-2.6.3-4.i586.rpm gnome-utils-2.10.0-9.i586.rpm gnome-panel-2.10.0-12.i586.rpm gnome-menus-2.10.0-10.i586.rpm libwnck-2.10.0-4.i586.rpm
Evolution 2.2.1 startet sogar. Ob es Nebenwirkungen gibt, muss man sich überraschen lassen.

Danke für die Bestätigung, dass die Version 2.3.3 von Evolution für SuSE 9.2 zur Zeit kaputt ist.
Grüße,
wolfgang

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste