installationen mit apt

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
linOS
Member
Member
Beiträge: 203
Registriert: 21. Mai 2004, 18:21
Wohnort: ruhrgebeat
Kontaktdaten:

installationen mit apt

Beitrag von linOS » 15. Jul 2005, 13:25

hallo

ich hatte vor perl-xmltv zu installieren, dabei kam aber folgenter fehler:

Code: Alles auswählen

You might want to run `apt-get --fix-broken install' to correct these:
Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
  kdebindings3: Hängt ab von: kdelibs3 (>= 3.4.1) aber 3.4.0-22 wird installiert werden
  perl-xmltv: Hängt ab von: perl-XML-DOM aber es wird nicht installiert werden
              Hängt ab von: perl-XML-Writer (>= 0.4.1) aber es wird nicht installiert werden
              Hängt ab von: perl-DateManip (>= 5.42) aber es wird nicht installiert werden
              Hängt ab von: perl-libwww-perl aber es wird nicht installiert werden
              Hängt ab von: perl-Log-TraceMessages aber es wird nicht installiert werden
              Hängt ab von: perl-Term-ProgressBar aber es wird nicht installiert werden
              Hängt ab von: perl-Lingua-Preferred aber es wird nicht installiert werden
              Hängt ab von: perl-Tie-IxHash aber es wird nicht installiert werden
              Hängt ab von: perl-Compress-Zlib aber es wird nicht installiert werden
              Hängt ab von: perl-Lingua-EN-Numbers-Ordinate aber es wird nicht installiert werden
              Hängt ab von: perl-Tk-TableMatrix aber es wird nicht installiert werden
              Hängt ab von: perl-XML-Simple aber es wird nicht installiert werden
              Hängt ab von: perl-Unicode-String aber es wird nicht installiert werden
              Hängt ab von: perl-HTML-TableExtract aber es wird nicht installiert werden
              Hängt ab von: perl-XML-Twig aber es wird nicht installiert werden
              Hängt ab von: perl-HTML-Tree aber es wird nicht installiert werden
              Hängt ab von: perl-PerlIO-gzip aber es wird nicht installiert werden
              Hängt ab von: perl-SOAP-Lite aber es wird nicht installiert werden
              Hängt ab von: perl-Text-Kakasi aber es wird nicht installiert werden
              Hängt ab von: perl-HTTP-Cache-Transparent aber es wird nicht installiert werden
              Hängt ab von: perl-WWW-Mechanize aber es wird nicht installiert werden
E: Unmet dependencies. Try 'apt-get --fix-broken install' with no packages (or specify a solution).
dann dacht ich mir, ich könnte ja kde neu installieren, steht ja auch ganz oben in der liste. außerdem wollte ich ja schon immer mal ein neues kade *gg. aber da das selbe. synaptic mochte mich auch nicht. ich glaub es liegt an meiner bedienung von apt oder? warum löst er die abhängigkeiten nicht auf?

gruß
linos
office: kubuntu 6.06, kde 3.5.3 - amd duron 1,2ghz - ram auch... alles =)

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 15. Jul 2005, 13:34

das sieht so aus, als ob dir ein Eintrag in der sources.list fehlt, denn dein apt findet die perl* Pakete nicht. Und ein weiteres Indiz: dein apt will kde-3.4.0 installieren ...

poste mal deine sources.list und wir sehen weiter ...
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

linOS
Member
Member
Beiträge: 203
Registriert: 21. Mai 2004, 18:21
Wohnort: ruhrgebeat
Kontaktdaten:

Beitrag von linOS » 15. Jul 2005, 14:49

ungeschminkt ;)

Code: Alles auswählen

# Erstellt am Fr Jul 15 12:25:35 CEST 2005
#
# Repository created by: aptate (version 0.69.2)
# At: Fri Jul 15 09:41:01 MEST 2005
# More info about aptate at: http://apt4rpm.sourceforge.net
#
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-oc2pus
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-guru
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 rpmkeys
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 base
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 update
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 kde
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 xorg
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 x-ati
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 mozilla
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 samba3
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-rbos
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-gbv
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-kpietrz
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-obengs
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-tcousin
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-tux
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-scorot
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-sbarnin
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-ollakka
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 funktronics
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 packman
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 packman-i686
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 kraxel
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 wine
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suse-projects
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 kde3-stable
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 security
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-oc2pus
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-guru
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 rpmkeys
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 base
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 update
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 kde
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 xorg
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 x-ati
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 mozilla
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 samba3
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-rbos
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-gbv
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-kpietrz
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-obengs
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-tcousin
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-tux
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-scorot
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-sbarnin
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suser-ollakka
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 funktronics
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 packman
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 packman-i686
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 kraxel
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 wine
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 suse-projects
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 kde3-stable
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 security

## EIGENE

rpm ftp://ftp.funktronics.ca/pub/rpm/apt SuSE/9.2-i586 funktronics
sollte vielleicht hinzufügen, daß es die liste ist, die in /etc/apt/ liegt. man kan ja noch eine mit einem script erstellen. frag mich aber, was ich damit soll, ich kann ja diese ändern. zudem habe ich es nicht geschaft, zb die funktronics-respority einzutragen (was, wie ich gesehen habe, gar nicht nötig gewesen wäre).
office: kubuntu 6.06, kde 3.5.3 - amd duron 1,2ghz - ram auch... alles =)

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 26. Jul 2005, 14:08

deinstalliere mal die kdebindings3 (temporär)

danach ein apt install perl-xmltv
wenn apt wieder über die fehlenden Perl-Module meckert schreibe alle diese perl-Module in eine Zeile

apt install perl-xmltv perl-XML-DOM perl-XML-Writer ...

kann es sein, das du nach Änderung an deiner sources.list KEIN apt update aufgerufen hast ?
was ergibt z.Bsp ein apt policy perl-XML-Writer bei dir ?
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste