[gelöst]Apt-get meldet Speicherzugriffsfehler?

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Benutzeravatar
Erischa
Member
Member
Beiträge: 119
Registriert: 21. Jun 2004, 18:36
Wohnort: Schweiz

[gelöst]Apt-get meldet Speicherzugriffsfehler?

Beitrag von Erischa » 9. Jul 2005, 10:29

Hallo,

ich habe mir beim letzten Aufräumen irgendwie Apt zertrümmert.
Bei apt-get update ist alles i.O.

Code: Alles auswählen

erich # apt-get update
Hole:1 http://ftp.gwdg.de SuSE/9.2-i386 release [11,7kB]
11,7kB in 0s (23,7kB/s) geholt
Treffer http://ftp.gwdg.de SuSE/9.2-i386/base pkglist
Treffer http://ftp.gwdg.de SuSE/9.2-i386/base release
Hole:1 http://ftp.gwdg.de SuSE/9.2-i386/update pkglist [588kB]
Hole:2 http://ftp.gwdg.de SuSE/9.2-i386/update release [132B]
Treffer http://ftp.gwdg.de SuSE/9.2-i386/kde pkglist
Treffer http://ftp.gwdg.de SuSE/9.2-i386/kde release
Treffer http://ftp.gwdg.de SuSE/9.2-i386/kde3-stable pkglist
Treffer http://ftp.gwdg.de SuSE/9.2-i386/kde3-stable release
Treffer http://ftp.gwdg.de SuSE/9.2-i386/rpmkeys pkglist
Treffer http://ftp.gwdg.de SuSE/9.2-i386/rpmkeys release
Treffer http://ftp.gwdg.de SuSE/9.2-i386/ximian pkglist
Treffer http://ftp.gwdg.de SuSE/9.2-i386/ximian release
Treffer http://ftp.gwdg.de SuSE/9.2-i386/xorg pkglist
Treffer http://ftp.gwdg.de SuSE/9.2-i386/xorg release
Treffer http://ftp.gwdg.de SuSE/9.2-i386/misc pkglist
Treffer http://ftp.gwdg.de SuSE/9.2-i386/misc release
Treffer http://ftp.gwdg.de SuSE/9.2-i386/packman pkglist
Treffer http://ftp.gwdg.de SuSE/9.2-i386/packman release
Treffer http://ftp.gwdg.de SuSE/9.2-i386/packman-i686 pkglist
Treffer http://ftp.gwdg.de SuSE/9.2-i386/packman-i686 release
Treffer http://ftp.gwdg.de SuSE/9.2-i386/suser-rbos pkglist
Treffer http://ftp.gwdg.de SuSE/9.2-i386/suser-rbos release
Treffer http://ftp.gwdg.de SuSE/9.2-i386/funktronics pkglist
Treffer http://ftp.gwdg.de SuSE/9.2-i386/funktronics release
Treffer http://ftp.gwdg.de SuSE/9.2-i386/suser-oc2pus pkglist
Treffer http://ftp.gwdg.de SuSE/9.2-i386/suser-oc2pus release
Treffer http://ftp.gwdg.de SuSE/9.2-i386/suser-ollakka pkglist
Treffer http://ftp.gwdg.de SuSE/9.2-i386/suser-ollakka release
Treffer http://ftp.gwdg.de SuSE/9.2-i386/suser-sbarnin pkglist
Treffer http://ftp.gwdg.de SuSE/9.2-i386/suser-sbarnin release
Treffer http://ftp.gwdg.de SuSE/9.2-i386/suser-gbv pkglist
Treffer http://ftp.gwdg.de SuSE/9.2-i386/suser-gbv release
Treffer http://ftp.gwdg.de SuSE/9.2-i386/suser-scorot pkglist
Treffer http://ftp.gwdg.de SuSE/9.2-i386/suser-scorot release
Treffer http://ftp.gwdg.de SuSE/9.2-i386/mozilla pkglist
Treffer http://ftp.gwdg.de SuSE/9.2-i386/mozilla release
588kB in 15s (36,9kB/s) geholt
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Bei einem apt-get upgrade kommt???

Code: Alles auswählen

erich # apt-get upgrade
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Die folgenden Pakete werden upgegradet werden:
  zlib
1 upgraded, 0 newly installed, 0 entfernt und 0 nicht upgegradet.
Muss 0B/63,7kB an Archiven holen.
Nach dem Auspacken werden 32B zusätzlicher Plattenplatz benutzt werden.
Wollen Sie fortsetzen? [J/n] j
        libc.so.6 is needed by zlib-1.2.1-74.2
        libc.so.6(GLIBC_2.0) is needed by zlib-1.2.1-74.2
        libc.so.6(GLIBC_2.1) is needed by zlib-1.2.1-74.2
        libc.so.6(GLIBC_2.1.3) is needed by zlib-1.2.1-74.2
E: Transaction set check failed
E: Handler silently failed
Bei einem apt-get check und apt-get -f install scheint alles normal

Code: Alles auswählen

/erich # apt-get check
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig

erich # apt-get -f install
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
0 upgraded, 0 newly installed, 0 entfernt und 1 nicht upgegradet.
Aber bei apt-get dist-upgrade erscheint Speicherzugriffsfehler

Code: Alles auswählen

erich # apt-get dist-upgrade
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Berechne Upgrade... Fertig
Die folgenden Pakete werden upgegradet werden:
  zlib
Die folgenden Pakete werden ERSETZT:
  memtest86 (by memtest86+)
Die folgenden NEUEN Pakete werden installiert werden:
  apt apt-libs cyrus-sasl gpg libnscd libxcrypt memtest86+ module-init-tools
  openldap2-client openslp pam-modules pwdutils rpm suse-build-key util-linux
1 upgraded, 15 newly installed, 1 ersetzt, 0 entfernt und 0 nicht upgegradet.
Muss 0B/7727kB an Archiven holen.
Nach dem Auspacken werden 22,9MB zusätzlicher Plattenplatz benutzt werden.
Wollen Sie fortsetzen? [J/n] j
Speicherzugriffsfehler
Es ist mir auch nicht mehr möglich Pakete wie RealPlayer zu installieren er beginnt die Installation normal und bricht ebenfalls mit Speicherzugriffsfehler ab.

1.) Gibt es ein Befehl in Apt um dieses Dilema zu beheben? Wenn Punkt 1. nicht zutrifft:
2.) Wie deinstalliere ich apt um das gute Paket wieder zu installieren? Kann ich da einfach alle Apt-Ordner löschen? -Fertig! Oder muss ich da noch andere Punkten bedenken.

Vielen Dank für Hilfe und ...
Zuletzt geändert von Erischa am 9. Jul 2005, 18:32, insgesamt 1-mal geändert.
Es Grüssle Erich

Öfters hilft ein rpm --rebuilddb
Compaq Presario 700
Linux Suse 9.3
Kernel 2.6.11-XX.XX-default
KDE 3.4

Werbung:
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 9. Jul 2005, 16:16

Mach mal ein

rpm --rebuilddb

Vielleicht hilft das ja.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

Benutzeravatar
Erischa
Member
Member
Beiträge: 119
Registriert: 21. Jun 2004, 18:36
Wohnort: Schweiz

Beitrag von Erischa » 9. Jul 2005, 18:30

Hallo,
Martin Breidenbach hat geschrieben:Mach mal ein

rpm --rebuilddb

Vielleicht hilft das ja.
Volltreffer, dies hat das Problem behoben.
Es Grüssle Erich

Öfters hilft ein rpm --rebuilddb
Compaq Presario 700
Linux Suse 9.3
Kernel 2.6.11-XX.XX-default
KDE 3.4

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast