apt-get problem (mit glibc)

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
damarges
Newbie
Newbie
Beiträge: 23
Registriert: 7. Jul 2005, 11:19
Kontaktdaten:

apt-get problem (mit glibc)

Beitrag von damarges » 7. Jul 2005, 11:31

Halli Hallo!

Habe ein problem! Und zwar benötige ich für meinen Half Life -Server das glib paket! Folgende Fehlermeldung:

scandir failed:/home/damarges/hlds/./platform/SAVE
Error:/lib/libpthread.so.0: version `GLIBC_2.3.2' not found (required by ./tier0_s_i486.so)

nun habe ich hier ein neues debian laufen und habe versucht mit

apt-get install glibc

zu installieren! daraufhin kam diese fehlermeldung:

skidoo:/home/damarges/hlds# apt-get install glibc
Reading Package Lists... Done
Building Dependency Tree... Done
E: Couldn't find package glibc
skidoo:/home/damarges/hlds#

was kann ich machen um das paket zu bekommen?

Werbung:
Benutzeravatar
Bibaltik
Member
Member
Beiträge: 208
Registriert: 28. Jul 2004, 19:33
Wohnort: Neubrandenburg
Kontaktdaten:

Beitrag von Bibaltik » 8. Jul 2005, 08:53

Erstmal die Info was glibc überhaupt ist: http://www.computerbase.de/lexikon/Glibc

Dann solltest du herausfinden welche Version bei dir installiert ist: http://www.pc-magazin.de/praxis/windows ... &start=120

Und da ich nicht weis welche Dist auf dem Server läuft mal ein Thread aus diesem Board: http://www.linux-club.de/viewtopic.php?t=3772
Bild

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Re: apt-get problem (mit glibc)

Beitrag von oc2pus » 8. Jul 2005, 09:07

damarges hat geschrieben:apt-get install glibc

zu installieren! daraufhin kam diese fehlermeldung:

skidoo:/home/damarges/hlds# apt-get install glibc
Reading Package Lists... Done
Building Dependency Tree... Done
E: Couldn't find package glibc
skidoo:/home/damarges/hlds#
das bedeutet: dein APT "sieht" kein Paket glibc ;)

Lösungen:
anpassen der sources.list
apt-get update laufen lassen, dann nochmal probieren.

Ansonsten: Immer die Version und deine Distri nennen, sonst kann dir keiner helfen.

Anmerkung: glibc ist ein zentrales Paket, ohne das geht nichts. Du solltest es sogar bereits installiert haben, nur in der "falschen" Version. Und wenn dein apt-get dann mit dieser Fehlermeldung kommt ==> dein apt ist NICHT korrekt installiert/konfiguriert da du mindestens EIN Paket glibc sehen solltest.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
TheTuxKeeper
Member
Member
Beiträge: 127
Registriert: 31. Jan 2005, 17:18
Kontaktdaten:

Beitrag von TheTuxKeeper » 8. Jul 2005, 13:24

Das Paket heißt bei Debian libc6 nicht glibc. Deswegen findet apt nichts.

MfG

Daniel
IBM X30 -- PIII M 1200MHz -- 512MB Ram
OpenSUSE 10.2 -- KDE
Gentoo 2006.1 ~x86

Antworten

Wer ist online?

Mitglieder in diesem Forum: Google [Bot] und 1 Gast