Problem bei Upgrade 9.1=>9.2

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

ojkastl
Hacker
Hacker
Beiträge: 547
Registriert: 15. Dez 2004, 04:51
Wohnort: Erlangen
Kontaktdaten:

Problem bei Upgrade 9.1=>9.2

Beitrag von ojkastl » 1. Jul 2005, 10:08

Hallo,

ich versuche mal einer Upgrade meiner 9.1 auf 9.2, dazu bin ich nach der Anleitung hier
http://www.linux-club.de/viewtopic.php?t=23601
vorgegangen.

Das myupgrade.sh lädt alles runter, und dann kommt:
Wollen Sie fortsetzen? [J/n] j
xv = 3.10a-1062 | xv = 3.10a-1062.2 is needed by xv-3.10a-1062.4
gnome-filesystem = 0.1-189 is needed by gnome-filesystem-0.1-189.2
bzip2 = 1.0.2-347 is needed by bzip2-1.0.2-347.3
esound = 0.2.35-4 is needed by esound-0.2.35-4.2
tcpd = 7.6-713 is needed by tcpd-7.6-713.2
gnome-vfs2 = 2.6.1-38 | gnome-vfs2 = 2.6.1-38.2 is needed by gnome-vfs2-2.6.1-38.4
aaa_base = 9.2-5 | aaa_base = 9.2-5.2 is needed by aaa_base-9.2-5.4
htdig = 3.2.0b6-3 is needed by htdig-3.2.0b6-3.2
ImageMagick-Magick++ = 6.0.7-4 | ImageMagick-Magick++ = 6.0.7-4.2 | ImageMagick-Magick++ = 6.0.7-4.4 is needed by ImageMagick-Magick++-6.0.7-4.6
bison = 1.875-53 is needed by bison-1.875-53.2
sudo = 1.6.7p5-118 is needed by sudo-1.6.7p5-118.2
libreadline.so.4 is needed by (installed) freeciv-2.0.1-1.pm.1
libreadline.so.4 is needed by (installed) xine-ui-0.99.3-0.pm.0
E: Transaction set check failed
Ich hab mal mit xv angefangen:

RobinLinux:/etc/apt # apt policy xv
xv:
Installiert: 3.10a-1053.12
Kandidat: 3.10a-1062.4
Versionstabelle:
3.10a-1062.4 0
1001 ftp://ftp.gwdg.de SuSE/9.2-i386/update-prpm pkglist
1001 ftp://ftp.gwdg.de SuSE/9.2-i386/update pkglist
1001 ftp://ftp.gwdg.de SuSE/9.2-i386/security-prpm pkglist
1001 ftp://ftp.gwdg.de SuSE/9.2-i386/security pkglist
3.10a-1062.2 0
1001 ftp://ftp.gwdg.de SuSE/9.2-i386/update pkglist
1001 ftp://ftp.gwdg.de SuSE/9.2-i386/security pkglist
3.10a-1062.1 0
1001 ftp://ftp.gwdg.de SuSE/9.2-i386/base pkglist
*** 3.10a-1053.12 0
500 ftp://ftp.uni-erlangen.de SuSE/9.1-i386/updates pkglist
500 ftp://ftp.uni-erlangen.de SuSE/9.1-i386/security pkglist
100 RPM Database
3.10a-1053.9 0
500 ftp://ftp.uni-erlangen.de SuSE/9.1-i386/updates pkglist
3.10a-1051 0
500 ftp://ftp.uni-erlangen.de SuSE/9.1-i386/base pkglist
RobinLinux:/etc/apt #
und wenn ich die Version 3.10a-1062.1 explizit angebe im Skript, dann geht es.

Warum zum Henker braucht ein Paket xv in Version 3.10a-1062.4 ein schon installiertes in Version 3.10a-1062 oder 3.10a-1062.2? Wie ist da der Zusammenhang? Das ist doch bescheuert, oder seh ich da was nicht.

Naja, werd mal die anderen versuche.

Saber

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 1. Jul 2005, 10:17

das liegt schlicht und einfach daran das du immer noch die prpm und drpm (Patch-Pakete) in deiner sources.list drin hast ... genau lesen hilft immer.

nach Änderung an der sources.list apt update NICHT vergessen.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

ojkastl
Hacker
Hacker
Beiträge: 547
Registriert: 15. Dez 2004, 04:51
Wohnort: Erlangen
Kontaktdaten:

Beitrag von ojkastl » 1. Jul 2005, 10:42

Hallo,

meine Güte, ist das kompliziert. Da muss man erstmal drauf kommen, dass es ja ab 9.2 auch die drpms und so gibt. Wären mir gar nicht aufgefallen.

Also, vielen Dank für die Hilfe. Und sorry für die Aufregung.

Saber

ojkastl
Hacker
Hacker
Beiträge: 547
Registriert: 15. Dez 2004, 04:51
Wohnort: Erlangen
Kontaktdaten:

Beitrag von ojkastl » 4. Jul 2005, 22:23

Hallo nochmal,

ich hab mich jetzt langsam aber stetig durch die zahlreichen Fehlermeldungen durchgekämpft, und jetzt kommt beim Aufruf des Skripts nur noch folgendes:
Preparing... ########################################### [100%]
package libquicktime-0.9.4-1.pm.1 is already installed
package libkexif-0.2.1-2 is already installed
package digikam-0.7.3beta2-3 is already installed
package uae-0.8.27-1.pm.0 is already installed
package libogg-1.1.2-0.pm.0 is already installed
package libogg-devel-1.1.2-0.pm.0 is already installed
package libusb-0.1.10-0.pm.2 is already installed
package a52dec-0.7.4-3.pm.1 is already installed
package libffmpeg0-0.4.9-3.pm.pre1 is already installed
package libraw1394-1.2.0-1.pm.2 is already installed
package libavc1394-0.5.0-1.pm.1 is already installed
package lve-0.040322-0.pm.1 is already installed
package boost-1.32.0-0.pm.1 is already installed
package divx4linux-20030428-0.pm.0 is already installed
package libieee1284-0.2.10-0.pm.1 is already installed
package subtitleripper-0.3-4.pm.1 is already installed
package fame-0.9.0-5.pm.0 is already installed
package ogmtools-1.5-0.pm.0 is already installed
package rar-3.4.1-0.pm.0 is already installed
package w32codec-all-20050412-0.pm.0 is already installed
file /usr/bin/libquicktime_config from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/bin/lqt_transcode from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/bin/lqtplay from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/bin/lqtvrplay from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/bin/qtdechunk from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/bin/qtdump from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/bin/qtinfo from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/bin/qtrechunk from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/bin/qtstreamize from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/bin/qtyuv4toyuv from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/lib/libquicktime.so.0.0.0 from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/lib/libquicktime/lqt_audiocodec.a from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/lib/libquicktime/lqt_audiocodec.la from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/lib/libquicktime/lqt_audiocodec.so from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/lib/libquicktime/lqt_dv.a from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/lib/libquicktime/lqt_dv.la from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/lib/libquicktime/lqt_dv.so from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/lib/libquicktime/lqt_mjpeg.a from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/lib/libquicktime/lqt_mjpeg.la from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/lib/libquicktime/lqt_mjpeg.so from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/lib/libquicktime/lqt_png.a from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/lib/libquicktime/lqt_png.la from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/lib/libquicktime/lqt_png.so from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/lib/libquicktime/lqt_rtjpeg.a from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/lib/libquicktime/lqt_rtjpeg.la from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/lib/libquicktime/lqt_rtjpeg.so from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/lib/libquicktime/lqt_videocodec.a from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/lib/libquicktime/lqt_videocodec.la from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/lib/libquicktime/lqt_videocodec.so from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/lib/libquicktime/lqt_vorbis.a from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/lib/libquicktime/lqt_vorbis.la from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/lib/libquicktime/lqt_vorbis.so from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/lib/libquicktime1394.so.0.0.0 from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /usr/share/man/man1/lqtplay.1.gz from install of libquicktime-0.9.4-1.pm.1 conflicts with file from package libquicktime-0.9.4-1.pm.1
file /opt/kde3/lib/libkexif.la from install of libkexif-0.2.1-2 conflicts with file from package libkexif-0.2.1-2
file /opt/kde3/lib/libkexif.so.1.0.0 from install of libkexif-0.2.1-2 conflicts with file from package libkexif-0.2.1-2
file /opt/kde3/bin/digikam from install of digikam-0.7.3beta2-3 conflicts with file from package digikam-0.7.3beta2-3
file /opt/kde3/bin/showfoto from install of digikam-0.7.3beta2-3 conflicts with file from package digikam-0.7.3beta2-3
file /opt/kde3/lib/kde3/digikamimageplugin_core.la from install of digikam-0.7.3beta2-3 conflicts with file from package digikam-0.7.3beta2-3
file /opt/kde3/lib/kde3/digikamimageplugin_core.so from install of digikam-0.7.3beta2-3 conflicts with file from package digikam-0.7.3beta2-3
file /opt/kde3/lib/kde3/kio_digikamio.la from install of digikam-0.7.3beta2-3 conflicts with file from package digikam-0.7.3beta2-3
file /opt/kde3/lib/kde3/kio_digikamio.so from install of digikam-0.7.3beta2-3 conflicts with file from package digikam-0.7.3beta2-3
file /opt/kde3/lib/kde3/kio_digikamtags.la from install of digikam-0.7.3beta2-3 conflicts with file from package digikam-0.7.3beta2-3
file /opt/kde3/lib/kde3/kio_digikamtags.so from install of digikam-0.7.3beta2-3 conflicts with file from package digikam-0.7.3beta2-3
file /opt/kde3/lib/kde3/kio_digikamthumbnail.la from install of digikam-0.7.3beta2-3 conflicts with file from package digikam-0.7.3beta2-3
file /opt/kde3/lib/kde3/kio_digikamthumbnail.so from install of digikam-0.7.3beta2-3 conflicts with file from package digikam-0.7.3beta2-3
file /opt/kde3/lib/libdigikam.la from install of digikam-0.7.3beta2-3 conflicts with file from package digikam-0.7.3beta2-3
file /opt/kde3/lib/libdigikam.so.0.0.0 from install of digikam-0.7.3beta2-3 conflicts with file from package digikam-0.7.3beta2-3
file /opt/kde3/share/doc/HTML/da/digikam/index.cache.bz2 from install of digikam-0.7.3beta2-3 conflicts with file from package digikam-0.7.3beta2-3
file /opt/kde3/share/doc/HTML/en/digikam/index.cache.bz2 from install of digikam-0.7.3beta2-3 conflicts with file from package digikam-0.7.3beta2-3
file /opt/kde3/share/doc/HTML/et/digikam/index.cache.bz2 from install of digikam-0.7.3beta2-3 conflicts with file from package digikam-0.7.3beta2-3
file /opt/kde3/share/doc/HTML/it/digikam/index.cache.bz2 from install of digikam-0.7.3beta2-3 conflicts with file from package digikam-0.7.3beta2-3
file /opt/kde3/share/doc/HTML/nl/digikam/index.cache.bz2 from install of digikam-0.7.3beta2-3 conflicts with file from package digikam-0.7.3beta2-3
file /opt/kde3/share/doc/HTML/pt/digikam/index.cache.bz2 from install of digikam-0.7.3beta2-3 conflicts with file from package digikam-0.7.3beta2-3
file /opt/kde3/share/doc/HTML/pt_BR/digikam/index.cache.bz2 from install of digikam-0.7.3beta2-3 conflicts with file from package digikam-0.7.3beta2-3
file /opt/kde3/share/doc/HTML/sv/digikam/index.cache.bz2 from install of digikam-0.7.3beta2-3 conflicts with file from package digikam-0.7.3beta2-3
file /usr/bin/uae from install of uae-0.8.27-1.pm.0 conflicts with file from package uae-0.8.27-1.pm.0
file /usr/lib/uae/readdisk from install of uae-0.8.27-1.pm.0 conflicts with file from package uae-0.8.27-1.pm.0
file /usr/share/applications/uae.desktop from install of uae-0.8.27-1.pm.0 conflicts with file from package uae-0.8.27-1.pm.0
file /usr/bin/testlibusb from install of libusb-0.1.10-0.pm.2 conflicts with file from package libusb-0.1.10-0.pm.2
file /usr/lib/libusb-0.1.so.4.4.2 from install of libusb-0.1.10-0.pm.2 conflicts with file from package libusb-0.1.10-0.pm.2
file /usr/lib/libusbpp-0.1.so.4.4.2 from install of libusb-0.1.10-0.pm.2 conflicts with file from package libusb-0.1.10-0.pm.2
file /usr/lib/libraw1394.so.8.1.0 from install of libraw1394-1.2.0-1.pm.2 conflicts with file from package libraw1394-1.2.0-1.pm.2
file /usr/bin/dvcont from install of libavc1394-0.5.0-1.pm.1 conflicts with file from package libavc1394-0.5.0-1.pm.1
file /usr/bin/mkrfc2734 from install of libavc1394-0.5.0-1.pm.1 conflicts with file from package libavc1394-0.5.0-1.pm.1
file /usr/lib/libavc1394.so.0.2.0 from install of libavc1394-0.5.0-1.pm.1 conflicts with file from package libavc1394-0.5.0-1.pm.1
file /usr/lib/librom1394.so.0.2.0 from install of libavc1394-0.5.0-1.pm.1 conflicts with file from package libavc1394-0.5.0-1.pm.1
file /usr/share/man/man1/dvcont.1.gz from install of libavc1394-0.5.0-1.pm.1 conflicts with file from package libavc1394-0.5.0-1.pm.1
file /usr/share/man/man1/mkrfc2734.1.gz from install of libavc1394-0.5.0-1.pm.1 conflicts with file from package libavc1394-0.5.0-1.pm.1
file /usr/bin/lve from install of lve-0.040322-0.pm.1 conflicts with file from package lve-0.040322-0.pm.1
file /usr/bin/lvedemux from install of lve-0.040322-0.pm.1 conflicts with file from package lve-0.040322-0.pm.1
file /usr/bin/lvedump from install of lve-0.040322-0.pm.1 conflicts with file from package lve-0.040322-0.pm.1
file /usr/bin/lvefilter from install of lve-0.040322-0.pm.1 conflicts with file from package lve-0.040322-0.pm.1
file /usr/bin/lvemkdvd from install of lve-0.040322-0.pm.1 conflicts with file from package lve-0.040322-0.pm.1
file /usr/bin/lvemkidx from install of lve-0.040322-0.pm.1 conflicts with file from package lve-0.040322-0.pm.1
file /usr/bin/lvemux from install of lve-0.040322-0.pm.1 conflicts with file from package lve-0.040322-0.pm.1
file /usr/bin/lverequant from install of lve-0.040322-0.pm.1 conflicts with file from package lve-0.040322-0.pm.1
file /usr/bin/qdir from install of lve-0.040322-0.pm.1 conflicts with file from package lve-0.040322-0.pm.1
file /usr/lib/liblve.a from install of lve-0.040322-0.pm.1 conflicts with file from package lve-0.040322-0.pm.1
file /usr/lib/liblve.so from install of lve-0.040322-0.pm.1 conflicts with file from package lve-0.040322-0.pm.1
file /usr/lib/libboost_date_time-gcc-1_32.so.1.32.0 from install of boost-1.32.0-0.pm.1 conflicts with file from package boost-1.32.0-0.pm.1
file /usr/lib/libboost_filesystem-gcc-1_32.so.1.32.0 from install of boost-1.32.0-0.pm.1 conflicts with file from package boost-1.32.0-0.pm.1
file /usr/lib/libboost_prg_exec_monitor-gcc-1_32.so.1.32.0 from install of boost-1.32.0-0.pm.1 conflicts with file from package boost-1.32.0-0.pm.1
file /usr/lib/libboost_program_options-gcc-1_32.so.1.32.0 from install of boost-1.32.0-0.pm.1 conflicts with file from package boost-1.32.0-0.pm.1
file /usr/lib/libboost_python-gcc-1_32.so.1.32.0 from install of boost-1.32.0-0.pm.1 conflicts with file from package boost-1.32.0-0.pm.1
file /usr/lib/libboost_regex-gcc-1_32.so.1.32.0 from install of boost-1.32.0-0.pm.1 conflicts with file from package boost-1.32.0-0.pm.1
file /usr/lib/libboost_signals-gcc-1_32.so.1.32.0 from install of boost-1.32.0-0.pm.1 conflicts with file from package boost-1.32.0-0.pm.1
file /usr/lib/libboost_test_exec_monitor-gcc-1_32.so.1.32.0 from install of boost-1.32.0-0.pm.1 conflicts with file from package boost-1.32.0-0.pm.1
file /usr/lib/libboost_thread-gcc-mt-1_32.so.1.32.0 from install of boost-1.32.0-0.pm.1 conflicts with file from package boost-1.32.0-0.pm.1
file /usr/lib/libboost_unit_test_framework-gcc-1_32.so.1.32.0 from install of boost-1.32.0-0.pm.1 conflicts with file from package boost-1.32.0-0.pm.1
file /usr/X11R6/include/X11/extensions/vldXvMC.h conflicts between attempted installs of libXvMCW-0.9.3-0.pm.0 and xorg-x11-devel-6.8.2-35.1
file /usr/lib/libieee1284.so.3.2.2 from install of libieee1284-0.2.10-0.pm.1 conflicts with file from package libieee1284-0.2.10-0.pm.1
E: Error while running transaction
RobinLinux:/etc/apt #
Leider kann ich keine Pakete mehr deinstallieren, da das immer einen Rattenschwanz an Änderungen/Abhängigkeiten nach sich zieht. Vorher stand da drin dass was aus dem Paket sane mit was aus dem Paket sane nicht mag, also sane deinstalliert, und gut ist. Aber die jetzt noch verbliebenen Fehlermeldungen gehen nicht weg, weil ich die Pakete nicht deinstallieren kann.

FRAGE: Kann ich jetzt einfach im Skript auf apt install --force umstellen, oder wird das wegen der Fehlermeldungen nicht klappen?

Danke,
Saber

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 5. Jul 2005, 07:58

FRAGE: Kann ich jetzt einfach im Skript auf apt install --force umstellen, oder wird das wegen der Fehlermeldungen nicht klappen?
ja ;)

und bei den Paketen wo "is already installed" steht, nach dem upgrade auf 9.2 folgendes tun:
rpm -e --nodeps <paket1 paket2 ...>
dann apt install paket1 paket2 ...

in diesen Paketen fehlt leider die Angabe das sie zu SuSE-9.2 gehören und die Versionsnummern sind in 9.1 und 9.2 gleich ... deshalb "irrt" apt bzw rpm hier und will kein upgrade durchführen.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

ojkastl
Hacker
Hacker
Beiträge: 547
Registriert: 15. Dez 2004, 04:51
Wohnort: Erlangen
Kontaktdaten:

Beitrag von ojkastl » 5. Jul 2005, 12:04

Dein Wort in Gottes Ohren...


Ich werds dann wohl mal probieren. Ich meld mich wieder, wenn ich weiss ob es geklappt hat oder nicht.

Danke,
Saber

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 5. Jul 2005, 13:06

Saber_Rider hat geschrieben:Dein Wort in Gottes Ohren...
hehe, doch glaube es mir, das funzt so. durch die temporäre deinstallation mit der Option --nodeps "hängt" deine RPM-Datenbank kurz in der Luft, aber da du die entsprechenden Pakete ja anschliessend gleich neu installierst, gibt es kein Problem.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

ojkastl
Hacker
Hacker
Beiträge: 547
Registriert: 15. Dez 2004, 04:51
Wohnort: Erlangen
Kontaktdaten:

Beitrag von ojkastl » 5. Jul 2005, 18:01

Hi,

ich häng grad mittendrin, und es geht nicht weiter.

Seit 15min hängt das Updaten an einer Stelle:
Updating etc/shadow...unchanged
gpg: key 9C800ACA: "SuSE Package Signing Key <build@suse.de>" not changed
gpg: Total number processed: 1
gpg: unchanged: 1
362:apache ########################################### [ 41%]
Updating etc/sysconfig/apache...
Please remember to run 'SuSEconfig --module apache' to configure the server
363:htdig ########################################### [ 41%]
364:recode ########################################### [ 41%]
365:wget ########################################### [ 42%]
366:info2html ########################################### [ 42%]
367:susehelp ########################################### [ 42%]
Updating etc/sysconfig/susehelp...
Updating etc/sysconfig/apache2...
368:EastWest ########################################### [ 42%]
369:dosbootdisk ########################################### [ 42%]
370:suse-build-key ########################################### [ 42%]
importing SuSE build key to rpm keyring... done.
371:rpm ########################################### [ 42%]
Updating etc/sysconfig/services...
372:sax2-ident ########################################### [ 42%]
373:xorg-x11-server-glx ########################################### [ 42%]
374:xorg-x11-server ########################################### [ 43%]
Starting SuSEconfig, the SuSE Configuration Tool...
Running module permissions only
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.permissions...
Und da geht nix. Festplatte nicht aktiv, in top ist apt-get nicht zu sehen.

Was tun?
Ich lass jetzt erstmal laufen...

Saber

ojkastl
Hacker
Hacker
Beiträge: 547
Registriert: 15. Dez 2004, 04:51
Wohnort: Erlangen
Kontaktdaten:

Beitrag von ojkastl » 5. Jul 2005, 18:13

ENTWARNUNG:

JETZT GEHTS WIEDER bzw. WEITER!

ojkastl
Hacker
Hacker
Beiträge: 547
Registriert: 15. Dez 2004, 04:51
Wohnort: Erlangen
Kontaktdaten:

Beitrag von ojkastl » 5. Jul 2005, 20:40

Und die nächste Runde.

Obwohl er mich immer wieder warten ließ, ging soweit alles ganz gut.

Bis hier:

Das letzte installierte Paket war:
874:yast2-tftp-server ########################################### [100%]
875:yast2-trans-de ########################################### [100%]
876:yast2-tv ########################################### [100%]
877:zip ########################################### [100%]
878:ziptool ########################################### [100%]
apt executing: /sbin/SuSEconfig
Starting SuSEconfig, the SuSE Configuration Tool...
Running in full featured mode.
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.apache...
Installing new /etc/httpd/httpd.conf
Installing new /etc/httpd/suse_loadmodule.conf
Installing new /etc/httpd/suse_addmodule.conf
Installing new /etc/httpd/suse_include.conf
Installing new /etc/httpd/suse_define.conf
Installing new /etc/httpd/suse_text.conf
Executing /sbin/conf.d/SuSEconfig.automake...
Executing /sbin/conf.d/SuSEconfig.fonts...
Creating cache files for Xft .........................
Creating fonts.{scale,dir} files ...........
can't open file /usr/lib/ooo-1.1/share/registry/data/org/openoffice/Office/Common.xcu: Datei oder Verzeichnis nicht gefunden at /usr/sbin/fonts-config line 1428.
Executing /sbin/conf.d/SuSEconfig.gnome-vfs2...
Executing /sbin/conf.d/SuSEconfig.groff...
Executing /sbin/conf.d/SuSEconfig.gtk2...
Executing /sbin/conf.d/SuSEconfig.guile...
Executing /sbin/conf.d/SuSEconfig.isdn...
Reading cfg-contr0 ...
provider einsundeins-dsl done
provider provider0 done
provider provider1 done
Executing /sbin/conf.d/SuSEconfig.ispell...
Executing /sbin/conf.d/SuSEconfig.kde...
Executing /sbin/conf.d/SuSEconfig.kdm3...

ATTENTION: You have modified /etc/opt/kde3/share/config/kdm//kdmrc. Leaving it untouched...
You can find my version in /etc/opt/kde3/share/config/kdm//kdmrc.SuSEconfig...

Executing /sbin/conf.d/SuSEconfig.libxml2...
Executing /sbin/conf.d/SuSEconfig.news...
Executing /sbin/conf.d/SuSEconfig.pango...
Executing /sbin/conf.d/SuSEconfig.perl...
Executing /sbin/conf.d/SuSEconfig.permissions...
Checking permissions and ownerships - using the permissions files
/etc/permissions.d/cups-client
/etc/permissions.d/gscmxx
/etc/permissions.d/kdebase3
/etc/permissions.d/postfix
/etc/permissions.d/susehelp
/etc/permissions.d/tetex
/etc/permissions
/etc/permissions.easy
/etc/permissions.local
setting /usr/bin/ziptool to root:trusted 4755. (wrong permissions 4750)
setting /bin/eject to root:audio 4755. (wrong permissions 4750)
Executing /sbin/conf.d/SuSEconfig.postfix...
Setting up postfix local as MDA...
Setting SPAM protection to "off"...
Executing /sbin/conf.d/SuSEconfig.profiles...
Executing /sbin/conf.d/SuSEconfig.scpm...
Executing /sbin/conf.d/SuSEconfig.scrollkeeper...
Statistiken zur Datei »/usr/local/share/gnome/help/gtkam/C/gtkam.xml« konnten nicht abgerufen werden: Datei oder Verzeichnis nicht gefunden
Executing /sbin/conf.d/SuSEconfig.sgml-skel...
Executing /sbin/conf.d/SuSEconfig.sortpasswd...
Executing /sbin/conf.d/SuSEconfig.susehelp...
Executing /sbin/conf.d/SuSEconfig.tetex...
Danach kommt ewig Zeug (das wohl alles zu tetex gehört), bis er hier abbricht:
fmtutil: /var/lib/texmf/web2c/amstex.fmt installed.
fmtutil: /var/lib/texmf/web2c/cslatex.fmt installed.
fmtutil: /var/lib/texmf/web2c/csplain.fmt installed.
fmtutil: /var/lib/texmf/web2c/pdfcslatex.fmt installed.
fmtutil: /var/lib/texmf/web2c/pdfcsplain.fmt installed.
fmtutil: /var/lib/texmf/web2c/pdftex.fmt installed.
fmtutil: /var/lib/texmf/web2c/tex.fmt installed.
fmtutil: /var/lib/texmf/web2c/metafun.mem installed.
fmtutil: /var/lib/texmf/web2c/mpost.mem installed.
fmtutil: /var/lib/texmf/web2c/mf.base installed.
mktexlsr: Updating /var/lib/texmf/ls-R...
mktexlsr: Updating /var/lib/texmf/db/ls-R...
mktexlsr: Updating /var/cache/fonts/ls-R...
mktexlsr: Done.
Executing /sbin/conf.d/SuSEconfig.xdm...
Executing /sbin/conf.d/SuSEconfig.xpdf...
Executing /sbin/conf.d/SuSEconfig.zmessages...
Finished.
apt executing: /sbin/ldconfig
W: Some errors occurred while running transaction
RobinLinux:/etc/apt #
Was nun? Einfach nochmal laufen lassen?

Ich hab ja ein Image der Suse-Partition, also kann ich nach dem Zurückspielen die Prozedur nochmal laufen lassen.
Nur warum bricht er hier ab?

Ach ja, nur mal aus Interesse hab ich den letzten Befehl /sbin/ldconfig wiederholt, der ohne Probleme durchlief.

Ratlos,
Saber

ojkastl
Hacker
Hacker
Beiträge: 547
Registriert: 15. Dez 2004, 04:51
Wohnort: Erlangen
Kontaktdaten:

Beitrag von ojkastl » 5. Jul 2005, 21:20

Ich spiel mal die Ingrid...

Hab mal ein bißchen weiter probiert. Das Problem war ein fehlerhafter Link in /usr/lib/, der nicht auf das aktuelle OOo-Verzeichnis zeigte. Den hatte ich zwar gesetzt, aber da war wohl was faul.

Dann per Hand Suseconfig.fonts angestossen, was durchlief.

Danach das Skript neu gestartet. Da waren zwei Pakete doppelt installiert, jeweils mit --nodeps rausgehauen. Danach lief es durch. Mal sehen ob da was dabei rauskommt.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 5. Jul 2005, 23:17

Saber_Rider hat geschrieben:Ich spiel mal die Ingrid...

Hab mal ein bißchen weiter probiert. Das Problem war ein fehlerhafter Link in /usr/lib/, der nicht auf das aktuelle OOo-Verzeichnis zeigte. Den hatte ich zwar gesetzt, aber da war wohl was faul.
damals war der link /usr/lib/ooo-1.1
heute sollte es wohl /usr/lib/ooo-2.0 sein

Ansonsten sagt die letzte Meldung nur, das es irgendwo ein paar Probleme gab bei SuSEconfig, bzw bei den preun/postinst Routinen der Pakete. Aber das ist nur eine Warnung!

Das Problem das SuSEconfig manchmal hängt, taucht immer mal wieder auf. Bisherige brute-force Lösung: in einer zweiten Konsole einen SuSEconfig Prozess killen. Ansonsten wartet man 15min (!!!) bis SuSEconfig selber weitermacht. Es gibt hier im Forum dazu schon einen Thread, aber noch keine bessere Lösung, leider. Ich selbst hatte dieses Phänomen noch nie.

Die doppelten Pakete stammen wohl aus deiner Zeit vor apt.
Mit rpm -qa | sort > myRPMS.txt eine Liste der installierten Pakete erstellen und danach die Datei myRPMS.txt durchsuchen auf Duplikate und mit rpm diese manuell entfernen. Dann mit apt die jeweils neueste Version wieder draufinstallieren. Ausnahme bei den Duplikaten sind die gpg-keys, die MÜSSEN mehrfach vorhanden sein!
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

ojkastl
Hacker
Hacker
Beiträge: 547
Registriert: 15. Dez 2004, 04:51
Wohnort: Erlangen
Kontaktdaten:

Beitrag von ojkastl » 5. Jul 2005, 23:18

Also,

nachdem soweit alles zu gehen schien (ausser das gwdg total langsam war), hab ich den Reboot eingeleitet.

Dabei kam der neue "Startbildschrim" von Grub, also schon der der Suse 9.2. Danach konnte er auch starten, blieb aber bei
Waiting for device /dev/hda5 to appear: ....not found -- exiting to /bin/sh
> sh: can't access tty; job control turned off
> $
hängen.

Das Problem hatte ich auch schon mit dem letzten Kernelupdate per YOU (auf der Suse 9.1). Ich werd jetzt

1. das Backup zurückspielen
2. Das ganze nochmal versuchen, und dabei den Link vorher richtig setzen.
3. Sollte das nicht klappen, dann werd ich mal bei der 9.1 versuch das Kernelupdate hinzukriegen. Wenn das geht, dann könnte auch das apt-update klappen.

Irgendwelche Vorschläge?

P.S: Warum stimmt denn die Zeit schon wieder nicht? Im Profil sit sie mit GMT+1 drin, das sollte doch stimmen oder? Dieser Beitrag ist vor der letzten Antwort getippt worden, und jetzt editiert worden.

ojkastl
Hacker
Hacker
Beiträge: 547
Registriert: 15. Dez 2004, 04:51
Wohnort: Erlangen
Kontaktdaten:

Beitrag von ojkastl » 7. Jul 2005, 20:53

Alsooo,

das Problem geht tiefer und hängt nicht mit apt zusammen.

Beim Installieren eines Kernel-RPMs baut rpm die neue initrd zum Kernel mit "mkinitrd" statt mit "mkinitrd -R -u". Wenn ich per Hand mit Paramtern ausführe, geht auch der neue Kernel.
Das war bisher nicht nötig, und jetzt geht auch ein alter Kernel nicht mehr ohne den neuen mkinitrd-Aufruf. Bisher ging alles ohne Nacharbeiten per Hand.

Mal sehen wie ich da wieder rauskomme. Wollt euch nur mal informieren, falls jemand zufällig (ähem) nen Rat weiss....

Saber

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 7. Jul 2005, 21:00

Dann hast du sehr wahrscheinlich ein mkinitrd aus suse-projects am Wickel.

Ermittle mal das mkinitrd von der Original SuSE-CD/DVD bzw das aus base oder update mit dem Befehl apt policy mkinitrd.

Dann verwendest du dieses mkinitrd (durch Angabe der Versionsnummer in deinem Script).
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

ojkastl
Hacker
Hacker
Beiträge: 547
Registriert: 15. Dez 2004, 04:51
Wohnort: Erlangen
Kontaktdaten:

Beitrag von ojkastl » 8. Jul 2005, 00:27

Sag mal, weisst du dass du ein unheimliches Talent hast genau ins Schwarze zu treffen. Mann o Mann.


Soll ich jetzt suse-projects auch aus der sources.list schmeissen?

Danke,
Saber

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 8. Jul 2005, 08:07

Hehe, nein ich hatte auf meinem 9.1er SuSE auch mal dieses Problem und habe dann die mkinitrd gepinnt.

Leider weiss ich aber nicht mehr genau welche Version es war, aber das solltest du herausfinden können.

Offensichtlich schwirrt diese "böse" mkinitrd immer noch im Repository rum. Das Ding hat damals bei vielen dafür gesorgt das kein boot mehr ging, weil keine initrd erstellt wurde ;(

Aber deshalb würde ich suse-projects nicht aus der sources.list rauswerfen, i.d.R. sind die Pakete dort in Ordnung. Pinning reicht in diesem Fall.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

ojkastl
Hacker
Hacker
Beiträge: 547
Registriert: 15. Dez 2004, 04:51
Wohnort: Erlangen
Kontaktdaten:

Beitrag von ojkastl » 8. Jul 2005, 11:52

Danke für die Info.

Ich werd mal schauen was da bei dem jetzt anstehenden apt dist-upgrade draus wird.

ojkastl
Hacker
Hacker
Beiträge: 547
Registriert: 15. Dez 2004, 04:51
Wohnort: Erlangen
Kontaktdaten:

Es ist geschafft!

Beitrag von ojkastl » 11. Jul 2005, 14:13

Hallo,

mittlerweile bin ich soweit, dass ich auf meinem Computer eine laufende Suse 9.2 habe. Das apt-Upgrade hat funktioniert.

Ein paar kleinere Probleme gabs, aber die ließen sich lösen.

Was jetzt noch fehlt ist:

1. Eine Möglichkeit YOU zu erzählen dass ich jetzt ne Suse 9.2 hab.

2. Beim upgrade mittels ./myUpgrade die ganzen Textzeilen mitloggen zu lassen, dann kann man besser Fehler suchen.
Ein
./myUpgrade.sh |tee ausgabe.txt
funktioniert nicht, es fehlen die Fehlermeldungen, und apt läuft nicht durch, warum auch immer. Es fehlen z.B. auch in der Shell (also nicht nur in der Datei) die Nummer des aktuellen Paktes und die %-Angabe.

3. Meine AVM Fritzcard DSL SL (nicht USB) geht nicht mehr. Hab alles installiert, was ich meinte installieren zu müssen, aber da geht nichts. Genau die gleiche Vorgehensweise wie unter 9.1 (zuerst als ISDN einrichten, dann als DSL) klappt nicht. Die genauen Fehlermeldungen kann ich posten, da bin ich glaub ich aber im falschen Forum, oder?

Jedenfalls DANKE DANKE DANKE für die Hilfe,

Saber

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 11. Jul 2005, 15:01

ad 1.)
in /etc/SuSE-release steht eine Versionsnummer, evtl steht dort die alte noch drin.

AFAIK, sucht YaST "seine Nummer" aber in /var/adm/YaST/ProdDB/prod_00000001
(kannst du nur als root editieren und sehen!)
evtl steht die Versionsnummer dort auch noch in anderen Dateien, untersuche einfach mal den /var/adm/YaST Zweig, sind meistens nur Textdateien.

ad 2.)
entweder mit
myScript > ausgabe.txt die Standardausgabe umlenken in eine Datei.

oder

myScript 1> ausgabe.txt 2>fehler.txt die Standardausgabe nach ausgabe.txt und alle Fehler nach fehler.txt umlenken.

apt schreibt auch ein Logfile nach /var/log/apt.log. Dort kannst du sehen welche Pakete upgedatet bzw neu installiert wurden.

ad 3.)
muss ich passen, sollte auch in einem anderen Forum gelöst werden können.

P.S. freut ich das es geklappt hat und danke für Feedback.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast