Glib2 u.ä. Probleme

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Gesperrt
Devekola
Newbie
Newbie
Beiträge: 19
Registriert: 31. Mai 2005, 15:19

Glib2 u.ä. Probleme

Beitrag von Devekola » 31. Mai 2005, 15:23

Hallo! Ich habe Suse 9.2 von EasyLinux installiert, habe folgendes Problem:
2005-05-31 15:12:57 gle-3.0.6-646.1.i586.rpm install failed
rpm output:
error: /var/adm/YaST/InstSrcManager/IS_CACHE_0x00000001/MEDIA/suse/i586/gle-3.0.6-646.1.i586.rpm: MD5 digest: BAD Expected(82650c2250ac9ba9f3350c63fbb106da) != (17309be7b810d6872b01d966ea02b855)
error: /var/adm/YaST/InstSrcManager/IS_CACHE_0x00000001/MEDIA/suse/i586/gle-3.0.6-646.1.i586.rpm cannot be installed

Das bei vielen anderen Dateien auch, kann nix von Gnome, geschweige denn glib2 installieren. Was kann ich tun?

Schöne Grüße!

Werbung:
Benutzeravatar
admine
Administrator
Administrator
Beiträge: 8722
Registriert: 15. Feb 2004, 21:13
Wohnort: Dresden
Kontaktdaten:

Beitrag von admine » 31. Mai 2005, 16:02

Dein Installationsmedium wird da wohl nicht in Ordnung sein.
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Re: Glib2 u.ä. Probleme

Beitrag von traffic » 31. Mai 2005, 16:19

Kohlerevier hat geschrieben:Was kann ich tun?
Du könntest den FTP-Server von SuSE als Ersatz-Installationsquelle eintragen.

YaST -> Software -> Installationsquelle wechseln -> Hinzufügen -> FTP:

Code: Alles auswählen

Protokoll: FTP
Servername: ftp.gwdg.de
Verzeichnis auf dem Server: pub/linux/suse/ftp.suse.com/suse/i386/X.Y
Authentifikation: Anonymous
X.Y ist Deine SuSE-Version, also 9.2.
openSUSE Factory - GNOME 2.32.1

Devekola
Newbie
Newbie
Beiträge: 19
Registriert: 31. Mai 2005, 15:19

Beitrag von Devekola » 1. Jun 2005, 14:53

Vielen Dank! Jetzt hab ich es hingekriegt. Habe nun aber folgendes Problem nach dem Start:

"Prozess Aufruf des Ein/Ausgabe-Moduls nicht möglich.
klauncher meldet: Unbekanntes Protokoll "devices".
lässt sich nicht starten"

Kein Plan, was der will, als ich das letzte Mal Linux drauf hatte, war ja alles problemlos....

Benutzeravatar
admine
Administrator
Administrator
Beiträge: 8722
Registriert: 15. Feb 2004, 21:13
Wohnort: Dresden
Kontaktdaten:

Beitrag von admine » 1. Jun 2005, 15:00

..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Devekola
Newbie
Newbie
Beiträge: 19
Registriert: 31. Mai 2005, 15:19

Beitrag von Devekola » 2. Jun 2005, 08:22

Okay, soweit geht jetzt das auch alles, und schon habe ich neue Probleme, ich hoffe ihr könnt mir nochmal helfen. Und zwar kann ich einige Anwendungen, z.B. "Firefox", "Gimp" oder auch sog. "Mulitmediasystem" nicht starten. Wenn ich anklicke, erscheint ein neuer Tab in der Statusleiste, der Mauszeiger verändert sich auch, als würde das Programm gestartet; nach einiger Zeit bricht aber alles ohne Fehlermeldung ab und das Programm ist dennoch nicht gestartet.

Schöne Grüße!

Benutzeravatar
admine
Administrator
Administrator
Beiträge: 8722
Registriert: 15. Feb 2004, 21:13
Wohnort: Dresden
Kontaktdaten:

Beitrag von admine » 2. Jun 2005, 08:34

Starte die Programme mal aus einer Shell heraus.
Da bekommst du sicher Fehlermeldungen.

Bsp. Firefox startest du in einer shell mit

Code: Alles auswählen

firefox
;)
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Devekola
Newbie
Newbie
Beiträge: 19
Registriert: 31. Mai 2005, 15:19

Beitrag von Devekola » 3. Jun 2005, 20:59

Dies erscheint, wenn ich Gimp über das Terminal starten will:
gimp

(gimp:5913): Gtk-WARNING **: Fehler beim Laden des Symbols: Das Format der Bilddatei »/opt/kde3/share/icons/crystalsvg/22x22/actions/button_cancel.png« konnte nicht erkannt werden

** (gimp:5913): WARNING **: No builtin or dynamically loaded modules
were found. Pango will not work correctly. This probably means
there was an error in the creation of:
'/etc/opt/gnome/pango/pango.modules'
You may be able to recreate this file by running pango-querymodules.

(gimp:5913): GLib-GObject-CRITICAL **: file gobject.c: line 1561 (g_object_ref): assertion `G_IS_OBJECT (object)' failed

** (gimp:5913): CRITICAL **: file pango-engine.c: line 68 (_pango_engine_shape_shape): assertion `PANGO_IS_FONT (font)' failed
gimp: fatal error: file shape.c: line 75 (pango_shape): assertion failed: (glyphs->num_glyphs > 0)

Edit: Im Übrigen kann ich auch Gnome als Arbeitsfläche nicht starten... Ich denke es hängt zusammen.

Devekola
Newbie
Newbie
Beiträge: 19
Registriert: 31. Mai 2005, 15:19

Beitrag von Devekola » 4. Jun 2005, 10:03

Okay, das geht jetzt, hatte noch was nachinstalliert. Schöne Grüße!

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast