yast startet nicht mehr wegen libcurl.so.3/ 9.1, 3.3.1

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
wolfgang-popp
Member
Member
Beiträge: 77
Registriert: 14. Nov 2004, 19:12
Wohnort: Südschwarzwald

yast startet nicht mehr wegen libcurl.so.3/ 9.1, 3.3.1

Beitrag von wolfgang-popp » 25. Mai 2005, 17:35

hallo,

wegen eines xine-updates wurde libcurl.so.2 gegen libcurl.so.3 ausgetauscht:

yast startet nicht mehr (ncurses).

libcurl.7.11 (mit libcurl.so.2) lässt sich mit rpm -i natürlich nicht installieren, genausowenig wie sich

curl.7.12 (mit libcurl.so.3) nicht deinstallieren läßt, wegen zweier yast abhängigkeiten.

wie also vorgehen?

deinstallation erzwingen? (wie heisst nochmal der befehl?).
oder gibt es eine bessere methode?
oder gibt es einen befehl zum downgrading bei rpm?

grüße

w.popp

Werbung:
traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 25. Mai 2005, 17:57

http://rpm.pbone.net/index.php3/stat/4/ ... 6.rpm.html

Installieren mit

Code: Alles auswählen

rpm -ivh curl-7.11.0-39.4.i586.rpm --oldpackage
oder direkt von der CD, ohne YaST, sondern mit rpm von der Kommandozeile. Aber die Abhängigkeiten müssen natürlich auch weg, welche sind das denn?
openSUSE Factory - GNOME 2.32.1

wolfgang-popp
Member
Member
Beiträge: 77
Registriert: 14. Nov 2004, 19:12
Wohnort: Südschwarzwald

libcurl.so.3

Beitrag von wolfgang-popp » 25. Mai 2005, 20:16

hallo,

danke für die hilfe:
antwort von `rpm`:

linux:/ # rpm -ihv curl.7.rpm --oldpackage
Preparing... ########################################### [100%]
file /usr/bin/curl from install of curl-7.11.0-39.4 conflicts with file from package curl-7.12.0-2.1
file /usr/lib/libcurl.la from install of curl-7.11.0-39.4 conflicts with file from package curl-7.12.0-2.1
file /usr/share/man/man1/curl.1.gz from install of curl-7.11.0-39.4 conflicts with file frompackage curl-7.12.0-2.1

BEIM DEINSTALLIEREN VON CURL GIBT ES FOLGENDE MELDUNG:

rpm -e curl
error: Failed dependencies:
curl is needed by (installed) yast2-transfer-2.9.2-10
curl is needed by (installed) yast2-installation-2.9.57-1

gruß

wolfgang



wolfgang-popp
Member
Member
Beiträge: 77
Registriert: 14. Nov 2004, 19:12
Wohnort: Südschwarzwald

problem vorerst gelöst

Beitrag von wolfgang-popp » 25. Mai 2005, 21:21

curl mit --nodept deinstalliert
und alte version mit rpm -i installiert:

yast läuft wieder.

nur mein xine-ui muss jetzt auf libcurl.so.3 verzichten
mal sehen.

danke

wolfgang

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste