Handler silently failed

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Gesperrt
neoent
Newbie
Newbie
Beiträge: 44
Registriert: 30. Sep 2004, 15:43

Handler silently failed

Beitrag von neoent » 19. Mai 2005, 15:13

Hi,
habe doch ein kleines Problem mit apt. Egal ob ich apt-get -f oder apt --force upgrade oder dist-upgrade mache ich habe immer diesen fehler.

[code]
aaa_base = 9.3-9 is needed by aaa_base-9.3-9.2
util-linux = 2.12q-7 is needed by util-linux-2.12q-7.2
SuSEfirewall2 = 3.3-18 is needed by SuSEfirewall2-3.3-18.2
smpeg = 0.4.5-228 is needed by smpeg-0.4.5-228.1
sysvinit = 2.85-38 is needed by sysvinit-2.85-38.2
gnome-filesystem = 0.1-211 | gnome-filesystem = 0.1-211.2 is needed by
normalize = 0.7.6-383 is needed by normalize-0.7.6-383.1
E: Transaction set check failed
E: Handler silently failed
[/code]

Da dachte ich mir, install die doch mal alleine also :

[code]
apt-get -f install aaa_base
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Die folgenden Pakete werden upgegradet werden:
aaa_base
1 upgraded, 0 newly installed, 0 entfernt und 99 nicht upgegradet.
Muss 0B/205kB an Archiven holen.
Nach dem Auspacken werden 3323B zusätzlicher Plattenplatz benutzt werden.
aaa_base = 9.3-9 is needed by aaa_base-9.3-9.2
E: Transaction set check failed
E: Handler silently failed

[/code]

Ich habe auch apt update usw. sogar apt-get --fix-broken.

Meine source.list habe ich sogar mit den ausgaben des apt-sorti.sh scriptes gändert. Gleiches Ergebnis.

Habe auch hier und über google und im irc gesucht. Leider nix.
Hoffe hier kann mir geholfen werden.

Besten Dank

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 19. Mai 2005, 15:17

1.) hast du SuSE-9.3 ?
wenn ja, es gibt kein base-repository für SuSE-9.3, deshlab musst du deine DVD ins apt einbinden um die fehlenden Komponenten zur Verfügung zu stellen.

2.) oder du hast *-prpm oder *-drpm noch in deiner sources.list drin ...

3.) Bitte bei allen Fragen: die SuSE-Version angeben. das spart Rückfragen ;)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

neoent
Newbie
Newbie
Beiträge: 44
Registriert: 30. Sep 2004, 15:43

Beitrag von neoent » 19. Mai 2005, 15:21

Ich habe 9.2 und die über ftp installiert.

und ich habe beide noch drin sowohl drpm als auch prpm.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 19. Mai 2005, 15:25

aha, und was machst du dann mit 9.3er Komponenten ?
1 upgraded, 0 newly installed, 0 entfernt und 99 nicht upgegradet.
Muss 0B/205kB an Archiven holen.
Nach dem Auspacken werden 3323B zusätzlicher Plattenplatz benutzt werden.
aaa_base = 9.3-9 is needed by aaa_base-9.3-9.2
das aaa-base von 9.2 heisst:
rpm -q aaa_base
aaa_base-9.2-5.4
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

neoent
Newbie
Newbie
Beiträge: 44
Registriert: 30. Sep 2004, 15:43

Beitrag von neoent » 19. Mai 2005, 15:28

weil ich ein dist-upgrade machen wollte und irgendwo mal gelesen habe, einfach nur die source.list mit den quellen für 9.3 erweitern.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 19. Mai 2005, 15:35

neoent hat geschrieben:weil ich ein dist-upgrade machen wollte und irgendwo mal gelesen habe, einfach nur die source.list mit den quellen für 9.3 erweitern.
aha, Helden des Alltags unterwegs ;)

du willst also ein update von 9.2 auf 9.3 durchführen mit apt. Fein. Aber es gibt leider noch kein base-repository (frühestens Anfang Juni) und solange geht das noch nicht. Es sei denn, man hat die Medien zu 9.3 zur Verfügung und bindet die DVD als lokales base-Repository ein.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

neoent
Newbie
Newbie
Beiträge: 44
Registriert: 30. Sep 2004, 15:43

Beitrag von neoent » 19. Mai 2005, 15:40

ahh so ist das.
Klar bin ich so ein Held :D.
Ich lebe von try and error.
Also die 9.3 wieder aus der source.list nehmen oder nicht dist-upgrade machen?

Besten Dank oc2pus

P.S nicht mehr im irc ?

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 19. Mai 2005, 15:44

neoent hat geschrieben:ahh so ist das.
Klar bin ich so ein Held :D.
Ich lebe von try and error.
Also die 9.3 wieder aus der source.list nehmen oder nicht dist-upgrade machen?
besser die 9.3er Repositories aus der sources.list rausnehmen.

es ist ja bald Anfang Juni ... nur noch 11 Tage ... und dann können wir auf 9.3 mit apt lüpfen ;)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

neoent
Newbie
Newbie
Beiträge: 44
Registriert: 30. Sep 2004, 15:43

Beitrag von neoent » 19. Mai 2005, 16:03

ok mach ich. besten dank

Nur wie kann ich dann das hier ändern

[code]
apt-get -f upgrade
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Die folgenden Pakete sind zurückgehalten worden
OpenEXR amarok arts arts-devel jack kdebase3 kdebase3-devel kdegraphics3
kdegraphics3-fax kdelibs3 kdelibs3-devel kdemultimedia3 kdenetwork3
kdenetwork3-vnc kdeutils3 libavc1394 libglade2 libquicktime libraw1394
libsigc++2 libxslt libxslt-devel rekall
0 upgraded, 0 newly installed, 0 entfernt und 23 nicht upgegradet.
[/code]

Ich will aber das er upgradet

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 19. Mai 2005, 16:22

ne ne ne, nicht in diesem Thread ;)
den mach ich jetzt zu, weil gelöst.

zu diesem Problem gibt es eine kleine Sammlung im apt-Forum, wie man auf die unterschiedlichen Fehlermeldungen reagieren kann:
[Tip] Abhängigkeiten lösen / Fehlermeldungen von apt
http://www.linux-club.de/viewtopic.php?t=16315
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste