apt findet die Paket-Versionen nicht richtig

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

apt findet die Paket-Versionen nicht richtig

Beitrag von Grothesk » 26. Apr 2005, 20:22

Ich will vlc für SuSE 9.3 über apt updaten lassen.
Es kommt jedoch

Code: Alles auswählen

vlc:
 Benötigt: libdvbpsi (>=0.1.3) but it is not installable
 Benötigt: xvidcore (>=0.9.2) but it is not installable
Dabei ist aber bereits das installiert:
libdvbpsi3 0.1.4-0.pm.4
xvid 1.1.0-0.pm.1beta2
Warum findet apt die Versionen nicht?

Werbung:
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 26. Apr 2005, 20:48

Hab das gerade mal ausprobiert. Ich schätze da sind die Abhängigkeiten im vlc kaputt.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Re: apt findet die Paket-Versionen nicht richtig

Beitrag von oc2pus » 26. Apr 2005, 20:55

Grothesk hat geschrieben:Ich will vlc für SuSE 9.3 über apt updaten lassen.
Es kommt jedoch

Code: Alles auswählen

vlc:
 Benötigt: libdvbpsi (>=0.1.3) but it is not installable
 Benötigt: xvidcore (>=0.9.2) but it is not installable
Dabei ist aber bereits das installiert:
libdvbpsi3 0.1.4-0.pm.4
xvid 1.1.0-0.pm.1beta2
1.) xvidcore != xvid :)
2.) probiere apt install vlc libdvbpsa xvidcore
==> du wirst sehen das mehre Pakete installiert werden/downgraded werden...

3.) poste mal
apt policy xvidcore
apt policy vlc
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 26. Apr 2005, 20:57

Code: Alles auswählen

apt install vlc libdvbpsi xvidcore
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
vlc ist bereits die neueste Version.
Package libdvbpsi has no available version, but exists in the database.
This typically means that the package was mentioned in a dependency and
never uploaded, has been obsoleted or is not available with the contents
of sources.list
E: Paket libdvbpsi hat keinen Installationskanditaten

Code: Alles auswählen

apt policy xvidcore
xvidcore:
  Installiert: (nichts)
  Kandidat: (nichts)
  Versionstabelle:

Code: Alles auswählen

apt policy vlc
vlc:
  Installiert: 0.8.1-0.pm.9
  Kandidat: 0.8.1-0.pm.9
  Versionstabelle:
 *** 0.8.1-0.pm.9 0
        100 RPM Database
     0.8.1-0.pm.8 0
        500 ftp://ftp.gwdg.de SuSE/9.3-i386/packman-i686 pkglist
     0.8.1-0.pm.7 0
        500 ftp://ftp.gwdg.de SuSE/9.3-i386/packman-i686 pkglist
     0.8.1-0.pm.7 0
        500 ftp://ftp.gwdg.de SuSE/9.3-i386/packman pkglist
Hab's jetzt von Hand über yast installiert. Da ging's. Dabei hätte die Abhängigkeit doch auch von yast angemeckert werden müssen, oder?

Hatte das Problem zuletzt auch mit einem anderen Paket, ich weiß leider nicht mehr welches es gewesen ist.
Zuletzt geändert von Grothesk am 26. Apr 2005, 21:05, insgesamt 1-mal geändert.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 26. Apr 2005, 21:04

Grothesk hat geschrieben:apt install vlc libdvbpsi xvidcore
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
vlc ist bereits die neueste Version.
Package libdvbpsi has no available version, but exists in the database.
This typically means that the package was mentioned in a dependency and
never uploaded, has been obsoleted or is not available with the contents
of sources.list
E: Paket libdvbpsi hat keinen Installationskanditaten

Hab's jetzt von Hand über yast installiert. Da ging's. Dabei hätte die Abhängigkeit doch auch von yast angemeckert werden müssen, oder?

Hatte das Problem zuletzt auch mit einem anderen Paket, ich weiß leider nicht mehr welches es gewesen ist.
dann "sieht" apt dieses Paket nicht, d.h es ist auf der DVD/CD und nur dort (es gibt noch kein vollständiges base-Repository!), deshalb ist es mit YaST installierbar :)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 26. Apr 2005, 21:06

Aber von der DVD ist nichts nachinstalliert worden.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 26. Apr 2005, 21:07

Grothesk hat geschrieben:Aber von der DVD ist nichts nachinstalliert worden.
ei, dann hat SuSE es direkt bei der Erstinstallation installiert ...
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 26. Apr 2005, 21:16

Aber dann steht es doch in der rpm-Datenbank drin? Wird die nicht von apt genutzt? Denke doch schon.? *verwirrtbin*

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 26. Apr 2005, 21:22

Auf der SuSE 9.3 DVD ist vlc nicht drauf.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 26. Apr 2005, 21:25

schau dir die Ausgabe von apt policy vlc genau an ...

die installierte Version von dir gibt es nirgends, auf keinem Server, deshalb versucht apt "kabinett-stückchen" und will eigentlich die 0.pm.8 installieren ... Jetzt sagt aber rpm: nö, 0.pm.9 ist neuer ...

you see ...
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 27. Apr 2005, 09:16

Auf meinem Laptop mit SuSE 9.3 läuft apt install vlc gerade meckerfrei durch.

Dafür mögen sich jetzt libxine1 und kaffeine nicht mehr. Irgendwas ist immer *seufz*.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 27. Apr 2005, 09:18

Kaffeine musste ich auch auf die letzte Packman-Version pinnen. Mit der aktuellsten Version aus dem kde-Repository lief das bei mir auch nicht mehr.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste