? Suse 9.3 via NFS installieren und DVD 1 kopieren ?

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
sni
Newbie
Newbie
Beiträge: 3
Registriert: 26. Apr 2005, 18:51

? Suse 9.3 via NFS installieren und DVD 1 kopieren ?

Beitrag von sni » 26. Apr 2005, 19:21

Nach Lieferung der Version 9.3 habe ich wie sonst auch von der DvD 1 eine
Sicherungskopie erstellt.
Die Installation von dieser Sicherungskopie kann nicht durchgeführt werden.
Yast meldet, daß keine Installationsquellen gefunden werden können.
Die Installation mit der Original DvD funktioniert.
Ich habe ausserdem die OriginalDvD komplett in ein Verzeichnis meines Linux-Servers kopiert und von dort aus versucht via NFS zu installieren. Die Installationsprozedur
beginnt und bricht dann mit der Meldung ab, daß ein "Image nicht gefunden" werden konnte. Ich habe den DvD-Inhalt mit dem Verzeichnisinhalt auf dem NFS-Server abgeglichen, kann allerdings keinen Unterschied feststellen
Wenn ich die gemountete CD via NFS-Export zur Verfügung stelle klappt die Installation.
Zwischen den beiden vorstehend genannten Installationsarten via NfS, die vom grundsätzlichen Vorgehen her ja identisch sind, sind auf Konsole 4 allerdings deutliche Unterschiede zu sehen.

Ich habe ab Suse 8.0, 8.1., 8.2, 9.0, 9.1 und 9.2 von meinen DvD´s Sicherungskopien erstellt, diese auf NFS-Shares kopiert und von dort aus konnte ich immer ohne Probleme installieren.
Das selbe Verhalten zeigt die Version 9.3 auch bei der Installation via Samba und ftp.

Ist bei der 9.3 etwa ein Kopierschutz drin? Wer konnte die Version 9.3 schon erfolgrecih via NFS installieren?

Werbung:
isolde
Member
Member
Beiträge: 57
Registriert: 20. Mai 2004, 16:35
Wohnort: Hallbergmoos
Kontaktdaten:

Beitrag von isolde » 9. Mai 2005, 11:08

Ich hatte ein ähnliches Problem, allerdings bei der Erstellung einer 32Bit- CD...
1) Stelle sicher dass ALLE Daten der DVD von /media.1 (inkl. aller Unterverzeichnisse) rüber kopiert sind. Aus irgendeinem Grund hatten (bei meinem Versuch) bei mir Daten gefehlt...
2) Die Installationsroutine bietet die "manuelle Installation" nicht mehr an, daher statt dessen bei dem Schirm, wo alles dargestellt wird (Partitionierung, Pakete, Start, usw...) "abbrechen" - danach erscheint die Text- Meldung, dass die Installation abgebrochen wurde. Danach gelangt man in das "Boot-Yast", wo Module usw. geladen werden können. Dort kann dann auch eine Installation via NFS gemacht werden.

Übrigens - ich habe ein DD- Image der DVD erstellt - und zumindest davon funktionierte die Installation (in einer VM) - vielleicht geht's ja dann, wenn Du das Image als Loop mountest und dann via NFS freigibst.

Achso: vielleicht (und das hatte ich auch schon festgestellt) stimmen ja auch die Rechte Deines NFS- Servers nicht (richtig).
GreeZ!

Isolde

PS: Nichts mache ich lieber als Arbeiten...

sni
Newbie
Newbie
Beiträge: 3
Registriert: 26. Apr 2005, 18:51

Beitrag von sni » 14. Mai 2005, 17:50

ich habe ALLE Inhalte der DvD kopiert und, siehe oben, durch Abgleich die Vollständigkeit überprüft.

Die manuelle Installation gibt es noch, siehe Administrationshandbuch auf Seite 137. (Am Bootprompt manual=1 eingeben)

....Übrigens - ich habe ein DD- Image der DVD erstellt....

Habe ebenfalls ein dd-image hergestellt, geloopt und dann via nfs freigeben und es klappt halt immer noch nicht.

Nachdem ich die Firmware meines Brenners LG 4163b von V102 auf V104 gebracht habe, kann nun auch von der DvD-Kopie aus installiert werden.

Praktisch wäre halt nach wie vor eine Lösung für die Installation über das Netzwerk.

sni
Newbie
Newbie
Beiträge: 3
Registriert: 26. Apr 2005, 18:51

mit Version klappt es jetzt wieder

Beitrag von sni » 5. Nov 2005, 11:15

alles oben angeführte funktioniert mit Suse 10 auf unerklärliche Weise
wieder. Von der kopierten DVD kann wieder gebootet werden. Wenn der kopierte DVD-Inhalt auf ein NFS-Share übertragen wird kann auch von dort aus wieder installiert werden usw. usw.
Den Fehler auf der 9.3 habe ich nicht finden können. Dafür sind wieder einige andere Schlampereien in der Version 10 und ich befürchte, daß diese bei den m.E. immer schneller aufeinanderfolgenden Releases zunehmen werden.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast