abhängigkeiten bei kdelibs3 update [gelöst]

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Gesperrt
fRiSi
Newbie
Newbie
Beiträge: 3
Registriert: 23. Apr 2005, 14:38

abhängigkeiten bei kdelibs3 update [gelöst]

Beitrag von fRiSi » 23. Apr 2005, 14:45

momentan habe ich ein inkonsistentes system. kile und kover starten zum beispiel nicht mehr.

Code: Alles auswählen

   kile: symbol lookup error: kile: undefined symbol: _ZN11KMainWindow7setIconERK7QPixmap
mach ich mal nen check:

Code: Alles auswählen

   frisi-laptop:/home/frisi # apt check
   Lese Paketlisten... Fertig
   Erzeuge Abhängigkeitsbaum... Fertig
   You might want to run `apt-get --fix-broken install' to correct these.
   Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
   kdeartwork3: Hängt ab von: kdelibs3 (>= 3.3.2) aber 3.3.0-34.5 ist installiert
   E: Unmet dependencies. Try using --fix-broken.
und mach was mir apt rät:

Code: Alles auswählen

  frisi-laptop:/home/frisi # apt-get --fix-broken install
   Lese Paketlisten... Fertig
   Erzeuge Abhängigkeitsbaum... Fertig
   Korrigiere Abhängigkeiten ... Fertig
   Die folgenden zusätzlichen Pakete werden installiert werden:
   amarok kdelibs3 qt3
   Die folgenden Pakete werden upgegradet werden:
   amarok kdelibs3 qt3
   3 upgraded, 0 newly installed, 0 entfernt und 426 nicht upgegradet.
   Muss 0B/26,7MB an Archiven holen.
   Nach dem Auspacken werden 7327kB zusätzlicher Plattenplatz benutzt werden.
   Wollen Sie fortsetzen? [J/n] j
   Committing changes...
   Preparing...                ########################################### [100%]
         file /opt/kde3/share/mimelnk/application/x-webarchive.desktop from install of kdelibs3-3.4.0-22 conflicts with file from package kdeaddons3-konqueror-3.3.0-10
         file /opt/kde3/lib/kde3/kstyle_plastik_config.la from install of kdelibs3-3.4.0-22 conflicts with file from package kdeartwork3-3.3.2-4
         file /opt/kde3/lib/kde3/kstyle_plastik_config.so from install of kdelibs3-3.4.0-22 conflicts with file from package kdeartwork3-3.3.2-4
         file /opt/kde3/lib/kde3/plugins/styles/plastik.la from install of kdelibs3-3.4.0-22 conflicts with file from package kdeartwork3-3.3.2-4
         file /opt/kde3/lib/kde3/plugins/styles/plastik.so from install of kdelibs3-3.4.0-22 conflicts with file from package kdeartwork3-3.3.2-4
         file /opt/kde3/share/apps/kstyle/themes/plastik.themerc from install of kdelibs3-3.4.0-22 conflicts with file from package kdeartwork3-3.3.2-4
         file /opt/kde3/bin/kcmshell from install of kdelibs3-3.4.0-22 conflicts with file from package kdebase3-3.3.0-29.3
         file /opt/kde3/lib/kde3/kcmshell.la from install of kdelibs3-3.4.0-22 conflicts with file from package kdebase3-3.3.0-29.3
         file /opt/kde3/lib/kde3/kcmshell.so from install of kdelibs3-3.4.0-22 conflicts with file from package kdebase3-3.3.0-29.3
         file /opt/kde3/lib/libkdeinit_kcmshell.la from install of kdelibs3-3.4.0-22 conflicts with file from package kdebase3-3.3.0-29.3
         file /opt/kde3/lib/libkdeinit_kcmshell.so from install of kdelibs3-3.4.0-22 conflicts with file from package kdebase3-3.3.0-29.3
         file /opt/kde3/share/services/xcf.kimgio from install of kdelibs3-3.4.0-22 conflicts with file from package gwenview-1.1.5-8.1
   E: Error while running transaction
   E: Handler silently failed
nach ein wenig suche im linux-club forum stosse ich auf den artikel (http://www.linux-club.de/viewtopic.php?t=30325) der das gleiche problem beschreibt und mit folgenden worten endet
apt --force upgrade laufenlassen ...
und damit ist dieser Thread geschlossen

also versuche ichs mit 'apt --force upgrade'

Code: Alles auswählen

  frisi-laptop:/home/frisi # apt --force upgrade
   Lese Paketlisten... Fertig
   Erzeuge Abhängigkeitsbaum... Fertig
   You might want to run `apt-get --fix-broken install' to correct these.
   Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
   kdeartwork3: Hängt ab von: kdelibs3 (>= 3.3.2) aber 3.3.0-34.5 ist installiert
   E: Unmet dependencies. Try using --fix-broken.

und auch mit der in posting #4 auf http://www.linux-club.de/viewtopic.php?t=16315 angeführten lösung

Code: Alles auswählen

   frisi-laptop:/home/frisi # apt --force install kdelibs3
   Lese Paketlisten... Fertig
   Erzeuge Abhängigkeitsbaum... Fertig
   You might want to run `apt-get --fix-broken install' to correct these:
   Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
   amarok: Hängt ab von: kdelibs3 (< 3.3.999) aber 3.4.0-22 wird installiert werden
   kdelibs3: Hängt ab von: qt3 (>= 3.3.4) aber 3.3.3-24 wird installiert werden
   E: Unmet dependencies. Try 'apt-get --fix-broken install' with no packages (or specify a solution).

wie bekomme ich wieder in konsistentes system (dass kile kover etc wieder starten)?


suse 9.2

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
sources list
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 base suser-scorot rpmkeys update kdemisc xorg mozilla samba3 suser-rbos suser-oc2pus suser-guru suser-gbv suser-tcousin funktronics packman packman-i686 wine suse-people suse-projects kde3-stable security

rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386 base suser-scorot rpmkeys update kde misc xorg mozilla samba3 suser-rbos suser-oc2pus suser-guru suser-gbv suser-tcousin funktronicspackman packman-i686 wine suse-people suse-projects kde3-stable security
Zuletzt geändert von fRiSi am 24. Apr 2005, 23:09, insgesamt 1-mal geändert.

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 23. Apr 2005, 15:54

Try 'apt-get --fix-broken install'
genau lesen!!

Das Script apt unterstützt die Option --force NICHT,
deshalb apt-get -f install und NICHT apt -f install
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

fRiSi
Newbie
Newbie
Beiträge: 3
Registriert: 23. Apr 2005, 14:38

apt-get -f install scheitert an abhängigkeiten

Beitrag von fRiSi » 23. Apr 2005, 17:44

danke für die rasche antwort

'apt-get --fix-broken install' bringt wie oben beschrieben die vielen konflikte wegen verschobener dateien

im deinem posting in http://www.linux-club.de/viewtopic.php?t=30325 hast du '==> apt --force upgrade' geschrieben. (vielleicht kannst du das noch ausbessern)

da ich mit apt-get -f upgrade 574MB/601MB herunteladen müsse, würde ich eine schlankere version bevorzugen.

deshalb versuche ichs mit:

Code: Alles auswählen

frisi-laptop:/home/frisi # apt-get -f install kdelibs3
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
You might want to run `apt-get --fix-broken install' to correct these:
Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
  amarok: Hängt ab von: kdelibs3 (< 3.3.999) aber 3.4.0-22 wird installiert werden
  kdelibs3: Hängt ab von: qt3 (>= 3.3.4) aber 3.3.3-24 wird installiert werden
E: Unmet dependencies. Try 'apt-get --fix-broken install' with no packages (or specify a solution).

nehm ich amarok dazu sieht es schon etwas besser aus:

Code: Alles auswählen

frisi-laptop:/home/frisi # apt-get -f install kdelibs3 amarok

Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
You might want to run `apt-get --fix-broken install' to correct these:
Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
  kdelibs3: Hängt ab von: qt3 (>= 3.3.4) aber 3.3.3-24 wird installiert werden
E: Unmet dependencies. Try 'apt-get --fix-broken install' with no packages (or specify a solution).
mit qt3 steh ich dann wieder ganz am anfang:

Code: Alles auswählen

frisi-laptop:/home/frisi # apt-get -f install kdelibs3 amarok qt3
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Die folgenden Pakete werden upgegradet werden:
  amarok kdelibs3 qt3
3 upgraded, 0 newly installed, 0 entfernt und 426 nicht upgegradet.
Muss 0B/26,7MB an Archiven holen.
Nach dem Auspacken werden 7327kB zusätzlicher Plattenplatz benutzt werden.
Committing changes...
Preparing...                ########################################### [100%]
        file /opt/kde3/share/mimelnk/application/x-webarchive.desktop from install of kdelibs3-3.4.0-22 conflicts with file from package kdeaddons3-konqueror-3.3.0-10
        file /opt/kde3/lib/kde3/kstyle_plastik_config.la from install of kdelibs3-3.4.0-22 conflicts with file from package kdeartwork3-3.3.2-4
        file /opt/kde3/lib/kde3/kstyle_plastik_config.so from install of kdelibs3-3.4.0-22 conflicts with file from package kdeartwork3-3.3.2-4
        file /opt/kde3/lib/kde3/plugins/styles/plastik.la from install of kdelibs3-3.4.0-22 conflicts with file from package kdeartwork3-3.3.2-4
        file /opt/kde3/lib/kde3/plugins/styles/plastik.so from install of kdelibs3-3.4.0-22 conflicts with file from package kdeartwork3-3.3.2-4
        file /opt/kde3/share/apps/kstyle/themes/plastik.themerc from install of kdelibs3-3.4.0-22 conflicts with file from package kdeartwork3-3.3.2-4
        file /opt/kde3/bin/kcmshell from install of kdelibs3-3.4.0-22 conflicts with file from package kdebase3-3.3.0-29.3
        file /opt/kde3/lib/kde3/kcmshell.la from install of kdelibs3-3.4.0-22 conflicts with file from package kdebase3-3.3.0-29.3
        file /opt/kde3/lib/kde3/kcmshell.so from install of kdelibs3-3.4.0-22 conflicts with file from package kdebase3-3.3.0-29.3
        file /opt/kde3/lib/libkdeinit_kcmshell.la from install of kdelibs3-3.4.0-22 conflicts with file from package kdebase3-3.3.0-29.3
        file /opt/kde3/lib/libkdeinit_kcmshell.so from install of kdelibs3-3.4.0-22 conflicts with file from package kdebase3-3.3.0-29.3
        file /opt/kde3/share/services/xcf.kimgio from install of kdelibs3-3.4.0-22 conflicts with file from package gwenview-1.1.5-8.1
E: Error while running transaction
E: Handler silently failed

ist die einzige möglichkeit also ein

Code: Alles auswählen

apt-get -f upgrade
bei dem man volle 574MB ziehen muss und bei dem am ende wiederum die konfliktliste kommt wie man sie weiter oben sieht?

irgendwas muss ich da falsch machen, vielleicht kann mir jemand weiterhelfen.

danke

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 23. Apr 2005, 18:18

Dein Problem resultiert aus den Paketen von suser-guru, die sind alle gegen kde-3.3.99 gelinkt ... und wenn du andere kde-3.4er Programme haben willst beisst sich das.

Lass mal suser-guru weg, apt update nicht vergessen nach der Änderung an der sources.list.
Dann upgrade erst mal deine kde auf 3.4.
Dann installierst du den Rest.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

fRiSi
Newbie
Newbie
Beiträge: 3
Registriert: 23. Apr 2005, 14:38

kde3.4 update gelöst!

Beitrag von fRiSi » 24. Apr 2005, 23:08

ich hab suser-guru aus den sources genommen und 'apt update' ausgeführt wie empfohlen

versuch die abhängigkeiten automatisch zu lösen:
'apt-get -f install' funktioniert immer nocht nicht


kdeupdate wie in http://www.linux-club.de/viewtopic.php?t=14759 - übrigens auch ein sehr interessanter thread - funktionierte nicht

Code: Alles auswählen

frisi-laptop:/home/frisi # apt-get -f install kdelibs3 kdebase3
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
You might want to run `apt-get --fix-broken install' to correct these:
Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
  amarok: Hängt ab von: kdelibs3 (< 3.3.999) aber 3.4.0-22 wird installiert werden
  kdelibs3: Hängt ab von: qt3 (>= 3.3.4) aber 3.3.3-24 wird installiert werden
E: Unmet dependencies. Try 'apt-get --fix-broken install' with no packages (or specify a solution).
dann hab ich amarok und und qt3 dazugenommen.
danach hatte ich konflikte mit kdeaddons3-konqueror und gwenview
und

Code: Alles auswählen

apt-get -f install kdelibs3 kdebase3 amarok qt3 kdeartwork3 kdeaddons3-konqueror gwenview
führte schlussendlich zum erfolg!

nach einem neustart steigt mein puls nochmal als nach der anmeldung durch kdm auf einmal fvwm gestartet wurde. aber mit sitzungsart/kde war wieder alles in butter!

danke für die hilfe!

Huepftigger
Newbie
Newbie
Beiträge: 22
Registriert: 5. Mai 2005, 13:15

Beitrag von Huepftigger » 13. Jun 2005, 13:23

Oh, hab grad entdeckt, daß ich exakt dieselbe Fehlermeldung habe.

Nur ein APT Check bringt bei mir rein gar nix zu tage:

Code: Alles auswählen

# apt check
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Wie krieg ich es denn nun hin, daß Kile bei mir läuft??

Edit: Ein Upgrade würde folgendes machen. Da ich aber Angst habe, mir das ganze System zu zerschiessen, poste ich erstmal hier, bevor ich irgendwas ausführe:

Code: Alles auswählen

# apt-get -f upgrade
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Die folgenden Pakete werden upgegradet werden:
  abiword alsa anthy arts ash bc bind-chrootenv bind-libs bind-lwresd
  bind-utils boehm-gc bzip2 chkrootkit compat-curl2 compat-openssl096g curl
  cyrus-sasl devs digikam docbook_4 evolution-data-server freeciv gaim gdb
  gimp glib2 gnet gnome-icon-theme gphoto gqview grip gstreamer gtk-qt-engine
  guile gwenview hp-officeJet imlib imlib2 imlib2-filters imlib2-loaders
  info2html iptables iso_ent kaffeine kde3-i18n-de kdeaddons3-kate
  kdeaddons3-kicker kdeaddons3-konqueror kdeartwork3 kdeartwork3-sound
  kdeartwork3-xscreensaver kdebase3 kdebase3-kdm kdebase3-ksysguardd
  kdebase3-nsplugin kdebase3-samba kdebluetooth kdegames3 kdegraphics3
  kdegraphics3-imaging kdegraphics3-kamera kdegraphics3-postscript
  kdegraphics3-scan kdelibs3 kdelibs3-doc kdemultimedia3 kdemultimedia3-CD
  kdemultimedia3-jukebox kdemultimedia3-mixer kdemultimedia3-sound kdenetwork3
  kdenetwork3-InstantMessenger kdenetwork3-news kdenetwork3-vnc kdepim3-kpilot
  kdepim3-sync kdetv kdeutils3 kdeutils3-laptop kernel-bigsmp
  kernel-bigsmp-nongpl kernel-smp kernel-smp-nongpl kino kipi-plugins knights
  krecord lame lbreakout libart_lgpl libavc1394 libcroco libdv libgphoto2
  libgsf libgsf-gnome libgtop libidl libieee1284 libkexif libkipi liblcms
  liblcms-devel libmikmod libmusicbrainz libogg libotf libquicktime libraw1394
  libsmbclient libsoup libtheora libtunepimp libusb libvorbis libxml2
  liby2util linc lineak_defaultplugin lineak_kde lineak_xosdplugin lineakd
  linux-atm-lib m17n-db m17n-lib mozilla multisync multisync-backup
  multisync-irmc multisync-irmc-bluetooth multisync-ldap multisync-opie
  multisync-palm multisync-syncml mysql-shared ndiswrapper net-snmp oaf
  ooqstart openldap2-client openssl orbit2 pan parted perl-spamassassin
  postgresql-libs ppp python-gtk qca qt3 samba samba-client samba-doc
  samba-winbind sane scrollkeeper sgml-skel shared-mime-info smpppd
  spamassassin speex sqlite taglib tcl tcpdump tcsh thinkeramik
  thinkeramik-style tk uim vte wine wireless-tools wvdial wvstreams xchat
  xmlcharent xmms-kde xorg-x11 xorg-x11-Mesa xorg-x11-Xvnc
  xorg-x11-fonts-75dpi xorg-x11-fonts-scalable xorg-x11-libs xorg-x11-server
  xorg-x11-server-glx xosd yast2-control-center yast2-packagemanager
  yast2-storage yast2-tv ypbind
Die folgenden Pakete sind zurückgehalten worden
  OpenEXR alsa-tools amarok amarok-xmms gstreamer-plugins
  gstreamer-plugins-default gstreamer-plugins-excess gstreamer-plugins-extra
  jack k3b kdegraphics3-fax kdepim3 kdepim3-organizer kernel-default
  kernel-default-nongpl kernel-source libglade2 libofx librsvg libxslt mlterm
192 upgraded, 0 newly installed, 0 entfernt und 21 nicht upgegradet.
Muss 358MB an Archiven holen.
Nach dem Auspacken werden 75,5MB zusätzlicher Plattenplatz benutzt werden.

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 13. Jun 2005, 13:37

Ich würde auf jeden Fall schon mal den Kernel vom Update ausschließen. Steht in den How-Tos zu apt hier im Forum.
Ansonsten kann ich apt nur empfehlen, das funktioniert sehr gut bei mir.

Huepftigger
Newbie
Newbie
Beiträge: 22
Registriert: 5. Mai 2005, 13:15

Beitrag von Huepftigger » 13. Jun 2005, 13:56

Und ich dachte ich hätte den schon ausgeschlossen? Bin exakt nach der Anleitung für Newbees vorgegangen. Aber ich schau nochmal - vielen Dank!

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 13. Jun 2005, 14:01

Du musst in der entsprechenden Zeile in der apt.conf auf jedes Leerzeichen achten! Hatte das Problem auch. Bei mir fehlte ein führendes Leerzeichen vor "kernel-default".
Und bei deinem System musst du wohl auch "kernel-bigsmp" auf Hold setzen.

Huepftigger
Newbie
Newbie
Beiträge: 22
Registriert: 5. Mai 2005, 13:15

Beitrag von Huepftigger » 13. Jun 2005, 14:29

Super, vielen Dank. Ich hab da jetzt einfach mal alles, was mit "kernel" begonnen hat, reingesetzt. Ergebnis: Alle Kernel-Dinge draussen:

Code: Alles auswählen

Die folgenden Pakete werden upgegradet werden:
  abiword alsa anthy arts ash bc bind-chrootenv bind-libs bind-lwresd
  bind-utils boehm-gc bzip2 chkrootkit compat-curl2 compat-openssl096g curl
  cyrus-sasl devs digikam docbook_4 evolution-data-server freeciv gaim gdb
  gimp glib2 gnet gnome-icon-theme gphoto gqview grip gstreamer gtk-qt-engine
  guile gwenview hp-officeJet imlib imlib2 imlib2-filters imlib2-loaders
  info2html iptables iso_ent kaffeine kde3-i18n-de kdeaddons3-kate
  kdeaddons3-kicker kdeaddons3-konqueror kdeartwork3 kdeartwork3-sound
  kdeartwork3-xscreensaver kdebase3 kdebase3-kdm kdebase3-ksysguardd
  kdebase3-nsplugin kdebase3-samba kdebluetooth kdegames3 kdegraphics3
  kdegraphics3-imaging kdegraphics3-kamera kdegraphics3-postscript
  kdegraphics3-scan kdelibs3 kdelibs3-doc kdemultimedia3 kdemultimedia3-CD
  kdemultimedia3-jukebox kdemultimedia3-mixer kdemultimedia3-sound kdenetwork3
  kdenetwork3-InstantMessenger kdenetwork3-news kdenetwork3-vnc kdepim3-kpilot
  kdepim3-sync kdetv kdeutils3 kdeutils3-laptop kile kino kipi-plugins knights
  krecord lame lbreakout libart_lgpl libavc1394 libcroco libdv libgphoto2
  libgsf libgsf-gnome libgtop libidl libieee1284 libkexif libkipi liblcms
  liblcms-devel libmikmod libmusicbrainz libogg libotf libquicktime libraw1394
  libsmbclient libsoup libtheora libtunepimp libusb libvorbis libxml2
  liby2util linc lineak_defaultplugin lineak_kde lineak_xosdplugin lineakd
  linux-atm-lib m17n-db m17n-lib mozilla multisync multisync-backup
  multisync-irmc multisync-irmc-bluetooth multisync-ldap multisync-opie
  multisync-palm multisync-syncml mysql-shared ndiswrapper net-snmp oaf
  ooqstart openldap2-client openssl orbit2 pan parted perl-spamassassin
  postgresql-libs ppp python-gtk qca qt3 samba samba-client samba-doc
  samba-winbind sane scrollkeeper sgml-skel shared-mime-info smpppd
  spamassassin speex sqlite taglib tcl tcpdump tcsh thinkeramik
  thinkeramik-style tk uim vte wine wireless-tools wvdial wvstreams xchat
  xmlcharent xmms-kde xorg-x11 xorg-x11-Mesa xorg-x11-Xvnc
  xorg-x11-fonts-75dpi xorg-x11-fonts-scalable xorg-x11-libs xorg-x11-server
  xorg-x11-server-glx xosd yast2-control-center yast2-packagemanager
  yast2-storage yast2-tv ypbind
Die folgenden Pakete sind zurückgehalten worden
  OpenEXR alsa-tools amarok amarok-xmms gstreamer-plugins
  gstreamer-plugins-default gstreamer-plugins-excess gstreamer-plugins-extra
  jack k3b kdegraphics3-fax kdepim3 kdepim3-organizer kernel-bigsmp
  kernel-bigsmp-nongpl kernel-default kernel-default-nongpl kernel-smp
  kernel-smp-nongpl kernel-source libglade2 libofx librsvg libxslt mlterm
189 upgraded, 0 newly installed, 0 entfernt und 25 nicht upgegradet.
Muss 309MB/311MB an Archiven holen.
Nach dem Auspacken werden 75,0MB zusätzlicher Plattenplatz benutzt werden.
Wollen Sie fortsetzen? [J/n] n
Vielen Dank, Grothesk :D

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: Google [Bot] und 2 Gäste