Konflikte mit kde(?) bei test-update mit apt (synaptic)

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Gesperrt
Benutzeravatar
LudwigVan
Member
Member
Beiträge: 110
Registriert: 28. Feb 2004, 08:42

Konflikte mit kde(?) bei test-update mit apt (synaptic)

Beitrag von LudwigVan » 9. Apr 2005, 12:17

Hallo,

ich hatte ja versprochen, mich erst zu melden, wenn etwas nicht klappt ;)

Also, newbee-anleitung gelesen, installiert, sources.list upgedatet (und kontrolliert). Nun, dann wollte ich einen test fahren und habe mir irgendwas unverfängliches rausgesucht, d.h. update von grip, kaffeine oder k3b. Doch jedes mal, wenn ich das update anstoße, bekomme ich folgende Meldung:
Während der Vorbereitung für die Installation:

file /opt/kde3/share/services/xcf.kimgio from install of kdelibs3-3.4.0-22 conflicts with file from package gwenview-1.1.5-8
file /opt/kde3/share/mimelnk/application/x-webarchive.desktop from install of kdelibs3-3.4.0-22 conflicts with file from package kdeaddons3-konqueror-3.3.0-10
file /opt/kde3/lib/kde3/kstyle_plastik_config.la from install of kdelibs3-3.4.0-22 conflicts with file from package kdeartwork3-3.3.0-7
file /opt/kde3/lib/kde3/kstyle_plastik_config.so from install of kdelibs3-3.4.0-22 conflicts with file from package kdeartwork3-3.3.0-7
file /opt/kde3/lib/kde3/plugins/styles/plastik.la from install of kdelibs3-3.4.0-22 conflicts with file from package kdeartwork3-3.3.0-7
file /opt/kde3/lib/kde3/plugins/styles/plastik.so from install of kdelibs3-3.4.0-22 conflicts with file from package kdeartwork3-3.3.0-7
file /opt/kde3/share/apps/kstyle/themes/plastik.themerc from install of kdelibs3-3.4.0-22 conflicts with file from package kdeartwork3-3.3.0-7
file /opt/kde3/bin/kcmshell from install of kdelibs3-3.4.0-22 conflicts with file from package kdebase3-3.3.0-29.3
file /opt/kde3/lib/kde3/kcmshell.la from install of kdelibs3-3.4.0-22 conflicts with file from package kdebase3-3.3.0-29.3
file /opt/kde3/lib/kde3/kcmshell.so from install of kdelibs3-3.4.0-22 conflicts with file from package kdebase3-3.3.0-29.3
file /opt/kde3/lib/libkdeinit_kcmshell.la from install of kdelibs3-3.4.0-22 conflicts with file from package kdebase3-3.3.0-29.3
file /opt/kde3/lib/libkdeinit_kcmshell.so from install of kdelibs3-3.4.0-22 conflicts with file from package kdebase3-3.3.0-29.3
file /opt/kde3/lib/kde3/libk3bmaddecoder.la conflicts between attempted installs of k3b-mad-0.11.20-7 and k3b-0.11.23-3.pm.0
file /opt/kde3/lib/kde3/libk3bmaddecoder.so conflicts between attempted installs of k3b-mad-0.11.20-7 and k3b-0.11.23-3.pm.0
E: Error while running transaction
hm, was mich noch wundert: apt behauptet, es müsse für die Installation der Programme erstmal die beiden Programme basket und showimg deinstallieren, die meiner Meinung nach nichts mit den oben genannten, zu installierenden drei programmen (nicht aus der Fehlermeldung) zu tun haben.

Dann habe ich mir gedacht, dass die aktuellen Versionen von grip, kaffeine oder k3b vielleicht ein aktuelles KDE benötigen. Aber dann bleibt die Frage, warum apt dann im Zuge der Installationsvorbereitungen nur die aktuelle kde-lib runterläd?

Vielleicht kann mir einer einen Tip zur Fehlersuche geben?

Meine Daten:

SuSE 9.2
kde 3.3
apt: 0.5.15cnc6-rb.suse092.6
synaptic 0.55.3-0.suse092.rb1
naja, und ich weiß nicht, ob's ne Rolle spielt, aber
Kernel 2.6.8-24.14 (SuSE Update-Kernel)

Ludwig.

Werbung:
}-Tux-{
Moderator
Moderator
Beiträge: 696
Registriert: 12. Dez 2004, 19:54
Kontaktdaten:

Beitrag von }-Tux-{ » 9. Apr 2005, 14:27

Hi

mit welchem befehl startest du denn das "update" ?
poste bitte mal alles, was du eingibst...

ansonsten schaue dir mal die --force option an...


mfg }-Tux-{

Benutzeravatar
LudwigVan
Member
Member
Beiträge: 110
Registriert: 28. Feb 2004, 08:42

Beitrag von LudwigVan » 9. Apr 2005, 18:52

... hm, ich 'gebe' gar keinen befehl ein. Ich wähle über synaptic die zu aktualisierenden Pakete aus, gehe auf 'Anwenden' und dann zeigt mir synaptic an, welche Pakete es noch installiern muß um die Abhängigkeiten aufzulösen. Das bestätige ich (u.a. die kdelib) und nach dem download der Pakete startet der Installationsversuch mit der abschließenden Fehlermeldung.

Ludwig

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 10. Apr 2005, 18:06

diese Fehlermeldung bedeutet, das Dateien innerhalb der RPMs verschoben wurden ...

siehe hier:
Wichtig: [Tip] Abhängigkeiten lösen / Fehlermeldungen von apt
http://www.linux-club.de/viewtopic.php?t=16315

Posting #4

==> apt --force upgrade laufenlassen ...

und damit ist dieser Thread geschlossen :)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste