Adaptec Raid Controller HostRaid-8130

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Jens1984
Newbie
Newbie
Beiträge: 3
Registriert: 6. Apr 2005, 20:30

Adaptec Raid Controller HostRaid-8130

Beitrag von Jens1984 » 6. Apr 2005, 21:09

Hallo,

habe hier einen neuen Server stehen von HP (ML150 G2) und wollte diesen soebene mit Suse Linux 9.2 installieren.

Leider sagt mir dieser das er die Festplatten nicht finden kann, da ich mal vermute, das er keine treibe rfür den Raid Controller hat.

Verbaut ist hierbei ein Adaptec Embedded SATA HoastRaid Controller (HostRaid-8130).

Habe bereits bei HP den Suse Linux Treiber herunter geladen und die EXE Datei ausgeführ und eine Diskette mit dem Treiber erstellt.

http://h18000.www1.hp.com/support/f...load/22402.html

Wenn ich nun von der CD boote, erhalte ich einen Begrüßungsbildschrim, in welchem ich F6 drücken kann um einen Treiber zu installieren. Danach drücke cih auf Installieren. Daraufhin fragt er nach dem Treiber, worin ich das Diskettenlaufwerk angebe. Leider sagt er mir, dass er keinen Treiber auf der Diskette finden kann. Habe auch bereits die Treiber von der HP CD verwendet, leider selbes Problem.

No driver updates found!

Auf der Adaptecseite, konnte ich leider nicht mal den Controller finden

Vielen Dank für die Hilfe

MfG

Jens

Werbung:
Jens1984
Newbie
Newbie
Beiträge: 3
Registriert: 6. Apr 2005, 20:30

Beitrag von Jens1984 » 10. Apr 2005, 14:35

Problem konnte gelöst werden, es muss Suse Linux 9 Enterprise installiert werden.

MfG

Jens

Dr. Glastonbury
Advanced Hacker
Advanced Hacker
Beiträge: 1149
Registriert: 20. Aug 2004, 12:27
Wohnort: München
Kontaktdaten:

Beitrag von Dr. Glastonbury » 26. Jul 2005, 20:43

Hi,
hab jetzt den selben Server hier stehen - und bekomm das einfach ned hin! Ich würde gerne SuSE9.3 installieren, weil n SLES is mir dann doch n bisserl zu teuer.
Im Internet hab ich diesen Forumsbeitrag dazu gefunden: http://debian.catsanddogs.com/forum/ind ... ,35.0.html

Außerdem stolpert man immer wieder über Installationsprobleme mit dem Schmarrn.

Meine Frage ist jetzt aber folgende: Kann ich das HowTo hier ( http://www.keffective.com/mvsata/ ) auch für SuSE hernehmen? Weil das ist ja eigentlich für Fedora.
Oder aber hat da einer vielleicht schon so ein Kernelmodul für den kernel-default-2.6.11.4-21.2 (müsste der sein, hab hier zu Hause das gleiche SuSE wie ich auf den Server installieren wollte - nur halt 32Bit und kein SMP) erstellt? Wäre toll, wenn mir das einer zuschicken könnte. Sonst würde ich das hier zu Hause probieren, wobei ich hier ja keinen 64Bit-Kernel hab....

Achja noch ne blede Frage: Kann ich die Sourcen des SMP-64Bit Kernels installieren und auf den dann das modul kompillieren...? Wenn ja - wie?

Tut mir leid für die vielen Fragen - nachdem aber HP unfähig ist Treiber rauszubringen muss ich mir die eben selber machen :( Leider bin ich noch nicht so "gut" im Kernelmodulbau, also wäre es nett, wenn mir das einer etwas ausführlicher erklähren könnte.


Dann sag ich schon mal vielen Dank ;)
Das Leben: hasse oder ignoriere es, lieben kannst du es nicht.

Dr. Glastonbury
Advanced Hacker
Advanced Hacker
Beiträge: 1149
Registriert: 20. Aug 2004, 12:27
Wohnort: München
Kontaktdaten:

Beitrag von Dr. Glastonbury » 27. Jul 2005, 15:25

So,
hab heute ne ganze Weile rumprobiert. Das ganze ließ sich schon ganz nett kompillieren, allerdrings bricht der Vorgang mit der Meldung

Code: Alles auswählen

  Building modules, stage 2.
make[2]: scripts/mod/modpost: Kommando nicht gefunden
make[2]: *** [__modpost] Fehler 127
make[1]: *** [modules] Fehler 2
make: *** [modules] Fehler 2
cp: Aufruf von stat für „mv_sata.ko“ nicht möglich: Datei oder Verzeichnis nicht gefunden
failed to copy mv_sata.ko to ./../build/Linux/DebugFull
ab...

Was kann ich machen, damit das build-script diesen blöden modpost-Befehl findet. Ich hab schon hier im Forum gesucht, aber zum einen make mit "KERNDIR=/usr/src/linux" hat nicht funktioniert...

Was kann ich nur machen, damit das gefunden wird? Der würde nämlich sonst ganz normal installieren... :(

EDIT:
Bin überglücklich! Habs hinbekommen - und damit sich andere Leute nicht auch noch damit rumquälen müssen, sollten sie auch diesen Adapter haben schreib ich hier doch glatt schnell ein kleines HowTo:

Also zunächst mal die Kernelsourcen installieren.
Jetzt muss man eine cloneconfig vom Kernel erstellen, auf die das build.sh-Script des Treibers dann zugreift. Dazu einfach in /usr/src/linux-2.6.xx gehen und hier den Befehl make cloneconfig ausführen.
Danach muss man einen Link von /usr/src/linux-2.6.xx auf /usr/src/linux-2.6 machen.

Wenn man den SMP-Kernel hat muss auch noch ein zweiter Link von /usr/src/linux-obj/i386/default/scripts/mod/modpost auf /usr/src/linux-2.6/scripts/mod/modpost machen, damit das build.sh-Script später den Befehl modpost findet -> siehe oben. (Bei dem default-Kernel hier bei mir zu Hause, war der modpost Befehl hier schon vorhanden)

Jetzt auf http://www.keffective.com/mvsata/FC3/ das entsprechende Paket laden -> ich habe das hier verwendet: http://www.keffective.com/mvsata/FC3/mvsata340.zip

Das einfach im /home/dir entpacken und in den Ordner LinuxIAL wechseln. Jetzt dem build.sh-Script noch ausführungsrechte geben: chmod +x build.sh und dann mit ./build.sh ausführen.

Wenn man jetzt alles richtig gemacht hat, dann sollte es das Kernelmodul kompillieren. Das kann man dann am Ende im selben Ordner unter mv_sata.ko finden und mit insmod mv_sata.ko laden. Wenige Sekunden danach wurde bei mir eine neue Festplatte erkannt ;)

-----

Wenn man ein System hat, dass den SMP-Kernel braucht und man gleich auf der Festplatte installieren will ist es noch etwas komplizierter: Es gibt nämlich ein kleines Problem mit dem Installer (also dem Kernel, der für die Installation geladen wird - dieser ist der default-Kernel) und somit nicht mit dem Modul kopatibel, was ihr mit dem SMP-Kernel kompilliert habt. Hier braucht ihr dann zwei Systeme: einmal mit dem default-Kernel mit dem ihr das Modul für die installation erstellt und einmal das Modul für SMP, was ihr dann direkt nach der installation einbinden müsst, damit Linux überhaupt von dieser Platte laden kann.

Also einfach für beide Kernel kompillieren, dann sollte es funzen :lol:

Auf meiner Homepage hab ich nochmal n ausführliches HowTo geschrieben und drei Kernelmodule für den 2.6.11.4-21.2[default]/[smp] Kernel in i386 und x86_64 geladen. Wer was damit anfangen kann soll sichs saugen^^

Quellen: http://www.keffective.com/mvsata/ , http://linuxmafia.com/faq/Hardware/sata.html#marvell , http://debian.catsanddogs.com/forum/ind ... ,35.0.html
Das Leben: hasse oder ignoriere es, lieben kannst du es nicht.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast