Fehlermeldung bei Dist-Upgrade

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Schwartmann
Newbie
Newbie
Beiträge: 33
Registriert: 11. Mär 2005, 00:03
Wohnort: Köln
Kontaktdaten:

Fehlermeldung bei Dist-Upgrade

Beitrag von Schwartmann » 13. Mär 2005, 22:36

Nachdem ich nun 1 knappes GB mit apt-get dist-upgrade heruntergeladen habe, kommt am Ende folgende Fehlermeldung:


1192MB in 1h10m1s (284kB/s) geholt
Committing changes...
Preparing... ########################################### [100%]
file /usr/lib/libgc.a from install of boehm-gc-32bit-9.2-200412202043 conflicts with file from package boehm-gc-3.3.4-11
file /usr/lib/libgc.so.1.0.1 from install of boehm-gc-32bit-9.2-200412202043 conflicts with file from package boehm-gc-3.3.4-11
file /usr/lib/lib-org-w3c-dom.so.0.0.0 from install of libgcj-32bit-9.2-200412202043 conflicts with file from package libgcj-3.3.4-11
file /usr/lib/lib-org-xml-sax.so.0.0.0 from install of libgcj-32bit-9.2-200412202043 conflicts with file from package libgcj-3.3.4-11
file /usr/lib/libgcj.so.4.0.0 from install of libgcj-32bit-9.2-200412202043 conflicts with file from package libgcj-3.3.4-11
E: Error while running transaction
seneca:/home/andreas #


Gibt's dafür eine Lösung?

Andreas

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 13. Mär 2005, 22:39

Wichtig: [Tip] Abhängigkeiten lösen / Fehlermeldungen von apt
http://www.linux-club.de/viewtopic.php?t=16315

4. Posting

und btw:
/usr/lib/libgc.a from install of boehm-gc-32bit-9.2-200412202043
du installierst scheinbar wieder 32bit software ???
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Schwartmann
Newbie
Newbie
Beiträge: 33
Registriert: 11. Mär 2005, 00:03
Wohnort: Köln
Kontaktdaten:

Beitrag von Schwartmann » 13. Mär 2005, 22:51

Ich habe das beim Installieren von Suse überprüft: Einige Pakete werden zusätzlich auch als 32 Bit Version installiert. Kann es sein, daß einige Programme darauf zurückgreifen müssen?

Wahrscheinlich will apt diese Pakete nun eben auch aktualisieren.

Ich habe nun Synaptic manuell installiert und in der Liste der zu aktualisierenden Software dieses Boehm-Gedings und die lib.... gelöscht. Nun werden 880 Pakete aktualisiert, und nicht 882. ;-)

Mal sehen, ob es klappt.

Andreas

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast