Nochmals: APT und Suse 9.2 64 Bit

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Schwartmann
Newbie
Newbie
Beiträge: 33
Registriert: 11. Mär 2005, 00:03
Wohnort: Köln
Kontaktdaten:

Nochmals: APT und Suse 9.2 64 Bit

Beitrag von Schwartmann » 13. Mär 2005, 17:45

Hallo,

nachdem ich vor ein paar Tagen schon einmal an dem Problem verzweifelt bin und ich mit Fedora nicht ins Internet komme, habe ich nun mein Suse 9.2 komplett neuinstalliert und dabei (beim Booten von der DVD) darauf geachtet, daß ich im 64 Bit Modus neu installiere.

Nun sollte ich ja eigentlich ein 64 Bit System haben, oder hätte ich alle Pakete, die in zweifacher Ausführung auch als 32-Bit-Variante ausgewählt waren, manuell auf "Tabu" setzen müssen?

Wie dem auch sei: Ich bekomme apt immer noch nicht installiert.

Weiterhin bekomme ich folgende Fehlermeldung:

warning: apt-0.5.15cnc6-rb5.x86_64.rpm: V3 DSA signature: NOKEY, key ID 6143b445
error: Failed dependencies:
libreadline.so.4()(64bit) is needed by apt-0.5.15cnc6-rb5
linux:/windows/D #

Ich weiß nicht, was ich falsch mache. Das System ist doch völlig neu aufgesetzt (im 64 Bit Modus) und außer dem Yast Online Update habe ich nichts, aber auch gar nichts verändert.

DIese "libreadline.so4" findet sich auf meiner DVD auch nicht, lediglich libreadline für java, aber auch das brachte keine Abhilfe.

Wenn es auf anderen System klappt, nur bei mir nicht, dann muß irgendwo der Wurm drin sein. Aber wo?

Vielleicht kann mir der ein oder andere doch noch einen wertvollen Hinweis geben.

Danke!

Andreas

Werbung:
Benutzeravatar
admine
Administrator
Administrator
Beiträge: 8745
Registriert: 15. Feb 2004, 21:13
Wohnort: Dresden
Kontaktdaten:

Beitrag von admine » 13. Mär 2005, 17:50

Du musst außer apt auch die apt-libs mit installieren ... in einem Zug !

http://ftp.gwdg.de/pub/linux/suse/apt/S ... r-jmorris/
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Schwartmann
Newbie
Newbie
Beiträge: 33
Registriert: 11. Mär 2005, 00:03
Wohnort: Köln
Kontaktdaten:

Beitrag von Schwartmann » 13. Mär 2005, 18:11

Auch das hilft nicht:

linux:/home/andreas/RPM # rpm -ihv *.rpm
warning: apt-0.5.15cnc6-rb5.x86_64.rpm: V3 DSA signature: NOKEY, key ID 6143b445
error: Failed dependencies:
libreadline.so.4()(64bit) is needed by apt-0.5.15cnc6-rb5
linux:/home/andreas/RPM #


:-(

OldKid
Hacker
Hacker
Beiträge: 448
Registriert: 2. Aug 2004, 19:37
Wohnort: Sauerland
Kontaktdaten:

Beitrag von OldKid » 13. Mär 2005, 18:14

na dann versuchs mal so rum

erst libreadline.so.4()(64bit

dann apt-0.5.15cnc6-rb5

weil

libreadline.so.4()(64bit) is needed by apt-0.5.15cnc6-rb5 !!!!!!!


also erst die libs und dann apt
“Regression testing? What's that? If it compiles, it is good, if it boots up it is perfect.”Linus Torvalds
AMD64 X2 4200+ - 4GB RAM - 1,2 TB Disk - GeForce 8400 GS - 2.6.38-ck
Creative Commons Lizenz

Schwartmann
Newbie
Newbie
Beiträge: 33
Registriert: 11. Mär 2005, 00:03
Wohnort: Köln
Kontaktdaten:

Beitrag von Schwartmann » 13. Mär 2005, 19:10

Danke, aber lesen kann ich auch.

Ich scheine mich wohl unklar auszudrücken:

1. Ich habe zuerst die abt-libs installiert. Das klappte problemlos.

2. Dann habe ich versucht, apt zu installieren, aber das fragt nach dieser "libreadline".

3. ICH HABE ABER KEINE libreadline.so (64 Bit), und ich weiß auch nicht, wo ich sie her bekomme.

Ist das denn so schwer, zu verstehen?


Wieso funktioniert der Mist überall, nur nicht bei mir?

Andreas

OldKid
Hacker
Hacker
Beiträge: 448
Registriert: 2. Aug 2004, 19:37
Wohnort: Sauerland
Kontaktdaten:

Beitrag von OldKid » 13. Mär 2005, 19:17

ok dann installier mal mit Yast

readline-devel-5.0-1.2.x86_64 .rpm

wenn du die nicht auf der DVD findest dann hier

ftp://ftp.gwdg.de/pub/linux/suse/ftp.su ... use/x86_64
“Regression testing? What's that? If it compiles, it is good, if it boots up it is perfect.”Linus Torvalds
AMD64 X2 4200+ - 4GB RAM - 1,2 TB Disk - GeForce 8400 GS - 2.6.38-ck
Creative Commons Lizenz

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 13. Mär 2005, 19:17

tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

}-Tux-{
Moderator
Moderator
Beiträge: 696
Registriert: 12. Dez 2004, 19:54
Kontaktdaten:

Beitrag von }-Tux-{ » 13. Mär 2005, 19:18

Schwartmann hat geschrieben:Wieso funktioniert der Mist überall, nur nicht bei mir?
immer schön locker bleiben :wink:

hast du schonmal dieses rpm probiert?
http://ftp.gwdg.de/pub/linux/suse/apt/S ... x86_64.rpm

denn

Code: Alles auswählen

XyZ@laptop:~> rpm -qlp http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/9.2-x86_64/RPMS.base/readline-5.0-1.2.x86_64.rpm
/lib64/libhistory.so.5
/lib64/libhistory.so.5.0
/lib64/libreadline.so.5
/lib64/libreadline.so.5.0
/usr/share/info/history.info.gz
/usr/share/info/readline.info.gz
mfg }-Tux-{

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 13. Mär 2005, 19:33

btw im jmorris Repository gibt es mehrere apt(-libs) Versionen ...

welche verwendest du denn ?
apt-0.5.15cnc6-rb5.x86_64.rpm 08-Nov-2004 00:05 386k
apt-0.5.15cnc6-suse092.jm.6.x86_64.rpm 02-Feb-2005 17:20 386k
apt-0.5.15cnc7_20050311a-suse092.jm.1.x86_64.rpm 11-Mar-2005 23:41 395k
apt-libs-0.5.15cnc6-rb5.x86_64.rpm 08-Nov-2004 00:05 621k
apt-libs-0.5.15cnc6-suse092.jm.6.x86_64.rpm 02-Feb-2005 17:20 688k
apt-libs-0.5.15cnc7_20050311a-suse092.jm.1.x86_..> 11-Mar-2005 23:41 690k
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Schwartmann
Newbie
Newbie
Beiträge: 33
Registriert: 11. Mär 2005, 00:03
Wohnort: Köln
Kontaktdaten:

Beitrag von Schwartmann » 13. Mär 2005, 19:34

Danke vielmals, werde ich gleich direkt mal ausprobieren, aber jetzt bin ich gerade in Windows.

Aber vielleicht bekomme ich ja Apt doch noch ans Laufen.


Die Hoffnung stirbt zuletzt.

Andreas

Schwartmann
Newbie
Newbie
Beiträge: 33
Registriert: 11. Mär 2005, 00:03
Wohnort: Köln
Kontaktdaten:

Beitrag von Schwartmann » 13. Mär 2005, 20:07

Wäre ja auch zu schön gewesen:

Ich habei die empfohlenen Pakete installiert:

linux:/windows/D # rpm -i readline-5.0-1.2.x86_64.rpm
package readline-5.0-1.2 is already installed
linux:/windows/D # rpm -i readline-devel-5.0-1.2.x86_64.rpm

Dann nochmals das apt Patet versucht:

linux:/home/andreas/RPM # rpm -i apt-0.5.15cnc6-rb5.x86_64.rpm
warning: apt-0.5.15cnc6-rb5.x86_64.rpm: V3 DSA signature: NOKEY, key ID 6143b445
error: Failed dependencies:
libreadline.so.4()(64bit) is needed by apt-0.5.15cnc6-rb5
linux:/home/andreas/RPM #

Tja, also keine Änderung.

Wo gibt es denn nun diese libreadline.so.4()(64bit) ?

Ich gebe es bald auf. Apt und Suse 64 Bit vertragen sich wohl doch nicht miteinander.

Andreas





linux:/home/andreas/RPM # rpm -i apt-0.5.15cnc6-rb5.x86_64.rpm
warning: apt-0.5.15cnc6-rb5.x86_64.rpm: V3 DSA signature: NOKEY, key ID 6143b445
error: Failed dependencies:
libreadline.so.4()(64bit) is needed by apt-0.5.15cnc6-rb5
linux:/home/andreas/RPM #

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 13. Mär 2005, 20:15

Schwartmann hat geschrieben:linux:/home/andreas/RPM # rpm -i apt-0.5.15cnc6-rb5.x86_64.rpm
warning: apt-0.5.15cnc6-rb5.x86_64.rpm: V3 DSA signature: NOKEY, key ID 6143b445
error: Failed dependencies:
libreadline.so.4()(64bit) is needed by apt-0.5.15cnc6-rb5
linux:/home/andreas/RPM #
du musst schon mal genau lesen ... libreadline.so.4 wird von apt verlangt ... du installierst aber libreadline.so.5 :(

deshlab mein Hinweis auf die anderen apt(-libs) RPMs ...
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Schwartmann
Newbie
Newbie
Beiträge: 33
Registriert: 11. Mär 2005, 00:03
Wohnort: Köln
Kontaktdaten:

Beitrag von Schwartmann » 13. Mär 2005, 20:20

Diese hier:

apt-libs-0.5.15cnc6-rb5.x86_64.rpm

weil Du auf diese in http://www.linux-club.de/viewtopic.php?t=23176 hingewiesen hast.

Sollte ich eine andere nehmen?

Die apt-libs habe ich ja problemlos installieren können: Apt selbst macht Probleme.

Andreas

Schwartmann
Newbie
Newbie
Beiträge: 33
Registriert: 11. Mär 2005, 00:03
Wohnort: Köln
Kontaktdaten:

Beitrag von Schwartmann » 13. Mär 2005, 20:21

oc2pus hat geschrieben:
Schwartmann hat geschrieben:linux:/home/andreas/RPM # rpm -i apt-0.5.15cnc6-rb5.x86_64.rpm
warning: apt-0.5.15cnc6-rb5.x86_64.rpm: V3 DSA signature: NOKEY, key ID 6143b445
error: Failed dependencies:
libreadline.so.4()(64bit) is needed by apt-0.5.15cnc6-rb5
linux:/home/andreas/RPM #
du musst schon mal genau lesen ... libreadline.so.4 wird von apt verlangt ... du installierst aber libreadline.so.5 :(
Stimmt, aber wo bekomme ich denn so.4?

Andreas

OldKid
Hacker
Hacker
Beiträge: 448
Registriert: 2. Aug 2004, 19:37
Wohnort: Sauerland
Kontaktdaten:

Beitrag von OldKid » 13. Mär 2005, 20:31

compat-readline4-4.3-2.x86_64.rpm

ftp://ftp.gwdg.de/pub/linux/suse/ftp.su ... use/x86_64


edit:

als kleiner TIP wenn man rpm's oder bestimmte libs usw. sucht

FAQ: Welches rpm-paket enthält die datei xyz
“Regression testing? What's that? If it compiles, it is good, if it boots up it is perfect.”Linus Torvalds
AMD64 X2 4200+ - 4GB RAM - 1,2 TB Disk - GeForce 8400 GS - 2.6.38-ck
Creative Commons Lizenz

Schwartmann
Newbie
Newbie
Beiträge: 33
Registriert: 11. Mär 2005, 00:03
Wohnort: Köln
Kontaktdaten:

Beitrag von Schwartmann » 13. Mär 2005, 20:46

Hurra, das war es, was ich gesucht habe! Danke, jetzt konnte ich apt installieren. :-)

Jetzt muß ich nur noch meinen Drucker ans Laufen bekommen (siehe Drucker-Forum), dann bin ich wunschlos glücklich.

Andreas

Antworten

Wer ist online?

Mitglieder in diesem Forum: Bequimão und 3 Gäste