[teilweise gelöst] Probleme nach Kernel-Of-The-Day

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Mav
Newbie
Newbie
Beiträge: 31
Registriert: 12. Mär 2005, 12:14

[teilweise gelöst] Probleme nach Kernel-Of-The-Day

Beitrag von Mav » 12. Mär 2005, 13:11

Moin zusammen :)

Ich habe ein Problem, welches ich nicht so 100% eingrenzen kann. Vielleicht wäre es in einem anderen Forum besser aufgehoben, aber da es nach einem apt update aufgetreten ist, bin ich hier wohl nicht ganz so falsch ;)

Zum Problem:

Habe mein System mit

Code: Alles auswählen

apt update
und

Code: Alles auswählen

apt dist-upgrade
auf den neuesten Stand gebracht.

Unter anderem kam dabei ein neues Kernel und ein neues ALSA mit.

Seitdem habe ich Probleme mit der Soundkarte und meinem USB-Stick.

Zur Soundkarte:
Nach dem Booten startet mein KDE-TV nicht mehr (er lädt kurz etwas, startet aber das Programm nicht). Wenn ich dann mit Yast die Soundkarte konfigurieren will, kommt zuerst die Meldung, daß die Anzahl der Soundkarten nicht stimmt, und ich das Soundsystem neu starten soll. Danach läuft dann KDE-TV. Wenn ich aber die Soundkarte weiter konfigurieren will, kommt die Fehlermeldung, daß das Modul snd-via82xx nicht geladen werden kann. Außerdem hört sich der Sound bei KDE-TV 'übersteuert' an, also wie wenn man die Boxen zu laut stellt, und dann teilweise Alles verzerrt wird. Mit KMIX kann ich runterregeln wie ich will, das Krächzen bleibt leider bestehen.
Komischerweise wird das Modul mit

Code: Alles auswählen

modprobe snd-vi82xx
ohne Fehlermeldung geladen.

Code: Alles auswählen

alsaconf
rennt auch durch, bringt aber ein 'failed' beim Setzen der Lautstärke und spielt keinen Testsound.

Zum USB-Stick:
Seit dem Kernelupdate wird der USB-Stick, welcher vorher anstandslos lief, nicht mehr gemountet. Das Lämpchen am Stick verhält sich aber wie vorher (blinkt erst etwas, leuchtet dann durch).

Habe jetzt schon einiges probiert, und dabei ist mir dann folgender Fehler beim Update aufgefallen:

Code: Alles auswählen

   2:kernel-default         ########################################### [ 50%]
Setting up /lib/modules/2.6.11.1-20050308123837-default
Root device:    /dev/sda7 (mounted on / as reiserfs)
Module list:    sata_via sym53c8xx reiserfs

Kernel image:   /boot/vmlinuz-2.6.11.1-20050308123837-default
Initrd image:   /boot/initrd-2.6.11.1-20050308123837-default
Shared libs:    lib64/ld-2.3.3.so lib64/libc.so.6 lib64/libselinux.so.1 lib/ld-2.3.3.so lib/libc.so.6
Usage: hwinfo [options]
Probe for hardware.
  --short        just a short listing
  --log logfile  write info to logfile
  --debug level  set debuglevel
  --version      show libhd version
  --dump-db n    dump hardware data base, 0: external, 1: internal
  --hw_item      probe for hw_item
  hw_item is one of:
    all, bios, block, bluetooth, braille, bridge, camera, cdrom, chipcard, cpu,
    disk, dsl, dvb, floppy, framebuffer, gfxcard, hub, ide, isapnp, isdn,
    joystick, keyboard, memory, modem, monitor, mouse, netcard, network,
    partition, pci, pcmcia, pcmcia-ctrl, pppoe, printer, scanner, scsi, smp,
    sound, storage-ctrl, sys, tape, tv, usb, usb-ctrl, vbe, wlan, zip

  Note: debug info is shown only in the log file. (If you specify a
  log file the debug level is implicitly set to a reasonable value.)

/sbin/mkinitrd: line 585: /lib/modules/2.6.11.1-20050308123837-default/modules.pcimap: syntax error: operand expected (error token is "/lib/modules/2.6.11.1-20050308123837-default/modules.pcimap")

Usage: hwinfo [options]
Probe for hardware.
  --short        just a short listing
  --log logfile  write info to logfile
  --debug level  set debuglevel
  --version      show libhd version
  --dump-db n    dump hardware data base, 0: external, 1: internal
  --hw_item      probe for hw_item
  hw_item is one of:
    all, bios, block, bluetooth, braille, bridge, camera, cdrom, chipcard, cpu,
    disk, dsl, dvb, floppy, framebuffer, gfxcard, hub, ide, isapnp, isdn,
    joystick, keyboard, memory, modem, monitor, mouse, netcard, network,
    partition, pci, pcmcia, pcmcia-ctrl, pppoe, printer, scanner, scsi, smp,
    sound, storage-ctrl, sys, tape, tv, usb, usb-ctrl, vbe, wlan, zip

  Note: debug info is shown only in the log file. (If you specify a
  log file the debug level is implicitly set to a reasonable value.)
[color=red]/sbin/mkinitrd: line 585: /lib/modules/2.6.11.1-20050308123837-default/modules.pcimap: syntax error: operand expected (error token is "/lib/modules/2.6.11.1-20050308123837-default/modules.pcimap")
[/color]
Modules:        kernel/drivers/scsi/scsi_mod.ko kernel/drivers/scsi/sd_mod.ko kernel/drivers/scsi/libata.ko kernel/drivers/scsi/sata_via.ko kernel/drivers/scsi/scsi_transport_spi.ko kernel/drivers/scsi/sym53c8xx_2/sym53c8xx.ko kernel/fs/reiserfs/reiserfs.ko kernel/drivers/parport/parport.ko kernel/drivers/parport/parport_pc.ko kernel/drivers/net/mii.ko kernel/drivers/net/via-rhine.ko kernel/lib/crc-ccitt.ko kernel/drivers/net/via-velocity.ko kernel/drivers/net/8390.ko kernel/drivers/net/ne2k-pci.ko kernel/drivers/ide/ide-core.ko kernel/drivers/ide/pci/generic.ko kernel/drivers/ide/pci/via82cxxx.ko kernel/drivers/i2c/i2c-core.ko kernel/drivers/i2c/busses/i2c-viapro.ko kernel/drivers/i2c/algos/i2c-algo-bit.ko kernel/drivers/i2c/busses/i2c-via.ko kernel/drivers/i2c/i2c-sensor.ko kernel/drivers/i2c/chips/via686a.ko kernel/sound/oss/ac97_codec.ko kernel/sound/soundcore.ko kernel/sound/oss/sound.ko kernel/sound/oss/uart401.ko kernel/sound/oss/via82cxxx_audio.ko kernel/sound/core/snd-page-alloc.ko kernel/sound/core/snd.ko kernel/sound/core/snd-timer.ko kernel/sound/core/snd-pcm.ko kernel/sound/pci/ac97/snd-ac97-codec.ko kernel/sound/pci/snd-via82xx-modem.ko kernel/sound/core/seq/snd-seq-device.ko kernel/sound/core/snd-rawmidi.ko kernel/sound/drivers/mpu401/snd-mpu401-uart.ko kernel/drivers/input/gameport/gameport.ko kernel/sound/pci/snd-via82xx.ko kernel/drivers/ide/ide-disk.ko kernel/drivers/ide/ide-floppy.ko kernel/drivers/cdrom/cdrom.ko kernel/drivers/ide/ide-cd.ko
Including:      klibc udev
Bootsplash:     SuSE (1280x1024)
Using grub, re-install of bootloader not required.
(ein wenig gekürzt, die restlichen APT-Meldungen sind normal).

Der Fehler oben tritt mittlerweile bei jedem Kernel-Update auf.

Weiß vielleicht jemand, was mir APT da zerschossen hat? Hat es nur meinen Rechner erwischt, oder ist das vielleicht ein Fehler in den Kernels von APT?

Mein System ist ein SuSE 9.2 x86_64 (direkt installiert, also nicht irgendwie upgegraded, sondern nur upgedatet), Board ist von ASUS aus der K8V Serie (ATHLON 64 3000+), Soundkarte laut Yast eine VT8233/A/8235/8237 AC97 Audio Controller. Kernel wurde durch APT vom Standard-SuSE mittlerweile auf

Code: Alles auswählen

Linux mav 2.6.11.1-20050309084849-default #1 Wed Mar 9 08:48:49 UTC 2005 x86_64 x86_64 x86_64 GNU/Linux
hochgeschraubt.

Wäre schön, wenn jemand Tipps hätte, wie ich das lösen kann (Google und auch die Suche hier in den Foren haben bisher leider nix gebracht), und mir fällt auch nix mehr ein :(

Danke schonmal!

See Ya !
Mav

Werbung:
Mav
Newbie
Newbie
Beiträge: 31
Registriert: 12. Mär 2005, 12:14

Teillösung

Beitrag von Mav » 13. Mär 2005, 18:43

Moin :)

Antworte einmal auf meinen eigenen Beitrag...

Das Problem ist mit dem Kernel

Code: Alles auswählen

Linux mav 2.6.11.2-20050312194734-default #1 Sat Mar 12 19:47:34 UTC 2005 x86_64 x86_64 x86_64 GNU/Linux
etwas besser geworden.

Soweit ich das Eingrenzen konnte, liegt es an der

Code: Alles auswählen

/lib/modules/(kernel-version)/modules.pcimap
Datei. Die mkinitrd scheint es nicht zu mögen, wenn in der Device-Spalte ein 0xffffffff steht. Im Vergleich zur alten Datei haben jetzt die snd-via82xx Einträge keinen 0xffffffff Eintrag mehr. KDE-TV usw. haben jetzt ohne Klimmzüge Sound. Nur der Realplayer weigert sich noch.
Der USB-Stick funktioniert leider immer noch nicht, aber ich vermute, das liegt daran, daß die Einträge uhci-hcd, ohci-hcd, ehci-hcd und shpchp immer noch unter Device 0xffffffff eingetragen haben.

See Ya !
Mav

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 13. Mär 2005, 18:54

mach einfach einen "downgrade" von mkinitrd auf die Version mkinitrd-1.2-4 und schon verschwindet der Fehler ;)

apt install mkinitrd=1.2-4
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Mav
Newbie
Newbie
Beiträge: 31
Registriert: 12. Mär 2005, 12:14

Erstmal Danke :)

Beitrag von Mav » 14. Mär 2005, 06:15

Moin :)

Danke !

Der Downgrade hat etwas geholfen :) Beim Kernel

Code: Alles auswählen

Linux mav 2.6.11.2-20050313164447-default #1 Sun Mar 13 16:44:47 UTC 2005 x86_64 x86_64 x86_64 GNU/Linux
hat es geholfen :) Kein Fehler mehr beim mkinitrd :) Der Sound funktioniert jetzt (und oh Wunder, der Mixer bringt jetzt auch mehr Auswahl). RealPlay funzt auch :) Also in dieser Richtung keine Klagen mehr, auch wenn ich es nicht so ganz verstehe, warum... Wenn Du Zeit und Muse hast, könntest Du mir das erklären? Würde gerne wissen, was da geht...
Der USB-Stick macht mir aber immer noch Probleme :( Wenn ich dem Stick einen Mount-Point gebe (über den SuSE-Plugger), dann wird er erkannt, und lässt sich nutzen. Nach einem Reboot ist er aber wieder weg :( Automount hat vor dem Kernelupdate (nur SuSE, ohne APT) wunderbar funktioniert (also mounten unter /media/usb...). Suche ich nur an der falschen Stelle, oder wird der nicht ins Filesystem eingebunden?

Naja, erstmal hast Du mir viel weitergeholfen! Dafür DANKE! Jetzt nur noch den Stick als Automount (also einstecken, und er ist unter /irgendwas drin), dann bin ich völlig zufrieden :)

BTW: APT hat mir gerade mkinitrd geupdated :( Ist das jetzt O.K., oder muß ich bei der alten Version bleiben?

Danke nochmal und im Vorraus :)

See Ya !
Mav

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Re: Erstmal Danke :)

Beitrag von oc2pus » 14. Mär 2005, 08:05

Mav hat geschrieben:Kein Fehler mehr beim mkinitrd :) Der Sound funktioniert jetzt (und oh Wunder, der Mixer bringt jetzt auch mehr Auswahl). RealPlay funzt auch :) Also in dieser Richtung keine Klagen mehr, auch wenn ich es nicht so ganz verstehe, warum... Wenn Du Zeit und Muse hast, könntest Du mir das erklären? Würde gerne wissen, was da geht...
naja, das neueste mkinitrd hat offensichtlich einen Bug. Deshalb soweit zurück wie nötig ... ich nutze dazu immer den Befehl
apt policy <paketname>
der zeigt mir dann an welche Pakete es wo gibt. Ansonsten ist der kernel-of-the-day immer mit Überraschungen verbunden, positiven wie auch negativen. Man sollte sich also schon etwas besser auskennen mit linux wenn man mit experimentellen Kerneln spielt. Es gab auch schon kernel-of-the-day, wo das System nicht mehr bootet! Wenn du also eher ein Linux-Anfänger bist, solltest du den kernel-of-the-day eher meiden.

Oder du machst ein Zwei-Kernel-Setup,
siehe hier: http://www.linux-club.de/viewtopic.php?t=21684
dann kannst du durch einfaches reboot wieder zurück zum stabilen SuSE-Kernel.
Mav hat geschrieben:Der USB-Stick macht mir aber immer noch Probleme :( Wenn ich dem Stick einen Mount-Point gebe (über den SuSE-Plugger), dann wird er erkannt, und lässt sich nutzen. Nach einem Reboot ist er aber wieder weg :( Automount hat vor dem Kernelupdate (nur SuSE, ohne APT) wunderbar funktioniert (also mounten unter /media/usb...). Suche ich nur an der falschen Stelle, oder wird der nicht ins Filesystem eingebunden?

Naja, erstmal hast Du mir viel weitergeholfen! Dafür DANKE! Jetzt nur noch den Stick als Automount (also einstecken, und er ist unter /irgendwas drin), dann bin ich völlig zufrieden :)
diese Frage ist hier leider im falschen Forum, deshalb werde ich hier auch nicht antworten ...
Mav hat geschrieben:BTW: APT hat mir gerade mkinitrd geupdated :( Ist das jetzt O.K., oder muß ich bei der alten Version bleiben?
nein, das wird dann den Fehler beim nächsten kernel-update wieder ans Licht zerren ... du solltest das mkinitrd-Paket "pinnen". Wie das geht steht hier:
Wichtig: [HOWTO] RPMs festnageln, unerwünschtes Update verhindern
http://www.linux-club.de/viewtopic.php?t=14567
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste