gimp mit apt installiert, gtk+ wird noch benötigt

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
mca
Hacker
Hacker
Beiträge: 351
Registriert: 10. Okt 2004, 00:27

gimp mit apt installiert, gtk+ wird noch benötigt

Beitrag von mca » 9. Mär 2005, 19:49

suse 9.2
apt-0.5.15cnc6-rb.suse092.6
synaptic-0.55.3-0.suse092.rb1

moin community,
ich war begeistert, wieviel man mit gimp-2.0.4-3 von den suse92-cds mit wenigen klicks machen kann. also wollte ich die neue version gimp-2.2.3-1.guru.suse92, die ich mit synaptic gefunden habe, installieren. ich hab gimp und gimp-devel problemlos aktualisiert, doch wenn ich gimp starte, kommt folgendes fenster, obwohl ich gtk2-2.4.9-10.1 installiert hab. wo krieg ich ne höhere her?
(er will gtk+ 2.4.4 oder höher)
Bild
was soll ich tun?

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 9. Mär 2005, 19:54

dem lieben Packager "guru" eine email schreiben, das er seine Abhängigkeiten in seinem RPM korrigiert ...

in dem RPM sind die eMail-Infos vom Packager enthalten.
(rpm -qi gimp)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

mca
Hacker
Hacker
Beiträge: 351
Registriert: 10. Okt 2004, 00:27

Beitrag von mca » 9. Mär 2005, 19:56

ist das dein ernst? den interessiert doch mein problem bestimmt nicht.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 9. Mär 2005, 20:00

hassan hat geschrieben:ist das dein ernst? den interessiert doch mein problem bestimmt nicht.
na klar ist das mein Ernst .. wenn "guru" Pakete mit falschen Infos erstellt, wird dieses RPM nicht funktionieren ;)
er muss Requires: gtk+ >= 2.4.4 in sein SPEC-File schreiben. Und es neu generieren.

Der "guru" ist ein netter Belgier, Pascal Bleser <guru@unixtech.be> und beisst nicht...
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 9. Mär 2005, 20:01

Ich glaube nicht, dass mit den Abhängigkeiten was nicht stimmt. Habe nämlich auch gimp 2.2.3-1 vom guru auf meinem System (SuSE 9.2). Synaptic zeigt mir auch gtk2 2.4.9 an.

mca
Hacker
Hacker
Beiträge: 351
Registriert: 10. Okt 2004, 00:27

Beitrag von mca » 9. Mär 2005, 20:02

alles klar, mal schauen, wann er antwortet

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 9. Mär 2005, 20:12

Grothesk hat geschrieben:Ich glaube nicht, dass mit den Abhängigkeiten was nicht stimmt. Habe nämlich auch gimp 2.2.3-1 vom guru auf meinem System (SuSE 9.2). Synaptic zeigt mir auch gtk2 2.4.9 an.
du hast das richtige gtk drauf ... aber hassan hat es nicht und wenn gimp mindestens gtk+-2.4.4 braucht sollte das gimp-RPM von guru das gtk+-RPM nachziehen ...
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 9. Mär 2005, 20:23

Aber hassan schreibt doch:
gtk2-2.4.9-10.1
sei installiert.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste