[FRAGEN ZU] Update auf KDE 3.3. mit YaST

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Snubnose
Hacker
Hacker
Beiträge: 410
Registriert: 18. Feb 2004, 19:19
Wohnort: Schwabenland

Beitrag von Snubnose » 16. Sep 2004, 07:56

ja wie sieht das denn mit den Suse Dingends aus ? Tut das diesmal ?
Ich hab auch noch das alte Update im Sinn (KDE 3.1 -> 3.2), das war irgendwie nicht so der bringer.....

z.B. die auomatische Erkennung wenn ich nen USB-Stick einstecke und so....

Werbung:
BlackNightShadow
Newbie
Newbie
Beiträge: 9
Registriert: 24. Sep 2004, 12:50

Beitrag von BlackNightShadow » 24. Sep 2004, 13:46

Hmm...bei mir gibts da aba ganz schöne viele Knoflikte. Woran liegts und was tun? Ich häng die liste mal dran!
### YaST2 conflicts list - generated 2004-09-24 13:41:07 ####

Konflikt mit arts 1.3.0-9
Ben?igt von:
kdelibs3 ben?igt arts >= 1.3.0-
Nicht erfllte Abh?gigkeiten:
arts ben?igt libjack.so.0
Konfliktl?ung:
( ) Alle 48 entsprechenden Pakete l?chen
susehelp_de l?chen
kdenetwork3-InstantMessenger l?chen
kdeaddons3-kicker l?chen
krecord l?chen
kdepim3 l?chen
kdepim3-kpilot l?chen
susehelp l?chen
kamix l?chen
Weitere 40...
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit digikam 0.6.9.20040920-3
Nicht erfllte Abh?gigkeiten:
digikam ben?igt libImlib2.so.1
digikam ben?igt libsqlite.so.0
Konfliktl?ung:
( ) digikam nicht aktualisieren
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit kdeaddons3-konqueror 3.3.0-8
Nicht erfllte Abh?gigkeiten:
kdeaddons3-konqueror ben?igt libjack.so.0
Konfliktl?ung:
( ) kdeaddons3-konqueror nicht aktualisieren
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit kdeartwork3 3.3.0-7
Nicht erfllte Abh?gigkeiten:
kdeartwork3 ben?igt libjack.so.0
Konfliktl?ung:
( ) kdeartwork3 nicht aktualisieren
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit kdebase3 3.3.0-15
Nicht erfllte Abh?gigkeiten:
kdebase3 ben?igt libjack.so.0
Konfliktl?ung:
( ) kdebase3 nicht aktualisieren
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit kdebluetooth 0.0.cvs20040713-3
Nicht erfllte Abh?gigkeiten:
kdebluetooth ben?igt /usr/bin/python
Konfliktl?ung:
( ) kdebluetooth nicht aktualisieren
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit kdelibs3 3.3.0-24
Ben?igt von:
kdeaddons3-konqueror ben?igt libkimproxy.so.0
kdeartwork3 ben?igt kdelibs3 >= 3.3.0-
kdebase3 ben?igt kdelibs3 >= 3.3.0-
kdegames3 ben?igt kdelibs3 >= 3.3.0-
kdegraphics3 ben?igt kdelibs3 >= 3.3.0-
kdemultimedia3 ben?igt kdelibs3 >= 3.3.0-
kdenetwork3 ben?igt kdelibs3 >= 3.3.0-
kdepim3 ben?igt kdelibs3 >= 3.3.0-
kdeutils3 ben?igt kdelibs3 >= 3.3.0-
Nicht erfllte Abh?gigkeiten:
kdelibs3 ben?igt libaspell.so.15
kdelibs3 ben?igt libjack.so.0
Konfliktl?ung:
( ) kdelibs3 nicht aktualisieren
( ) Alle 18 entsprechenden Pakete l?chen
kdegames3 l?chen
kdepim3 l?chen
susehelp_de l?chen
kdepim3-kpilot l?chen
susehelp l?chen
kdegraphics3-fax l?chen
kdeutils3 l?chen
kdeaddons3-kate l?chen
Weitere 10...
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit kdemultimedia3 3.3.0-7
Nicht erfllte Abh?gigkeiten:
kdemultimedia3 ben?igt libjack.so.0
Konfliktl?ung:
( ) kdemultimedia3 nicht aktualisieren
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit kdemultimedia3-jukebox 3.3.0-7
Nicht erfllte Abh?gigkeiten:
kdemultimedia3-jukebox ben?igt libjack.so.0
Konfliktl?ung:
( ) kdemultimedia3-jukebox nicht aktualisieren
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit kdemultimedia3-sound 3.3.0-7
Nicht erfllte Abh?gigkeiten:
kdemultimedia3-sound ben?igt libjack.so.0
Konfliktl?ung:
( ) kdemultimedia3-sound nicht aktualisieren
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit kdenetwork3-vnc 3.3.0-28
Nicht erfllte Abh?gigkeiten:
kdenetwork3-vnc ben?igt vnc
Konfliktl?ung:
( ) kdenetwork3-vnc nicht aktualisieren
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
libaspell.so.15 nicht verfgbar
Ben?igt von:
kdelibs3 ben?igt libaspell.so.15
Konfliktl?ung:
( ) Alle 48 entsprechenden Pakete l?chen
susehelp_de l?chen
kdenetwork3-InstantMessenger l?chen
kdeaddons3-kicker l?chen
krecord l?chen
kdepim3 l?chen
kdepim3-kpilot l?chen
susehelp l?chen
kamix l?chen
Weitere 40...
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
libImlib2.so.1 nicht verfgbar
Ben?igt von:
digikam ben?igt libImlib2.so.1
Konfliktl?ung:
( ) Entsprechendes Paket l?chen
digikam l?chen
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
libjack.so.0 nicht verfgbar
Ben?igt von:
kdeaddons3-konqueror ben?igt libjack.so.0
kdeartwork3 ben?igt libjack.so.0
kdebase3 ben?igt libjack.so.0
kdelibs3 ben?igt libjack.so.0
kdemultimedia3 ben?igt libjack.so.0
kdemultimedia3-jukebox ben?igt libjack.so.0
kdemultimedia3-sound ben?igt libjack.so.0
arts ben?igt libjack.so.0
Konfliktl?ung:
( ) Alle 50 entsprechenden Pakete l?chen
susehelp_de l?chen
kdenetwork3-InstantMessenger l?chen
kdeaddons3-kicker l?chen
krecord l?chen
kdepim3 l?chen
kdepim3-kpilot l?chen
susehelp l?chen
kamix l?chen
Weitere 42...
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
libsqlite.so.0 nicht verfgbar
Ben?igt von:
digikam ben?igt libsqlite.so.0
Konfliktl?ung:
( ) Entsprechendes Paket l?chen
digikam l?chen
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
/usr/bin/python nicht verfgbar
Ben?igt von:
kdebluetooth ben?igt /usr/bin/python
Konfliktl?ung:
( ) Entsprechendes Paket l?chen
kdebluetooth l?chen
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
vnc nicht verfgbar
Ben?igt von:
kdenetwork3-vnc ben?igt vnc
Konfliktl?ung:
( ) Entsprechendes Paket l?chen
kdenetwork3-vnc l?chen
( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren

#### YaST2 conflicts list END ###

Reverend Marcie
Newbie
Newbie
Beiträge: 2
Registriert: 24. Sep 2004, 22:03

Beitrag von Reverend Marcie » 24. Sep 2004, 22:09

gibt es beim KDE update die moeglichkeit, wenn man alle erforderlichen rpm`s bereits herunter geladen hat, das verzeichniss mit diesen in Yast als installationsquelle anzugeben, anstelleeiner FTP servers?
Habe mir naemlich voreilig alle rpm`s herunter geladen, kann diese aber nicht sorecht in der konsole handlen, da bei dem rpm befehlen immer fehlermeldungen bzw. probleme auftreten!
Und da ich leider zur zeit ueber keine flat verfuege, waehre es zu kostspielig das auf konventionellen weg im Yast zu machen!

Besten dank im vorraus :)

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 24. Sep 2004, 22:16

dann geh in dein download Verzeichnis.
rpm -Uhv *.rpm
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Reverend Marcie
Newbie
Newbie
Beiträge: 2
Registriert: 24. Sep 2004, 22:03

Beitrag von Reverend Marcie » 24. Sep 2004, 22:29

oc2pus hat geschrieben:dann geh in dein download Verzeichnis.
rpm -Uhv *.rpm
hmm.... ok, vielen dank, hat schon etwas weiter geholfen :)
Leider bin ich noch blutiger anfaenger, und weiss nix mit den folgenden meldungen anzufangen die ich trotzdem noch bekomme :?

error: Failed dependencies:
libjack.so.0 is needed by arts-1.3.0-7
glib2-devel is needed by arts-devel-1.3.0-7
mad-devel is needed by arts-devel-1.3.0-7
alsa-devel is needed by arts-devel-1.3.0-7
libjack.so.0 is needed by kdeaddons3-konqueror-3.3.0-5
libjack.so.0 is needed by kdeaddons3-sound-3.3.0-5
libjack.so.0 is needed by kdeartwork3-3.3.0-3
libjack.so.0 is needed by kdebase3-3.3.0-8
libjack.so.0 is needed by kdegames3-arcade-3.3.0-5
povray is needed by kdegraphics3-3D-3.3.0-5
ocrad is needed by kdegraphics3-scan-3.3.0-5
tetex is needed by kdegraphics3-tex-3.3.0-5
libaspell.so.15 is needed by kdelibs3-3.3.0-7
libjack.so.0 is needed by kdelibs3-3.3.0-7
libvorbis-devel is needed by kdelibs3-devel-3.3.0-7
autoconf is needed by kdelibs3-devel-3.3.0-7
automake is needed by kdelibs3-devel-3.3.0-7
libxslt-devel is needed by kdelibs3-devel-3.3.0-7
libxml2-devel is needed by kdelibs3-devel-3.3.0-7
fam-devel is needed by kdelibs3-devel-3.3.0-7
pcre-devel is needed by kdelibs3-devel-3.3.0-7
libidn-devel is needed by kdelibs3-devel-3.3.0-7
libjack.so.0 is needed by kdemultimedia3-3.3.0-7
libjack.so.0 is needed by kdemultimedia3-extra-3.3.0-7
libjack.so.0 is needed by kdemultimedia3-jukebox-3.3.0-7
libjack.so.0 is needed by kdemultimedia3-sound-3.3.0-7
libjack.so.0 is needed by kdemultimedia3-video-3.3.0-7
vnc is needed by kdenetwork3-vnc-3.3.0-5
libjack.so.0 is needed by kdepim3-time-management-3.3.0-9
freetype2-devel is needed by qt3-devel-3.3.3-6
libmng-devel is needed by qt3-devel-3.3.3-6
xdevel is needed by qt3-devel-3.3.3-6
libpng-devel is needed by qt3-devel-3.3.3-6
c++_compiler is needed by qt3-devel-3.3.3-6
make is needed by qt3-devel-3.3.3-6
zlib-devel is needed by qt3-devel-3.3.3-6
XFree86-Mesa-devel is needed by qt3-devel-3.3.3-6
freeglut-devel is needed by qt3-devel-3.3.3-6


Sind dies noch pakete die ich vorher installieren muss? wenn ja, woher kann ich die bekommen?

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 24. Sep 2004, 23:01

zuerst einmal alles weglassen was mit -devel endet ;)

und dann die restlichen Pakete nachinstallieren ...

Tip:
rpm -Uhv --force *.rpm (ohne -devel)
und dann yast aufrufen und den rest draufziehen. ...
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

jcnewman2003(noob)
Newbie
Newbie
Beiträge: 23
Registriert: 27. Okt 2004, 09:32

Noob braucht Hilfe

Beitrag von jcnewman2003(noob) » 27. Okt 2004, 09:42

Hi, ich hab ein Problem, Ich will KDE 3.3 installieren, mir fehlen allerdings ein paar rpm pakete, die mir fehlen und ich find die zum verrecken nicrgendwo.
fehlende pakete:
Libjack.so.0
Libaspell.so.15

Kasselhöfer
Member
Member
Beiträge: 69
Registriert: 28. Aug 2004, 10:27

Beitrag von Kasselhöfer » 27. Okt 2004, 16:43

@ jcnewman2003(noob)
Wenn du unter z.B. http://www.rmpseek.de libjack und libaspell saugst und installierst werden normalerweise aus die .so.0 und .so.15 installiert. Dies sind keine einzelnen Dateien die du irgendwo saugen kannst.

@ alle
Nun habe ich auch eine Frage:
Ich habe mir alle RPM's die meine zu benötigen von ftp://ftp.gwdg.de/pub/linux/suse/apt/Su ... 6/RPMS.kde gesaugt. Sind das die Richtigen? Es wird hier als von Source geschrieben. Wollte dann mit rpm -Fvh --fource --nodeps *.rpm die Daten updaten. Ist das ein gangbarer Weg?

Kasselhöfer

jcnewman2003(noob)
Newbie
Newbie
Beiträge: 23
Registriert: 27. Okt 2004, 09:32

Bin ein Stück weiter, hab aber immer noch Probleme!

Beitrag von jcnewman2003(noob) » 28. Okt 2004, 10:05

Hallo Leute, danke für den Tipp, hatte das aber trotzdem schon selbst rausbekommen, allerdings hab ich jetzt noch ein Problem und zwar brauch ich ein Paket, dass libkspell2.so.1 beinhaltet, finde aber keins, auch nicht per www.rpmseek.com . Kann mir da jemand helfen?
Ich wünsch mir mitlerweile schon nicht Suse sondern Gentoo installiert zu haben, dann hätte ich die Probs nicht, einfach emerge und die Sache wird erledigt!

Benutzeravatar
Sandman
Newbie
Newbie
Beiträge: 15
Registriert: 22. Jul 2004, 12:56
Kontaktdaten:

Beitrag von Sandman » 30. Okt 2004, 10:48

Hat super funktioniert. Habe mit folgendem Link gearbeitet: ftp.gwdg.de/pub/suse/i386/supplementary/KDE/update_for_9.1/yast-source/

Bei der Angabe das irgend welche Datein fehl habe ich eifach auf weiter gemacht und was soll ich sagen es laeuft.

Na aber wer weis vielleicht kommen ja noch irgend welche Probleme.
Have fun!
Sandman

Lausi
Newbie
Newbie
Beiträge: 40
Registriert: 24. Jul 2004, 12:51
Wohnort: Biel, Schweizlein
Kontaktdaten:

Beitrag von Lausi » 30. Okt 2004, 11:47

Hat super funktioniert. Habe mit folgendem Link gearbeitet: ftp.gwdg.de/pub/suse/i386/supplementary/KDE/update_for_9.1/yast-source/

Bei der Angabe das irgend welche Datein fehl habe ich eifach auf weiter gemacht und was soll ich sagen es laeuft.

Na aber wer weis vielleicht kommen ja noch irgend welche Probleme.
Da warst aber mutig :shock:

Ich habe nebst dem oben angegebenen Link in Yast gleichzeitig noch ftp://ftp.gwdg.de/pub/suse/i386/9.1/ als Installationsquelle aktiviert, damit hat Yast dann alle noch benötigten Dateien selbständig gesaugt (Abhängigkeiten automatisch überprüfen => aktiviert) => Keine Probleme in ca. 2 Wochen täglichem Gebrauch.
Gruss an die Gemeinde
Lausi

Der beste Beweis, dass es intelligente Lebewesen im All gibt, ist die Tatsache, dass sie bisher noch nie versucht haben, Kontakt mit uns aufzunehmen...

malawi
Newbie
Newbie
Beiträge: 17
Registriert: 24. Jun 2004, 22:27
Kontaktdaten:

Beitrag von malawi » 30. Okt 2004, 19:34

hallo
habe auch die ganzen Pakete vom server geladen und mir eine patch cd nach anleitung von suse angelegt.... bekomme aber eine fehler meldung wenn ich auf "Patch CD Update " gehe. hat eine von euch eine Idee?
mfg malawi

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 30. Okt 2004, 20:02

Nein.

Jedenfalls nicht solange Du uns nicht verrätst was für eine Fehlermeldung Du bekommst...
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

malawi
Newbie
Newbie
Beiträge: 17
Registriert: 24. Jun 2004, 22:27
Kontaktdaten:

Beitrag von malawi » 31. Okt 2004, 07:28

hallo
sorry fang noch mal an....also ich habe hier im board den Test- bericht von suse 9.2 gelesen und da war an ein der beiträge ein link dabei wie man eine "Pach CD von den Suse Updates erstellt " das habe ich genau nach anleitung gemacht. Im YAST Installations Quelle gewechselt ganz nach ober geschoben dann Patch CD_Update gestartet dann sucht er und es kommt " Weiter " klick auf weiter dann kommt diese Fehler meldung
" FEHLER Patch-Informationen konnten nicht geholt werden "
die Installations Quelle habe ich gewechselt weil ich versucht habe die updates so einzuspielen.
mfg malawi

jcnewman2003(noob)
Newbie
Newbie
Beiträge: 23
Registriert: 27. Okt 2004, 09:32

Habe immer noch ein Problem

Beitrag von jcnewman2003(noob) » 1. Nov 2004, 10:43

Kann mir jemand sagen wo ich kspell her krieg, per rpm seek kein ergebnis!

GolfOnkel
Newbie
Newbie
Beiträge: 3
Registriert: 31. Okt 2004, 15:46
Wohnort: LK Celle
Kontaktdaten:

Beitrag von GolfOnkel » 5. Nov 2004, 09:36

Ich mache auch gerade das Update. Bei mir waren von vornerein alle Paketabhänigkeit ok. :)

Mal schauen ob es klappt.


//Edit
Funktioniert alles ohne Anstand

Benutzeravatar
HagaRen
Newbie
Newbie
Beiträge: 11
Registriert: 9. Okt 2004, 19:00

Beitrag von HagaRen » 5. Nov 2004, 18:17

Mal ne Frage. Hab diese Quelle jetzt des öfteren benutzt, aber nach ein paar Neuinstallationen wollte ich heute die Quelle auch wieder dazugeben aber wenn ich das alles eingebe, und dann auf OK klicke kommt folgender Fehler:
ERROR(intSRC:E_Cache_dir_create)
Try Again?

Vielleicht kann mir da jemand helfen, woran das liegt.
Danke schonmal im Vorraus.

Edit: Okey, hat sich erledigt. Jetzt gings wieder.
Aber vielleicht kann mir ja trotzdem jemand sagen, was der Fehler bedeutet, falls der wieder auftaucht.

GolfOnkel
Newbie
Newbie
Beiträge: 3
Registriert: 31. Okt 2004, 15:46
Wohnort: LK Celle
Kontaktdaten:

Beitrag von GolfOnkel » 5. Nov 2004, 20:08

So ich habe jetzt doch noch ein Problem feststellen können.
Und zwar sind die Symbole im "Systemabschnitt" unten auf der Kontrollleiste sehr weit auseinander und der Bereich lässt sich nicht wieder kleiner "schieben".

Hat da jemand eine Lösung für?

Eine Frage habe ich als Ex-Windows User auch noch. Wie kann ich die Höhe der Kontrollleiste ändern, OHNE die Symbole zu vergrößern?

Benutzeravatar
Ronald0815
Newbie
Newbie
Beiträge: 1
Registriert: 8. Nov 2004, 10:18
Wohnort: Chemnitz

Danke

Beitrag von Ronald0815 » 13. Nov 2004, 15:39

THX @ oc2pus

hat wunderbar funktioniert. Danke für die "nette" Anleitung.

Gruß

Ronald
für Fehler und Schrift haftet der Stift
Bild

Yehudi
Guru
Guru
Beiträge: 2152
Registriert: 21. Jan 2004, 13:51
Wohnort: Hamburg
Kontaktdaten:

KDE 3.3 Update

Beitrag von Yehudi » 11. Dez 2004, 12:24

Ich habe gerade nach der obersten Anleitung ein FTP Update begonnen. Leider zeigt mir das System ein paar 100 Fehler. Es ist auch nicht so einfach durch ersetzen. Jetzt habe ich trotzdem mal das Update gestartet. Kann man im Nachhinein noch das System bereichnigen? (Suse 9.0)
Derzeit zeigt das System beim Start:
Could not start process Unable to create io-slave:
klauncher said: Fehler beim Laden von "kio_devices"
Was kann ich tun?

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast