apt installiert nicht / apt -f install meldet Fehler

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
deniere
Newbie
Newbie
Beiträge: 2
Registriert: 14. Feb 2005, 23:41

apt installiert nicht / apt -f install meldet Fehler

Beitrag von deniere » 14. Feb 2005, 23:49

Wenn ich ein neues Programm mit Apt installieren möchte bekomme ich diese Fehlermeldung
linux:/home/dragonkiss # apt-get install mldonkey
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Sie möchten `apt-get -f install' ausführen um diese zu beheben:
Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
winetools: Hängt ab von: Xdialog aber es ist nicht installierbar
E: Unerfüllte Abhängigkeiten. Versuchen Sie 'apt-get -f install' ohne Pakete(oder geben Sie eine Lösung an)
Jetzt habe ich schon Tagelang nach ner Lösung gesucht...
bin aber nicht erfolgreich gewesen :roll:

Das mit apt-get update und so klappt nicht
auch wenn ich apt-get -f install eintippe, bleibt diese Fehlermeldung bestehen und erscheint immer wieder....

Wie krieg ich das bloss weg?

Grüße Alexander

Werbung:
torstenkoeln
Hacker
Hacker
Beiträge: 308
Registriert: 22. Jul 2004, 17:37

Beitrag von torstenkoeln » 15. Feb 2005, 00:51

Ich vermute, dass Du nicht alle notwendigen Quellen eingebunden hast.

Poste doch mal Deine sources.list - in meiner ist mldonkey gar nicht enthalten...

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 15. Feb 2005, 14:18

die Hilfe könnte auch schneller gehen, wenn du mal
folgende Infos lieferst:
deine SuSE Version
und deine sources.list
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 15. Feb 2005, 17:28

torsten_ hat geschrieben:Ich vermute, dass Du nicht alle notwendigen Quellen eingebunden hast.

Poste doch mal Deine sources.list - in meiner ist mldonkey gar nicht enthalten...
SuSE-9.1

Code: Alles auswählen

apt policy mldonkey
mldonkey:
  Installiert: (nichts)
  Kandidat: 2.5.28g-1
  Versionstabelle:
     2.5.28g-1 0
        500 ftp://ftp.gwdg.de SuSE/9.1-i386/suser-scorot pkglist
     2.5.16t-1 0
        500 ftp://ftp.gwdg.de SuSE/9.1-i386/suser-scorot pkglist
     2.5.12-30 0
        500 ftp://ftp.gwdg.de SuSE/9.1-i386/suse-people pkglist
SuSE-9.2

Code: Alles auswählen

apt policy mldonkey
mldonkey:
  Installiert: (nichts)
  Kandidat: 2.5.28h-1
  Versionstabelle:
     2.5.28h-1 0
       1001 ftp://ftp.gwdg.de SuSE/9.2-i386/suser-scorot pkglist
     2.5.16u-1 0
       1001 ftp://ftp.gwdg.de SuSE/9.2-i386/suser-scorot pkglist
SuSE-8.2

Code: Alles auswählen

apt policy mldonkey
mldonkey:
  Installed: (none)
  Candidate: 2.02-36
  Version Table:
     2.02-36 0
        500 ftp://ftp.gwdg.de SuSE/8.2-i386/base pkglist
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
admine
Administrator
Administrator
Beiträge: 8722
Registriert: 15. Feb 2004, 21:13
Wohnort: Dresden
Kontaktdaten:

Beitrag von admine » 15. Feb 2005, 19:51

SuSE-9.0:

Code: Alles auswählen

apt policy mldonkey
mldonkey:
  Installiert: (nichts)
  Kandidat: 2.5.21-1suse90
  Versionstabelle:
     2.5.21-1suse90 0
        500 ftp://ftp.gwdg.de SuSE/9.0-i386/suser-guru pkglist
     2.5-65 0
        500 ftp://ftp.gwdg.de SuSE/9.0-i386/base pkglist
;)
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

deniere
Newbie
Newbie
Beiträge: 2
Registriert: 14. Feb 2005, 23:41

Beitrag von deniere » 15. Feb 2005, 23:43

Danke für die schnelle Antwort.
Meine Source.list
# Erstellt am So Feb 13 21:06:35 CET 2005
#
# Repository created by: aptate (version 0.69.0)
# At: Sun Feb 13 19:10:32 MET 2005
# More info about aptate at: http://apt4rpm.sourceforge.net
#
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 rpmkeys
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 base
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 update
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 kde
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 gnome
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 gnome2
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 xfree86
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 xorg
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 mozilla
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 samba3
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 suser-rbos
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 suser-oc2pus
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 suser-guru
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 suser-gbv
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 suser-kpietrz
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 suser-tcousin
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 suser-scorot
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 suser-sbarnin
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 suser-jogley
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 suser-ollakka
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 suser-tux
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 labplot
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 funktronics
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 packman
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 packman-i686
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 wine
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 suse-projects
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 kde3-stable
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 security
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 rpmkeys
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 base
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 update
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 kde
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 gnome
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 gnome2
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 xfree86
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 xorg
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 mozilla
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 samba3
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 suser-rbos
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 suser-oc2pus
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 suser-guru
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 suser-gbv
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 suser-kpietrz
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 suser-tcousin
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 suser-scorot
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 suser-sbarnin
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 suser-jogley
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 suser-ollakka
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 suser-tux
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 labplot
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 funktronics
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 packman
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 packman-i686
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 wine
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 suse-projects
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 kde3-stable
# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-i386 security
Eigentlich wollte ich gar nicht speziell auf mein Problem mit MLDonkey eingehen...
- aber inzwischen hat sich ja auch das Topic geändert :roll:
Ursprünglich ging es mir darum wenn jemand unerfüllte Abhängigkeiten hat und dann wie von apt empfohlen "apt-get -f install" durchführt, aber sich nichts tut, weiter vorgeht...

Ich bekomme ja diese Fehlermeldung nicht nur beim Versuch MLDonkey zu installieren, sondern bei jedem Programm...

Vielen Dank im vorraus für eure Hilfe[/quote]

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Re: apt findet mldonkey nicht

Beitrag von oc2pus » 16. Feb 2005, 10:06

deniere hat geschrieben:Wenn ich ein neues Programm mit Apt installieren möchte bekomme ich diese Fehlermeldung
linux:/home/dragonkiss # apt-get install mldonkey
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Sie möchten `apt-get -f install' ausführen um diese zu beheben:
Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
winetools: Hängt ab von: Xdialog aber es ist nicht installierbar
E: Unerfüllte Abhängigkeiten. Versuchen Sie 'apt-get -f install' ohne Pakete(oder geben Sie eine Lösung an)
ok, du hast eine Leiche im Keller, du hast ein rpm winetools installiert. Dieses braucht XDialog. Dein apt findet aber nirgends ein RPM welches Xdialog enthält.

Und jetzt besteht apt darauf das das gerichtet wird ...

Die Frage ist woher hast du winetools ? Das ist kein SuSE-RPM.
evtl hilft ein virtuelles RPM welches Xdialog zur Verfügung stellt. Oder winetools deinstallieren und das entsprechende SuSE-pendant dazu installieren.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 16. Feb 2005, 11:24

ad Xdialog:

schaust du hier:
http://www.linux-club.de/viewtopic.php?t=26533

und installierst es dir dann via apt, dann sollte dein Problem verschwinden ;)
Zuletzt geändert von oc2pus am 16. Feb 2005, 11:29, insgesamt 1-mal geändert.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
pawe
Member
Member
Beiträge: 148
Registriert: 14. Dez 2004, 21:38
Wohnort: Bayern
Kontaktdaten:

Beitrag von pawe » 16. Feb 2005, 11:26

Ursprünglich ging es mir darum wenn jemand unerfüllte Abhängigkeiten hat und dann wie von apt empfohlen "apt-get -f install" durchführt, aber sich nichts tut, weiter vorgeht...
Ich bekomme ja diese Fehlermeldung nicht nur beim Versuch MLDonkey zu installieren, sondern bei jedem Programm...
kannst auch so vorgehen:
wenn bei dir winetools einwandfrei funktioniert kannst du die Ignore-Option in der /etc/apt/apt.conf.d/apt.conf verwenden. Dann werden die Abhänigkeiten von winetools nicht überprüft.

oc2pus hat einen Thread zur lösung von Abhängigkeitsproblemen eröffnet. lies mal den vorletzten Beitrag da hab ich´s genauer beschrieben
http://www.linux-club.de/viewtopic.php?t=16315
P III, 700 MHz, 384 MB Ram, SuSE 9.3 - fluxbox/idesk // NB: AMD 2800+, 704 MB Ram, SuSE 9.3 - KDE 3.4.

Fundiertes Wissen über Linux: www.de.linwiki.org
HowTo´s, Tutorials, Softwarelisten, Begriffserklärungen und vieles mehr!

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast