Abhängigkeiten auflösen mit -f install nicht möglich

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
sd8rdb
Newbie
Newbie
Beiträge: 3
Registriert: 5. Feb 2005, 10:31

Abhängigkeiten auflösen mit -f install nicht möglich

Beitrag von sd8rdb » 5. Feb 2005, 10:38

Hallo,

habe folgendes Problem:


linux:/home/Sven # apt upgrade
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Sie werde `apt-get -f install' ausführen wollen um diese zu beheben.
Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
kdebindings3: Hängt ab von: kdelibs3 (>= 3.3.91_2005011711) aber 3.3.0-34.3 ist installiert
kdesdk3: Hängt ab von: kdelibs3 (>= 3.3.91_2005011711) aber 3.3.0-34.3 ist installiert
kssh: Hängt ab von: kdelibs3 (>= 3.3.1) aber 3.3.0-34.3 ist installiert
libxine1: Hängt ab von: speex (>= 1.1) aber 1.0.4-3 ist installiert
E: Unerfüllte Abhängigkeiten. Versuche -f zu benutzen.

linux:/home/Sven # apt-get -f install
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Korrigiere Abhängigkeiten ... Fertig
Die folgenden zusätzlichen Pakete werden installiert werden:
arts kdelibs3 qt3 qt3-devel qt3-devel-tools qt3-extensions qt3-man qt3-mysql
qt3-non-mt qt3-postgresql qt3-sqlite qt3-unixODBC speex
Die folgenden Pakete werden upgegradet werden:
arts kdelibs3 qt3 qt3-devel qt3-devel-tools qt3-extensions qt3-man qt3-mysql
qt3-non-mt qt3-postgresql qt3-sqlite qt3-unixODBC speex
Die folgenden Pakete werden ENTFERNT:
arts-devel kdebase3-devel kdegraphics3-devel kdelibs3-devel
kdemultimedia3-devel kdevelop3 qt3-devel-32bit
13 upgraded, 0 newly installed, 7 entfernt und 165 nicht upgegradet.
Muss 0B/33,4MB an Archiven holen.
Nach dem Auspacken werden 62,5MB Plattenplatz freigegeben werden.
Wollen Sie fortsetzen? [J/n] J
Committing changes...
Preparing... ########################################### [100%]
file /opt/kde3/share/services/xcf.kimgio from install of kdelibs3-3.3.92-1 conflicts with file from package gwenview-1.1.5-8
file /opt/kde3/share/mimelnk/application/x-webarchive.desktop from install of kdelibs3-3.3.92-1 conflicts with file from package kdeaddons3-konqueror-3.3.0-10
file /opt/kde3/lib64/kde3/kstyle_plastik_config.la from install of kdelibs3-3.3.92-1 conflicts with file from package kdeartwork3-3.3.0-7
file /opt/kde3/lib64/kde3/kstyle_plastik_config.so from install of kdelibs3-3.3.92-1 conflicts with file from package kdeartwork3-3.3.0-7
file /opt/kde3/lib64/kde3/plugins/styles/plastik.la from install of kdelibs3-3.3.92-1 conflicts with file from package kdeartwork3-3.3.0-7
file /opt/kde3/lib64/kde3/plugins/styles/plastik.so from install of kdelibs3-3.3.92-1 conflicts with file from package kdeartwork3-3.3.0-7
file /opt/kde3/share/apps/kstyle/themes/plastik.themerc from install ofkdelibs3-3.3.92-1 conflicts with file from package kdeartwork3-3.3.0-7
file /opt/kde3/bin/kcmshell from install of kdelibs3-3.3.92-1 conflictswith file from package kdebase3-3.3.0-29.3
file /opt/kde3/lib64/kde3/kcmshell.la from install of kdelibs3-3.3.92-1conflicts with file from package kdebase3-3.3.0-29.3
file /opt/kde3/lib64/kde3/kcmshell.so from install of kdelibs3-3.3.92-1conflicts with file from package kdebase3-3.3.0-29.3
file /opt/kde3/lib64/libkdeinit_kcmshell.la from install of kdelibs3-3.3.92-1 conflicts with file from package kdebase3-3.3.0-29.3
file /opt/kde3/lib64/libkdeinit_kcmshell.so from install of kdelibs3-3.3.92-1 conflicts with file from package kdebase3-3.3.0-29.3
file /usr/share/man/man1/speexdec.1.gz from install of speex-1.1.6-2 conflicts with file from package speex-devel-1.0.4-3
file /usr/share/man/man1/speexenc.1.gz from install of speex-1.1.6-2 conflicts with file from package speex-devel-1.0.4-3
E: Error while running transaction
linux:/home/Sven #
Kann mir jemand helfen? O_o

--force hat auch nicht wirklich geholfen

Werbung:
root24
Member
Member
Beiträge: 68
Registriert: 23. Dez 2004, 23:22
Wohnort: St. Pölten (Österreich)
Kontaktdaten:

Beitrag von root24 » 5. Feb 2005, 11:03

Hallo!

Probier mal folgenden Befehl:

Code: Alles auswählen

apt install kdelibs3 speex arts
Sollte nach dem Befehl eigentlich funktionieren mit dem apt upgrade.

Aber solltest du ein Soundproblem (mit Soundproblem mein ich, dass du dann in KDE und dessen Dienstprogrammen keinen Sound mehr hörst) haben nach der Installation von arts, schreib hier zurück. Dann muss du noch was nachinstallieren.

mfg,
root24.
Hardware: 128 MB ATI Radeon 9600 Pro All in Wonder, AMD Athlon XP 3000+, 512 MB DDR-RAM, Nvidia nforce2 Chipset
Software: SuSE Professional Linux 9.2, Kernel 2.6.8-24-default, Maschine i686, KDE 3.3.0

sd8rdb
Newbie
Newbie
Beiträge: 3
Registriert: 5. Feb 2005, 10:31

Beitrag von sd8rdb » 5. Feb 2005, 11:14

danke für deine Antwort..
linux:/home/Sven # apt install kdelibs3 speex arts
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Sie möchten `apt-get -f install' ausführen um diese zu beheben:
Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
arts-devel: Hängt ab von: arts (= 1.3.0) aber 1.3.92-1 wird installiert werden
kdelibs3: Hängt ab von: qt3 (>= 3.3.4) aber 3.3.3-24 wird installiert werden
kdelibs3-devel: Hängt ab von: kdelibs3 (= 3.3.0) aber 3.3.92-1 wird installiert werden
E: Unerfüllte Abhängigkeiten. Versuchen Sie 'apt-get -f install' ohne Pakete(oder geben Sie eine Lösung an)
linux:/home/Sven #
hat leider nichts gebracht, wenn ich wiederrum -f install mache passiert wieder das oben genannte O_o

sd8rdb
Newbie
Newbie
Beiträge: 3
Registriert: 5. Feb 2005, 10:31

Beitrag von sd8rdb » 5. Feb 2005, 11:24

ich glaub ich hab den übeltäter..

Ich hab speex über Yast runtergehauen und über apt wieder installiert nun scheints zu gehen :shock: :roll:

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 9. Feb 2005, 14:56

sd8rdb hat geschrieben:ich glaub ich hab den übeltäter..
Ich hab speex über Yast runtergehauen und über apt wieder installiert nun scheints zu gehen :shock: :roll:
das rettet dich aber nur kurzzeitig ;)
13 upgraded, 0 newly installed, 7 entfernt und 165 nicht upgegradet.
du solltest mal die 165 "alten" RPMs angehen....
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast