fehlermeldung bei apt-get update

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Gesperrt
christian_k
Member
Member
Beiträge: 57
Registriert: 29. Sep 2004, 14:41
Wohnort: Obertshausen
Kontaktdaten:

fehlermeldung bei apt-get update

Beitrag von christian_k » 4. Feb 2005, 15:10

hallo,

habe mal wieder ein problem.

und zwar habe ich apt für suse 9.1 auf 64-bit basis.

und nun kommt folgende fehlermeldung:

apt-get upgrade
error: cannot get exclusive lock on /var/lib/rpm/Packages
error: cannot open Packages index using db3 - Die Operation ist nicht erlaubt (1)
error: cannot open Packages database in /var/lib/rpm
E: könnte RPM-Datenbank nicht öffnen

könnte mir einer sagen, was ich verkehrt gemacht habe?

p.s. bin apt noob

hier noch die source.list:

rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/SuSE/9.1-x86_64 rpmkeys update-drpm update-prpm update kde misc xorg mozilla samba3 suser-rbos suser-oc2pus suser-guru suser-gbv suser-tcousin suser-scorot suser-sbarnin suser-ollakka funktronics packman packman-i686 wine suse-people suse-projects kde3-stable security-prpm security

rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/Su ... 86_64/base

# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt/Su ... 86_64/base rpmkeys update-drpm update-prpm update kde misc xorg # mozilla samba3 suser-rbos suser-oc2pus suser-guru suser-gbv suser-tcousin suser-scorot suser-sbarnin suser-ollakka # funktronics packman packman-i686 wine suse-people suse-projects kde3-stable security-prpm security

und hier noch meine security:

rpm ftp://mirrors.mathematik.uni-bielefeld. ... x/suse/apt SuSE/9.1-x86_64 security
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.1-x86_64 security


danke euch
mfg Tux^

Werbung:
Gast

Beitrag von Gast » 4. Feb 2005, 15:29

Du solltest schon root sein um dieses zu machen........... ansonsten kein Zugriff auf die RPM-Datenbank usw..............

christian_k
Member
Member
Beiträge: 57
Registriert: 29. Sep 2004, 14:41
Wohnort: Obertshausen
Kontaktdaten:

Beitrag von christian_k » 4. Feb 2005, 16:00

ne daran liegt es nicht...ich habe nämlich apt auch auf meinem 2. rechner(suse linux 9.2 - 32bit) installiert, da geht alles ohne probleme...

könntest du mir mal deine source.list per email schicken oder posten?

oder zumindest die ftp-server

danke dir für deine hilfe

Gast

Beitrag von Gast » 4. Feb 2005, 16:07

Tux^ hat geschrieben:ne daran liegt es nicht...ich habe nämlich apt auch auf meinem 2. rechner(suse linux 9.2 - 32bit) installiert, da geht alles ohne probleme...

könntest du mir mal deine source.list per email schicken oder posten?

oder zumindest die ftp-server
Die obige Meldung ist aber typisch dafür, das man nicht root ist. Das hat nix mit der source.list zu tun. Wenn du wirklich root bist mit der besagten Meldung, dann ist irgend was da inne Dutten, wo von ich keine Ahnung habe. Die Meldug besagt einwandfrei das dir der Zugriff auf die RPM-Datenbank verwehrt wird.

christian_k
Member
Member
Beiträge: 57
Registriert: 29. Sep 2004, 14:41
Wohnort: Obertshausen
Kontaktdaten:

Beitrag von christian_k » 4. Feb 2005, 16:17

...
jo okay mag sein...aber momentan habe ich einen anderen fehler...

Fehler: apt-get update
E: Misbildete Zeile 10 in Quellliste /etc/apt/sources.list (dist)

sources.list:
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/SuSE/9.1-x86_64 rpmkeys update-drpm update-prpm update kde misc xorg mozilla samba3 suser-rbos suser-oc2pus suser-guru suser-gbv suser-tcousin suser-scorot suser-sbarnin suser-ollakka funktronics packman packman-i686 wine suse-people suse-projects kde3-stable security-prpm security

rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/Su ... 86_64/base

# rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt/Su ... 86_64/base rpmkeys update-drpm update-prpm update kde misc xorg # mozilla samba3 suser-rbos suser-oc2pus suser-guru suser-gbv suser-tcousin suser-scorot suser-sbarnin suser-ollakka # funktronics packman packman-i686 wine suse-people suse-projects kde3-stable security-prpm security

sry bin halt nen noob

Gast

Beitrag von Gast » 4. Feb 2005, 16:22

Du solltest schon mal beim Posting deiner source.list die Klammerung

Code: Alles auswählen

[code]
[/code]
benutzen. So seh ich da garnix........................

christian_k
Member
Member
Beiträge: 57
Registriert: 29. Sep 2004, 14:41
Wohnort: Obertshausen
Kontaktdaten:

Beitrag von christian_k » 4. Feb 2005, 16:30

sources.list

Code: Alles auswählen


#
# Repository created by: aptate (version 0.69.0)
# At: Sun Jan  2 18:02:54 MET 2005
# More info about aptate at: http://apt4rpm.sourceforge.net
#


rpm      ftp://ftp.gwdg.de/pub/linux/suse/apt/SuSE/9.1-x86_64  rpmkeys update-drpm update-prpm update kde misc xorg mozilla samba3  suser-rbos suser-oc2pus suser-guru suser-gbv suser-tcousin suser-scorot suser-sbarnin suser-ollakka funktronics packman packman-i686  wine suse-people suse-projects kde3-stable  security-prpm security

rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/SuSE/9.1-x86_64/base
 
# rpm-src  ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386  rpmkeys update-drpm update-prpm update kde misc xorg    # mozilla samba3  suser-rbos suser-oc2pus suser-guru suser-gbv suser-tcousin suser-scorot suser-sbarnin suser-ollakka  # funktronics packman packman-i686  wine suse-people suse-projects kde3-stable  security-prpm security

hoffe das es jetzt besser geht...

Gast

Beitrag von Gast » 4. Feb 2005, 16:44

In der Zeile ist ein Fehler. Es fehlt das Leerzeichen zwischen '9.1-x86_64' und 'base'. Und das Backslash dazwischen gehört da auch nicht hin.

So muss das aussehen.

Code: Alles auswählen

rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/SuSE/9.1-x86_64 base
Kleine Anmerkung sei mir erlaubt.
In der Liste ist ja alles drin, auch die gefährlichen und unverträglichen Repository. Lies dir im Aptforum noch mal die Beiträge was die source.list anbelangt durch.

christian_k
Member
Member
Beiträge: 57
Registriert: 29. Sep 2004, 14:41
Wohnort: Obertshausen
Kontaktdaten:

Beitrag von christian_k » 4. Feb 2005, 16:46

ich danke dir vielmals für deine mühe

mfg Tux^

christian_k
Member
Member
Beiträge: 57
Registriert: 29. Sep 2004, 14:41
Wohnort: Obertshausen
Kontaktdaten:

Beitrag von christian_k » 4. Feb 2005, 16:50

also langsam reichts mir ja mit apt^^

Code: Alles auswählen

apt-get update
E: Misbildete Zeile 10 in Quellliste /etc/apt/sources.list (URI parse)

christian_k
Member
Member
Beiträge: 57
Registriert: 29. Sep 2004, 14:41
Wohnort: Obertshausen
Kontaktdaten:

Beitrag von christian_k » 4. Feb 2005, 16:55

okay habe es selbst behoben...^^

Gast

Beitrag von Gast » 4. Feb 2005, 16:57

Nimm mal die ganzen 'rpm-src raus' aus der Liste, brauchst mit sicherheit sowieso nicht. weg damit.

Code: Alles auswählen

 # rpm-src  ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.2-i386  rpmkeys update-drpm update-prpm update kde misc xorg    # mozilla samba3  suser-rbos suser-oc2pus suser-guru suser-gbv suser-tcousin suser-scorot suser-sbarnin suser-ollakka  # funktronics packman packman-i686  wine suse-people suse-projects kde3-stable  security-prpm security 
Und dann teste nochmal............... wenn wieder Fehler dann hier entlang............
http://www.linux-club.de/viewtopic.php?t=23969

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 9. Feb 2005, 12:10

und um weitere Probleme zu vermeiden: lass die *-prpm und *-drpm auch gleich weg .....

und noch ein Tip: es gibt hier ein Script mit dem Anfänger gut verträgliche sources.list erstellen können, um gerade diese Startprobleme zu vermeiden. Das ist genau der link den dir auch misterhsp empfohlen hat !!

Schaust du hier:
Wichtig: [HOWTO] sources.list automatisch erstellen/upgraden
http://www.linux-club.de/viewtopic.php?t=23969

Und aus diesem Grunde wird dieser Thread nun geschlossen ;)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 2 Gäste