Probleme bei Erstinstallation synaptic

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Benutzeravatar
|condor|
Newbie
Newbie
Beiträge: 7
Registriert: 30. Jan 2005, 11:01
Kontaktdaten:

Beitrag von |condor| » 30. Jan 2005, 11:23

Ich wollte erstmal ein großes Lob an alle geben, die sich hier im Forum beteilligen.
Alle probleme die ich bisher hatte konnten problemlos über die Suchfunktion gelöst werden.
Nur jetz komme ich absolute nicht weiter.
Ich habe das How To mehr als nur einmal gemacht abber immer bleibe ich an einer stelle liegen und zwar bei der installation von synaptic.
Hier ein Auszug der Konsole:

Code: Alles auswählen

linux:/home/condor # apt-get install synaptic
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Sie möchten `apt-get -f install' ausführen um diese zu beheben:
Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
  apollon: Hängt ab von: libgiFT aber es wird nicht installiert werden
  giFT: Hängt ab von: ImageMagick-libs aber es ist nicht installierbar
        Hängt ab von: lcms aber es ist nicht installierbar
        Hängt ab von: libltdl aber es ist nicht installierbar
        Hängt ab von: libmagic aber es ist nicht installierbar
        Hängt ab von: libmagic.so.1 aber es ist nicht installierbar
  gift-fasttrack: Hängt ab von: gift aber es wird nicht installiert werden
  gift-plugin-opennap: PreDepends: /sbin/postun_ldconfig aber es ist nicht installierbar
  giftd: Hängt ab von: libgiftproto (>= 0.11.4-alt4) aber es ist nicht installierbar
         Hängt ab von: perl(Data/Dumper.pm) aber es ist nicht installierbar
         Hängt ab von: perl(File/Glob.pm) aber es ist nicht installierbar
         Hängt ab von: perl(IO/File.pm) aber es ist nicht installierbar
  kisdnmon: Hängt ab von: libkdecore.so.2 aber es ist nicht installierbar
            Hängt ab von: libkdeui.so.2 aber es ist nicht installierbar
            Hängt ab von: libqt.so.1 aber es ist nicht installierbar
  kssh: Hängt ab von: kdelibs3 (>= 3.3.1) aber 3.3.0-34 wird installiert werden
  libgift: PreDepends: /sbin/postun_ldconfig aber es ist nicht installierbar
  mplayer: Hängt ab von: faad2 aber es wird nicht installiert werden
           Hängt ab von: libdivxdecore.so.0
           Hängt ab von: libdivxencore.so.0
           Hängt ab von: libdv.so.2
           Hängt ab von: libdvdread.so.2 aber es ist nicht installierbar
           Hängt ab von: libpostproc (= 0.90-3asp) aber es wird nicht installiert werden
           Hängt ab von: libpostproc.so.0
           Hängt ab von: mplayer-fonts aber es ist nicht installierbar
           Hängt ab von: xvidcore aber es ist nicht installierbar
  synaptic: Hängt ab von: libzvt2
            Hängt ab von: scrollkeeper aber es wird nicht installiert werden
            Hängt ab von: xsu aber es wird nicht installiert werden
            Hängt ab von: libzvt-2.0.so.0
  xine-ui: Hängt ab von: libxine1 (>= 1) aber es wird nicht installiert werden
E: Unerfüllte Abhängigkeiten. Versuchen Sie 'apt-get -f install' ohne Pakete(oder geben Sie eine Lösung an)
linux:/home/condor #


Ich hab schon hier im Forum gesucht aber alles was da stand und was ich ausprobiert hat mich nicht wirklich weiter gebracht.
Ich hoffe mir kann jemand helfen.



greetz |condor|

P.S. Ja ich weiß das mein Rechner nicht gerade der schnellste ist :-)
PII 400MHz; 128Mb RAM; 4Mb Graka; Suse 9.2 Professional; KDE 3.3.2 level "a"; Kernel 2.6.8-24-Default

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 30. Jan 2005, 11:32

1.) du solltest mal dein gift Sachen aufräumen ...
==> libgift != libgiFT
das resultiert aus verschiedenen Quellen ...

2.) dir fehlen offensichtlich einige Repositories in deiner sources.list

3.) du hast "fremde" RPMs installiert, die passen nicht zu SuSE

4.) welche SuSE Version ?
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
|condor|
Newbie
Newbie
Beiträge: 7
Registriert: 30. Jan 2005, 11:01
Kontaktdaten:

Beitrag von |condor| » 30. Jan 2005, 11:59

Wie soll ich denn die gift sachen aufräumen? Bei dem All-in-one installer von apollon waren die alle dabei.
Was heist das Repositories in meiner sources.list fehlen?
Sind dann die Fremden RPM's schuld daran das das nicht funktioniert?

Aso ja ich habe Suse Linux 9.2 Professional.

Und vielen dank für die schnelle antwort, langsm bin ich echt am verzweifeln.

greetz
PII 400MHz; 128Mb RAM; 4Mb Graka; Suse 9.2 Professional; KDE 3.3.2 level "a"; Kernel 2.6.8-24-Default

Keepers
Advanced Hacker
Advanced Hacker
Beiträge: 1061
Registriert: 25. Jun 2004, 17:58
Wohnort: Hessen

Beitrag von Keepers » 30. Jan 2005, 12:05

apt-get -f install

bereinigte bei mir immer anfangs so aehnliche Meldungen, (sogar nach einer SuSE Neuinstallation). Aber danach hat apt alles aufgeraeumt ... zumindest bei mir.
Gruß Keepers
Only time will tell - but who does listen?

Benutzeravatar
|condor|
Newbie
Newbie
Beiträge: 7
Registriert: 30. Jan 2005, 11:01
Kontaktdaten:

Beitrag von |condor| » 30. Jan 2005, 12:10

Das hat mir die Apt ja auch empfohlen, das hab ich dann schon gemacht und dann kam das heraus:

Code: Alles auswählen

linux:/home/condor # apt-get -f install
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Korrigiere Abhängigkeiten ... Fertig
Die folgenden zusätzlichen Pakete werden installiert werden:
  divx4linux faad2 giFT giFT-openft gift kssh libgiFT libpostproc libxine1
  speex
Die folgenden Pakete werden upgegradet werden:
  giFT kssh speex
Die folgenden Pakete werden ERSETZT:
  xine-lib (by libxine1)
Die folgenden Pakete werden ENTFERNT:
  gift-plugin-opennap giftd kisdnmon libgift mplayer
Die folgenden NEUEN Pakete werden installiert werden:
  divx4linux faad2 giFT-openft gift libgiFT libpostproc libxine1
3 upgraded, 7 newly installed, 1 ersetzt, 5 entfernt und 1053 nicht upgegradet.
Muss 0B/11,9MB an Archiven holen.
Nach dem Auspacken werden 7235kB zusätzlicher Plattenplatz benutzt werden.
Wollen Sie fortsetzen? [J/n] j
Committing changes...
Preparing...                ########################################### [100%]
        file /usr/bin/giftd conflicts between attempted installs of gift-0.11.8.1-3.guru.suse92 and giFT-0.11.8.1-1
        file /usr/lib/libgift.so.0.0.0 conflicts between attempted installs of gift-0.11.8.1-3.guru.suse92 and libgiFT-0.11.8.1-1
        file /usr/lib/libgiftproto.so.0.0.0 conflicts between attempted installs of gift-0.11.8.1-3.guru.suse92 and libgiFT-0.11.8.1-1
E: Error while running transaction
linux:/home/condor #                          linux:/home/condor # apt-get -f install
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Korrigiere Abhängigkeiten ... Fertig
Die folgenden zusätzlichen Pakete werden installiert werden:
  divx4linux faad2 giFT giFT-openft gift kssh libgiFT libpostproc libxine1
  speex
Die folgenden Pakete werden upgegradet werden:
  giFT kssh speex
Die folgenden Pakete werden ERSETZT:
  xine-lib (by libxine1)
Die folgenden Pakete werden ENTFERNT:
  gift-plugin-opennap giftd kisdnmon libgift mplayer
Die folgenden NEUEN Pakete werden installiert werden:
  divx4linux faad2 giFT-openft gift libgiFT libpostproc libxine1
3 upgraded, 7 newly installed, 1 ersetzt, 5 entfernt und 1053 nicht upgegradet.
Muss 0B/11,9MB an Archiven holen.
Nach dem Auspacken werden 7235kB zusätzlicher Plattenplatz benutzt werden.
Wollen Sie fortsetzen? [J/n] j
Committing changes...
Preparing...                ########################################### [100%]
        file /usr/bin/giftd conflicts between attempted installs of gift-0.11.8.1-3.guru.suse92 and giFT-0.11.8.1-1
        file /usr/lib/libgift.so.0.0.0 conflicts between attempted installs of gift-0.11.8.1-3.guru.suse92 and libgiFT-0.11.8.1-1
        file /usr/lib/libgiftproto.so.0.0.0 conflicts between attempted installs of gift-0.11.8.1-3.guru.suse92 and libgiFT-0.11.8.1-1
E: Error while running transaction
linux:/home/condor #                          
:-([/code]
PII 400MHz; 128Mb RAM; 4Mb Graka; Suse 9.2 Professional; KDE 3.3.2 level "a"; Kernel 2.6.8-24-Default

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 30. Jan 2005, 12:26

3 upgraded, 7 newly installed, 1 ersetzt, 5 entfernt und 1053 nicht upgegradet.
du hast 1053 upgradefähige RPMs .....

das meinte ich mit "sauberem" System ... solange du so einen Misch-Masch alt/neu hast kann das nix werden :)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
|condor|
Newbie
Newbie
Beiträge: 7
Registriert: 30. Jan 2005, 11:01
Kontaktdaten:

Beitrag von |condor| » 30. Jan 2005, 12:32

Soll ich dann jetzt Per Yast alle Pakete die ich nachträglich Installiert habe löschen? DAnn hab ich doch den ursprünglichen zustand dann müsste das ja klappen oder nicht?
PII 400MHz; 128Mb RAM; 4Mb Graka; Suse 9.2 Professional; KDE 3.3.2 level "a"; Kernel 2.6.8-24-Default

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 30. Jan 2005, 12:41

warum mit YaST ?

Lass mal apt -d upgrade laufen, dann werden alle updates downgeloaded.
Dann lässt du apt upgrade laufen und dein System wird aktualisiert.

Evtl. gibt es dann noch das eine andere Problem, aber das lösen wir dann :)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
|condor|
Newbie
Newbie
Beiträge: 7
Registriert: 30. Jan 2005, 11:01
Kontaktdaten:

Beitrag von |condor| » 30. Jan 2005, 12:52

So musste notgedrungen Linux neu installieren. Bin das How To dann noch mal durchgegangen und alles klappt jetzt (hoffentlich) bestens. Bin gerade ein Upgrade am machen.

Danke schon mal an alle die mir geholfen haben.
PII 400MHz; 128Mb RAM; 4Mb Graka; Suse 9.2 Professional; KDE 3.3.2 level "a"; Kernel 2.6.8-24-Default

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste