Fehlermeldungen in apt

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Benutzeravatar
Tux-Manni
Member
Member
Beiträge: 172
Registriert: 12. Jun 2004, 18:46
Wohnort: Ludwigsburg

Fehlermeldungen in apt

Beitrag von Tux-Manni » 22. Jan 2005, 11:32

Hallo

Habe mich mittlerweile auch etwas mit apt vertraut gemacht und erstaunlich viele Dateien geupdatet.
Doch nun zu den Problemen.
Als letztes bleiben folgende übrig:
linux:/home/manfred # apt -s upgrade
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Die folgenden Pakete werden upgegradet werden:
OpenOffice_org-Quickstarter arts kplayer sensors xpdf-config
Die folgenden Pakete sind zurückgehalten worden
k3b
5 upgraded, 0 newly installed, 0 entfernt und 1 nicht upgegradet.
Inst arts [1.3.2-1] (1.3.2-3 SuSE:9.1/stable)
Inst OpenOffice_org-Quickstarter [1.0-457] (2.0.3-0.pm.1 SuSE:9.1/stable)
Inst kplayer [0.5.3-1] (0.5.3-1.guru.suse91.kde33 SuSE:9.1/stable)
Inst sensors [2.8.6-0.pm.0] (2.8.6-0.2 SuSE:9.1/stable)
Inst xpdf-config [3.00-61] (3.00-64.17 SuSE:9.1/stable)
Conf arts (1.3.2-3 SuSE:9.1/stable)
Conf OpenOffice_org-Quickstarter (2.0.3-0.pm.1 SuSE:9.1/stable)
Conf kplayer (0.5.3-1.guru.suse91.kde33 SuSE:9.1/stable)
Conf sensors (2.8.6-0.2 SuSE:9.1/stable)

OOqs werd ich nicht updaten. Mir gefällt die ältere Version besser.
arts ist eigentlich auf Hold gesetzt!? // Hold { "kernel-default"; "kernel-source"; "arts"; };
Kplayer hatte auch Probleme gemacht, hab die "alte" Version belassen.
sensors = 2.8.3-99 is needed by sensors-2.8.6-0.2
E: Transaction set check failed
file /usr/bin/pdfinfo conflicts between attempted installs of xpdf-3.00-64.27 and xpdf-config-3.00-64.17
E: Error while running transaction

Zu arts: hab ich mit Hold wohl falsch verstanden? Muss wohl über preferences gepinnt werden; richtig?

Wieso wird ein Programm (hier k3b) zurückgehalten?

Des weiteren scheint auch die gtk-qt engine bei Gimp nicht mehr für den KDE Look zu sorgen. Ist allerdings nicht so schlimm.

Danke und Gruß
Manni
Suse 10 / KDE 3.5.1 Level "a"
Kernel 2.6.13-15.8-default
xorg 6.9.0-3.1
Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.12) Gecko/20050920 Firefox/1.0.7 SUSE/1.0.7-0.1

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Re: Fehlermeldungen in apt

Beitrag von oc2pus » 22. Jan 2005, 11:46

Tux-Manni hat geschrieben:arts ist eigentlich auf Hold gesetzt!? // Hold { "kernel-default"; "kernel-source"; "arts"; };
die zwei // bedeuten: das ist ein Kommentar ==> deine Hold Anweisung ist nicht aktiv :)
Tux-Manni hat geschrieben:sensors = 2.8.3-99 is needed by sensors-2.8.6-0.2
E: Transaction set check failed
file /usr/bin/pdfinfo conflicts between attempted installs of xpdf-3.00-64.27 and xpdf-config-3.00-64.17
E: Error while running transaction
Lösung: apt --force install sensors

xpdf und xpdf-config, da sind wohl Dateiverschiebungen erfolgt, innerhalb der beiden RPMs.
Lösung: apt install --force xpdf xpdf-config
Tux-Manni hat geschrieben:Wieso wird ein Programm (hier k3b) zurückgehalten?
evtl benötigt es zusätzliche Pakete.
Lösung: apt install k3b

Du solltest besser Pinning statt Hold verwenden.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
Tux-Manni
Member
Member
Beiträge: 172
Registriert: 12. Jun 2004, 18:46
Wohnort: Ludwigsburg

Beitrag von Tux-Manni » 22. Jan 2005, 12:04

Hallo
Danke für die schnelle Antwort.
die zwei // bedeuten: das ist ein Kommentar ==> deine Hold Anweisung ist nicht aktiv
:oops: :oops:
Wird korrigiert.

xpdf und xpdf-config hat geklappt.
sensors bringt immer noch die selbe Fehlermeldung.

Pinning: ok, werd ich machen.
Zurückhalten: bei Installation mit Synaptic wird auf zusätzliche Pakete hingewiesen. Grad getestet.

Danke Manni
Suse 10 / KDE 3.5.1 Level "a"
Kernel 2.6.13-15.8-default
xorg 6.9.0-3.1
Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.12) Gecko/20050920 Firefox/1.0.7 SUSE/1.0.7-0.1

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 22. Jan 2005, 12:09

Code: Alles auswählen

sudo apt policy sensors
sensors:
  Installiert: 2.8.6-0.2
  Kandidat: 2.8.6-0.2
  Versionstabelle:
 *** 2.8.6-0.2 0
        500 ftp://ftp.gwdg.de SuSE/9.1-i386/update pkglist
        100 RPM Database
     2.8.6-0.pm.0 0
        500 ftp://ftp.gwdg.de SuSE/9.1-i386/packman pkglist
     2.8.3-99 0
        500 ftp://ftp.gwdg.de SuSE/9.1-i386/base pkglist
welche sensors hast du installiert ? ==> rpm -q sensors

probiere: rpm -e --nodeps sensors
apt install sensors
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
Tux-Manni
Member
Member
Beiträge: 172
Registriert: 12. Jun 2004, 18:46
Wohnort: Ludwigsburg

Beitrag von Tux-Manni » 22. Jan 2005, 16:51

Hallo
Da bin ich wieder (musste erst mal ne Runde radfahren...).
Bei mir war das Packman Paket drauf ( 2.8.6-0.pm.0 ).
probiere: rpm -e --nodeps sensors
apt install sensors
Hat leider nicht geholfen.
Aber ich habs gelöst: in Yast auf das alte Paket (2.8.3-99) downgegradet.
Dann apt install sensors - voila!

Danke für Deine Hilfe
Manni
Suse 10 / KDE 3.5.1 Level "a"
Kernel 2.6.13-15.8-default
xorg 6.9.0-3.1
Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.12) Gecko/20050920 Firefox/1.0.7 SUSE/1.0.7-0.1

Slowman
Newbie
Newbie
Beiträge: 49
Registriert: 27. Jun 2004, 18:06
Wohnort: Berlin
Kontaktdaten:

Beitrag von Slowman » 24. Jan 2005, 10:12

Schmeisse mal meine Fehlermeldung auch mal hier mit rein, um nicht extra ein neues Thema zu öffenen.

Folgende Fehlermeldung bekomme ich von Synaptic, nachdem er die paket runtergeladen hat und installieren möchte:

Code: Alles auswählen

APT-System meldet:
E: Error(s) while checking package signatures:
5 unsigned package(s)
45 package(s) with unknown signatures
0 package(s) with illegal/corrupted signatures
Wer kann mir da weiterhelfen ?

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 24. Jan 2005, 10:18

Slowman hat geschrieben:Folgende Fehlermeldung bekomme ich von Synaptic, nachdem er die paket runtergeladen hat und installieren möchte:

Code: Alles auswählen

APT-System meldet:
E: Error(s) while checking package signatures:
5 unsigned package(s)
45 package(s) with unknown signatures
0 package(s) with illegal/corrupted signatures
schaust du hier:
Wichtig: [HOWTO] gpg-signierte Pakete für apt einspielen
http://www.linux-club.de/viewtopic.php?t=14561

und hier:
Wichtig: [HOWTO] Installation von apt für SuSE
http://www.linux-club.de/viewtopic.php?t=14724
Schritt 2 genau lesen ;)

und hier:
Wichtig: Anleitung fuer Newbees
http://www.linux-club.de/viewtopic.php?t=24634
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Slowman
Newbie
Newbie
Beiträge: 49
Registriert: 27. Jun 2004, 18:06
Wohnort: Berlin
Kontaktdaten:

Beitrag von Slowman » 24. Jan 2005, 10:34

erledigt, habe einfach das Paket nicht mit installiert, was die Fehlermeldung geschmissen hat und jetzt funzt es der Abgleich 8) 8)

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast