Seltsamer Fehler bei apt

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Peter Lustig
Newbie
Newbie
Beiträge: 3
Registriert: 5. Mai 2004, 17:51

Seltsamer Fehler bei apt

Beitrag von Peter Lustig » 8. Jan 2005, 13:53

Hi alle zusammen. Also irgendwie ist es zum Haare raufen. Ich versuche seit heute morgen ein apt-get upgrade zu starte bekomme aber immer folgende Fehlermeldung:
Die folgenden Pakete werden upgegradet werden:
3ddiag BASS CheckHardware Crystalcursors DirectFB EastWest FA_clalsadrv FA_clxclient FOTAQ FooBillard ImageMagick ImageMagick-Magick++ ImageMagick-devel
Maelstrom MainActor-5 OpenEXR OpenOffice_org OpenOffice_org-de OpenOffice_org-gnome OpenOffice_org-kde RealPlayer SDL SDL_image SDL_mixer SDL_net
SDL_perl SDL_ttf SuperCollider TeXmacs TraceToolkit WindowMaker WindowMaker-applets ZynAddSubFX a2ps a52dec aalib abiword acpid acroread aeolus alevt
alsa alsa-devel alsa-tools alsa-tools-gui alsamixergui alsamodular alsaplayer amarok amarok-xmms apache2 apache2-doc apache2-example-pages
apache2-mod_php4 apache2-prefork armagetron arts arts-devel aseqview ash aspell aspell-de aspell-devel astools at at-spi at-spi-devel at-spi-doc
audacity aumix autoconf autofs automake autoyast2 autoyast2-installation avifile baghira barcode bash bbtools bbtools-gui bc bcel bind bind-chrootenv
bind-libs bind-utils bitchx blackbox blender blt bluez-utils bogofilter bonobo bootsplash bootsplash-theme-SuSE briquolo broadcast2000 bug-buddy bzflag
calctool canna canna-devel canna-libs cannadic capi4linux cdparanoia cdrdao cedilla chromium circuslinux ckermit clanbomber clanlib clisp cmatrix
compat-curl2 control-center coriander cscope csmash csound cups cups-SUSE-ppds-dat cups-client cups-drivers cups-drivers-stp cups-libs curl cvs
cyrus-sasl cyrus-sasl-crammd5 cyrus-sasl-digestmd5 cyrus-sasl-gssapi cyrus-sasl-otp cyrus-sasl-plain cyrus-sasl-saslauthd dar dasher ddd
desktop-data-SuSE devhelp devs dhcp dhcp-server dia digikam ding dirmngr distcc djvulibre docbook-dsssl-stylesheets docbook-toys docbook-xsl-stylesheets
docbook_3 docbook_4 dosbootdisk doxygen dvb dvd+rw-tools dvdauthor dviutils ecamegapedal ecasound efont-unicode emacs emacs-info emacs-x11 eog
epiphany-extensions esound esound-devel ethereal evlog evlog-devel evms evms-gui evolution-data-server faad2 falconseye festival fetchmail ffmpeg fftw
file file-roller filesystem filters flac fltk fluidsynth foomatic-filters freeciv freefont freeglut freeglut-devel freeradius freetype freetype-tools
fribidi frozen-bubble fvwm2 g3utils gabber gaim gal galan gambas gamix gawk gconf gdb gdk-pixbuf gdk-pixbuf-gnome gdm gfxboot ggv ghex
ghostscript-fonts-other ghostscript-fonts-std ghostscript-library ghostscript-x11 giflib gimp gimp-cmyk gimp-devel gl-117 glade glame glchess gle gltt
gnet gngeo gnokii gnome-desktop gnome-games gnome-libs gnome-mag gnome-panel gnome-print gnome-speech gnome-spell2 gnome-system-monitor gnome-vfs
gnome2-SuSE gnome2-user-docs gnomemeeting gnomemm gnopernicus gnumeric gnuplot gok gpdf gpg gpg2 gpgme gphoto gpsdrive gq gqview graphviz grip groff
gstreamer-plugins gstreamer-plugins-default gstreamer-plugins-devel gstreamer-plugins-excess gstreamer-plugins-extra gthumb gtk gtk-engines
gtk-qt-engine gtk2-engines gtkam gtkcomm gtkdoc gtkglarea gtkhtml2 gtkhtml2-devel gtkiterm gtklp gtkmm gtkspell gucharmap gucharmap-devel guile gv
gwenview gxmhtml heimdal heimdal-lib heimdal-tools heimdal-x11 hk_classes hotplugctl hp-officeJet htdig html-dtd hwinfo hydrogen i4l-base i4l-isdnlog
i4l-vbox i4lfirm icewm icewm-default id-utils ifnteuro imap imap-lib imhangul imlib imlib2-loaders imwheel indeview info2html inn input-utils insight
insserv intlfnts iproute2 iptables ipxrip irssi irssi-extra iso_ent itcl jaaa jack jack-rack jackEQ jadetex jamin java-1_4_2-sun java-1_4_2-sun-plugin
jazz joy2key k3b kadslwatch kaffeine kalamaris kalbum kalsatools kam2 kamplus kappdock karchiver kbarcode kbear kbiff kconfigure kdar kdbg kdclock
kde3-i18n-de kdeaccessibility3 kdeaddons3-games kdeaddons3-kate kdeaddons3-kicker kdeaddons3-konqueror kdeaddons3-kontact kdeaddons3-sound kdeadmin3
kdeartwork3 kdeartwork3-sound kdeartwork3-xscreensaver kdebase3 kdebase3-SuSE kdebase3-devel kdebase3-kdm kdebase3-ksysguardd kdebase3-nsplugin
kdebase3-samba kdebindings3-java kdebindings3-javascript kdebindings3-perl kdebluetooth kdeedu3 kdegames3 kdegames3-arcade kdegames3-board
kdegames3-card kdegames3-tactic kdegraphics3 kdegraphics3-3D kdegraphics3-devel kdegraphics3-fax kdegraphics3-kamera kdegraphics3-pdf
kdegraphics3-postscript kdegraphics3-scan kdegraphics3-tex kdelibs3 kdelibs3-devel kdelibs3-devel-doc kdelibs3-doc kdemultimedia3 kdemultimedia3-CD
kdemultimedia3-devel kdemultimedia3-jukebox kdemultimedia3-midi kdemultimedia3-mixer kdemultimedia3-sound kdemultimedia3-video kdemultimedia3-video-xine
kdenetwork3 kdenetwork3-IRC kdenetwork3-InstantMessenger kdenetwork3-dialup kdenetwork3-news kdenetwork3-query kdenetwork3-vnc kdenetwork3-wireless
kdepim3 kdepim3-kpilot kdepim3-mobile kdepim3-organizer kdepim3-sync kdepim3-time-management kdesdk3 kdesdk3-devel kdesdk3-profile kdesdk3-translate
kdetoys3 kdetv kdeutils3 kdeutils3-devel kdeutils3-laptop kdevelop3 kdirstat kernel-docs kernel-um kfilter kfs khrono khunphan kile kimdaba kinternet
kio_slp kio_sql kiosktool kipi-plugins kisdnwatch klipsi klogic km_afs km_antivir km_drm km_ipppcomp km_iscsi km_smartlink-softmodem km_submount
km_tpctl km_usbvision km_wlan kmymoney knights knoda koffice koffice-i18n-de koffice-illustration koffice-presentation koffice-spreadsheet
koffice-wordprocessing konserve konversation kover kphone kpl kpopup kpowersave kprof kpsion kradio krecord krename krpmbuilder kscpm kseg ksetiwatch
kshowmail ksimus kssh ksteak ktamaga kvdr kvim kvirc kwatch kwebget kxmleditor ladcca ladcca-libs ladspa latex2html-pngicons lbreakout ldapcpplib lftp
libapr0 libbtctl libcddb libcdio libcdio-devel libcroco libdar libdc1394 libdv libdvdnav libexif-gtk libfame libffmpeg0 libffmpeg0-devel libgda
libgda-devel libgimpprint libglade libgnome libgnome-doc libgnomecups libgnomedb libgnomedb-devel libgnomeui libgnomeui-doc libgphoto2 libgsf
libgsf-devel libgsf-doc libgsf-gnome libgtop libical libidl libidl-devel libidn libidn-devel libieee1284 libiterm libjasper libkexif libkipi liblcms
liblcms-devel liblrdf libmal libmikmod libmng libmng-devel libmpeg2 libnetpbm libofx libquicktime libquicktime-devel librsvg libsmbclient libsoup
libstroke libstroke-devel libtabe libtabe-devel libtheora libtiff libtiff-devel libtunepimp libusb libvcd libwmf libxine1 libxml libxml2 libxml2-devel
libxslt libxslt-devel liby2util libzvt libzvt-devel lilo linc linc-devel linc-doc lincity links linux-atm-lib linux-iscsi liquid lirc lkcdutils ltris
lua lynx madbomber mailman mailx man manufacturer-PPDs marbles mc mergeant metacity-themes meterbridge methane mgetty mgp minicom mjpegtools mlterm
mod_php4-core moneyplex mono mozilla-deat mozilla-devel mozplugger mpg123 mpg321 mrtg mtools mtr multisync multisync-backup multisync-irmc
multisync-irmc-bluetooth multisync-ldap multisync-opie multisync-palm multisync-syncml mupad muse musicman mutt myldapklient mysql-client mysql-shared
mysqlcc nagios-nrpe nagios-plugins nautilus nautilus-media ncpfs neon net-snmp net-tools netatalk netpbm neverball nmap normalize noteedit nss_ldap ntop
nvtv oaf obconf openafs openal openbox openct openh323 openhbci openldap2 openldap2-client openmotif openmotif-libs opensc openslp openslp-server
openssh openssh-askpass openssl openssl-devel oprofile pachi pam-modules pam_krb5 pam_ldap pan parted pcsc-lite pd pd-externals penguin-command
perl-Archive-Zip perl-Authen-SASL-Cyrus perl-DBD-mysql perl-IO-Socket-SSL perl-Net_SSLeay perl-OPENSSL perl-PDA-Pilot perl-SNMP perl-Tk perl-XML-SAX
perl-XML-Stream perl-Xmms perl-ldap perl-ldap-ssl perl-spamassassin php4 php4-bcmath php4-bz2 php4-calendar php4-ctype php4-curl php4-dbase php4-dbx
php4-devel php4-domxml php4-exif php4-filepro php4-ftp php4-gd php4-gettext php4-gmp php4-iconv php4-imap php4-ldap php4-mbstring php4-mcal php4-mcrypt
php4-mhash php4-mime_magic php4-mysql php4-pear php4-pgsql php4-qtdom php4-session php4-shmop php4-snmp php4-sockets php4-swf php4-sysvsem php4-sysvshm
php4-unixODBC php4-wddx php4-xslt php4-yp php4-zlib pia pico pilot-link pine pinentry pingus pixmp planner plotutils plptools plptools-kde
pnet-interpreter pnetlib postfix postgresql-libs povray powersave powertweak powertweak-extra ppp privoxy procmail pwdutils pwlib pwlib-plugins-alsa
pwlib-plugins-v4l pyecasound python python-devel python-gnome python-japanese python-korean python-numeric python-orbit python-pygame python-tk
python-xml pyxml qamix qca qdvdauthor qinternet qjackconnect qjackctl qmidiarp qpopper qsa qsa-devel qscintilla qt3 qt3-devel qt3-devel-doc
qt3-devel-tools qt3-examples qt3-man qt3-mysql qt3-non-mt qt3-postgresql qt3-sqlite qt3-unixODBC quagga quilt raptor rcs rdesktop readline
readline-devel regexp rekall rekall-xbase root-tail rosegarden4 rpmkey-packman rpmkey-suser-scorot rsync rtsynth rxvt samba samba-client samba-doc
samba-winbind sane sax2 sax2-gui sax2-ident sax2-tools scim scmxx scotty scpm scrollkeeper scsi scummvm seq24 sgi-fonts sgml-skel sharutils slrn smpeg
smpppd snack solarwolf solfege spamassassin sqlite squid steak submount subversion subversion-cvs2svn subversion-viewcvs suck sudo superkaramba supertux
suse-build-key suse-release susehelp susehelp_de susevbox sweep swig synaesthesia synce-kde t1lib t1lib-devel taglib tamil-gtk2im tar taskjuggler
taskjuggler-kde tcl tcl-devel tclldap tclplug tcpdump tcsh te_etex te_latex te_pdf terminatorX terminus-font tetex thinkeramik thinkeramik-style
tightvnc timidity tix tk tk-devel tkeca tkimg tktable tls torcs totem trackballs trackballs-music transfig tuxpaint tuxracer tv-common tv-fonts uim
unarj unclutter units unixODBC usbutils usbview v4l-conf v4l-tools valgrind vcdimager vdr vim vkeybd vorbis-tools vte w3m wesnoth wget wine
wireless-tools wsndpref wsndsrv wv wv2 wvdial wvstreams wwwoffle wxGTK wxGTK-compat x2x xanim xaos xaw3d xawtv xawtv4 xbanner xboard xbsql xchat xdmbgrd
xemacs xemacs-info xemacs-packages xemacs-packages-info xephem xf86tools xfig xgammon xgrabsc xine-ui xlockmore xlogical xmahjong xmcd xmgrace
xmlcharent xmms xmms-jack xmms-kde xmms-lib xmms-plugins xorg-x11 xorg-x11-Mesa xorg-x11-Mesa-devel xorg-x11-Xvnc xorg-x11-devel xorg-x11-fonts-75dpi
xorg-x11-fonts-scalable xorg-x11-libs xorg-x11-man xorg-x11-server xorg-x11-server-glx xosd xosview xpdf xpdf-config xpp xrestop xscreensaver
xscreensaver-gnome xsidplay xsu xv xvid xvkbd xzgv y2pmsh yafray yast2 yast2-backup yast2-bluetooth yast2-bootfloppy yast2-bootloader
yast2-control-center yast2-core yast2-country yast2-dhcp-server yast2-dns-server yast2-firewall yast2-http-server yast2-inetd yast2-installation
yast2-irda yast2-kerberos-client yast2-ldap yast2-ldap-client yast2-mail yast2-mail-aliases yast2-mouse yast2-ncurses yast2-network yast2-nfs-client
yast2-nfs-server yast2-nis-client yast2-nis-server yast2-ntp-client yast2-online-update yast2-packagemanager yast2-packager yast2-pam
yast2-perl-bindings yast2-phone-services yast2-power-management yast2-powertweak yast2-printer yast2-profile-manager yast2-qt yast2-repair yast2-restore
yast2-runlevel yast2-samba-client yast2-samba-server yast2-scanner yast2-schema yast2-security yast2-slp yast2-sound yast2-storage yast2-support
yast2-sysconfig yast2-tftp-server yast2-theme-SuSELinux yast2-transfer yast2-tune yast2-tv yast2-update yast2-users yast2-x11 yast2-xml ypbind ypserv
yudit zapping zenity zinf zip zvbi
Die folgenden Pakete sind zurückgehalten worden
freqtweak kernel-default kernel-default-nongpl kernel-source libgdiplus mozilla python-wxGTK
Die folgenden Pakete werden DOWNGRADED:
OpenOffice_org-Quickstarter atk atk-devel atk-doc bin2iso cdda2wav cdrecord cdrecord-devel control-center2 db41 db41-devel desktop-file-utils divx4linux
eel eel-devel enchant enchant-devel gail gail-devel gal2 gal2-devel gconf-editor gconf2 gconf2-devel gconf2-doc gd gd-devel gdome2 gedit glib2
glib2-devel glib2-doc glibc glibc-devel gnome-desktop-devel gnome-icon-theme gnome-keyring gnome-media gnome-mime-data gnome-pilot-devel gnome-terminal
gnome-themes gnome-vfs2 gnome-vfs2-devel gob2 gstreamer gstreamer-devel gtk2 gtk2-devel gtk2-doc gtksourceview gtksourceview-devel gtksourceview-doc
imlib2 imlib2-devel imlib2-filters kino kmldonkey ksensors lame libao libao-devel libbonobo libbonobo-devel libbonobo-doc libbonoboui libbonoboui-devel
libbonoboui-doc libglade2 libglade2-devel libglade2-doc libgnome-devel libgnomecanvas libgnomecanvas-devel libgnomecanvas-doc libgnomeprint
libgnomeprint-devel libgnomeprint-doc libgnomeprintui libgnomeprintui-devel libgnomeprintui-doc libgnomeui-devel libgtkhtml libgtkhtml-devel
libgtop-devel libogg libogg-devel libsigc++2-devel libtool libvorbis libvorbis-devel libwnck libwnck-devel libxklavier libxklavier-devel lve metacity
mkisofs nautilus-cd-burner nautilus-devel ogmtools opera orbit2 orbit2-devel pango pango-devel perl-libintl-perl python-gtk shared-mime-info speex
speex-devel startup-notification startup-notification-devel subtitleripper vsftpd w32codec-all xsane
1057 upgraded, 0 newly installed, 117 downgegradet, 0 entfernt und 12 nicht upgegradet.
Muss 1105MB/1545MB an Archiven holen.
Nach dem Auspacken werden 15,8MB zusätzlicher Plattenplatz benutzt werden.
Wollen Sie fortsetzen? [J/n] J
E: Method ftp has died unexpectedly!
E: Tried to dequeue a fetching object
Ich habe auch schon ziemlich gegoogelt aber ohne besondere erkenntnisse. Bis auf das es vieleicht mit /usr/lib/apt/methods etwas zu tun haben könnte.
Achja aufgetreten ist der Fehler das erstemal nachdem ich die base Repository in meine source.list aufgenommen habe. Und zwar kamm dann die Zeile E: Tried to dequeue a fetching object sehr oft. Dann habe ich den apt Server gewechselt von gwdg nach chemnitz und jetzt kommt nur eine Zeile. Liegt es vieleicht an überlasteten Servern?

Naja vielen Dank für die Arbeit

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 8. Jan 2005, 19:54

1057 upgraded, 0 newly installed, 117 downgegradet, 0 entfernt und 12 nicht upgegradet.
Muss 1105MB/1545MB an Archiven holen.
Wow, du hast wohl alles und jedes installiert, frei nach dem Motto: Wir installieren gern wenn es nix kost :)

Dein Problem, zuwenig Speicher für apt. Probiere die Option "Cache-Limit" (man apt.conf)

oder installiere partiell mit apt install <teilliste von rpms>
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

RD
Newbie
Newbie
Beiträge: 13
Registriert: 12. Dez 2004, 17:15

Beitrag von RD » 8. Jan 2005, 20:22

Bist du sicher das der Fehler bezüglich der HDD Speichers auftritt? Ich habe das selbe Problem, habe aber angeblich noch 7GB frei.

Edit: Habe den cache-limit angepasst, wird auch per apt-config dump richtig angezeigt, ändetr an der Fehlermeldung dennoch nix :-/

Peter Lustig
Newbie
Newbie
Beiträge: 3
Registriert: 5. Mai 2004, 17:51

Beitrag von Peter Lustig » 8. Jan 2005, 23:48

Danke erstmal für die Hilfe. Leider besteht der Fehler immer noch. Ich habe jetzt eine andere sources.list erstellt wieder mit gwdg und jetzt sieht der Fehler wie folgt aus:
Nach dem Auspacken werden 22,6MB zusätzlicher Plattenplatz benutzt werden.
Wollen Sie fortsetzen? [J/n] J
E: Method http has died unexpectedly!
E: Tried to dequeue a fetching object
E: Tried to dequeue a fetching object
E: Tried to dequeue a fetching object
E: Tried to dequeue a fetching object
E: Tried to dequeue a fetching object
E: Tried to dequeue a fetching object
E: Tried to dequeue a fetching object
E: Tried to dequeue a fetching object
E: Tried to dequeue a fetching object
E: Tried to dequeue a fetching object
Werde daraus nicht schlau. Gibt es eine Möglichkeit sich eine genauere Fehlerbeschreibung anzeigen zu lassen?

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 9. Jan 2005, 01:00

Schau dir deine apt Konfiguration nochmal genau an und
vergleiche mit /usr/share/doc/packages/apt/examples/configure-index (Master Konfig mit allen Optionen) evtl ein Tippfehler ...

Zum debuggen und eingrenzen des Fehlers:
http://laiskiainen.org/apt/tricks/ (Debugging apt behavior)

Probiere zum Beispiel:
apt -o Debug::pkgAcquire=1 upgrade
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Chris1308
Member
Member
Beiträge: 84
Registriert: 19. Jun 2004, 20:59
Wohnort: Altenberge
Kontaktdaten:

Beitrag von Chris1308 » 9. Jan 2005, 12:21

Hi,
deinen ersten fehler hatte ich auch mal. es lag daran das apt zu viele pakete auf einmal upgraden wollte. dann hab ich apt install <teil der rpms> gemacht und dannn nochmal apt upgrade. danach ging alles ohne probs. :wink:

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 10. Jan 2005, 12:01

kann es sein, das du ein upgrade einer SuSE 9.x auf 9.2 durchführen willst ?

prüfe mal ob deine "cache" Struktur stimmt:
/var/cache/apt/archives
/var/cache/apt/archives/partial

/var/state/apt/lists
/var/state/apt/lists/partial

in /var/state/apt/lists und /var/cache/apt/archives muss es zusätzlich eine lock Datei geben (mit touch /var/cache/apt/archives/lock anlegen)

Ich meinte in meinem obigen mail, nicht den Plattenplatz, sondern RAM. Beobachte mal apt mit top, wenn du es gestartet hast. apt braucht bei so einer grossen Anzahl von Paketen nicht gerade wenig an RAM.

Ansonsten kannst du in der apt-Mailinglist mal nachschauen ob es was zu diesem Problem gibt:
https://lists.sourceforge.net/lists/lis ... t4rpm-suse
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Peter Lustig
Newbie
Newbie
Beiträge: 3
Registriert: 5. Mai 2004, 17:51

Beitrag von Peter Lustig » 11. Jan 2005, 10:59

So erstmal danke für die schnelle Hilfe.
Das mit dem Ram stimmt anscheinend. Bin gerade dabei das upgrade teilweise durchzuführen. In lese mich gerade ins scripen ein, um das ein wenig automatischer zu machen. Denn wenn ich einfach copy&paste mache schneidet die Konsole ja nach jeder Zeile ab und dann meckert sie rum.
Wenn jemand Lust hat kann er mir ja sagen, wie ich sauber so eine Teilliste erstellen kann, muss aber nicht sein, da ich noch im Internet ein wenig googeln werde.

Also Danke erstmal.

p.s. hätte nicht gedacht dass mein Gigabyte Ram noch zu wenig ist.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 11. Jan 2005, 11:09

erstelle dir ein Script:

Code: Alles auswählen

#!/bin/bash
apt install <liste von rpms>
speichere dieses Script als myInstall
chmod +x myInstall
./myInstall

die Liste der RPMs erhälst du mit:
apt -s upgrade | tee meineListe.txt

jetzt kannst du aus meineListe.txt portionsweise die RPM-Namen in dein script myInstall überführen.

TIP: mit apt list-nodeps bekommst du eine Liste von RPMs welche von keinem anderen RPM gebraucht werden. Einige dieser RPMs können problemlos entfernt werden, wenn du sie nicht brauchst. Damit würde die Menge der zu "upzugradenden" Pakete kleiner und dein RAM reicht vielleicht ...
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Gerd
Member
Member
Beiträge: 56
Registriert: 13. Feb 2004, 10:57

Beitrag von Gerd » 11. Jan 2005, 15:15

Hier dein Script.
Da macht er alle Files nacheinander. Ob sowas bei deiner Menge von Files sinnvoll ist eine andere Frage.

Code: Alles auswählen

#! /bin/bash

apt -s upgrade | gawk '/Inst / {print $2;}' > apt-upgrade.tmp

for pak in $(cat apt-upgrade.tmp); do
	apt-get --yes install $pak || echo $pak >> failed_inst.txt
done

rm apt-upgrade.tmp
Ich würds vorher aber mal mit apt-get -s testen.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste