Kann apt4 auf suse 9.0 nicht mehr installieren:

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
ktlmq
Newbie
Newbie
Beiträge: 18
Registriert: 6. Jan 2005, 14:37

Kann apt4 auf suse 9.0 nicht mehr installieren:

Beitrag von ktlmq » 6. Jan 2005, 15:01

Hallo,

ich habe suse 9.0 prof und wollte wie früher schon mal apt4
installieren. Ich habe viele Anleitungen gelesen, die
notwendigen Packete heruntergeladen, aber die Fehlermeldungen häufen sich so daß ich wahrscheinlich suse 9.0 nicht mehr länger benutzen will. Ich brauche wahrscheinlich dringend 9.2 sonst werde ich noch wahnsinnig.

In meinem Verzeichniss befinden sich folgende Dateie
rechner:/home/user/apt-suse2 # ls -l
insgesamt 6935
drwxr-xr-x 2 user users 376 2005-01-06 14:22 .
drwxr-xr-x 80 user users 5640 2005-01-06 14:38 ..
-rw-r--r-- 1 user users 485116 2004-12-28 16:54 apt-0.5.15cnc6-rb5.i586.rpm
-rw-r--r-- 1 user users 309872 2004-12-28 17:09 apt-libs-0.5.15cnc6-rb3.i586.rpm
-rw-r--r-- 1 user users 340280 2004-12-28 17:09 apt-libs-0.5.15cnc6-rb4.i586.rpm
-rw-r--r-- 1 user users 360552 2004-12-28 17:09 apt-libs-0.5.15cnc6-rb5.i586.rpm
-rw------- 1 user users 241696 2005-01-06 13:47 lua-5.0.2-rb1.i586.rpm
-rw------- 1 user users 6828 2005-01-06 13:46 lua-devel-5.0.2-rb1.i586.rpm
-rw------- 1 user users 5326244 2005-01-06 14:12 synaptic-0.48.1-rb3.i586.rpm

rechner:/home/user/apt-suse2 # rpm -ivh apt-libs-0.5.15cnc6-rb4.i586.rpm
Fehler: apt-libs-0.5.15cnc6-rb4.i586.rpm: V3 DSA signature: BAD, key ID 8c9b4b0d
Fehler: apt-libs-0.5.15cnc6-rb4.i586.rpm cannot be installed
rechner:/home/user/apt-suse2

Diese Fehlermeldungen treten immer auf egal welche Dateien ich aus folgendem Verzeichniss herunterlade und installieren:

ftp://ftp.gwdg.de/pub/linux/suse/apt/Su ... user-rbos/

ich habe sogar versucht alle Dateien herunterzuladen, und alle zu installieren aber ich bekomme nur Fehlermeldungen.

Irgendwas stimmt mit meinem Suse 9.0 nicht mehr. Ich habe schon viel installiert und kompilliert aber ich schaffe es
einfach nicht. Ebenso den mplayer kann ich aus rpms nicht
installieren. Jedoch ogle und samba3 hat funktioniert.

Jetzt wollte ich den mplayer mit apt-get installieren, aber
leider kann ich auch apt-get nicht installieren, obwohl es
auf einem anderen Rechner mit suse9.0 prof schonmal geklappt
hat.

Kann mir bitte jemand helfen? Warum passen Packete nicht,
die für suse 9.0 bestimmt sind?
Warum diese Fehlermeldung: V3 DSA signature: BAD, key ID 8c9b4b0d Sie tritt immer häufiger auf, je älter Suse 9.0 wird. Früher gar nie. Früher gab es nur Fehlermeldungen über
fehlende Abhängigkeiten.

Mit freundlichen Grüßen
Zuletzt geändert von ktlmq am 24. Jan 2008, 23:31, insgesamt 1-mal geändert.

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 6. Jan 2005, 15:10

dann verwende mal die:
http://ftp.gwdg.de/pub/linux/suse/apt/S ... 5.i586.rpm
http://ftp.gwdg.de/pub/linux/suse/apt/S ... 5.i586.rpm

die lua brauchst du nicht.
Wenn dein apt dann läuft, kannst du synaptic dann mit apt installieren ...
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

ktlmq
Newbie
Newbie
Beiträge: 18
Registriert: 6. Jan 2005, 14:37

apt-get für suse9.0

Beitrag von ktlmq » 6. Jan 2005, 15:40

Hallo,

habe es versucht, aber es kommt dann folgende Fehlermeldung:

rechner/home/user/apt-suse3 # rpm -ivh *
Warnung: apt-0.5.15cnc6-rb5.i586.rpm: V3 DSA signature: NOKEY, key ID 8c9b4b0d
Fehler: apt-libs-0.5.15cnc6-rb5.i586.rpm: V3 DSA signature: BAD, key ID 8c9b4b0d
Fehler: apt-libs-0.5.15cnc6-rb5.i586.rpm cannot be installed
rechner:/home/user/apt-suse3 #

Irgendwas scheint mit meiner RPM Datenbank zu sein.

Das Problem was ich da habe hat glaube ich niemand.
Zuletzt geändert von ktlmq am 24. Jan 2008, 23:34, insgesamt 2-mal geändert.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 6. Jan 2005, 16:10

ok,
dann probiere rpm --rebuilddb

danach:
rpm -Uhv --nosignature *.rpm

ansonsten man rpm lesen, es gibt noch mehr Optionen für Signaturprüfungen ....

Und du solltest die rpmkeys* installieren, das sind die Signaturen der Packager für die apt-RPMS.

evtl hat dein Filesystem eine Macke, mit fsck /dev/hdX mal prüfen von einer Rescue-CD aus.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

ktlmq
Newbie
Newbie
Beiträge: 18
Registriert: 6. Jan 2005, 14:37

Beitrag von ktlmq » 6. Jan 2005, 16:55

Hallo,
danke für Deine Antwort, bin deinem Link gefolgt, habe diese Dateien heruntergeladen und offensichtlich sind das nicht die selben Dateien wie von
meinem Link. Dein Link muß ein anderer Server sein.

Das Installieren der beiden Dateien hat jetzt funktioniert. Es lag also am Mirror
wahrscheinlich. Obwohl die Versions-Nr. übereinstimmt, habe ich jetzt andere
Packete heruntergeladen.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast