apt-get nicht aktuell !?

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Horschd
Newbie
Newbie
Beiträge: 31
Registriert: 22. Nov 2004, 20:14

apt-get nicht aktuell !?

Beitrag von Horschd » 19. Dez 2004, 19:54

hi,

ich habe jetzt mal mit debian angefangen (davor suse ),
ich hab schon apt-get update und apt-get upgrade gemacht.

wenn ich jetzt z.b. den apache mit (apt-get install apache) installier, is die neuetse version die 1.3.26, das sis doch nicht normal oder ??

wenn ich mit apt-cache search apache2 such, findet er gar nichts.

installier ich den apache, und mach danach apt-get upgrade müsste er doch den apache updaten oder ?!

dann kommt aber immer :"0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded"

was mach ich da falsch ? in den log files steht eigentlich auch nichts auffälliges drin, ich benutze "debian 3.0_rc3"

danke schon mal im voraus für eine antwort :D

Werbung:
}-Tux-{
Moderator
Moderator
Beiträge: 696
Registriert: 12. Dez 2004, 19:54
Kontaktdaten:

Beitrag von }-Tux-{ » 19. Dez 2004, 20:20

Hi

welches Debian verwendest du?
mach mal
cat /etc/apt/sources.list | grep -va '#'

mfg }-Tux-{

Horschd
Newbie
Newbie
Beiträge: 31
Registriert: 22. Nov 2004, 20:14

Beitrag von Horschd » 20. Dez 2004, 18:01

hi, ich verwende diese versione ftp://ftp-stud.fht-esslingen.de/debian-cd/images/

hier die sources

Code: Alles auswählen

deb ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/ftp.debian.org/debian/ stable main
deb-src ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/ftp.debian.org/debian/ stable main
deb http://non-us.debian.org/debian-non-US stable/non-US main
deb-src http://non-us.debian.org/debian-non-US stable/non-US main

deb ftp://ftp2.de.debian.org/debian/ stable main
deb-src ftp://ftp2.de.debian.org/debian/ stable main

deb http://security.debian.org/ stable/updates main

deb ftp://ftp.us.debian.org/debian/ stable main
deb-src ftp://ftp.us.debian.org/debian/ stable main

deb http://ftp.de.debian.org/debian/ stable main
deb-src http://ftp.de.debian.org/debian/ stable main

deb ftp://ftp.fu-berlin.de/pub/unix/linux/mirrors/debian/ stable main
deb-src ftp://ftp.fu-berlin.de/pub/unix/linux/mirrors/debian/ stable main

deb ftp://debian.uni-essen.de/debian/ stable main
deb-src ftp://debian.uni-essen.de/debian/ stable main

}-Tux-{
Moderator
Moderator
Beiträge: 696
Registriert: 12. Dez 2004, 19:54
Kontaktdaten:

Beitrag von }-Tux-{ » 20. Dez 2004, 18:13

Hi

du verwendest Debian woody (also stable). Da gibt es keine aktuellen packages (außer auf irgendwelchen backports).

Woody(stable): alte Software
Sarge(testing): halbwegs aktuelle Software
Sid(unstable): aktuelle Software

Also das ist bei deiner Debian-Version normal

mfg }-Tux-{

Horschd
Newbie
Newbie
Beiträge: 31
Registriert: 22. Nov 2004, 20:14

Beitrag von Horschd » 20. Dez 2004, 20:18

hi, ich hab mal zum spass die source list geändert, jetzt empfängt er die pakete, danke schon mal an dich dafür, jetzt hab ich auch den sinn verstanden ;-) !

jetzt hab ich aber das problem, dass folgender fehler kommt.

Code: Alles auswählen

linux2:/etc/apt# apt-get update
Hit http://ftp.de.debian.org stable/main Packages
Hit http://ftp.de.debian.org stable/main Release
Hit http://ftp.de.debian.org stable/main Sources
Hit http://ftp.de.debian.org stable/main Release
Get:1 ftp://ftp-stud.fht-esslingen.de unstable/main Packages [3383kB]
Hit ftp://debian.uni-essen.de unstable/main Packages
Hit ftp://debian.uni-essen.de unstable/main Release
Hit ftp://debian.uni-essen.de unstable/main Sources
Hit ftp://ftp2.de.debian.org stable/main Packages
Hit ftp://ftp2.de.debian.org stable/main Release
Hit ftp://debian.uni-essen.de unstable/main Release
Hit ftp://ftp2.de.debian.org stable/main Sources
Hit ftp://ftp2.de.debian.org stable/main Release
Get:2 ftp://ftp-stud.fht-esslingen.de unstable/main Release [82B]
Get:3 ftp://ftp-stud.fht-esslingen.de unstable/main Sources [1338kB]
Get:4 ftp://ftp-stud.fht-esslingen.de unstable/main Release [84B]
Fetched 4721kB in 43s (108kB/s)
Reading Package Lists... Error!
E: Dynamic MMap ran out of room
E: Error occured while processing kdelibs-dev (NewVersion1)
E: Problem with MergeList /var/lib/apt/lists/ftp2.de.debian.org_debian_dists_stable_main_binary-i386_Packages
E: The package lists or status file could not be parsed or opened.

edit:// ich depp hatte stable und unstable drin, ein unstable bei der stud.esslingen reichte, er hat jett alles geupdatet, danke an euch !!

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast