Upgrade von 9.0 auf 9.1: Konflikte mit installierten Paketen

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
baerbaer
Newbie
Newbie
Beiträge: 4
Registriert: 4. Dez 2004, 14:22

Upgrade von 9.0 auf 9.1: Konflikte mit installierten Paketen

Beitrag von baerbaer » 4. Dez 2004, 15:45

Ich versuche, ein Upgrade von 9.0 auf 9.1 mit apt anhand des Howtos http://www.linux-club.de/viewtopic.php?t=13107 durchzuführen.
Wenn ich das myUpgrade Skript ausführe, kriege ich die folgenden Fehlermeldungen:
libjasper-1.700.so.2 is needed by (installed) kdelibs3-3.3.1-17
libsmbclient3.so.0 is needed by (installed) kdebase3-samba-3.3.1-10
liblber.so.2 is needed by (installed) kdebase3-samba-3.3.1-10
liblber.so.2 is needed by (installed) kdebase3-3.3.1-10
libldap.so.2 is needed by (installed) kdebase3-samba-3.3.1-10
libldap.so.2 is needed by (installed) kdebase3-3.3.1-10
libslang.so.1 is needed by (installed) kdeaddons3-sound-3.3.1-3
libslang.so.1 is needed by (installed) amarok-libvisual-1.1.1-7
libdb-4.1.so is needed by (installed) kdesdk3-translate-3.3.1-5
libdb-4.1.so is needed by (installed) kdelibs3-3.3.1-17
libdb_cxx-4.1.so is needed by (installed) kdeaddons3-sound-3.3.1-3
libresmgr.so.0.1 is needed by (installed) kdemultimedia3-CD-3.3.1-3
libresmgr.so.0.1 is needed by (installed) kdegraphics3-scan-3.3.1-3
libresmgr.so.0.1 is needed by (installed) kdemultimedia3-sound-3.3.1-3
libresmgr.so.0.1 is needed by (installed) gnome-vfs2-2.6.1-7
libsensors.so.2 is needed by (installed) kdebase3-ksysguardd-3.3.1-10
Das Merkwürdige daran ist, dass die Pakete, die installiert werden sollen, zum Beispiel, kdelibs3, diese Abhängigkeiten nicht haben.
> rpm -qiRp /local/cache/apt/archives-9.1/kdelibs3_3.3.1-17_i586.rpm

Name : kdelibs3 Relocations: (not relocateable)
Version : 3.3.1 Vendor: SuSE Linux AG, Nuernberg, Germany
Release : 17 Build Date: Sat 27 Nov 2004 11:59:30 AM EST
Install date: (not installed) Build Host: ivanova.suse.de
Group : System/GUI/KDE Source RPM: kdelibs3-3.3.1-17.src.rpm
<snip>
libgthread-2.0.so.0
libidn.so.11
libjack.so.0
libjasper-1.701.so.1
libjpeg.so.62
libkabc.so.1
libkabc_dir.so.1
<snip>
Somit sollte nach dem Upgrade alles wieder in Ordnung sein. Ich habe versucht mit, z.B.,
Fake-Provides{"liblber.so.2";};
in /etc/apt/apt.conf.d/apt.conf, die Fehlermeldung zu umgehen, aber das hat leider nichts geändert. Irgendwelche Tipps?

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 4. Dez 2004, 18:38

das Problem liegt wohl darin, das 9.0 "neuere" RPM-Versionen hat als 9.1
(aus Sicht von RPM)
Die Fehlermeldung bezieht sich auch auf deine aktuell installierten RPMs nicht auf die zukünftig installierten.

du kannst die Pakete auf der "linken" Seite der Fehlermeldungen mit
rpm -e --nodeps <paket>
deinstallieren.
Mit deinem myUpgrade-Script werden sie dann anschliessend in der 9.1er Version installiert.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

baerbaer
Newbie
Newbie
Beiträge: 4
Registriert: 4. Dez 2004, 14:22

Beitrag von baerbaer » 5. Dez 2004, 14:52

Danke für den Hinweis. Nach dem Löschen vieler weiterer Pakete (insgesamt ca. 30) funktionierte das Update dann, und ich benutze jetzt 9.1. :)

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste