Xine und apt-get mit SuSE 9.1

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
ando
Member
Member
Beiträge: 88
Registriert: 1. Mai 2004, 17:34

Xine und apt-get mit SuSE 9.1

Beitrag von ando » 16. Nov 2004, 07:54

Hallo,

ich habe den Tipp bekommen mal direkt die apt-Helden zu befragten was ich hiermit auch gerne mache.

Ich wollte unter SuSE 9.1 Xine installieren.

Habe mir dann mit apt-get libxine1 und xine-ui installiert. Das hat nach einer Weile (zunächst Abhängigkeiten bereinigt) auch funktioniert.
Allerdings konnte ich dannach keine Videos schauen. Es kam immer die Meldung, dass xine kein Eingabeplugin finden kann (obwohl lt. Xine-Check Alles gefunden wurde.)

Ich habe mir dann von Xine-ui und libxine1 die aktuellsten Sourcen geholt und neu kompiliert.

Die Installation ging dann ohne Probleme und vor Allem auch ohne ungelöste Abhängigkeiten.

Nur eine Frage ist noch geblieben. Wenn ich mit apt-get nach Updates schaue bietet er mir auch welche für xinelib1 an, obwohl das die gleiche Version ist, die ich selbst kompiliert habe.

Kann apt-get das nicht erkennen, weil ich es nicht via apt-get installiert habe?
Was passiert wenn ich via apt-get "aktualisiere" ist mein Xine dann wieder dahin?

Danke schon mal.

Gruss von
Ando
Was ist denn jetzt wieder passiert?!

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 16. Nov 2004, 11:06

alles das was du selber compilierst steht nicht in der RPM-Datenbank drin ... ergo kann weder YaST noch apt wissen, das du da was installiert hast. ...

Prüfe ob in deiner sources.list packman und packman-i686 als Repositories drin stehen. Falls nicht, dann füge sie ein und du wirst die richtige libxine1 und xine-ui installieren können.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

ando
Member
Member
Beiträge: 88
Registriert: 1. Mai 2004, 17:34

Danke schön

Beitrag von ando » 16. Nov 2004, 13:53

Danke für den Tipp.

Hatte ich mir schon gedacht, dass es am selbst kompilieren liegt.

Die Links die Du genannt hast habe ich drin.

Aber ich will ja eben nicht, dass xine und xine-ui von packmann geholt werden, weil es mit den Paketen von dort nicht funktioniert hatte.

Habe hier im Forum aber schon was gefunden, wie ich die selbst erstellten Pakete pinnen kann.

Ciao
Ando
Was ist denn jetzt wieder passiert?!

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Re: Danke schön

Beitrag von oc2pus » 16. Nov 2004, 14:02

ando hat geschrieben:Habe hier im Forum aber schon was gefunden, wie ich die selbst erstellten Pakete pinnen kann.
nochmal zur Verdeutlichung:
Pakete welche mit:
/configure; make; make install
installiert wurden können NICHT gepinnt werden. Sie sind nicht in der RPM-Datenbank enthalten!!

Du kannst mit checkinstall ein RPM selber erstellen und dieses dann installieren. Ein solches RPM kann dann gepinnt werden.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

ando
Member
Member
Beiträge: 88
Registriert: 1. Mai 2004, 17:34

jo

Beitrag von ando » 16. Nov 2004, 19:54

Hallo nochmal,

schon klar.

Ich habe mit ./configure, make und checkinstall ein rpm erstellt und dann dieses rpm installiert.

Wenn ich Dich richtig verstehe, kann ich es dann pinnen, oder?

Werde ich gleich mal versuchen.

Ich lese hier immer wieder was von synaptic oder kynaptic. Ist das Installieren mit apt-get mit den tools einfacher? Besser? Schöner?

Prinzipiell finde ich apt-get von der Konsole schon sehr komfortabel...

Danke nochmal
Ando
Was ist denn jetzt wieder passiert?!

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast