error: unpacking of archive failed: cpio: Bad magic ???

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Gesperrt
torbi71
Newbie
Newbie
Beiträge: 1
Registriert: 12. Nov 2004, 13:34

error: unpacking of archive failed: cpio: Bad magic ???

Beitrag von torbi71 » 12. Nov 2004, 13:42

Hi Leute,
habe Apt nachdem Howto in diesem Forum installiert und nutze es mit Synaptic unter Suse 9.2.
Hat auch alles bisher wunderbar funktioniert.
Doch nun habe ich gestern und heute versucht Pakete zu aktialisieren und bei den meisten hats geklappt, nur bei zwei Paketen bekam ich diese Meldung:

Code: Alles auswählen

error: unpacking of archive failed: cpio: Bad magic
Es handelt sich um das aktuelle Kaffeine- und das Lineak-Kde-Paket!

Wo könnte der Fehler liegen?

Wäre für jede Hilfe dankbar!

Gruß torbi71

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 16. Nov 2004, 11:15

du solltest vor einem update immer die neuesten apt-Listen mit
apt update holen.

Die apt-Server werden mehrfach am Tag gespiegelt, d.h. es kann sein das deine Information im lokalen Cache (/var/lib/state/apt/*) veraltet ist und du rpm's referenzierst die es gar nicht mehr gibt. Das Resultat ist dann ein cpio-Error.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Red14
Newbie
Newbie
Beiträge: 2
Registriert: 8. Nov 2004, 13:32

Beitrag von Red14 » 16. Nov 2004, 15:59

ich habe diese Fehler auch. Das liegt glaub ich daran,
das es sich um Patches handelt. Also kein komplettes RPM, sondern nur ein Diff zwischen dem alten und neuen.
Mit YOU klappt das Update dann ohne Probleme

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 17. Nov 2004, 21:58

Hatte das Problem heute auch. Hab dann auch mit YOU upgedated. Aber was bedeutet denn "bad magic" jetzt genau? Und warum hab ich die Fehlermeldungen erst seit 9.2? Kenne das von 9.1 überhaupt nicht.

skipper2000d
Newbie
Newbie
Beiträge: 1
Registriert: 23. Mai 2004, 16:28

Bei mir das gleiche

Beitrag von skipper2000d » 21. Nov 2004, 19:52

Auch ich hatte das Problem und konnte es dank Eurer Hilfe einfach mit dem Yast Update lösen. Es scheint sich wirklich um die patch Dateien zu handeln. Ich kann mich erinnern, dass ich damals beim setup die neuen Delta Patches zugelassen habe und bei meinen updates kamen auch die Delta Patches. Vielleicht hat es damit irgendwie zu tun.

skipper 2000d

Martin1802
Member
Member
Beiträge: 73
Registriert: 19. Sep 2004, 17:02
Wohnort: Konstanz
Kontaktdaten:

apt ... bad magic

Beitrag von Martin1802 » 22. Nov 2004, 18:07

Hi Leute,

auch bei mir klappt es nicht mit apt dist-upgrade einige Pakete upzugraden :-( ... was soll den diese meldung von cpio "bad magic" ...

Für mich hört sich das nur nach fehlern in den archiven an ... oder der Fehlermeldung ist schei*** ...

Gruss
Martin

--------------------------------------
linuxnote1:~ # apt dist-upgrade
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Berechne Upgrade... Fertig
Die folgenden Pakete werden upgegradet werden:
ImageMagick acpid tcsh wget xorg-x11-libs xorg-x11-server
Die folgenden Pakete sind zurückgehalten worden
synaptic
6 upgraded, 0 newly installed, 0 entfernt und 1 nicht upgegradet.
Muss 639kB an Archiven holen.
Nach dem Auspacken werden 502B zusätzlicher Plattenplatz benutzt werden.
Wollen Sie fortsetzen? [J/n]
Hole:1 ftp://ftp.gwdg.de SuSE/9.2-i386/update-drpm xorg-x11-libs 6.8.1-15.3 [212kB]
Hole:2 ftp://ftp.gwdg.de SuSE/9.2-i386/update-drpm ImageMagick 6.0.7-4.2 [73,8kB]
Hole:3 ftp://ftp.gwdg.de SuSE/9.2-i386/update-drpm acpid 1.0.3-4.2 [13,2kB]
Hole:4 ftp://ftp.gwdg.de SuSE/9.2-i386/update-drpm wget 1.9.1-50.2 [110kB]
Hole:5 ftp://ftp.gwdg.de SuSE/9.2-i386/update-drpm xorg-x11-server 6.8.1-15.3 [193kB]
Hole:6 ftp://ftp.gwdg.de SuSE/9.2-i386/update-drpm tcsh 6.12.00-453.2 [37,8kB]
639kB in 9s (68,4kB/s) geholt
Committing changes...
Preparing... ########################################### [100%]
1:xorg-x11-libs ########################################### [ 17%]
error: unpacking of archive failed: cpio: Bad magic
2:ImageMagick ########################################### [ 33%]
error: unpacking of archive failed: cpio: Bad magic
3:acpid ########################################### [ 50%]
error: unpacking of archive failed: cpio: Bad magic
4:wget ########################################### [ 67%]
error: unpacking of archive failed: cpio: Bad magic
5:xorg-x11-server ########################################### [ 83%]
error: unpacking of archive failed: cpio: Bad magic
6:tcsh ########################################### [100%]
error: unpacking of archive failed: cpio: Bad magic
apt executing: /sbin/SuSEconfig
Starting SuSEconfig, the SuSE Configuration Tool...
Running in full featured mode.
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.automake...
Executing /sbin/conf.d/SuSEconfig.fonts...
Creating cache files for Xft ..........................
Creating fonts.{scale,dir} files ............
Executing /sbin/conf.d/SuSEconfig.gnome-vfs2...
Executing /sbin/conf.d/SuSEconfig.groff...
Executing /sbin/conf.d/SuSEconfig.gtk2...
Executing /sbin/conf.d/SuSEconfig.guile...
Executing /sbin/conf.d/SuSEconfig.isdn...
Modify isdn.conf
/usr/bin/net: line 1: ELF: command not found
provider net done
Executing /sbin/conf.d/SuSEconfig.ispell...
Executing /sbin/conf.d/SuSEconfig.kde...
Executing /sbin/conf.d/SuSEconfig.kdm3...
Executing /sbin/conf.d/SuSEconfig.libxml2...
Executing /sbin/conf.d/SuSEconfig.news...
Executing /sbin/conf.d/SuSEconfig.pango...
Executing /sbin/conf.d/SuSEconfig.perl...
Executing /sbin/conf.d/SuSEconfig.permissions...
Executing /sbin/conf.d/SuSEconfig.postfix...
Setting up postfix local as MDA...
Setting SPAM protection to "off"...
Executing /sbin/conf.d/SuSEconfig.profiles...
Executing /sbin/conf.d/SuSEconfig.scpm...
Executing /sbin/conf.d/SuSEconfig.scrollkeeper...
Executing /sbin/conf.d/SuSEconfig.sgml-skel...
Executing /sbin/conf.d/SuSEconfig.sortpasswd...
Executing /sbin/conf.d/SuSEconfig.susehelp...
Executing /sbin/conf.d/SuSEconfig.tetex...
Executing /sbin/conf.d/SuSEconfig.xdm...
Executing /sbin/conf.d/SuSEconfig.zmessages...
Finished.
apt executing: /sbin/ldconfig

--------------------------------------

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 22. Nov 2004, 18:53

Hole:1 ftp://ftp.gwdg.de SuSE/9.2-i386/update-drpm xorg-x11-libs 6.8.1-15.3 [212kB]
Hole:2 ftp://ftp.gwdg.de SuSE/9.2-i386/update-drpm ImageMagick 6.0.7-4.2 [73,8kB]
Hole:3 ftp://ftp.gwdg.de SuSE/9.2-i386/update-drpm acpid 1.0.3-4.2 [13,2kB]
Hole:4 ftp://ftp.gwdg.de SuSE/9.2-i386/update-drpm wget 1.9.1-50.2 [110kB]
Hole:5 ftp://ftp.gwdg.de SuSE/9.2-i386/update-drpm xorg-x11-server 6.8.1-15.3 [193kB]
Hole:6 ftp://ftp.gwdg.de SuSE/9.2-i386/update-drpm tcsh 6.12.00-453.2 [37,8kB]
du soltest mal die *-drpm aus deiner sources.list rausnehmen, das sind nur patch-rpms.....

danach apt update nicht vergessen!
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Martin1802
Member
Member
Beiträge: 73
Registriert: 19. Sep 2004, 17:02
Wohnort: Konstanz
Kontaktdaten:

.. tja einfach besser lesen ... *lach*

Beitrag von Martin1802 » 22. Nov 2004, 19:11

Hi ..

DANKE ... hab ich doch glatt übersehen zu entfernen :-( aber was ist eigentlich der Unterschied zu den patch rpms ... *-prpm

Gruss und Thanks again @oc2pus
Martin

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 22. Nov 2004, 19:41

das sind patch-rpms, diese enthalten nur die Deltas zu einem Basis-rpm.

Wenn aber das Basis-RPM nie installiert war ... dann knirscht es :)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste